Использование мастер-страниц

From Scribus Wiki
Jump to: navigation, search
edit

Главная страница

Уроки

  1. Вводный курс по Scribus
  2. Плашечные цвета
  3. Использование мастер-страниц
  4. Вёрстка статей


Зачем нужны мастер-страницы

Как только вы столкнётесь с необходимостью использовать много одинаковых объектов (общих «шапок», логотипов, фоновых изображений, номеров страниц и т.д.) в одинаковых местах страниц на протяжении всего документа, вам посоветуют использовать мастер-страницы. Использование мастер-страниц позволяет избежать ненужной и нудной работы и сэкономить время. Объекты, являющиеся частью мастер-страницы, не могут изменяться в режиме обычной правки. Причиной тому является возможностью случайной нежелательной правки содержимого мастер-страницы. Мастер-страница всегда является частью документа и не может быть сохранена в отдельный файл. Вместе с тем, вы можете создать документ, содержащий наиболее часто используемые мастер-страницы и использовать его в качестве источника для новых документов (импортировать в них мастер-страницы).

Как создать мастер-страницы

План A:

Создайте новый документ. Выберите из главного меню Правка > Мастер-страницы... (Иллюстрация 1) для запуска диалога Правка мастер-страниц и перехода в Режим правки мастер-страниц (Иллюстрация 2).

Мастер-страница Normal есть в документе всегда и не может быть удалена — кнопка удаления для неё отключена (Иллюстрация 2). Эта мастер-страница может быть изменена, хотя лучше оставить её в исходном виде, чтобы можно было создавать новые чистые страницы.

Иллюстрация 2

Подержав курсор мыши над кнопками, можно увидеть полезные подсказки (Иллюстрация 2).

Кнопки слева направо:

  • Добавить новую мастер-страницу
  • Продублировать выбранную мастер-страницу
  • Импортировать мастер-страницу из другого документа
  • Удалить выбранную мастер-страницу

Щелчком по кнопке Добавить новую мастер-страницу открывается диалог, в котором задаётся имя новой мастер-страницы (Иллюстрация 3).

Совет: подбирайте такое имя, которое отражало бы назначение этой мастер-страницы, так чтобы вы всегда смогли догадаться, что в ней, даже если давно не работали с этим документом.

Иллюстрация 3

После нажатия кнопки OK вы увидите окно Правка мастер-страниц, где будет выбрана только что созданная мастер-страница. Вы можете переключаться между созданными мастер-страницами одиночным щелчком мышью по их названиям (Иллюстрация 4).

Закрыв окно диалога Правка мастер-страниц, вы вернётесь в обычный режим работы со Scribus.

Иллюстрация 4

Если вам нужна новая мастер-страница, мало отличающаяся от выбранной, нажмите кнопку Продублировать мастер-страницу — этим вы сэкономите себе время на создание новой мастер-страницы с нуля.

Вы также можете добавить в текущий документ мастер-страницу из другого документа, щёлкнув по кнопке Импортировать мастер-страницу из другого документа, которая откроет окно Импорт мастер-страницы (Иллюстрация 5).

Иллюстрация 5
Затем щёлкните кнопку Изменить... для выбора документа, содержащего нужную мастер-страницу.
Иллюстрация 1


План Б:

Вы можете создавать новые мастер-страницы из обычной редактируемой страницы документа. В меню выберите пункт Страница > Преобразовать в мастер-страницу... (Иллюстрация 6). Вслед за этим появится диалоговое окно Преобразовать в мастер-страницу, в которое можно дать название новой мастер-странице (наподобие Иллюстрации 3 вверху).

После этого вы можете вернуться в меню Правка > Мастер-страницы... и в диалоге Правка мастер-страниц найти свежесозданную мастер-страницу (Иллюстрация 4 вверху).

Иллюстрация 6


Двухсторонние страницы, страницы с двумя и тремя фальцовками

Иллюстрация 7
Иллюстрация - Double Sided
Иллюстрация 9 - 3-fold
Иллюстрация 10 - 4-fold

Как мы можем использовать эти концепции с двухсторонними страницами, а также страницами с двумя и тремя фальцовками?

Вы заметите, что именно в таких случаях использование мастер-страниц особенно экономит время. При создании нового документа выберите подходящий макет (Иллюстрация 7). После этого создайте мастер-страницы согласно Плану А или Плану Б. На иллюстрации справа вы увидите, почему правильно выбранные названия мастер страниц так важны.

  • двухсторонний макет (Иллюстрация 8)
  • макет с двумя фальцовками (Иллюстрация 9)
  • макет с тремя фальцовками (Иллюстрация 10)


Применение мастер-страниц

К чистым страницам документа:

Иллюстрация 11
Иллюстрация 12

Через пункт меню Страница > Применить мастер-страницу... (Иллюстрация 7) или Применить мастер-страницу... в контекстном меню (щелчком правой клавишей мыши по странице - Иллюстрация 11) открывается окно Применение мастер-страницы. В нём вы можете выбрать, к чему применить мастер-страницу:

  • к текущей странице;
  • к чётным страницам;
  • к нечётным страницам;
  • ко всем страницам;
  • к диапазону страниц.

Выберите нужную мастер-страницу из раскрывающегося списка Мастер-страница.

Вряд ли вас удивит, что вариант Чётные страницы доступен только если в документе больше одной страницы. Кроме того, диапазон можно указать только в том случае, когда выбран вариант Все страницы.

Вставка в качестве новых страниц:

Иллюстрация 13

При вставке новой страницы (меню Страница > Вставить) открывается диалог, в котором можно выбрать количество добавляемых страниц, откуда начинать вставку и автоматически применяемые мастер-страницы, если в них есть необходимость (Иллюстрация 13).

Обратите внимание на то, что область Мастер-страницы изменяется согласно макету документа. На Иллюстрации 14 изображён диалог вставки страницы в документ, использующий макет Три фальцовки.

Совет: Пагинацию лучше всего делать в Story Editor. Находясь в режиме редактирования мастер-страницы, создайте текстовый блок на месте предполагаемого номера страниц. Из меню Story Editor выберите Вставка > Символ > Номер страницы (или используйте комбинацию клавиш Ctrl+Shift+Alt+P). В окне Story Editor появится символ #, но это будет не символ, получаемый по Shift+3.

Если количество страниц в документе двухзначное (10-99), введите хотя бы два таких спецсимвола, а если трёхзначное, т.е. 100-999 - хотя бы три.

Иллюстрация 14


Первая версия этой статьи на немецком была опубликована на немецкоязычном форуме по Scribus.