CMake Build Options

From Scribus Wiki
Jump to: navigation, search
Announcement: This page contains CMake Build Options

These are the options for the CMake command line supported by Scribus.

See Building_SVN_versions_with_CMake on how to use them.

Confirmed working (as of 2012)

  • CMAKE_INSTALL_PREFIX:PATH : PATH : destination folder of bin file cmake result (ex : -DCMAKE_INSTALL_PREFIX:PATH=~/bin/scribus) (OK 2014)
  • WITH_PODOFO : BOOL: Enable support for PDF embedded in AI import
  • WANT_QT3SUPPORT: BOOL: Turn on Qt3 support in Qt when building, defaults to off, we don't need Qt3 support
  • WANT_DEBUG : BOOL : Turn on debugging and turn off stripping of debug information
  • WANT_RELEASEWITHDEBUG : BOOL : Set release mode but keep debugging information
  • WANT_NO_EXAMPLES (1.4.2+, 1.5.0+) : BOOL :Set this to not install the scripter examples scripts
  • WANT_NO_TEMPLATES (1.4.2+, 1.5.0+) : BOOL: Set this to not install the document templates
  • WANT_VERSIONING (prior to 1.4.0, and higher) : BOOL :Add version tags to the installation directories for installations allowing multiple versions to be installed
  • APPLICATION_DATA_DIR : PATH : specify the user configuration directory at compile time
  • WANT_CAIRO : BOOL : Turn on using cairo as the rendering library, (DEPRECATED WITH 1.5.x)
  • WANT_QTARTHUR : BOOL: Turn on Qt Arthur as the rendering library (DEPRECATED WITH 1.5.x)
  • WANT_NOHEADERINSTALL : BOOL: Do not install the headers (if you don't intend to develop with Scribus, turn this off)
  • WITH_ASPELL : BOOL : Turn on aspell spelling support (OBSOLETE: starting from v. 1.4.2, Hunspell is used for spellchecking)
  • WANT_HUNSPELL: BOOL : Turn on hunspell spelling support (1.4.2 and higher)(libhunspell-dev has to be installed) (OK 2014)
  • WANT_GUI_LANG: STRING : Select GUI languages [1] to install. Useful for speeding up regular build processes or limiting install size, eg: WANT_GUI_LANG="en_GB;de;fr" (OK 2014)
  • WANT_SVNVERSION=1 : Adds the SVN version to the "About" dialog. (OK 2014)
  • WANT_GRAPHICSMAGICK: BOOL : use graphicsmagick libraries for advanced file formats imports exports (OK 2014)
  • WANT_SYSTEM_CAIRO=1 : Removes the internal cairo,(may not be necessary). See Resolved Bug 9753



If any of your libraries are in non-standard locations you will need to provide some extra arguments to CMake to ensure that CMake and gcc can find all the required files. Where /path/to/libfoo is the path to the the directory the library was installed to, eg /usr/local or /home/fred/libfoo (not the 'lib' subdirectory the actual .so files are in), you can use the following extra arguments to CMake to help it find the library:


If you have multiple custom paths to specify, use a ; path separator, eg:


OS X Specific

  • BUILD_OSX_BUNDLE : Set some options relating to building the OSX bundle
  • WANT_UNIVERSAL_BUNDLE : BOOL : Attempt to build a PPC/Intel binary bundle for OSX
  • WANT_QT4MAC_COCOA : BOOL : Where the OSX build machine supports Carbon and Cocoa, use Cocoa


  • USE_QT5 : BOOL : Use Qt5 instead of Qt4 (DEPRECATED with versions later than september 2013)
  • QT_PREFIX : PATH : path for Qt5 libs (for example : -DQT_PREFIX="/opt/qt5/bin" or -DQT_PREFIX="/usr/local/Qt-5.2.0" or -DQT_PREFIX=/home/username/Qt/5.2.0/gcc_64 when installed with default setting via installer found on

Unversioned or prior to 1.4.0 (work in progress)

  • WANT_LIB64 :


  1. all the language codes in Scribus/resources/translations link