Complex tables in Scribus

From Scribus Wiki
Jump to: navigation, search
This article is part of the Tips & Tricks series.
Installation Usage PDF issues Other

Scribus provides the ability to create tables. Unfortunately, scribus tables are nothing more than combined text frames, and it is a bit hard to work with them. If you need to have more complex tables, here is a reliable workaround:

  1. Create your table in either OpenOffice.org Writer or Calc.
  2. Copy the table items you need in scribus (this means: not the whole spreadheet in Calc) to the clipboard, create a new OpenOffice.org Draw document, and use Edit > Paste Special > GDI Metafile to insert the table as a vector file into Draw.
  3. Use File > Export to export the graphic as an EPS file. Make sure that Selection is checked in the export dialog, because otherwise the whole page will be exported.
  4. Now import the EPS file as a vector drawing in Scribus via File > Import > Import Vector File.