Domande frequenti: installazione di Scribus

From Scribus Wiki
Jump to: navigation, search


Quale versione di Scribus è quella giusta per me?

Piattaforma

Come posso installare Scribus su Linux?

  • Se non hai speciali esigenze, usa il gestore di pacchetti della tua distribuzione (synaptics, yum, apt-get, ecc.). Questo è il metodo da preferire per l'installazione di Scribus.
  • Se vuoi installare la versione più recente, ma questa non è ancora disponibile nella tua distribuzione, puoi usare i repository di Scribus. Ne esistono per Debian, Ubuntu, Fedora, CentOS, Red Hat, OpenSuse, SUSE Linux Enterprise, e Mandriva.
  • Se vuoi sperimentare le ultime novità (o se non esiste un eseguibile per la tua piattaforma) puoi compilare il codice sorgente, che trovi su Sourceforge o Subversion (svn://scribus.net).

Come posso installare Scribus per OS X?

Il pacchetto di installazione per le versioni 10.5 (Leopard) e successive basate su Intel si può prelevare direttamente dalla pagina Download.

Per altre versioni:

  • La versione stabile è disponibile soltanto tramite Fink o Darwinports.
  • Gli snapshot della versione di sviluppo si possono reperire su Sourceforge.
  • Attualmente non c'è un modo (facile) di compilare Scribus su OS X.
  • Puoi trovare un .dmg di Ghostscript qui
  • Le immagini (.dmg) per le più recenti versioni di sviluppo non funzionano su OS X 10.4. Se vuoi installare Scribus 1.3.8 o successivo dovrai farlo tramite Fink:
    • installa Fink.
    • poi installa Finkcommander.
    • attiva i pacchetti instabili (Fink Commander > Preferenze > Fink, Usa pacchetti instabili).
    • installa scribus-135+ da sorgenti o da binari (se installi da sorgenti anche Qt4 ci vorrà molto tempo, ma funzionerà).

Come posso installare Scribus su Windows?

Che versione devo usare?

L'attuale versione stabile è la 1.4.4. La precedente versione stabile era la 1.3.3.14.

Una regola pratica per distinguere tra le versioni è la seguente. Tutte le versioni in cui il secondo numero di versione (cioè quello detto "minore") è dispari (1.1, 1.3, 1.5, 1.7) sono instabili/di sviluppo; tutte le versioni in cui il secondo numero di versione è pari (1.0, 1.2, 1.4, 1.6, ...) sono stabili.
Le versioni 1.3.3.x sono un'eccezione e sono state definite stabili perché la 1.2 era troppo invecchiata e la 1.4 ancora lontana nel futuro.

Versione stabile

L'attuale versione stabile è la 1.4.4; dovresti usare questa per il normale lavoro. Ma ricorda che i documenti creati con essa non possono essere aperti dalle precedenti versioni 1.3.3.x, poiché il formato del file è cambiato.

Ramo di sviluppo (sperimentale)

La versione 1.5 è l'attuale ramo sperimentale. Dovrebbe essere usato solo da coloro che desiderano sperimentare le novità più recenti. Ricorda che se usi questa versione, non potrai aprire i file generati da essa in nessuna delle versioni precedenti.

Compatibilità

Fin dai suoi inizi, Scribus ha sempre mantenuto la retrocompatibilità, e quindi ogni versione è in grado di aprire i file generati da quelle precedenti. Poiché col tempo nuove caratteristiche e funzionalità vengono aggiunte, non è vero il contrario. Ad esempio, la 1.3.3.14 non può aprire un file generato dalla 1.3.5, ma tutte le versioni dalla 1.3.5 in poi possono aprire un file generato dalla 1.3.3.14.

Insomma, che versione devo usare?

Se hai ancora dubbi, usa la versione stabile 1.4.4, e difficilmente avrai problemi. Se hai acquistato il manuale ufficiale di Scribus (o se hai intenzione di acquistarlo): il libro è basato sulla serie 1.3.3.x, ma può essere usato anche con le versioni successive.

Come posso compilare Scribus?

Ci sono alcuni motivi perché potresti voler compilare Scribus, invece di usare gli eseguibili pronti:

  • non esiste una versione di Scribus per la tua piattaforma (è così, ad esempio, per Linux PPC o Mac OS X 10.4);
  • hai bisogno di una modifica o di una correzione che è stata eseguita dopo la generazione dell'ultimo eseguibile;
  • vuoi seguire lo sviluppo di Scribus per essere aggiornato sulle ultime modifiche e per testarlo.

Nel primo caso dovresti prelevare i sorgenti da Sourceforge. In tutti gli altri casi è meglio se li prelevi via Subversion.

Altre informazioni:

Dipendenze

Vedi questa pagina.

Problemi relativi all'installazione

Dov'è Ghostscript?

Sei riuscito a installare Scribus, ma un avviso ti dice che manca Ghostscript.

Ghostscript è necessario solo per l'importazione di file in formato EPS e per l'anteprima di stampa: se non ti servono queste funzioni, puoi ignorare l'avviso. Ghostscript può anche essere installato in seguito.

Linux

È molto improbabile che ricevi quest'avviso in Linux, a meno che tu abbia installato Ghostscript in qualche posizione insolita. Ma se accade, usa il tuo gestore di pacchetti per installare Ghostscript.

Mac OS X

  • puoi trovare un .dmg di Ghostscript qui (potrebbe non essere la versione più recente, ma probabilmente sarà sufficiente).
  • puoi anche installare Ghostscript tramite Fink o MacPorts.

Quando Ghostscript è stato installato, vai in File > Preferenze > Strumenti esterni > Interprete postscript e inserisci (Cambia...) l'eseguibile gs (il percorso sarà simile a "/usr/local/bin/gs").

Windows

  • prima di tutto devi scaricare Ghostscript e installarlo.
  • dopo l'installazione, Scribus ha bisogno di sapere dove trovarlo. Potrebbe rilevarlo automaticamente, ma se questo non funziona, vai in File > Preferenze > Strumenti esterni > Interprete postscript e cerca l'eseguibile gs (Cambia...). Per le versioni di Windows a 32 bit l'eseguibile è gswin32c.exe: fa' attenzione a selezionare quello con la "c" nel nome, perché ne esiste un altro senza "c".

Problemi di avvio

Scribus è molto lento ad avviarsi. Perché?

  • A differenza di molti altri programmi, per le applicazioni di desktop publishing è molto importante rilevare quali tipi di carattere sono installati e se i loro percorsi nel file system sono validi. Quindi Scribus all'avvio esegue un esame completo dei percorsi dei caratteri e verifica che siano validi. Ciò richiede tempo: se hai molti tipi di carattere (200 o più) e se la lentezza nell'avvio è un problema, dovresti ridurre il numero dei tipi di carattere installati o dei percorsi in cui si trovano.
  • Un'altra possibile causa è che tu abbia nella biblioteca dei file di immagine grandi o complessi. In tal caso puoi cancellare dalla biblioteca gli elementi superflui, oppure salvarla con un nome diverso e crearne una nuova vuota. Questo dovrebbe rendere l'avvio di Scribus meno lento.

Plugin

Dove posso trovare un plugin?

Tutti i plugin stabili accettati dagli sviluppatori sono compresi nella versione più recente di Scribus. Chiunque sia interessato a crearne di nuovi dovrebbe consultare la pagina Plugin_Architecture.