Help:Manual Frames

From Scribus Wiki
Jump to: navigation, search

Table of Contents

Working with Frames

Working with Scribus is for the most part working with a frames environment. Some more generic terms you may see in menus and commands are objects or items, of which frames are one kind of object or item. There are five kinds of frames you will work with in Scribus:

Each of these have their own section in this online manual, but here we will explain features they share.

Creating Frames

There are at least six ways to create frames:
  1. Clicking the toolbar icon for the type of frame
  2. Choosing from the menu, Insert > Type of frame
  3. Using the keyboard shortcut (when not in Edit Contents mode in an already existing frame)
    • T for Text frame
    • I for Image frame
    • D for Render frame
    • S for Shape
    • P for Polygon
  4. Using Duplicate or Multiple Duplicate to make one or more copies of the selected frame
  5. Duplicating a Layer with its contents
  6. Copying a page, with all of its contents
If you change your mind or pressed the wrong key (at least in the cases 1, 2 and 3), you can press Esc or the Spacebar to cancel, or click the toolbar icon for your next choice.

When you make one of the choices 1–3, your mouse cursor becomes activated to draw the frame, and a tooltip pops up to tell you the cursor's X-Pos and Y-Pos. As you click-drag to make the frame from one corner to its opposite, the tooltip now displays the Width and Height frame you are creating. For Shapes and Polygons, this describes the dimensions of the Bounding Box.

Usually the next step is adding or doing something with the content, but we will leave that to the individual sections regarding each type of frame.

Help shapes7.png

Here we see the Enter Object Size dialog that comes up if you left-click somewhere on the page, rather than doing a click-drag operation. Obviously this can be very handy for creating a frame of a precise size.

The fields Width and Height are spinboxes whose use will be explained below.

Context Menus

Each frame type has its own particular Context Menu, found by right-clicking on it. Since these are variable depending on the type of frame, they will not be elaborated upon here. Keep in mind that you can find interesting things in Scribus by right-clicking on various items.

Manipulating Frames

How to Use Spinboxes

  • Hover the cursor over the spinbox value and use your mousewheel to change it
  • Click the up or down arrow to the right side of the spinbox
  • Use the arrow keys – cursor must be over the appropriate spinbox
  • Change the value with the keyboard.
    Hint: Scribus will do math for you. Enter (615/2+20), for example. There are some keywords you can use also, and combine with math operations: pagewidth/2, for example. Other keywords are pageheight, width (of selected item), and height (of selected item).
The mousewheel digit changed can be modified:
  • No key pressed: units
  • Shift key held: tenths
  • Shift + Alt: hundredths
  • Ctrl or Alt: tens
  • Ctrl + Alt: hundreds – Careful with this one with a page measurement unit like inches
  • Except for those that use Alt, you can use most of these keymods when moving the frame with the arrow keys (cursor not over spinbox), but not for resizing with arrow keys.

Moving Frames

The simplest method is to click-hold inside the frame and move with the mouse. While this is taking place a tooltip tells you the position of the Basepoint (default basepoint is left upper corner). You can also use the arrow keys to move the frame as long as the cursor is not over any spinboxes. For more precise movement, use Properties > X,Y,Z tab (X-Pos and Y-Pos) and its spinboxes.

Resizing Frames

A selected frame shows a dotted red border and in addition small square handles at the corners and at the midpoints of each side. Click and drag a handle to make manual adjustments. If you hold down the Alt key and the cursor is not over a spinbox, you can resize the frame using the arrow keys. To resize a frame proportionally, press Ctrl+Alt while moving a handle. Use the Width and Height spinboxes in the Properties Palette for precision.
Help XYZ Prop.png

Rotating Frames

There are 2 ways to rotate a frame:
  • Click the Rotate icon on the toolbar. You then click-drag inside the frame to rotate. As long as you click inside a frame, the basepoint is always the center of the frame. However, if click on any of the corner handles, the basepoint is the opposite corner.
  • Use the Rotation spinbox in Properties. In this case, you can choose the basepoint around which rotation takes place, as well as have more precision.

Moving Frames – Level to Level or Layer to Layer

You can move up or down levels using Properties > X,Y,Z tab, in the area labelled Level, either one level at a time or to the top or bottom. The number beside these arrows tells you which level your object is on (1 is the bottom).

There are also keyboard shortcuts:

  • Home: to the top
  • End: to the bottom
  • Ctrl+Home: up one level
  • Ctrl+End: down one level
If you have more than one layers.html layer, you can use the Context Menu (right-click on the frame) to send the frame to a different layer.

Final Section of Properties: X,Y,Z

Looking at the last group of seven buttons in the lower right corner of X,Y,Z, the two leftmost buttons, grayed out in this picture, will group and ungroup a collection of selected objects (note that vector drawings are always imported as groups of objects). The next two buttons, with the blue arrows, flip the object horizontally or vertically. The picture of the lock is where you can lock or unlock the selected object, and just to its right you can lock or unlock only the size of the object. The last button in the lower right corner enables is disables printing (and export to PDF) of the object.
Help XYZ Prop1.png

Copy, Cut, Paste, Delete

Most users should be familiar with these kinds of operations common to many types of editing software. They can be found in the Context Menu or the Edit menu, and have the standard keyboard shortcuts of Ctrl+C, Ctrl+X, Ctrl+V, and Del. In Scribus, Delete operates similar to Cut, since it can be undone, but in contrast is not copied to the clipboard and therefore cannot be pasted. If you move from one page or one layer to another, Paste will place the new copy at the same coordinates it had on the original page or layer.

Selecting Multiple Frames

You might do this as a prelude to grouping the frames, so you can move or scale them as a unit.

The simplest way of selecting a group of frames is to click-drag around them. You have to be sure that any frame you wish to be selected is fully within the temporary rectangle you see during this operation. This may not work when you only want some of the frames in a particular rectangular space. In that situation you can manually select additional frames in a cumulative way by holding down Shift as you click. If you make a mistake, click again while holding Shift to deselect individual frames. If you have not yet grouped the frames, click outside these collectively selected frames to "break" the multiple selection. You can also combine these approaches by click-dragging around a number of frames, then Shift-clicking any you wish to select in addition or deselect.

Selecting Frames Under Other Frames

If all you want to do is select an individual frame that happens to be completely underneath some other frame, hold Shift+Ctrl, and click serially on a particular spot to toggle through the frames covering that spot. You will cycle through the frames, but also at some point select none of them.

Note: if you find an inability to select a frame underneath another using this method, consider that this frame may be on another layer. You may only work on one layer at a time.

Line and Colors of Frames

The line of a frame is the border. For text, image and render frames, the default color of the line is None, so none of the line settings have any meaning until the line is given a color in the Colors tab of the Properties Palette. The default background or fill color of text and image frames is also None.

For Shapes and Polygons, the default fill color is set to None, wheras the default line color is Black. For all kinds of frames these default colors can be set in File > Document Setup > Tools for the current document and in File > Preferences > Tools for new documents.

Text Flow Around Frame

The first important thing to remember is that this can be a property of any kind of frame, and that it applies to any text frames underneath it, underneath being not only on a lower level, but also a lower layer.

Secondly, you need to choose whether you want flow around the frame, the contour line, or the bounding box – making your choice in the Shape tab of Properties. For text and image frames, all 3 coincide with each other when they are created.

As for shapes and polygons, only only the frame and contour lines coincide (i.e., they are identical with the shape/polygon itself), whereas the boundling box is always the surrounding rectangle. Details will be found elsewhere, but in the Shape tab of the Properties Palette you can edit the frame/shape or the contour line independently.

In this screenshot below, the left column flows around the frame, the right around an edited (enlarged) contour line:

Help text flow.png
This material may be distributed only subject to the terms and conditions set forth in the Open Publication License, v1.0 or later. Distribution of the work or derivative of the work in any standard (paper) book form is prohibited unless prior permission is obtained from the copyright holder. A copy of the license is included in the section entitled "Text of the Open Publication License."