Import Publisher to Scribus

From Scribus Wiki
Jump to: navigation, search


Scribus does not support importing Microsoft Publisher documents. There are no current plans to add support for it. The reasons are here: FAQ-Importing from Proprietary Formats

Copy paste from Publisher to Office

You may be able to import an approximation of the document by following this process:

  • Open your document in Publisher
  • Go to menu Edit --> Select All (Ctrl+A)
  • Go to menu Edit --> Copy (Ctrl+C)
  • Open Microsoft Word
  • Go to menu Edit --> Paste (Ctrl+V)
  • Save your Word document (eg. file.doc)
  • Open it in OpenOffice
  • In OpenOffice go to File --> Save as in OpenOffice Writer format (eg. file.sxw)
  • In OpenOffice with sxw file go to File --> Save as in OpenOffice Draw format (eg. file.sxd)
  • In Scribus File --> Import --> OpenOffice Draw file

Alternately, it may be better to export the plain text content from the Publisher document (you can use MS Word to save it as plain text, or you can use OO.o to open a word doc and save an OO.o doc so Scribus can preserve some of the text formatting), then recreate the document from that and the images used in the original.

Export to HTML

Have the Publisher owner save the file as html. This will give you an editable file. That file can be imported into Open Office or edited by other means.

Produce a PDF and use it to help you redo the layout in Scribus

If you want to import a single page layouted in Publisher into Scribus, you can do the following:

  • Install a pdf printer driver (there are several opensource programs available)
  • print your page to a pdf file.
  • Open the pdf in Inkscape and save as SVG
  • Import into Scribus

There are 2 caveats with this procedure:

  • the more complex the page is, the more error prone
  • if there is a lot of text in your publication, make sure it is not converted to outlines when printed to pdf, otherwise you will not be able to change the text in Scribus.


More resources

There are also some "Publisher to Scribus" tutorials with tips on how to reproduce BorderArt and Clip Art when switching from Publisher to Scribus.