Import Spreadsheet Tables to Scribus

From Scribus Wiki
Jump to: navigation, search

This paper describes how a table built with OpenOffice.org Calc can be easily exported  to an EPS file for import into Scribus.

Installing a Postscript Print Driver

  • Download the latest driver from <a href="http://www.adobe.com/products/printerdrivers/index.html">http://www.adobe.com/products/printerdrivers/index.html</a>.  At Adobe's site, do a search for 'Generic Postscript Driver'. At the time of writing, this was 'Adobe Universal Postscript Windows Driver Installer 1.0.6 - English' with the file name 'winsteng.exe'.
  • When installing the driver, be sure to specify File: Local Port as shown here. If you don't actually have a Postscript printer this is the only destination that will work with this driver.
  • Complete the installation and reboot. Open any application and select File -> Print. Check to ensure that you now have a "Generic Postscript Printer' option as well as your normal, default printer.
  • SprTabScrib1.jpg

Creating the Table in OOO Calc

  • Open OOO Calc and make yourself a table. This is just an example.
  • SprTabScrib2.jpg

Copy and Paste into OOO Draw

  • In Calc, click View and uncheck 'Column and Row Headers' item. Select all the cells to be in your image as shown here.
  • SprTabScrib3.jpg

  • Copy your selection to the clipboard with Edit -> Copy.
  • Click File -> New -> Drawing
  • When Draw is loaded, Click Edit -> Paste Special ( not just Paste). Accept the default source 'calc8' and click OK. Your table appears in the Drawing pane. It's fully scalable so you can resize it any way you like.
  • SprTabScrib4.jpg

Print the Image to EPS

  • In Draw, click File -> Print. Select the Generic Postscript Printer. Check Properties. In Properties, click Advanced. In Advanced, expand Postscript Options, then click the down arrow beside Optimize for Speed to show the other options.  Select Encapsulated Postscript. Your screens should look like this.
  • SprTabScrib5.jpg

  • Click OK for each of the screens until you get to Save As.
  • SprTabScrib6.jpg

  • Pick a folder and enter the file name including the '.eps' extension. Draw's 'Save as type' menu doesn't know anything about EPS so you have to tell it.  
  • If you want to have a look at your image before importing it into Scribus, it will display fine with Ghostview.

Import the EPS Image into Scribus

  • Import the EPS image into Scribus. 
  • Once imported, this vector image is fully scalable and can be housed in a bounding text frame with the text-flow-around option as in the following example.
  • SprTabScrib8.jpg