Lavorare con l'editor interno

From Scribus Wiki
Jump to: navigation, search
Tutte le pagine della serie Lavorare con...:

Lavorare con Scribus: come iniziare
Lavorare con le cornici di testo
Lavorare con l'editor interno
Lavorare con le cornici immagine
Lavorare con le pagine mastro


L'editor interno è la speciale finestra da cui si può inserire manualmente del testo in una cornice di testo. L'editor interno mostra solo in minima parte l'esatto aspetto grafico che il testo avrà.

L'editor interno mostra (approssimativamente) le seguenti caratteristiche grafiche del testo:
  • giustificazione (tranne i ritorni a capo automatici)
  • colore del testo
  • sottolineatura
  • apici
  • pedici
  • testo barrato
L'editor interno non mostra le seguenti caratteristiche grafiche del testo:
  • tipo di carattere
  • dimensioni del carattere
  • crenatura
  • interlinea
  • maiuscoletto
  • contorno
  • ombreggiatura
  • capolettera


Aprire l'editor interno

Selezionare una cornice di testo e fare clic sull'icona Modifica testo sulla barra degli strumenti (da tastiera: Ctrl+T), oppure dal menù Modifica > Modifica testo; questa voce si trova anche nel menù contestuale (clic col tasto destro del mouse nella cornice).

Impostazioni

È l'ultima voce nel menù dell'editor interno, ma queste impostazioni influenzano l'aspetto del testo e potrebbero essere importanti quando si inizia a lavorare sul testo.

L'editor interno nella vers. 1.3.X - fare clic per ingrandire

Impostazioni > Sfondo cambia il colore di sfondo, ma soltanto nell'editor interno. Potrebbe essere utile cambiare il colore di sfondo se il testo è bianco o ha un colore chiaro, per renderlo meglio visibile.

Impostazioni > Font visualizzato cambia il tipo di carattere, ma anche in questo caso soltanto nell'editor interno. Potete impostare il carattere che preferite, per vostra comodità di visualizzazione.

Impostazioni > Selezione rapida: per impostazione predefinita, quando si fa doppio clic su una parola, viene selezionata la parola e lo spazio immediatamente seguente. Con la selezione rapida attiva, viene selezionata soltanto la parola, senza lo spazio seguente.

Iniziare a usare l'editor interno

Quando si apre l'editor interno, si può semplicemente iniziare ad inserire del testo. L'editor interno non mostra l'esatto aspetto grafico del testo (questo sarà visibile solo quando il testo viene salvato e l'editor interno chiuso), ma le caratteristiche grafiche sono indicate nei diversi menù e opzioni al di sopra dell'area in cui si inserisce il testo.

All'inizio, al testo vengono applicate le impostazioni predefinite, che tuttavia si possono modificare secondo necessità. Le nuove impostazioni si applicano solo al testo inserito successivamente, non a quello già inserito. Per modificare il testo già inserito è necessario prima selezionarlo (fare clic con mouse e trascinare, oppure Maiusc+frecce) e poi cambiare le impostazioni.

Per cambiare le impostazioni predefinite è necessario uscire dall'editor interno e andare in File > Preferenze > Strumenti e fare clic sull'icona Proprietà cornice testo (nella vers. 1.2.4, in Impostazioni > Preferenze > Strumenti).

Le impostazioni per le proprietà del testo sono spiegate nella pagina Lavorare con le cornici di testo. Nell'editor interno la disposizione dei controlli è un po' diversa, ma le impostazioni sono le stesse. Tuttavia nell'editor interno non è presente quella per la regolazione della linea di base dei caratteri.

Stili

Uno stile è un insieme di caratteristiche grafiche (tipo e dimensioni del carattere, interlinea, giustificazione, ecc.) che viene applicato a una porzione di testo. L'uso degli stili è particolarmente utile quando diverse caratteristiche grafiche vengono applicate a diverse parti del testo (ad esempio, un certo stile può essere applicato ai titoli di capitolo, un altro ai titoli di paragrafo, un altro ancora al testo normale, ecc.); questo assicura che le parti del testo che hanno la stessa funzione (ad esempio, tutti i titoli di capitolo) abbiano lo stesso aspetto. Inoltre, basta modificare uno stile perché le modifiche abbiano effetto su tutte le parti di testo che usano quello stile.

Nell'editor interno gli stili possono essere applicati al testo (sia prima, sia dopo averlo inserito).

La finestra di dialogo Modifica stili nella vers. 1.3.3.2

Nelle versioni 1.3.3.x non esistono stili predefiniti: tutti gli stili devono essere creati dall'utente. Gli stili possono essere creati nell'editor interno in Modifica > Modifica stili, oppure facendo clic sull'indicatore Nessuno stile a sinistra dell'area di inserimento del testo e selezionando l'opzione Modifica stili. Nella finestra principale gli stili possono essere creati da Modifica > Stili di paragrafo (Modifica > Stili di linea non riguarda il testo). Nella finestra che si apre, facendo clic su Nuovo si apre un'altra finestra in cui si possono impostare le caratteristiche dello stile; il nome predefinito è Nuovo stile che è opportuno cambiare in qualcosa di più descrittivo. È possibile creare quanti stili si vuole, ed essi vengono salvati nel documento; inoltre gli stili possono essere salvati separatamente in un file, che può essere importato successivamente per utilizzare gli stessi stili in altri documenti.

Come il termine Stile di paragrafo suggerisce, uno stile è applicato a un intero paragrafo di testo (da un "a capo" al successivo). Quando si applica uno stile e si continua a inserire del testo, questo stile viene applicato anche ai paragrafi successivi finché non se ne sceglie un altro. Dopo aver creato diversi stili, ci si può dedicare all'inserimento del testo, e applicare in seguito gli stili alle diverse parti del testo. Lo si può fare facendo clic sul pulsante degli stili (accanto a quelli per la giustificazione), oppure sull'indicatore Nessuno stile a sinistra e scegliendone uno tra quelli mostrati.

Notare che quando ci si trova nella finestra principale, lo stile può essere cambiato anche dalla finestra Proprietà, scheda Testo; ma quando si è in modalità Seleziona elemento (che è quella predefinita) il cambiamento di stile si applica a tutto il testo contenuto nella cornice selezionata. Per cambiare lo stile di solo una parte del testo si deve passare alla modalità Modifica contenuto cornice (viene cambiato lo stile del paragrafo in cui si trova il cursore).

Nelle versioni 1.3.4 e successive la gestione degli stili è stata migliorata: oltre agli stili di paragrafo e di linea, esistono anche gli stili di carattere, ed è stato introdotto un nuovo gestore stili.

Come creare capilettera

I capilettera possono essere creati solo dalla finestra di dialogo per la gestione degli stili. Creare un nuovo stile, oppure selezionare lo stile in cui il capolettera deve essere presente, e attivare l'opzione relativa; poi impostare il numero di righe occupate dal capolettera e la spaziatura orizzontale tra esso e il testo. La linea di base del capolettera può essere lievemente alzata o abbassata, ma ciò potrebbe causare problemi di visualizzazione.
Capilettera più elaborati possono essere creati manualmente: vedi questa pagina per istruzioni ed esempi.

Rientri e rientri sporgenti

In basso nella finestra di dialogo Modifica Stili si trovano i controlli per impostare e regolare il rientro della prima riga del paragrafo; si può impostare il rientro anche per le righe successive, in modo da ottenere un rientro sporgente. L'ampiezza del rientro si può impostare agendo sulle frecce oppure modificando i valori numerici.

Il problema delle righe non allineate nelle colonne

Quando si inserisce del testo in una cornice con due o più colonne, può accadere che le righe che si trovano in colonne diverse non siano allineate tra loro. Questa situazione è più frequente quando si sovrappone una cornice immagine alla cornice di testo, e può verificarsi anche in due cornici di testo adiacenti.

Ecco un filmato che mostra come risolvere il problema (versione 1.3.3.x):

Scribus Video: Drop caps, baseline, text frame columns

Ecco come appare il problema:
selezionare Vista > Mostra griglia tipografica
per visualizzare le linee
Ecco come appare la soluzione:
Baseline2.png Baseline3.png

Per risolvere il problema, applicare uno stile di paragrafo. Gli stili possono essere creati e modificati da Modifica > Stili, ma dall'editor interno possono essere anche applicati al testo. Nell'editor interno fare clic su Modifica > Modifica stili per aprire la finestra di dialogo Gestione stili; qui fare clic su Stile paragrafo predefinito, oppure sul pulsante Nuovo e poi scegliere Stile paragrafo. In Distanze e allineamento è presente un menù a discesa in cui è selezionata Interlinea fissa: modificarlo in Allinea alla griglia tipografica. Tornare all'editor interno e applicare questo stile ai paragrafi di testo interessati. L'operazione può essere eseguita anche dalla finestra Proprietà nella scheda Testo.

Nella versione 1.3.3.x scegliere Modifica > Stili di paragrafo nel menù principale, oppure Modifica > Stili nell'editor interno. Fare clic, tenere premuta l'icona accanto all'impostazione dell'interlinea e selezionare Allinea alla griglia tipografica.

La spaziatura della griglia tipografica può essere modificata in File > Impostazioni documento > Guide per il documento corrente, e in File > Preferenze > Guide per i documenti futuri.

Dimensioni del carattere e interlinea

Vi sono alcune particolarità riguardanti la dimensione del carattere e l'interlinea.
Nell'editor interno, quando si modifica la dimensione del carattere, l'interlinea non viene modificata automaticamente. Quindi, se il carattere viene ingrandito oltre un certo limite, vi sarà una sovrapposizione tra i caratteri di righe adiacenti; per evitarla, l'interlinea deve essere regolata manualmente. Quando ci si trova nella finestra principale il funzionamento è diverso: dalla finestra Proprietà > Testo (e quando si è in modalità Seleziona elemento), se si modifica la dimensione del carattere, anche l'interlinea viene automaticamente modificata (le modifiche hanno effetto sull'intera cornice). Le proporzioni dell'interlinea automatica sono impostabili in File > Preferenze > Tipografico > Interlinea automatica. Quando si è in modalità Modifica contenuto cornice il funzionamento è uguale a quello dell'editor interno, cioè un cambiamento delle dimensioni del carattere non provoca automaticamente il cambiamento dell'interlinea, che deve essere regolata manualmente.

In uno stile di paragrafo, se si modifica la dimensione del carattere anche l'interlinea viene adattata; quindi l'utilizzo degli stili evita di dover regolare l'interlinea a mano.

Riassumendo: quando in una cornice di testo si modifica la dimensione del carattere o l'interlinea, è probabile che quest'ultima debba essere regolata manualmente. Usando gli stili, questa regolazione manuale sarà necessaria meno spesso, o comunque sarà più semplice.