Librevenge

From Scribus Wiki
Jump to: navigation, search

For those who always build the latest 1.5.0svn from source for testing, some new dependencies have been introduced to get the full functionality of 1.5.0. These are:

1) librevenge 0.0.1    Install this first
(http://sourceforge.net/projects/libwpd/files/librevenge/librevenge-0.0.1/)
2) libmspub 0.1.0
(http://cgit.freedesktop.org/libreoffice/libmspub/)
3) libvisio 0.1.0
(http://cgit.freedesktop.org/libreoffice/libvisio/)
4) libcdr
(http://cgit.freedesktop.org/libreoffice/libcdr/)
5) libpagemaker
(https://github.com/umanwizard/libpagemaker )

You need to download and extract the source archives of the libraries and then compile and install them yourselves. The procedure is the same for all of them:

1) cd to the respective directory.

2) run ./autogen.sh (This will tell you if other programs like libtool are missing on your computer. You can probably install the missing software via your package manager.)

3) run ./configure

4) run make

5) (as root) run make install, then ldconfig.

Note that librevenge needs to be installed first.

If you are building Scribus 1.5.0svn on Linux, and your distribution provides recent versions of these libraries, you can try to use them instead of building the libraries from source.

(Note http://wiki.scribus.net/canvas/1.5.0_(%3D_1.6.0_Alpha_1)_Roadmap )