Trabalhando com quadros de imagem

From Scribus Wiki
Jump to: navigation, search
Este artigo é parte da seção de Tutoriais.
Instalação Uso Questões sobre PDF DTP Outros
Voltar para a página principal

Versão em inglês.

A intenção deste artigo é listar as operações pertencentes aos quadros de imagem.

Criação

Para criar um quadro de imagem:

  1. Clique no ícone de quadro de imagem na barra de ferramentas.
  2. Selecione o menu Inserir > Quadro de imagem.
  3. Pelo teclado: I ou Alt+N, I.

Isto habilitará o seu mouse à posicionar e redimensionar o quadro de imagem. Clique e segure o esquerdo botão do mouse e então arraste-o diagonalmente na página. O clique determina um canto do quadro, você deve arrastá-lo no sentido oposto a esse ponto (na diagonal).

Menu de contexto

Clique com o botão direito do mouse no quadro para que o menu de contexto/propriedades apareça. Ele contém várias operações comuns de quadro, sendo uma das mais importantes a função para converter quadros de imagem em outros tipos de quadros.

Tamanho e Posicionamento

Propriedades: Aba XYZ

Nesse momento você achará que a Paleta de Propriedades é uma ferramenta indispensável para trabalhar com o Scribus. Se ela não estiver sendo mostrada, mostre-a através do menu Janelas > Propriedades. A aba XYZ mostra informações precisas sobre a posição espacial do quadro no eixo X e Y, a largura e altura do quadro e sua rotação. Note que essas informações apenas estão disponíveis quando um quadro está selecionado (uma linha tracejada vermelha é mostrada ao redor do quadro).

Carregando uma imagem no quadro

Ao criar um quadro de imagem você notará que o quadro está vazio com apenas um X desenhado de ponta a ponta (denotando que não há imagem).

Atualmente os formatos de importação suportados pelo Scribus são: TIFF, JPEG, PNG, GIF, XPM e EPS. Você também pode importar um PDF, mas, apesar disto, por enquanto somente a primeira página do documento será carregada no quadro (veja abaixo um método alternativo). Dicas de tipos de formatos (e suas atuais limitações) estão indicadas na documentação oficial do Scribus.
Menu Ajuda > Manual do Scribus > Documentation > Importing (Tecla F1 > Documentation > Importing).

Carregue uma imagem a partir do menu de contexto (clique direito no quadro) > Obter Imagem (Tecla Ctrl+D) ou do menu Arquivo > Importar > Obter Imagem. Por padrão, a imagem será carregada em seu tamanho nativo com o canto superior esquerdo da imagem no mesmo canto do quadro.

Você pode ajustar o quadro como quiser, mas é mais provável que você também queira ajustar a imagem dentro dele. Se você sabe qual o tamanho final que você quer para o quadro, siga as instruções da seção abaixo.

Sobre SVG

O SVG é um formato vetorial de código aberto e pode ser o formato ideal para DTP de diversas maneiras. O SVG não usa um quadro, eles são importados diretamente como objetos (menu Arquivo > Importar > Importar SVG). O SVG pode ser redimencionado e reposicionado, além de ser editável. Alguns recursos do SVG ainda não são suportados. Por enquanto, o único modo de usar um arquivo SVG num quadro de imagem, é através de sua conversão em um formato de mapas de bits (como os mencionados anteriormente).

Importando PDFs multipáginas

Isto é possível apenas com um editor externo como o Adobe Acrobat. Também há um programa de código aberto e livre chamado pdftk que pode quebrar múltiplas páginas de um PDF em uma só. Por fim, lembre-se que o Scribus pode criar múltiplos PDFs de páginas únicas -- procure por esta opção quando você for exportar o PDF.

Redimensionar e posicionar

Com o mouse:

  1. Clique e arraste em qualquer lugar do quadro para deslocá-lo. Os quadros podem ser posicionados até mesmo fora da página ou entre elas, dependendo da versão do Scribus que você estiver usando;
  2. Clique e arraste qualquer um dos pequenos retângulos vermelhos dispostos sobre a borda do quadro para redimensioná-lo.

Usando a paleta de propriedades:
Existem três modos de alterar as configurações:

  1. Editando através do teclado.
  2. Alterando os valores pelas setas ao lado de cada valor.
  3. Usando a roda do mouse em cada valor --normalmente deixar o cursor sobre o valor já é o suficiente, se não, clique primeiro sobre o valor.

Nas opções 2 e 3, segurar a tecla Ctrl, Shift ou Ctrl+Shift, dará uma precisão decimal ao deslocamento. Veja mais em Atalhos de teclado por tecla. Os valores são proporcionais por padrão. Se você deseja alterá-los em um proporção diferente da original, desmarque as "correntes".

Usando a grade e a guia como auxílio:

  • No menu Página selecione Atrair para a grade (v1.2.4: menu Visualizar > Atrair para a grade) para que os quadros fiquem "grudados" às linhas de grade na página. Exiba ou oculte a grade através do menu Visualizar > Mostrar grade (a grade não é impressa ou se torna parte de um PDF, ela serve apenas como referência).

Você pode ajustar os espaçamentos de pauta da grade pelo menu Arquivo > Preferências > Guias.

  • No menu Página selecione Atrair para a guia (v1.2.4: menu Visualizar > Atrair para a guia) para que os quadro fiquem "grudados" às linhas de guia na página. Exiba ou oculte a grade através do menu Visualizar > Mostrar guia (a guia também não é impressa ou se torna parte de um PDF).

Você pode ajustar a guia pelo menu Arquivo > Preferências > Guias ou em Página > Gerenciar guias.

Rotação

Com o mouse:
Clique no ícone de rotação na barra de ferramentas (Tecla R) e em seguida dentro do quadro. Rotacione no ângulo desejado.

Com a paleta de propriedades:
Funciona da mesma forma que a descrita no item acima. Note que há ainda a opção de escolher qual ponto de rotação será utilizado (o conjunto de botões de seleção).

Copiando quadros e operações similares

Há diversas maneiras de copiar ou mover quadros.

  1. O tradicional copiar, recortar e colar (Teclas Ctrl+C, Ctrl+R e Ctrl+V), acessíveis pelo menu Editar ou pelo menu de contexto. Para colar em um página diferente da selecionada, vá até a página que você deseja adicionar o item e então cole-o — o quadro terá as mesmas coordenadas que na página original.
  2. A opção duplicar (Teclas Ctrl+Alt+Shift+D) Editar > Duplicar. Isto cria uma cópia do objeto original na camada acima do objeto copiado.
  3. O menu Item > Duplicações Múltiplas para criar quantas copias automáticas você quiser do mesmo objeto com uma diferença seqüencial de deslocamento. Você também pode usar esse item para determinar o deslocamento de uma única cópia (assim a opção Item > Duplicar irá usar o mesmo deslocamento).
  4. E por fim, o bloco de rascunhos -- Item > Enviar para o bloco de rascunhos (v1.3.x) ou pelo menu de contexto. Isto criará uma cópia nomeada do quadro selecionado e de seu conteúdo no bloco de rascunhos. Para obter um item salvo no bloco, selecione o menu Janelas > Bloco de rascunhos (Ferramentas > Bloco de rascunhos no v1.2.4) para exibir os itens em seu bloco.

Note que você também pode salvar todo o conteúdo do bloco de rascunhos em um arquivo separado que poderá ser carregado e usado em um outro documento.

A prática o mostrará que até mesmo quadros que estão fora das páginas ainda podem ser copiados, duplicados e manipulados em diversas maneiras. Eles serão salvos na posição em que estão. Se você tentar gerar um PDF, você receberá um aviso que objetos estão fora da página, e, caso você o ignore, o PDF não terá esses objetos. Além disso, especialmente em grandes documentos com múltiplas páginas, você pode perder o controle desses objetos que não fazem parte do documento.

Níveis e camadas

Quadros em geral, não apenas quadros de texto, são representados em um espaço bidimensional no eixo X e Y. Cada quadro é disposto como um bloco de notas — cada folha é posta uma sobre a outra — sendo que essas folhas podem ter sua posição alterada, deixando a primeira folha no fundo e a última no início, por exemplo. Esse controle é feito pela janela de Níveis (dentro do menu Janelas).

Ainda sim, para uma melhor organização dos items, você pode criar um conjunto de camadas para que cada conjunto de objetos seja disposto em diferentes níveis de camada (níveis entre camadas) e objetos (níveis de diferentes objetos na mesma camada).

XYZ: Outras funções

Alguns botões e suas funções:

  1. Espelha o quadro selecionado na horizontal ou na vertical.
  2. Trava o quadro (tamanho, posicionamento, conteúdo etc).
  3. Trava o tamanho do quadro (note que os retângulos vermelhos desaparecem).
  4. Habilita ou desabilita a impressão. Por quê? Bem, você pode querer ter um quadro em uma página que é um lembrete ou uma anotação qualquer que você não queira imprimir, como anotações de cores, tamanhos, contatos etc.

Propriedades: Aba forma

No topo da janela há um botão com um quadrado no centro. Se você clicar nesse botão, uma janela de seleção com múltiplas formas aparecerá, dando outras opções de forma. Você ainda tem a opção de Editar forma através de uma ferramenta de edição vetorial, dando controle total de sua forma.

Uma outra visão sobre formas e quadro de imagens:

Você também pode usar a ferramenta Polígono na barra de ferramentas para criar um polígono regular que posteriormente pode ser convertido usando o menu de contexto (Converter em > Quadro de imagem).

Cantos arredondados:

Essa opção tornará os cantos do quadro arredondados, inclusive com valores negativos.

O texto flui ao redor do quadro:

Use isto para determinar o comportamento do texto "abaixo" do quadro selecionado.

Propriedades: Aba linha

A linha de um quadro de texto se refere a borda do quadro. A primeira coisa que você deve notar é que o valor padrão da cor de linha é nenhum. Você precisa determinar uma cor para poder configurar a linha ou então as alterações não serão aplicadas.

Propriedades: Aba cor

Como dito acima, a cor da linha se refere a cor da borda do quadro, sendo que seu valor padrão é nenhum.

A cor de preenchimento nada mais é que a cor de fundo do quadro. O valor nenhum indica que o fundo do quadro é transparente. A cor do texto pode se definida na aba texto ou através do editor de texto.

  • Intensidade é a saturação da cor, então 0% representaria uma escala cinza neutro.
  • Opacidade é relativo a quantidade do pigmento, sendo que 100% seria totalmente opaco e 0% completamente transparente.

Vale notar que algumas versões de PDF não suportam a transparência de cores, então fique atento.


Overprinting - versões 1.3.4 e posteriores.

Os métodos Knockout X Overprinting estão descritos aqui (em inglês).

Note que você não está limitado apenas a paleta de cores padrão do Scribus. Você pode criar, editar e remover essas cores através do menu Editar > Cores. Remover cores pode simplificar o uso do Scribus além de diminuir o tamanho total dos documentos.

Relacionados