Working with image frames

From Scribus Wiki
Jump to: navigation, search
This article is part of the HOWTOs series.
Installation Usage PDF issues Imposition Other

This article is intended to be a compilation of operations pertaining to image frames.

If you are using 1.3.8/1.3.9, you will find more accurate information in Working with Frames and Working with Images in your handy online manual.

All Working with pages:

Working with text frames
Working with Story Editor
Working with image frames
Working with Master Pages
Working with Scribus: How to begin

Creation

Create an image frame by:

  1. Clicking the Insert Image Frame icon on the toolbar
  2. Selecting Insert > Image Frame from menu
  3. Keyboard: I, or Alt+N, I.

This will enable your mouse to place and size the image frame: click-and-hold-down mouse button, then drag diagonally on the page. The click determines one corner of the frame, letting up the diagonally opposite corner. It may be more conventional to start with the upper-left hand corner, but you may start with any corner to its opposite.

Context Menu

Clicking with the right mouse button brings up the Context Menu, which contains several common frame operations, an important one of which is the ability to convert a Image Frame to another type of frame.

Size and Position

At this point you will find that the Properties window is an indispensible item for working with Scribus. If not already present, open it under the menu item Windows > Properties. The XYZ tab of the Properties window shows very precise information about the X,Y position of the upper left hand corner, the width and height of the frame, and the frame's rotation. Note that information is only displayed for a selected frame -- displayed as a dashed red border. A frame is automatically selected when created. Unselect a frame by clicking on the page outside its borders, select it again by clicking inside. A frame must be selected to be modified or repositioned.

Loading an Image into the Frame

When you first create an Image Frame, it will be blank except for an X drawn from opposite corners, denoting the fact that there is no image.

Acceptable image formats for importing are TIFF, JPEG, PNG, GIF, XPM, and EPS. You may also import a PDF, although at this time only the first page will be loaded into the frame (but see below to work around this problem). See the Scribus Manual, Help > Scribus Manual > Documentation > Importing (keyboard: F1 then Documentation > Importing) for advice about use of formats.

Load an image from the Context Menu (right-click in frame) > Get Image (keyboard: Ctrl+D), from the menu File > Import > Get Image (or its keyboard equivalents). By default, the image will be loaded at its native size, with the upper left corner of the frame the upper left corner of the image.

It is conceivable that you may be able to simply resize the frame, but most likely you will need to adjust scaling of the image. If you know the final size you want the frame to be, follow the directions in the next section, then go to Properties: Image Tab.

What about SVGs?

SVGs are an open source vector graphics format, and in many ways can be an ideal graphics format for DTP. SVGs do not use a frame, but can be imported directly into Scribus using the menu:
File > Import > Import SVG....
SVGs can be resized and repositioned, and some editing capability is also possible. Some file format features are not yet supported in Scribus. At this time the only way to use an SVG file in an image frame is by using a vector-drawing program such as Inkscape to save the file in one of the formats mentioned to the left.

If you do this, you will want to make the size much bigger (higher DPI) than the default to reduce pixelization in your final Scribus product.

Importing multiple pages of a PDF

This is possible presently only with external software, such as Adobe Acrobat. There are several opensource projects which can break up your multi-page PDF into single-page PDFs: One program called pdftk, one written in Java Swing (works in Windows) PDF Split and Merge that can both splitt multiple pages into single pages, and merge different pdf-documents into one document. Moreover, KPDFtool offers an easy to use GUI for simple PDF operations, such as extracting single pages from multipage PDFs. Finally, keep in mind that Scribus can create multiple single-page PDFs -- look for this option when you export to PDF.

With Scribus 1.5 you can also open the PDF and save it converted as a SLA file. This creates a multipage SLA document if the PDF has multiple page. It is then possible to copy an paste the content of the required pages to the document where you want them to be. Or to create single page PDFs through scribus aswell, so as to import them as images in another document.

Properties: XYZ Tab - Resizing, Repositioning

Properties: XYZ tab
With the mouse: With the Properties window:
  1. Click-and-drag anywhere inside the frame to reposition. Frames may even be positioned off the page, or slid from one page to another (depending on Scribus version).
  2. Click-and-drag any of the small red rectangles along the border to resize the frame.
There are three ways to change the individual settings --
  1. editing with the keyboard
  2. clicking on the up or down arrows to the right of each value. The keyboard up and down arrows will accomplish the same thing.
  3. using the mousewheel on each setting -- usually hovering the cursor will be enough, if not, click on the value first

Also note that for 2 and 3, holding down Ctrl, Shift, or Ctrl+Shift (works with up and down arrow keys also) will alter which decimal place is affected. In addition, when using the Properties window width and height are by default linked, but you need only click the chain icon to the right to unlink them.


Some Additional Help

  • From the Menu, Page > Snap to Grid will cause your frame to "stick" to the grid lines on the page. View > Show Grid toggles the grid on and off. (The grid does not print or become part of a PDF.) If you want to adjust the line spacing of the grid, go to File > Preferences > Guides.
  • From the Menu, Page > Snap to Guides will cause your frame to "stick" to guide lines on the page. View > Show Guides toggles them on and off. (Like the grid, guides do not print or become part of a PDF.) If you want to edit or add guides, go to Page > Manage Guides or File > Preferences > Guides .

Properties: Image Tab

If your frame is already the correct size, click Scale to Frame Size. Subsequent adjustments in frame size will adjust scaling to maintain scaling to the frame size. Clicking back to Free Scaling will allow you to crop edges, reposition, or change scaling.

Scaling, Repositioning -- the Image

See Resizing, Repositioning above for instructions on moving and resizing the frame -- Properties: XYZ Tab.

With the mouse on the frame: With the Properties window:
  1. Hold down Shift+Ctrl+Alt. Now clicking and dragging inside the frame will allow you to adjust the position of the image inside the frame (frame stays in place). As soon as you let up on the keys, you go back to moving the frame.
  2. Click on the Edit Contents of Frame icon on the toolbar (keyboard: E). This works like holding down Shift+Ctrl+Alt, except that you stay in the image-moving mode until you click back to Select Item on toolbar, or click outside the frame.
  • To resize the image directly with the mouse on the frame first click on the image frame. Then press F2 to open the Properties window. Select the Images tab. Turn on the Scale to frame size option and the Proportional suboption. Now the image will be resized according to the frame size.
Just as in the XYZ tab, there are three ways to change the individual settings --
  1. editing with the keyboard
  2. clicking on the up or down arrows to the right of each value. The keyboard up and down arrows will accomplish the same thing.
  3. using the mousewheel on each setting -- usually hovering the cursor will be enough, if not, click on the value first

And again note that for 2 and 3, holding down Ctrl, Shift, or Ctrl+Shift (works with up and down arrow keys also) will alter which decimal place is affected. In addition, when using the Properties, X-Scale, Y-Scale, and X-DPI, Y-DPI are by default linked, but you need only click the chain icon to the right to unlink them.

X-Pos, Y-Pos: These refer to the offset of the image inside the frame. Negative values will expose the background color of the frame.

X-Scale, Y-Scale, Actual X-DPI, Actual Y-DPI: Default linked, click the chain to unlink. Obviously, scaling and DPI are inversely related, but for high-quality printed output, knowing the end-product DPI is essential to avoid poor quality results. If your end-product will be a PDF for the web or for a presentation, a lower DPI may suffice. See this page at the Scribus website for more details.

Some Additional Info:

The Context Menu (right-click in frame) > Info will give some basic information about your image -- file source, original and final scaling. The menu item Extras > Manage Pictures may also be of help.

Rotation

With the mouse:

Click the Rotate Item icon on the toolbar (keyboard: R), then click inside the frame and drag-rotate to desired angle.

With the Properties window: XYZ Tab

Just like resizing and repositioning, you have the same three ways to change the rotation digitally. There is also an icon just below (looks something like one of a pair of dice) to alter the point around which rotation takes place -- center or one of the four corners.

Copying Frames and Similar Operations

There are several different ways to copy or move frames.

  1. You should be familiar with Copy and Paste (keyboard: Ctrl+C, Ctrl+V) and Cut and Paste (keyboard: Ctrl+X, Ctrl+V) -- also accessible from Edit on the menu, and from the Context Menu (right-click in frame). To paste to another page, move to that page, click on it, then paste -- the frame will have the same coordinates as on the original page.
  2. There is also Duplicate (keyboard: Ctrl+Alt+Shift+D) Item > Duplicate. This makes a copy which is slightly offset from the original, and on a layer above it.
  3. There is Multiple Duplicate, Item > Multiple Duplicate, which brings up a requestor to automatically create as many copies as you wish, with a sequential adjustable offset. You can also use this for a single duplication when you want to set the offset. Note that once you set the offset here, Item > Duplicate will use this same offset.
  4. Finally, there is the Scrapbook, Item > Send to Scrapbook or from Context Menu (right-click in frame). This will make a named copy of the selected frame and its contents to the Scrapbook. To retrieve a saved item from Scrapbook, select from the menu Windows > Scrapbook, to bring up a requestor to paste an item to a page. Also note that you can save your entire Scrapbook to a file, which can then be loaded and used in another document.

Experimentation will show you that frames can even be outside the document boundaries and still be copied, duplicated and manipulated in various ways. They will even be saved with the document in these locations. If you try to generate a PDF, you will receive error messages about objects not being on the page; if ignored, the PDF will not have these objects. Furthermore, especially in a large multipage document, you may lose track of these off-document objects.

Levels & Layers

Frames in general, not just image frames, represent a two-dimensional space that you manipulate and move around your workspace, much like a small note you can attach and detach. Like small physical notes, they are laid down, one by one, on the page, new ones over the previous ones. The small box labeled Level in the XYZ tab of Properties allows you to move the selected frame up or down levels; the arrows with bars will move all the way to the top or bottom. Since the background of your frame may be opaque or transparent, the level the frame is at will affect how much of the frame can be visible in relationship to other overlapping or underlying frames.

Layers

Layers Tool v1.3.x

When you start a document in Scribus, you are by default working on the Background Layer. This is your active working space, which in turn can have multiple Levels with which you can work. By clicking the menu Windows > Layers (keyboard: F6) you can create new Layers to work on. Each Layer can have multiple Levels, all of which you can edit. As you see in this Layers Tool, an entire Layer can be visible or invisible, may or may not print, and may be locked to prevent accidental editing. You can only work on one Layer at a time -- either highlight it in the Layers Tool, or select with the requester at the bottom of the main window.

For further information on the whys and hows of Layers, check the tutorial: Get Started With Scribus:5.

XYZ Tab: The Rest

The remaining buttons in the XYZ tab do the following:

  1. Flip the selected frame horizontally or vertically
  2. Lock a frame in place. Everything about your frame is locked -- size, position, contents. Copying and pasting a locked frame may produce unexpected results.
  3. Lock the size of the frame only. Note that the editing tabs disappear from the corners and sides.
  4. Enable/disable printing of the frame. Why? You may want to have a frame on the page that's a message to yourself or someone else, yet not be part of the printed finished work. Or the frame may just be a space-saver for some other purpose.

Properties: Shape Tab

Shape tab in Properties, v 1.3.3.x
For image frame, Distance of Text section
will be greyed out (inactive).
Click the Shape tab in Properties. Near the top is a button with a square in the center. If you click that button, you may quickly switch to one of a group of set shapes from your original rectangle. In addition, if you click Edit Shape..., you now have full vector-editing control of your shape.

Another angle on shapes and image frames:

You may also use the Polygon tool on the toolbar (use will be described in detail in another section) to create a regular polygon, which may then be converted using the Context Menu (right-click in the polygon) to Convert To > Image Frame.

Round Corners

Causes an adjustable degree of rounding of the Image Frame corners. Also note the effect of negative values.

Edit Shape requester
v1.3.3.3

Text Flows Around Frame

Use this to determine what happens with text underneath the selected frame.
Remember Levels & Layers?

When you create an image frame, the Bounding Box (of the image) and the Contour Line are the same size and position. But click on Edit Shape... and you can change this Contour Line's size, position, and shape as desired -- check the Edit Contour Line box in the Edit Shape requester.

Close-up in Shape Tab, v1.3.3.x


The appearance in v1.3.4:

Close-up in v1.3.4

Here is an example:

TextflowsExample.png

Below we see that the shape of the image, the Bounding Box (dotted red line), and Contour Line (faint grey dotted line) can occupy separate spaces. The Bounding Box will always have a rectangular shape.

Contourbounding.png

Flowing the text around the image's clipping path

Prepare the image in a bitmap editor (GIMP for example)

  • select the relevant part of image
  • create a mask from the selection and apply it (for removing background)
  • enlarge the selection if in Scribus you want to have a margin between the text and the image
  • create a path from selection
  • export image to TIF format

Apply the path in Scribus

  • load the image into the frame
  • in the context menu, select the image's extended properties
  • select the path you want to use (there may be multiple path stored in the image)
  • in the Properties Palette go to the Shape tab and select "Use Clipping Path"

Tip

The Clipping path is not properly changed when you manually scale the image in the frame. In that case in Scribus 1.4.1 and above you can convert the clipping path to a contour and edit it manually (move, scale).

Properties: Line Tab

The Line of an Image Frame refers to the border of the frame. The first thing to be aware of is that the default setting for Line Color is None, so regardless of the settings in the Line Tab, nothing will show until the Line Color is set.

Otherwise, the various settings for Line are straightforward. If a setting is greyed-out, it does not apply to frames.

Properties: Color Tab

As noted above, the Line Color refers to the border of the frame, with the default being None.

Fill Color means background color of the frame. None for a Fill Color means that the background is transparent.

Shade refers to saturation of the color, so that 0% should represent a neutral grey scale color. Opacity refers to the relative opacity/transparency, with 100% being totally opaque, 0% totally transparent. It is worth noting at this point that some PDF versions and some PDF viewers do not support transparency.

Overprinting versions 1.3.4 and above

Knockout versus Overprinting are described here.

Please note that you are not limited to colors you see displayed in the Color Tab, nor are you compelled to have all these choices. See the Menu item Edit > Colors to add, edit, or remove colors. Removing colors can simplify the use of Scribus, and does reduce saved file size.

(c) Gregory Pittman, 2006, 2007 The content of this page is licensed under the Free Documentation License.