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2 Scribus Quick Start Guide

BEFORE we start explaining Scribus in depth, it might be useful
to get a feeling for the way Scribus works. For that purpose,
you can learn how a simple front page of a magazine for an
imaginary Rembrandt exhibition is being created. If you want
to follow the description provided here, you need:

« the Gentium [1] and Bitstream Vera Sans [2] fonts installed on
your computer.

» Rembrandt’s self-portrait from Wikimedia. [3]
« the Scribus logo from your Scribus install directory.

This is what we want to achieve:

REMBRANDT
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2006

Painting the Dutch Golden Century
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Step One: Creating a Document
and a Page Background

You probably know what happens if you create a new file in a
word processor: the program you’re working with creates a
new page and you can start typing. If a new page is necessary,
the word processor will create a new one. This won’t work in
Scribus (or most other DTP programs). To create a new page,
you have to tell the program to do exactly that. The main pur-
pose of a DTP software is to give you a maximum of control
over design and content of your document. So we click File >
New, and Scribus brings up the following dialog:

< New Document 72 %
~Document Layout—— ~Page Si ~Options
Size: I[Custmm - Mumber of Pages: E
Orientation: | Partrait ~| || Defautt Unit. | Milimetres (mm) |~ |
g a g
— wetn: (10 000] % [aeiant s5 000
Double Sided ~Margin Guides————————————
bk Preset Layouts: | None -]
+| | -] Automatic Text Frames
3.Fald Left 0.00 mm =
Right: 0.00 mm S
Y =9 [E
4-Foid Top: 0.00 mm 2 [Eesrmm B
First Page is: Bottom: 0.00 mm =
T Printer Margins...

For our cover page we will choose a single page layout. Set
the page size to “Custom” and change the default value for
height to 285 mm. This is going to be about the same as US
Letter size. The cover page won’t need any margins, so that we
use 0 mm as the value for all page margins. Leave the rest of
the default settings as they are.

After clicking the “OK” button, Scribus creates a new page:
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Next, we need a gray background for our page. Click on the
white rectangle in the menu bar or simply press S on the key-
board. Yes, you’re reading correctly, pressing S doesn’t mean
anything will be “typed” on the page. To type, you need a spe-
cial environment called text frame, as you will see below. In
this case, we need a shape, thus the keyboard S command.

Your mouse pointer now turns into a rectangle with a + on
its upper left corner. Click and hold the mouse button, then
drag the + across the page and let up — you have just created a
shape. Size, position and color don’t matter here, as we will
soon change them.

DAMA N Wy 2

= 1If you haven’t clicked
* somewhere else on
screen, your new rect-
angle is still selected,
which means it is out-
lined in red dots and
so-called handles at
each corner and the
middle of a line. Now
use Windows > Prop-
erties or press F2 to
bring up the Properties Palette, which is the Swiss Army Knife
of Scribus. You will learn a lot more about its use later. For the
time being, let’s stay in the default tab of this dialog, which is
called X, Y, Z. The more complex a document is, the more use-
ful it is to give each object a unique name. It will make it easi-
er to find and to select it later on. Not surprisingly, we’ll call
our shape “Background.”

Next, we make our rectangle match the size of the page. Re-
member the values we chose for the page? Insert them here,
but first don’t forget to click on the chain symbol to the right
of the boxes for changing the values for width and height. If
you try to do this without unlinking that chain, you will see
that a change in one value changes the other in a proportional
way, and it will seem like you are forever stuck, which you
will be until you unlink that chain.

Now that our rectangle has exactly the size of our page, you
need to make sure that it matches the page borders by setting
its X and Y positions to 0.000 - if you just delete what is there
and replace with 0, then press Tab or Enter, Scribus will make
the decimal point and other zeros for you.

< Properties L=
XY, Z
\|Background] ]I‘

A-Pos; 0.000 mm

Y-Pos: 0.000 mm
Width 210.000 mm
Height. 285 000 mm

X

AW (4w [4]p] [4]] [a]r

Rotation:  |0.00

Basepaint | O |

~Level—

allz s gli=2
v X ! @ =

Shape

Line

Colours

A

The Properties Palette with the
values for the “Background”
shape.
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By clicking the lock icon in the
Properties Palette you can pro-
tect each item against further
changes.
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By default, Scribus uses black as the color for shapes, which
is not what is needed here. Provided our shape is still selected,
we use the Properties Palette again to assign a new color to it.
For that purpose we use the Colors tab. From the list select
“Grey41” as the fill color.
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Each shape and each frame in Scribus has a border. In the case
of shapes the default color is always black. Since we don’t
want any color for our frame border, click on the symbol with
the pen and select the color “None,” which is always at the top
of the list.

Our page background is now finished. To make sure it isn’t
changed unintentionally, return to the X, Y, Z tab of the Proper-
ties Palette and click on the “lock” symbol, so that our back-
ground is protected from any further changes.

Step Two: Inserting the Cover Picture

Now that the background has been created, you need to place
the cover picture. You may be accustomed to inserting images
directly in your word processor, but in Scribus they are inser-
ted in a container (called a frame). For images, or, more pre-
cisely, for bitmap images, we have to create an image frame by
clicking on the image frame icon in the toolbar or by pressing
I (as in image) on the keyboard. Draw your image frame as
you did with the rectangle and go to the X, Y, Z tab of Proper-
ties Palette again.
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Rename this image frame “Rembrandt1,” and for width and
height enter the values as shown in the screenshot on the right.
Our cover picture needs to be placed exactly in the lower right
of our page. How can this be achieved? Actually, it’s quite
simple. We know the X and Y coordinates of our page, namely
210 mm and 285 mm. So you can enter these values in “X-
Pos” and “Y-Pos,” but wait! Not so fast. Before you do that,
first change the basepoint of our object. When you set 0.000
values for the background shape, the values were for the upper
left of the page. But our image will have to align to our lower
right page margins, so we change the basepoint to lower right
before we enter the X and Y values. Also, fix the size of our
image frame by locking it.

To make our design a bit more stylish, let’s add an edited
copy of the image frame. We won’t see much of it, just a small
stripe on the left. Use Item > Multiple Duplicate for this opera-
tion, because it allows us to enter precise numbers for horizont-
al and vertical shift. We need one copy, and for “Horizontal
Shift,” insert -6 mm, as you want to place the copy on the left
of the cover image:

Since the new image
frame is a copy of
“Rembrandtl,” there
is no need to change
its size, and the posi-

-
X

S Multiple Duplicate

Number of Copies: |1

Harizantal Shift: -6.00 mm

wertical Shift; ooomm |2 | tion has been determ-
] ined by the copying

[—]gancel action. Assign the

name “Rembrandt2”

to the frame, but there’s another problem: The new image
frame is placed on top of the frame for the cover picture. The
solution is to move it behind the cover picture. So far, 3 items
have been created, and each new object is placed on top of the
others. Therefore, we simply move the copy one level down,
ie. behind “Rembrandt1.”

Now we have to become a little more serious and bring in
content from outside of Scribus into our document. To load
our cover picture into “Rembrandt1,” right-click on the frame
and click on “Get Image.”

This will open a file dialog, but, as is usual with exhibitions,
there are a huge number of images with similar names in one
directory. How can we identify the correct file? Houston, we
have a problem! Not. Fortunately, Scribus offers a preview in
its file dialog for images:

S Properties

~Geometry
*-Pos: 210.000 mm =
Height  [207.375 mm =]0
Ratation: [0.00 B
o—0
BESEDUH’T a
C—®
~Level—,
Sa)
Shape

Image

Line

Colours

A

Here we changed the basepoint
of the image frame and entered

the correct values for its place-

ment. We

also protected it

against a change of size.

< Properties

a

XY, Z

I|Rembranut2

Geometry
%-Pos
Y-Pas:
Width:
Height:

Rotation:

Basepoint

!

204.000 mm

285.000 mm

172921 mm
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=R
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!

Vove one level down

Image

Line

Colours

€10
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The levels

of items on a page

can be changed in the X, ¥, Z

tab of the

Properties Palette.
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2 open

Lookin: (i3 fome/christoph/Documentsfrembrandt_picst

[RiN_130jpg ¢&)Rembrandt_Harmensz._van_Rijn_141jpg
[Rijn_131jpg ¢fRembrandt_Harmensz._van_Rij

[RiN_132 jpg @IRembrandt_Harmensz._van_Rin_143 jpg

é Rembrandt_Harmensz._van_|
142jpg @]Rembrandt_Harmensz._van_|
! Rembrandt_Harmensz._van_|

[Rin_133jpg f|Rembrandt_Harmensz._van_Rij
| Rijn_134 jng @RembraﬂdLHarmensz ._van_Rijj
[Rin_135jpg ¢z]Rembrandt_Harmensz._van_Ril

Rijn_137.jpg BPENDFEHUIﬁHaFWEHSZ;‘IEH Rij
|Rin_138jpg @Rembrandt_Harmensz._van_Rij
| Rijn_139 jog ﬂRembraﬂdLHarmensz ._van_Rijj

[Rin_140jpg @JRembrandt_Harmensz. van_RIj

il

_Rijn_

_Rijn_

_Rijn_144 jpg ¢&|Rembrandt_Harmensz_van_|

_Rijn_145 jpg ¢@&JRembrandt_Harmensz._van_|

_Rijn_146 jpg ¢&|Rembrandt_Harmensz_van_|
LRijn_136 jpg _¢@&]Rembrandt_Harmensz._van_Rijn_147 jpg ¢&]Rembrandt_Harmensz._van_|

_Rijn_148 jpg ¢JRembrandt_Harmensz._van_|

_Rijn_149 jpg ¢&|Rembrandt_house_-_amsterc

_Rijn_150 jpg ¢IRembrandthuis_Amsterdam j

_Rijn_151jpg ¢&Rembrandt_-_Klesveverlauge

Size: 1256 x 1511
Resolution: 72 72 DPI

[ Colourspace: RGB

File name: [Rembranat_Harmensz _van_Rijn_137.jpg

| [ gpen |

File type: [A\ISUUDUF[EQ Formats (*.gif *.GIF *jpg " jpeg *JPG * JPEG *.png * PNG * xpm *.XPM * tif *.tiff *. TIF * TIFF "l [ Cancel ]

Now that we have identified the correct version of the file,
click on the “Open” button or just double-click, but what’s

that?

It seems obvious that the
size of the image and the
size of the image frame are
not identical twins, but fortu-
nately, the Properties Palette
will come to our rescue and
force them to behave as if
they were. In the Image tab
check “Scale to Frame Size”
and “Proportional” and our
cover picture will be per-
fectly placed.

The next thing we need is
a copy of the “Rembrandt1”
content in “Rembrandt2.”
Right-click on “Rembrandt1”
and click Contents > Copy.
Then right-click on the vis-
ible stripe of “Rembrandt2”
and click Contents > Insert.
The result is everything but
spectacular, so that you will
need to apply some magic to
“Rembrandt2.” Once again,
use the right mouse button to
bring up the context menu,
this time to bring up the “Im-
age Effects” dialog.

In the “Image Effects” dia-
log, let’s go all out and apply
four different effects to the

* Properties

Y. Z

Shape

Image

X-Pos:

¥-Pos:
A-Scale:
Y-Scale;
Actual X-DPI:
Actual Y-DPI:

[Loooom _H
[~]
R
gl
EEENC| -
[ Hf§
[—|z]
gl
-]

(%] Proportional

(@) Scale To Frame Size

Line

Colours
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image: invert, blur (values are Radius: 7.0 and Value: 5.0),
grayscale, and brightness (set to -43):

7 Image Effects 2.0 X

Avallable Effects Effects in use
Blur Invert
Brightness
Calourise Greyscale
Cantrast Brightness
Greyscale
Invert M
Posterise
Sharpen [ << |

Options;

Radius: 70 ]

valug: 50 3\ [a)[+]

[ ok |[ cancel |
Now, that looks a lot better, doesn’t it?
14 [Toa 00

mm [~ [10000% (510 11 G4 @ @ [ tor1 |~| > wi[Backorond [

Info

“ Undo

nd
Get Image

[% Image Visible
Preview Settings
Image Effects
Edit Image
Update Image
Adjust Frame to Image
Attributes
Is Locked

[% size is Locked
Send to Scrapbaok
Level
Canvert to

«f Cut

_1 Copy
Delete
Caontents

(X Properties

Ctri+Z

Ctri+D

Ctri+E

Ctri+L
Ctri+Shift+L

Ctrl+x
Ctri+C

F2

A

The context menu of an image
frame with the option "Image Ef-

fects" selected.
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Step Three: Adding Text

Next, let’s tell our audience who the hero in the image is. For
that purpose, create a text frame by clicking on the text frame
icon in the toolbar or by pressing the T key — surely you’re see-
ing this pattern now. You can create this frame by dragging,
just as you did with the shape. It should be big enough to con-
tain the text as shown below. Then double-click on the text
frame and type REMBRANDT. Next, click somewhere else on
screen and select the text frame again by clicking on it (single
click).

Open the Properties Palette (F2) and click on the Text tab. In
the font selector choose the “Gentium” font, set the font size to
97 pt and choose the text color “White” for Rembrandt’s
name. The result should look like this:

REMBRANDT

TRIETTIE « [&|a]sa
[wi={a==

Style o Style

Language | German

Line
Lalaurs

So far, our cover looks OK, but a bit boring. Time to add some
tasteful features. Historical facts are on our side when we try
to accomplish our task: Rembrandt was the man’s (admittedly
uncommon) first name, while his surname was “van Rijn.” So
create another text frame, double-click and type VAN RIJN.
Choose the same font and the same font size as in the first text
frame, but instead of “White” select “Pink2” as the text color.
“What?” you say, “Pink? Rembrandt would shoot you on the
spot!” Sure he would have, if he wouldn’t have seen where
we’re going with this, but we’re not finished yet. Switch to the
Color tab and set “Shade” to 50% and “Opacity” to 20%. Bet-
ter now? We told you so, and even Rembrandt is happy with
the result — you can almost see him smile.
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Finally, move the “Van Rijn” frame one level down, behind
the “Rembrandt” frame:

REMBRANDT

| Line N
1 culnurs N

Shade: [50% |2
Opacity -2u % 3

AliceBlue [E|
AntiqueWnite
Antiquewnitet

Antiquewhite2
Antiquewhite3
AntiqueWhited
Aquamarine
Aquamarinet
Aquamarine2

5 o
|=|=]=]=]=]=|

EeEE

Aquamarine3
Aguamarined
Azure

Azuret
Aaure2
Azure3

J000mE
=] =] ={ =] =]

]

Now add 3 other text frames and insert the texts “1606,”
“2006” and “Painting the Dutch Golden Century.” Use the Gen-
tium font for all text frames. The numbers need a font size of
53 pt and the text one of 31 pt. Select the text colors “Bisquel”
for “1606,” “Chocolate2” for “2006” and “Gold” for “Pain-
ting ...” After what you’ve learned so far, this should already
be easy. Here’s a design tip: Notice how pleasing this looks,
even though we are using different colors and sizes, when we
use the same font for all these text elements.

REMBRANDT

1606

Painting the Dutch Golden Century

To finish our title, draw a straight line by clicking on the line
icon in the toolbar and dragging with the mouse. Draw your
mouse from left to to right and press Ctrl while you drag to
make sure the line is exactly horizontal. Then open the Proper-
ties Palette and switch to the Line tab. Set the line width to
0.5 pt, then open the Colors tab. Here you open the color list
for lines (pen icon) and select “WhiteSmoke” from the list.

Finally, move our line halfway between the “1606” and the
“2006” text.

2 Properties =

XY, Z

Line

Basepoint: | Left Point n
Type of Line
Start Arrow: End Arrow:

Line Width 0.5pt =i
Enaings

@

Colours

A
In the Line tab of the Properties
Palette you have all options for
lines available, except for the
line color, which is set in the
Color tab.
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Step Four: Adding the Publishing
“Company”

The final steps include adding an imaginary publishing com-
pany and its logo. We’ll decide in modesty to call the company
“Scribus Publishing.” That way, we need not rack our brains
about a logo, but can simply use the Scribus logo. You’ll find
it in the folder ~/share/scribus/icons, where ~ is your
Scribus installation directory. The filename is scribusicon.png.

Now create a small image frame at the bottom our page,
between the page border and the cover image(s). Make sure
the fill color of the image frame is set to “None,” because we
are going to import an image with a transparent background.
Then, as with our first image, we import the icon via right-
click > Get Image. To prevent the icon’s colors from interfer-
ing with the colors chosen for our layout, open the “Image Ef-
fects” dialog, as explained in step two. Setting the image to
“Grayscale” and raising the contrast makes sure the logo won’t
“disappear,” and at the same time it won’t clash with the rest
of our colors.

7 Image Effects ? 0 X
Avallable Effects Effects in use
:Blur Greyscale
Brightness Contrast
Colaurise
Contrast
Greyscale
Invert
Posterise
Sharpen
Optians:
OK Cancel

To add our company name, create a text frame somewhere,
call it “ScribusPublishing” in the X, Y, Z tab of the Properties
Palette and enter the text “Scribus Publishing.” Choose “Bit-
stream Vera Sans” as the font, set the font size to 13 pt and the
font color to “Grey97.”
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Finally, rotate the text frame 90 degrees. The X, Y, Z tab of
the Properties Palette is the right place to do this. Just change
the value for “Rotation” to 90.

Now use the mouse to move the rotated text frame to a posi-
tion above the Scribus logo. Then click File > Save, enter
“Rembrandt-tp” as the file name and click “OK.” Voila! You
just successfully created your first document in Scribus. It
wasn’t that hard, was it?

[1] http://www.sil.org/~gaultney/Gentium

[2] http://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/current/ >
ghostscript-fonts-std-8.11.tar.gz

[3] http://commons.wikimedia.org/wiki/ >
Image:Rembrandt_Harmensz._van_Rijn_137.jpg
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