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  Introduction


  This book is an experiment, using Sigil, to try to make available some information about the operation and usage of Scribus. I was one of the main co-authors of Scribus: The Official Manual, along with Christoph Schäfer, but I wanted to try something easy to edit, and in particular make available in a variety of formats.


  Perhaps it’s a bit sacrilegious to use something other than Scribus for this, but in general we should use whatever tool(s) suit a particular purpose. Competition in this area will only make the various projects stronger, and we have certainly seen in recent years that one project trying to cover all possible uses can quickly become overwhelmed with various issues, not to mention being an unnecessary duplication of effort.


  What I am not going to do is simply upload information from other sources, even if they’re my own creations, which isn’t to say that I won’t re-use material which I think serves a good purpose. It actually turns out that Scribus has been advancing quite rapidly in recent years, and therefore, quite a bit of the information is already outdated from the manual we released in 2009.


  This manual is something of a left-brained effort, meaning that it deals with the mechanics of using Scribus, not much on creative aspects or layout in general. The presumption is that the reader already has some creative talent, or would be better learning from other sources (and practice).


  About Scribus


  What is Scribus?


  This is something of an obligatory question, which I’ll try to answer as simply as I can. The basic task that Scribus sets out to do is to allow you to create a high-quality PDF file, which might be of use as is, for example on the web or in a presentation, but in particular could be sent to a commercial printer for professional printing.


  Scribus might seem brand new to you, but at this point it’s 10 years old, something initially begun by Franz Schmid, who later showed it to Peter Linnell, who readily became involved in the project, after which a number of people have joined the team. If you check under the menu item Help > About Scribus, you can see a complete listing of the past and current contributors.


  Scribus really can cover the gamut of whatever a commercial printer might create, anything from a single-page flyer as an announcement or advertisement, business cards, a newsletter or magazine, a pamplet, or even a full-fledged book. In times past, one might have submitted a manuscript of either typewritten or even handwritten material, after which it was put through a process of typesetting, with some kind of layout created, thus there were a series of middlemen between an author or creator and the finished product. Consequently, this was time-consuming and expensive. Publishers organized all of these various tasks, and consequently expected to be paid for their services.


  Now, of course, with the advent and advancement of computing and printing technology, we have seen the rise of DTP, desktop publishing, which allows for an individual or small group to come up with the content, the layout, and assemble something that is ready to be taken to a printer. We have even seen the advent of POD, or print-on-demand, where one might advertise the availability of a book yet only when the book is ordered is the actual printing, binding, and shipping of that person’s copy accomplished, typically within 24 hours.


  Even though Scribus was very much designed for the needs of commercial printing operations, in the process it more than meets the requirements of someone who plans on not only creating all the material and doing the layout, but also printing themselves on their personal printing equipment.


  Is Scribus for me?


  In a literal sense, it’s for anyone to use as they see fit. It’s available free, and versions are available for Linux (where it all started), Windows (any reasonably current version), Mac OSX (best to have the latest version for the easiest installations), and OS/2 (if you don’t know what this is, you will never need to know).


  Furthermore, it’s open source. This means anyone can download the actual programming commands (mostly written in a programming language called C++), and compile (or “build”) Scribus. If you wanted to you could take the program and make your own version, just be mindful of the license, which mostly lets you do what you want other than claim it as your own. What you are a bit more likely to want to do once you are familiar with Scribus, is to see what’s happening to it as it is developing (it never stops developing). Keep in mind that all programs have bugs, or errors, that might cause problems. Fixing them is part of the development process. If you have run into a bug that is really cramping your use of Scribus and later find out it’s fixed, downloading the fixed code and building may help you immensely. Having said this, you are not likely to have an easy time building on anything other than Linux, unless you already understand something about compiling programs. We have a lot of help for Linux users, and all the ingredients you need are also free.


  Okay, you can get it, but why should you? You should if you seriously care about high quality layout and design, where experience has told you that you need maximum control over the output that you take to a commercial printer or even just print on your own. You especially should if you have experience with proprietary DTP programs, but you can’t afford to buy them for your own use.


  You probably should use Scribus if you’re already doing something like DTP with a wordprocessing program, which are increasingly able to save in a PDF format. If you want to get this commercially printed, you may have problems and the printer may have to process the files (translation: cost to you).


  Getting Scribus


  I’m not going to give much detail about getting and installing Scribus. This is because, once you get the hang of it, it’s quite straightforward. More importantly, it’s better that you learn the locations on the Scribus site that will guide you to downloads as well as provide you with more up to date information than a fixed reference like this book can give.


  If you go either to the main Scribus site, http://www.scribus.net or our wiki at http://wiki.scribus.net, you will see at the top of the page a link labeled Download, and after clicking this you will be on your way. If you’re using Linux, you may find it even easier than this.


  Linux


  If you have one of the main Linux distributions, like Fedora, SUSE, or Debian, there likely is a repository which will have a reasonably up to date version of Scribus. For these, use your typical method, such as yum or apt-get, or you may use a GUI-based package manager. As of the writing of this book, 1.4.1or later should be available as the stable version. If you are interested in building Scribus yourself, maybe even having an older and a newer version simultaneously on your computer, this can be found on the wiki.


  Windows


  For virtually everyone, the place to go for Windows is here: http://wiki.scribus.net/canvas/Download, where you will find a link to a download of a Windows installer.


  Note: You must have Windows XP, 2000, Vista, or 7 to be able to install Scribus. There is only a 32-bit version of Scribus, but this will install and run without problems on 64-bit Windows.


  Mac OS X


  You will have the easiest time of it if you have Leopard (Intel) or Tiger (Intel), since Sourceforge has binary .dmg files for download and installation. Go to http://wiki.scribus.net/canvas/Download as noted above.


  If you have something older than Leopard or a non-Intel machine, all is not lost, but you’ve got some work to do.


  http://wiki.scribus.net/canvas/Installing_Scribus_on_Mac_OS_X_via_Fink


  You can compile on Mac OS X, but this is clearly something for advanced Mac afficianados.


  OS/2 and eComStation


  Scribus will run on OS/2 Warp 4 and every release of eComStation. However, getting all necessary components installed can be tricky. It is therefore recommended that you use eCS 2.0 or later, as this release is being shipped with an older version of Scribus (1.3.8), which as the same requirements as Scribus 1.4, so everything you need is already in place.


  Pronouncing Scribus


  Scribus is pronounced to rhyme with “SKY-bus”, supposedly related to the English word scribes, more than any attempt at a pseudo-Latin word.


  Using Scribus


  
    

  


  
    Now that we’ve gotten through those preliminaries, you have Scribus installed on your system, and it’s time to get started. Go ahead and start Scribus by whatever method you prefer on your system.
  


  Uh, oh, what’s this Ghostscript thing?


  
    There’s a good chance you won’t get a warning about not having Ghostscript if you’re using Linux, since most installations have this automatically. On Windows and Macs, the warning is more likely. Ghostscript is a utility written some time after the invention of PostScript (PS), and it’s not just a coincidence that the two rhyme. PostScript was a language developed so that a computer could send layout commands to a printer for digital layout, and thus it required a printer that could understand PS commands. What was quickly felt to be needed was a way for any computer (in particular those using the Unix operating system) to be able to display these files, and also to be able to print to a non-PostScript capable printer. Thus, the ghostscript utility is able to convert PS files to bitmap and bitmap files to PS. Along the way, Encapsulated PostScript (EPS) was developed. PDF was also developed as a more advanced file format, with many new capabilities.
  


  
    

  


  
    Scribus does not use Ghostscript to create PDFs, but it does use them for conversion of PS, EPS, and PDF files when they need to be rasterized, or converted to bitmap. This occurs when they might be imported into an image frame, and also with Print Preview. Another particular need is for the barcode generator utility, since the barcode is created in EPS.
  


  
    

  


  
    You do not need to have Ghostscript to use Scribus outside of these areas, but it’s easily available and free. You should see a link in the warning that comes up on starting Scribus without Ghostscript installed: http://wiki.scribus.net/canvas/Ghostscript. The instructions you need are there.
  


  
    

  


  New Document


  
    [image: ]

  


  
    When you start Scribus, by default you bring up this New Document dialog. You could simply click the OK button in the right lower quadrant, but instead let’s have a look at these default settings. To do that, we’ll focus in on the various areas you see here.
  


  Page Display


  So here we see the area to choose the page display mode. The default, Single Page, is highlighted. If we have more than one page, they will be arranged in a vertical column, first page on top.

  [image: ]


  
    If we should instead select Double Sided, and have a number of pages,we would see the pages displayed side-by-side, in twos. This can be helpful for the layout of a book-like document, and in this situation, if you imagine an open book, some pages will be right pages and some left. Since the first page of most books is a right page, you would typically choose First Page: Right when this option pops up on choosing the Double Sided display. We’ll see later how you might use this to perform certain actions only on right pages, and others only on left pages.
  


  
    

  


  
    
      
        	Here to the right we see an example of a Double Sided display, shown at a very low zoom. It’s actually one of the newsletter templates that comes with Scribus and consists of 4 pages, the first page being a right page. Of course, when editing you would be viewing at a more normal size and would only be seeing one or two pages, or part of a page at a time. If you bring up one of these templates, you will quickly see that the content is sample text and generic images, so the template is mainly there to give you some sort of structure to begin with, and modify yourself. If you are an absolute beginner with DTP, I suspect you will find these templates a bit overwhelming and confusing, so realistically, it’s probably better to come to understand the basic components and tools before you tackle something with this complexity.

        	[image: ]
      

    

  


  
    

  


  
    I won’t show either 3-Fold or 4-Fold layouts since you can do this on your own. Again, you will still be working with individual pages  if you export or print Double Sided, 3-Fold, or 4-Fold layouts, the pages will print individually.
  


  
    

  


  
    With 3-Fold display you have not only right and left pages, but now also middle pages. With 4-Fold, you have left, middle left, middle right, and right pages. In the small graphic below under the heading Page Size, from the upper right corner of the New Document dialog, you see the bottom item is labeled “First Page is:”, where you choose which type of first page your document will have. The screen shot above was taken with Single Page selected, so you have no choices, but if we select Double Sided, for example, you choose between Right and Left.
  


  Page Size


  
    [image: ]Let’s cover the rest of this section. The first item here, Size, one might also think of as paper type. A common international paper size, A4, is the default size you will see when you use Scribus for the first time. Click on this button, and a very long list can be chosen from, including Letter (in other words, US Letter). The default Orientation is Portrait, thus resulting in these automatic Width and Height settings. With a Landscape orientation, we would see these numbers reversed, of course. We can also see that the default units for a Scribus document are points, i.e., PostScript points (there are 72 points in a US inch). We’ll see later how to use other units in your document. In addition, you will learn how to change these various default settings when you begin a new document in Preferences.
  


  
    

  


  
    The last thing to mention is that way at the bottom of that long list of size choices is Custom, where you can specify any dimensions you wish for width and height.
  


  Margins
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    Once again, we are looking at the situation when a Single Page display is chosen, where preset layouts do not apply, so for the moment we’ll skip this.
  


  
    

  


  
    Below the greyed-out None button we see the spinboxes (more about spinboxes in a later chapter) for the various margins. Margins can be used as a guide to keep your page content from being too close to the edge of the page. This is partly for appearances sake, but also you will typically find that the printer connected to your own computer may not be able to print all the way to the edge of the paper, and thus the button at the bottom so that you can set these margins to your printers limits. Since the margins are only guides, they will not prevent you from putting content wherever you want (even off the page completely!). Also note the weird-looking graphic at the right edge of this screenshot. This is supposed to suggest a chain, in other words a way to link the values in these 4 spinboxes, so changing one changes them all. Click the chain to link, click again to unlink. You will see this used in a number of locations in Scribus.
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    Now we’ll cover Preset Layouts. These will only be available when we have a layout other than Single Page. What is shown here is a depiction of the various time-honored choices available to you in Scribus. From left to right are Gutenberg, Magazine, Fibonacci, Golden Mean, and Nine Parts. We’ll leave it to you to investigate these different kinds of layout. Also worth mentioning is that each of these five images shows an example of a right page. A left page would set the margins as a mirror image of each of these.
  


  Options
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    At least for now, here’s our final area of interest in the New Document dialog. Here you can immediately create more than just the default of a single page. We also see just below one of the places you can indicate what units you want for the page.
  


  
    

  


  
    Automatic Text Frames requires some explanation. If you check this, what you will do is create a text frame on each page (I know we haven’t yet talked about text frames, but suffice it to say for now that if your document contains any text, it must contain text frames). Some further information about this process is that these automatic frames are the size of the page up to whatever margins you have, in other words filling the page to the margins.
  


  
    

  


  
    Depending on the project you’re working on, you may want more than one column of text, so once you select automatic text frames you can then choose how many columns and what size gap you wish to have in between those columns. See Page Units below for some further information
  


  
    

  


  
    In case you don’t sense that Show Document Settings After Creation is self-explanatory, I invite you to check that box before you click OK.
  


  Page Units


  
    We could bring this up at various points in this book but let’s discuss it a bit now. As we saw above, you have an opportunity to choose your page units as you create a document. Furthermore, as we will see later when we discuss Preferences, you can choose your default page units. In fact, at any time you can change page units right on the main canvas (also coming up later).
  


  
    

  


  
    Although the basic default is points, you can also choose millimeters (mm), inches (in), picas (p), centimeters (cm), and ciceros (c). There are 72 points in an inch, and 2.835 points in a millimeter. Picas are an old typographic unit, not used very much except in France, and one pica equals 12 points. Another important thing to know is that one does not use decimals with picas. Instead, one might say that some measurement is 3p3.2, which indicates that the length is 3 picas plus 3.2 points. If you choose picas as your unit, you will see this notation in spinboxes.
  


  
    

  


  
    A cicero is another esoteric unit, defined as 1/6 of a French inch. In case you didn’t know, a French inch is not quite the same as the inch used in North America. Therefore, there are about 1.063 picas to one cicero. Ciceros have a long tradition in typography, so this remains an actively used unit around the world.
  


  
    

  


  
    A personal recommendation of this manual is to select either points or millimeters as your basic page unit. The reason for this is you will find that the precision of placement of items is useful, and also that the various operations to resize and move objects on the page is more gradual with these small units. There is no reason to use picas or ciceros unless you are already familiar with them. You may find that some temporary usage of inches makes some sense when dealing with US Letter paper, but you are encouraged to switch back to a smaller unit as you work with your project.
  


  
    

  


  
    A good reason to become familiar with points is that, regardless of the units you choose for the page, your font size, its line spacing, and other measurements will always be shown in points. So you need to become familiar with points if you want to do serious typography.
  


  
    

  


  
    At this point, if you click OK, a new document will open, and it’s time to get introduced to the Scribus canvas.
  


  The Canvas: Title and Menu
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    This is without doubt such a small image of the Scribus canvas that it makes little sense talking about its details, so we’ll once again show some smaller areas up close so you can see what we’re referring to. Before we do that, we’ll talk about some of the words.
  


  
    

  


  
    In this screenshot, you have what appears to be a document, but really this white rectangular space is only an area to work in. At this point it has no content. The margins you see here will not be printed. The border of the page is highlighted in red to show that this is the page we are currently working on.
  


  Title Bar


  
    In the title bar we see what version of Scribus is running, and inside the brackets the name of current document. If you haven’t named it yet, its name will be Document-N, where N refers to the number of new documents you have created this session. Your first will by default be named Document-1, and even if you save it as something else, the next new document will be named Document-2.

  


  The Menu


  
    

  


  
    In the menu bar we see the following: File, Edit, Item, Insert, Page, View, Extras, Script, Windows, and Help. Now we’ll talk about the various submenus under each. Note that not only can you click on the word to drop down the choices under each, but like many programs, holding down Alt while pressing the underlined letter will also drop down this list. Pressing Alt-F is the same as clicking File for example.
  


  File


  
    
      	New  opens a new document by bringing up the New Document dialog we saw in the last chapter. We won’t discuss this further here, but also notice that to the right, for many of the menu items you are shown a keyboard shortcut. The shortcut for a new document is Ctrl+N.



      	New from Template …  this brings up a dialog showing a variety of templates, so that you can use one of these to begin a new document.



      	Open  brings up a dialog so that you can open an existing, saved document.



      	Open Recent  this will show you a list of the most recently saved documents to choose to open. The default number of documents in the list is 5.



      	Close  close the current document. This does not close Scribus entirely, even if no document is open. You will be asked if you want to save it.



      	Save  saves the current document. If you haven’t named it yet, you will be shown a dialog so that you can name it, but you can save it under the name Document-1 if you wish.



      	Save As  this will give you an opportunity to save the document under a different name, or perhaps just in a different directory.



      	Save as Template…  if you wish you can make your own templates, and if you do so, they will be available when you choose New from Template.



      	Revert to Saved  this will be greyed out (unclickable) if you haven’t saved your document at least once. Let say you are working on a document, save it, continue working on it but then wish to cancel any edits since it was last saved. This will be the quickest way to accomplish that, but keep in mind those edits will be permanently gone.



      	Collect for Output  it’s a bit early to comprehend this if you’re just getting started with Scribus. Collect for Output will not only save the Scribus document, but also collects together all the external files you are using in the document into a directory. The Scribus file you save will have the layout of your document, its text, but only has the filenames for any images. Imagine, though, that you want to work on this same document on another computer or you want to share it with someone else for a collaborative effort. Collect for Output brings all this together, and if you choose even the fonts needed, so that you have a single directory and contents to move or share. This is a good time to mention that if you are someone who is often collaborating on a document project, you would do well to get into the habit of keeping an entire project in a directory for the project.



      	Import here we have some sub-items.



      	
        
          	Get Text  we haven’t yet talked about frames (coming soon!), but this is one of the ways to put text from a file into a text frame.


          	Append Text  Get Text will replace any text already in your text frame, but this choice will add text from a file to what’s already there.


          	Get Image  bitmap images need image frames, so here we can get an image file for your frame.


          	Get Vector File  in contrast to the last item, vector image files do not need an image frame. Scribus can import SVG, EPS, and some other vector files.

        

      


      	Export again, there are sub-items.



      	
        
          	Save Text  again, something specific for text frames. This will let you save (just) the text from a particular frame to a plain text file.


          	Save as EPS  this will save the current page as an Encapsulated PostScript file.


          	Save as PDF  this saves your entire document as a PDF (really what Scribus is all about). There is an icon on the toolbar for this as well.


          	Save as Image  saves the current page as an image file (for example, JPEG, TIFF, or PNG).


          	Save as SVG  saves the current page as an SVG file.

        

      


      	Document Setup and Preferences  these are two different but similar items. Here you can change a variety of settings and defaults. Under Document Settings you can do this for the current document only. If you want to change these settings for future documents (only), select Preferences. We’ll give details in another chapter.



      	Print  this will print your document directly from Scribus, through your computer’s connected printer. You also can print to a file (create a PostScript file). On non-Linux/UNIX systems you must have a PostScript printer driver to print to a file.



      	Print Preview  here you can quickly get an impression of the final appearance of your document, minus various screen features which never print, such as margins. This will be discussed further, but can also be a way to see color separations, among other things.



      	Quit  this not only closes all open documents but shuts down Scribus. You will have a chance to save any files you have open.


    

  


  
    

  


  Edit


  
    
      	Undo  if you have yet to make any content on your page, there will be nothing to undo. Furthermore, while many things are undoable, there still are some that are not. You can expect to see greater Undo ability with each new Scribus release.



      	Redo  this too may have limited applicability, since it isn’t always the case that there is something to redo or that redoing will change anything. Action History is a bit of a different take on this same process  more on this downstream in this chapter



      	Item Action Mode 



      	Cut  Cut/Copy/Paste are pretty standard operations. Paste Recent simply allows you to select from recent additions to the buffer/clipboard to use for a Paste operation.



      	Copy  something else to mention here is that we’re talking here about objects on the page being cut, copied, or pasted.



      	Paste  and another thing to note is that if you cut/copy an object on one page, then paste it on another, it will be pasted to the same X,Y coordinates it had on the original page.



      	Paste Recent



      	Contents  you must have a text or image frame selected for this to be active, and if it is a text frame, your only choice is to clear text from the frame (with a warning to verify). Copy, Paste, and Paste Absolute apply to image frames. Copy is straightforward enough, and then if you Paste the upper left corner of the image lines up with the upper left corner of the frame it’s pasted to. With Paste Absolute, the upper left corner of the image retains its X, Y coordinates relative to the page.

    

  


  
    
      Here is an example of Paste and Paste (Absolute), and their differences.
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      The top picture shows the entire image. Below that is an L-shaped array of 3 smaller frames. If we Copy, then Paste the image to the upper left small frame, and then Paste to the bottom left frame, we see the results. Now Copy the contents of that smaller upper left frame, and Paste (Absolute) to the lower right frame, and now we see the lower right part of the image, as shown here.
    

  


  
    

  


  
    
      	Select All  selects all objects on the current page of your document. Note that if you want to omit some from selection, hold down Shift and click.



      	Advanced Select All  something potentially more useful and certainly more complex than the above. You begin by choosing between on Current Page, on Current Layer, or on Scratch Space, then by type of object and a number of its characteristics.



      	Deselect All  should be self-explanatory.



      	Search/Replace  this only applies to Text frames. One can do a simple search, in which case your text will be highlighted in the frame, or replace. Also note that there are a large number of features to include in the search, like font type, its size, and many other features, which can then be replaced by alternatives. The dialog is well-designed, the important thing to remember is that this feature is there.



      	Edit Text…  again, this only applies to Text frames, and simply brings up the Story Editor. You can also do this with the toolbar icon, and shortcut Ctrl+T.



      	Edit Image…  not surprisingly applies to Image frames. If you have specified an external image editor in Preferences, this will open that with the image in the selected frame. Note that this will be destructive editing (the image will be permanently altered), so you may want to rename your file as you edit and then save it. When you close your image editor, you will need to reload the image. Also keep in mind that there is nondestructive editing with Image Effects available in the Context menu (right-click your image frame). By nondestructive we mean that the appearance of the image will be altered only in the Scribus document, without affecting the actual image file.



      	Edit Source…  this will apply only to the contents of a Render frame, and will bring up the editor appropriate to the type of Render frame content.



      	Colors…  if you already have a document open (even a blank one), you bring up the Edit Colors dialog, where you can add, delete, or modify colors as desired. Modifications might include the name of a color, perhaps useful if you have imported a vector file which might create strange names. If you do not have a document open, Edit Colors brings up the ability to change Color Sets which are quite numerous. Some of them may contain spot colors (specific proprietary inks), so make sure you are aware of what this means.



      	Replace Colors…  here you can imagine that you may have chosen a particular color for a number of purposes, including background of a frame, lines, inside graphics, but now you have changed your mind and what to switch to some other color in all of these areas. You cannot be selective and only replace some.



      	Patterns…  unless you’ve loaded or created some patterns, this will be empty. There are many sources of free patterns and textures, but you can (more or less) convert most Scribus objects into a pattern, by bringing up the context menu and Send to Patterns.
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      Here is an example where I started with a Text frame containing sample text, which I then sent to Patterns. Then another text frame was created with a large letter B, which was converted to Outlines. Now with the outlined letter, I could go to Properties > Color and change the fill of the letter to the pattern I created. A color was used for the line of the letter so it would show up more easily.
    

  


  
    

  


  
    
      	Styles…  this brings up the Style Manager dialog, where you may create and edit Line Styles, Paragraph Styles, and Character Styles.



      	Master Pages…  Master Pages are created when you have some static features you wish to apply to many pages, which might include headings, and page numbers for example. This is where you create and edit Master Pages, which then can apply under Page > Apply Master Page.



      	JavaScripts…  JavaScripts, of course, do not make much sense for a printed PDF, but PDFs can be used online in a form, or used in a presentation, and one might use JavaScript to react to the user in some way, when the form is opened or with various mouse actions.

    

  


  Item


  
    If you have no item selected on the page, this menu selection will be greyed out and inactive.
  


  
    
      	Duplicate  clicking this will create a copy of your selected object with a displacement of +10 points in each of the X and Y directions. If your units of the document are not points the displacement will be the unit’s equivalent of 10 points.



      	Multiple Duplicate  this is a much more useful and flexible way of making one or more duplicates. The dialog is complex and described in detail in the online manual, in Scribus Basics > Multiple Duplicate and Transform.



      	Transform  similarly, check the online manual for a detailed description of usage. The flexibility of Transform is even greater than Multiple Duplicate.



      	Delete  deletes whatever object(s) you have selected. Pressing the Del key is probably more efficient than this.



      	Group  will be greyed out if you have not selected multiple items. This allows you to create a relationship (Group) of 2 or more objects, which then retain their relative relationships as you move them, resize them, and so forth. It’s worth mentioning that selecting a number of objects at once is enough to allow them to be collectively moved, copied and pasted, and other operations without formally grouping.



      	Ungroup  will be greyed out if you have not selected a Group. As you might imagine this breaks up the relationship between a group of objects.



      	Is Locked  locks and unlocks the selected item. Not only locks all of an item’s features, but you cannot delete the item. You can, however, copy and paste to another page, in which case the copy will also be locked.



      	Size is Locked  if this is checked, the item can be deleted.



      	Level  use to move your item up and down levels. Also serves as a reminder of the keyboard shortcuts for these operations.



      	Send to Layer  will only be usable if you have more than one layer in your document.



      	Send to Scrapbook  use the Scrapbook to easily reuse objects from one document to another. Once saved to the Scrapbook, it will be available for any document you are working on.



      	Send to Patterns  just about anything can become a pattern. See the example in Edit > Patterns…



      	Adjust Frame to Image  shrinks/enlarges the frame to its image size at the current resolution.



      	Adjust Image to Frame  shrinks/enlarges the image to fit the frame. This can be proportional or filling the frame in both directions  the checkbox is in Properties > Image, and can be set as a default.



      	Update Image  reloads the image from its file. Remember that a native Scribus file does not contain the image, but only the pathname for the file.



      	Image Effects  allows nondestructive editing of an image for features such as brightness, contrast, blur, sharpen, greyscale, and others. Nondestructive means that the image file is unaltered.



      	Extended Image Properties  if your image format is, for example, PSD (Photoshop), you can make use of features such as clipping paths.



      	Preview Settings  if you have a large number of images in your document, screen updates can be slower. Here you can change the screen resolution or even choose not to display images at all. This does not affect the exporting or resolution of exported images.



      	Attributes  set attributes of an object for some filtering operation, such as creating a table of contents.



      	PDF Options  of the “regular” sorts of frames, only text frames can be set as an annotation or a bookmark. Once you have declared your frame an annotation, then you may set its Annotation Properties  Text, simply showing the contents of the frame when it is clicked or on mouseover (and note that your text frame does not otherwise show except as an annotation marker on the page); Link, creating a link to some other page and X,Y position of the same PDF document; External Link, a link to some page of a different PDF document; and External Web-Link, a link to a URL on the internet or to an email address, if your PDF document viewer allows this.

    

  


  
    
      The last PDF option is Field Properties which only applies to the special page objects used for PDF forms.
    

  


  
    
      	Link Text Frames  if your selected frame is already linked in some fashion, selecting this shows the linkage with connecting arrows from frame to frame. If it is not linked, then click to the next frame to link to. In contrast with the linking done with the toolbar icon, you must select Item > Link Text Frames again to continue further linking. You will generate an error message if you try to link an already linked frame.



      	Unlink Text Frames  only if your selected frame is in a linkage will this be available. As above, selecting this item first shows the current linkage. Clicking a frame in the linkage breaks the link from it to the frame before it.



      	Attach Text to Path  this will only be available when you have simultaneously selected one text frame and one of the following: Bezier curve, shape, or polygon. Once you select this menu operation, your text frame disappears, and its text is applied to the curve, or the border of the shape or polygon. Use Properties > Text tab > Path Text Properties to change various settings about placement of this text on the shape/curve.



      	Detach Text from Path  this may not do as you expect. What happens is that a text frame is created the same size and in the same position as the bounding box of the curve or shape, and the text fills that frame, in other words, your original text frame does not appear. The Bezier curve, shape, or polygon remains, and is underneath this text frame. Use Undo if you wish to reverse the text on path operation and return to the original text frame.



      	Combine Polygons and Split Polygons  the former takes two or more shapes, polygons, and even Bezier curves and combines to a single object. The single object can only have a single color for border and a single color for fill. A Bezier curve will become a closed figure. In addition, splitting the combined polygons doesn’t exactly take you back to the original situation, and even worse, Undo will produce some strange results in most cases. Suffice it to say that you should save your document before trying this out.



      	Path Tools  here we have something with a complex set of possible uses. In some respects it might be considered a more versatile form of Combine Polygons, but it’s complexity requires a great deal of practice and experimentation to grasp how to use the various components. You will only have use of Path Tools with shapes, polygons, and curves (including freeform lines).



      	Lens Effects…and Mesh Distortion… allow for two kinds of ways to stretch and shrink various parts of the selected objects. They are pretty intuitive in their use.



      	Path Operations will be usable when you have more than one shape selected, and works a bit like Combine Polygons but with a number of adjustable parameters as well as a preview of your end result.



      	Create Path from Stroke is a bit difficult to explain simply with words. The image below will hopefully help. This began as an arrow shape having a black border and a fill of None. I then increased the thickness of the border to several points, then selected Item > Path Tools > Create Path from Stroke, and finally changed the fill color to magenta. Thus you can see that the shape has become the former border, and like any shape can still have a border, here a thin black line. To the right, I have converted this shape to an image frame, then loaded an image, and thus where the image fills can be seen as the confines of the shape.


    

  


  
    

  


  
    
      [image: ]

    

  


  
    

  


  
    
      	Spell Checker  The main thing to know about this is that you must have this external tool installed on your system. Use it on a selected text frame.

    

  


  Insert


  
    
      	Frame…  here we have something new for 1.4.0, a different way of making text and image frames. When you click the selection, the dialog below pops up (only part of it is shown). Choose text frame or image frame.
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        Moving on to the Location tab,
      

    

  


  
    
      [image: ]

    

  


  
    
      
        you can now choose which pages to apply this frame to and where its upper left corner will be located.
      

    

  


  
    
      
        Then, in Size we see the following choices:
      


      
        [image: ]

      

    

  


  
    
      
        Lastly, under Options, you can choose the file to import, and for text frames some other features like columns and linking:
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        [image: ]

      

    

  


  
    
      
        On top above is the appearance when text frame is chosen, on the bottom when image frame is chosen. It’s worth mentioning that you do not have to specify a file to load.
      

    

  


  
    
      	Insert Text Frame  this and the next 8 items are equivalent to clicking the toolbar icon that performs the same function. Here you can also see the keyboard equivalent. T for text frame, for example.



      	Insert Image Frame  keyboard: I



      	Insert Render Frame  keyboard: D



      	Insert Table  keyboard: A



      	Insert Shape  keyboard: S. Shapes has some subcategories for selecting the kind of shape, such as Default Shapes, Arrows, Flow Chart, Jigsaw, and Specials.



      	Insert Polygon  keyboard: P. With Polygons, you can bring up a Properties dialog (not to be confused with the Properties palette), for choosing the number of sides, and some other features of the polygon.



      	Insert Line  keyboard: L



      	Insert Bezier Curve  keyboard: B



      	Insert Freehand Line  keyboard: F



      	Sticky Tools  this is an interesting feature which keeps the choice of which object to insert active, so one might create a number of text frames one after the other. Right-click to turn off the sequence, but note that Sticky Tools remains active until deselected. This stickiness also applies to other tools such as rotation.



      	Glyph…  operational only when a text frame is selected and you are in Edit Contents mode. Brings up a dialog for selection of a glyph to insert from the current font.



      	Character  only for text frames in Edit Contents mode. Here you may choose from a list: Page Number (special character for this), Number of Pages, Soft Hyphen, Non Breaking Dash, Copyright (©), Registered Trademark (®), Trademark (™), Solidus, Bullet, Middle Dot, Em Dash, En Dash, Figure Dash, Quotation Dash.



      	Quote  only for text frames in Edit Contents mode. By Quote we mean typographic quotes, which have a number of species, depending on usage and language.



      	Space  only for text frames in Edit Contents mode. You might not think there would be so many kinds of spaces: Non Breaking Space, Em Space, En Space, Thin Space, Thick Space, Mid Space, Hair Space, but also some other sorts are here, like Newline Break, Frame Break, and Column Break. Finally, there is the apparent oxymoron Zero Width Space.



      	Ligature  only for text frames in Edit Contents mode. You have the possibility of having the ligatures for the following letter combinations: ff, fi, fl, ffi, ffl, ft, st. Being able to use these is dependent on them being included in your font. Also note that these are each a single glyph, not simply the regular glyphs pushed together.



      	Sample Text  only for text frames, but can be used in Edit Contents or Select Item mode. A dialog pops up for you to choose a language and amount of text by number of paragraphs. With either mode selected, this will replace the text in your frame (you get a warning about this).



      	Barcode  this is a freestanding item, and therefore has nothing to do with any kind of object. For whatever reason it’s disabled in Edit Contents mode, but otherwise will work whether you have some frame selected or not. You have a choice between 18 different types of barcodes. This will generate a PostScript image, which then you place with your mouse. As such, it requires that you have Ghostscript installed on your system, and also that Scribus knows where it is.


    

  


  
    Page

  


  
    
      	Insert…  allows adding one or more pages into your document, at End, or elsewhere as you choose. You can also choose which Master Page to apply, and you can change the page size if you wish, as well as its orientation (maybe of more use for PDFs not intended to be printed).
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      	Import…  here you can import an individual or selected pages from another Scribus document. You can place them where you wish in the current document, but they will all need to be inserted sequentially. Along with these pages will come any styles you may have used in the source document, and also any custom colors.



      	Delete…  just like it says. Will delete an individual or a sequence of contiguous pages.



      	Copy…  will copy a page, but it doesn’t have to be the current page. You can add more than one copy and place where you wish.



      	Move…  will move one or more pages to a location of your choice. If you are moving more than one page, the page number in the To: spinbox must be greater than the number in the other box, otherwise, you will only move the single page numbered in the To: spinbox.



      	Apply Master Page…  applies a Master Page to the Current Page, Odd Pages, Even Pages, or All Pages. Needless to say, perhaps, but you must have created some Master Pages for this to be worthwhile.



      	Convert to Master Page  makes a Master Page from the current page, and if you wish will also include any content from a Master Page that you applied to this page. It’s worth mentioning here that you cannot apply more than one kind of Master Page to a page in your document.



      	Manage Guides…  this is your one-stop shopping for creating, deleting, editing guides, individually or in multiples (in the Column/Row tab), and if you wish you can apply the guides to all pages here. In the Misc tab, you can delete all the guides from the current page, or all the guides from the entire document.



      	Manage Page Properties…  here is an opportunity to change various features of the current page: its size, its orientation, the margins, use a preset layout, and even apply a Master Page.



      	Snap to Grid  whether or not you are showing a grid, you can choose to create a stickiness of the grid, so some object you are moving will tend to stick to the lines of the grid. Makes more sense when the grid can be seen (see View > Grid).



      	Snap to Guides  a similar property for the guides. Even though it could be confusing or irritating you can have both Snap to Grid and Snap to Guides selected.


    

  


  
    View
  


  
    
      The first 7 selections in View are shortcuts to various degrees of zoom.
    

  


  
    
      	Fit to Height



      	Fit to Width



      	50%



      	75%


      	100%


      	200%


      	400%

    

  


  
    
      	Preview Mode  will give a simulated view of how your document will look, without any nonprinting markings such as margins, frame borders, grid and guides, and so on.


    

  


  
    

  


  
    
      The remaining selections show or hide various canvas features.
    

  


  
    
      	Show Margins


      	Show Bleeds


      	Show Frames


      	Show Layer Indicators


      	Show Images


      	Show Grid


      	Show Guides


      	Show Text Frame Columns


      	Show Baseline Grid  used to align text from one frame to another, by setting line spacing to Align to Baseline Grid.


      	Show Text Chain  a series of arrows indicates linked frames.


      	Show Control Characters  shows markers for various white space areas, such as spaces, soft line breaks, newline, tab, and so forth.


      	Show Rulers


      	Rulers Relative to Page  when selected aligns the 0,0 of the rulers to the upper left corner of the page.


      	Move/Resize Value Indicators

    

  


  Extras


  
    
      	Manage Images  this brings up a dialog showing thumbnails of the images in your document, along with a number of their properties, and the filename. If Scribus cannot find the image, there is a search function. You can also go to the page where any image is located, and select the frame.



      	Hyphenate Text  this turns on hyphenation for a selected frame. In File > Preferences > Hyphenator you will find a number of settings for this, such as exceptions, and limiting the smallness of a word which might be hyphenated. You can also have hyphenation turned on by default.



      	Dehyphenate Text  turns off hyphenation.



      	Generate Table of Contents  you must first set up a table of contents. On the Scribus wiki there is a explanation of the process, under Tips & Tricks: Creating a Table of Contents. Briefly, this involves


    

  


  
    
      
        Going to File > Document Setup > Table of Contents and Indexes.
      

    

  


  
    
      
        Create a table of contents named as you wish.
      

    

  


  
    
      	Color Wheel  this is a very complex dialog, which allows you to select color schemes according to various considerations of color theory and design. What you can do is select various patterns of similar and complementary colors, then modify these according to taste. Afterward, you can use these colors, and merge them with the existing palette you are using. Another potentially useful feature is an ability to simulate various types of color blindness, so you can maintain contrast between colors when this is necessary. Also note that you can also check these color blindness settings on the main screen in Preview mode, using the list button in the lower right side of the bottom toolbar.



      	Font Preview  this will bring up a dialog to interactively search for and check the appearance of various fonts using some standard text or text of your own choosing. You can also see various information about the font as you might also find in File > Preferences > Fonts.



      	Short Words  it helps to know what this refers to. This is used to prevent a line break between selected words. An example might be Dr. John Smith, where you do not want a line break to occur immediately after Dr., since this would be confusing while reading. The list of these short words for various languages can be found in File > Preferences > Short Words, where you can also edit this list as desired. Also to be seen in the dialog is that you may choose to apply some other language to particular text frames, although there can only be one alternative language per frame.


    

  


  Script



  
    
      	Scribus Scripts >  this will show a list of scripts included with Scribus. Each will have its own requirements and uses. Some may be used on a certain kind of selected frame, such as Autoquote for transforming typewriter quotes into typographical quotes, others may require a document to exist and have certain features. Others may create a document from scratch, such as Calendar Wizard.



      	Execute Script…  with this item you can execute your own script, which might be located anywhere on your computer, but you can specify in File > Preferences > General where you want to begin looking for scripts.



      	Recent Scripts >  shows you a list of your own executed scripts, if you have done so. Note that this list will not included built-in scripts you might have used.



      	Show Console  brings up a text entry space where you can interactively work on a script and try it out periodically as you go. Keep in mind that writing scripts requires some knowledge of the Python programming language and its syntax.



      	About Script…  if your script has been made following recommended practice, it will include a section which is marked off as a comment, and which explains what the script does and how to use it. For example, the message for Autoquote says:

    

  


  
    
      
        USAGE
      

    


    
      
        

      

    


    
      
        You must have a document open, and a text frame selected. There will be a valueDialog asking for your language for the quotes, the default is ‘en’, but change the default to suit your needs. Detected errors shut down the script with an appropriate message.
      

    

  


  Windows



  
    
      	Cascade and Tile  these only have meaning when you have more than one document open simultaneously, and represent different ways to display more than one file on screen for the purposes of moving from one file to the next. Note that even if you may show more than one document at a time, you will not be able to slide content from one to the next, though you can for example copy and paste between visible documents.



      	Properties  this menu item, and the keyboard shortcut F2 show or hide the Properties palette. Unless you are quite cramped for screen space, you will likely have this showing most of the time.



      	Outline  when you first click this you might think it merely displays the document name, but this can be expanded into a tree structure listing of master page used, each page and each page’s items. Even more useful is the ability to click on an item, causing the canvas to jump to that page and select the item. Furthermore, if you right-click on the list, in addition you will show the appropriate context menu for the selected item.



      	Scrapbook  this will bring up the scrapbook, useful for saving objects to be used in a future (or the same) document. To save something to the scrapbook, right-click the object for the context menu, and select Send to Scrapbook, after which you will have a choice of naming your item in the Scrapbook. You can also have different folders of scrapbook items, selectable by tabs. Thereafter, when you start up Scribus, these items will be available to you. To use an item in the scrapbook, left-click and drag to your document, or right-click and select Paste to Page, in which case it will be pasted on the current page, at the coordinates of the original. There are other options available with right clicking, including renaming the item or deleting it.



      	Layers  brings up the Layers dialog. A new document will have one layer, the default Background which cannot be deleted, though it can be renamed. If you open the online manual, read Working with Layers for the details. Some brief points to make: you can only work on one layer at a time. Any layer may have a number of objects on it, and is either above or below other layers. Although the default layer is named Background, it can be renamed, and it doesn’t have to be the bottom layer. At the top of the Layers dialog, there is a drop-down list to choose a Blend Mode (Normal, Darken, Lighten, Multiply, Screen, Overlay, Hard Light, Soft Light, Difference, Exclusion). This will only apply to layers other than the bottom layer, where objects overlay other objects. These are pretty standard algorithms for blending best understood by experimentation. The other choice at the top is Opacity, which can refer to which ever layer is selected.



      	Arrange Pages  this dialog does more than the name suggests. At the top you will see a list of Master Pages, which you might click-drag to assign to a particular page, shown in the window underneath. If you double-click on a Master Page name, you bring up the Edit Master Pages dialog. You can also rearrange the order of pages as the name suggests, but simply dragging page icons around. At the bottom, you can change the display of your document to any of the available modes, Single Page, Double-Sided, 3-Fold, and 4-Fold. In the bottom right corner is a trashcan icon, where you can drag a page or Master Page to delete it. You cannot delete the Normal Master Page, and you cannot delete the final page remaining in your document.



      	Bookmarks  this is a simple list of any PDF bookmarks you may have created, with the text of the bookmark displayed. There is no other functionality.



      	Measurements  the measurements dialog allows you to sequentially take linear distance measurements with the mouse. Only a single line is shown. The dialog allows you to choose some other unit than your document is set for, and without changing the display units. You stay in this measuring mode until you close the Measurements dialog.



      	Action History  whenever you Undo or Redo some operation, you know that obviously Scribus has some record of prior operations, as well at things you have undone. The Action History dialog shows you this list, either for the entire document or a particular selected item. Thus you can click to jump back or forward along that history of actions.



      	Preflight Verifier  this normally runs whenever you export to PDF (unless you have disabled it). Thus you have a check regarding any potential problems which may cause errors in your export operation, such as overflow of text in a frame, a missing image, or items which are not on the page.



      	Align and Distribute  these are really two separate parts of one dialog. It’s worth first pointing out that this is an interactive function, allowing you to go back and forth from the dialog and the document, selecting various objects and then making sequential choices in the dialog. Secondly, these operations are not undoable, so you may want to save your document before you experiment and at intervals.


    

  


  Context Menus


  
    These are small or not so small selection dialogs which pop up when you right-click various things.
  


  Toolbar


  
    [image: ]

  


  Right-click the toolbar, and this appears, allowing you to show or hide these various sections of the toolbar tools.


  Rulers


  
    What you are clicking here is the small square in the upper left corner of the horizontal and vertical rulers. If you left-click on that square, you toggle between having the 0,0 of the rulers at the upper left corner of the page and the upper left corner of the scratch space. Right-clicking brings up the following:
  


  
    
      	[image: ]

      	[image: ]
    

  


  The smaller menu to the left is the first one you see, then if you mouse over the Move on current Page >, you see the larger one on the right also. Reset Rulers brings 0,0 back to the upper left corner of the page. The list in the right context menu allows you to set the origin in these alternative locations, but note that if you subsequently click Reset Rulers, you take the origin back to the upper left corner of the page.


  Page
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    This will come up when you right-click on an empty area of a page. Although there is quite a list here, we've seen many of these before in the menu.
  


  
    Paste File... allows you to import a vector image file (such as SVG, EPS, PDF) onto your page, initially with the upper left corner of your image wherever you clicked. So this is similar to File > Import > Get Vector File...
  


  
    Undo here shows that there is some action which can be undone, just as we would in Edit > Undo. This action will also be seen with Windows > Action History.
  


  
    Everything from Show Margins to Rulers Relative to Page can also be found under View in the menu.
  


  
    Snap to Grid and Snap to Guides are found under the menu item Page.
  


  
    Apply Master Page..., Manage Guides..., and Manage Page Properties... are also found under Page.
  


  Text Frame


  
    
      [image: ]

    

  


  Everything here is of course going to apply to the text frame you right-click to show it. We'll take these one-by-one.


  
    	Info mousing over this brings out a strictly informational listing of Text Frame (i.e., what this menu applies to), then tells you how many paragraphs, lines, words, and characters there are in the frame, and finally whether Print is enabled or disabled for it. If you see numbers in parentheses, these indicate paragraphs, lines, and so on which have overflowed, and therefore are not visible.


    	Undo with versions 1.4+, you can now undo text editing, something not previously possible.


    	Redo


    	Get Text...use this to import text from a file for an empty frame or to replace what is already there.


    	Append Text...as you might expect, you can simply add text from a file to that already there, and it will be appended at the end. What you might not expect is that even in Edit Contents mode, with the cursor somewhere in the middle of text, new text will still be appended at the end of the contents of the frame, and even if it's not visible due to overflow.


    	Edit Text...brings up the Story Editor.


    	Sample Textuse this to load paragraphs of one of the various forms of Lorem Ipsum that are available in Latin and many other languages.


    	Attributes...is used in connection with File > Preferences (or Document Setup) > Table of Contents and Indexes to generate these products of your document.



    	PDF Optionsone of the options for text frames is that they can be PDF annotations or bookmark.



    	
      
        	is PDF Annotationonce you select this, you then have a choice of properties for the annotation (another item, Annotation Properties, appears for your selection). The default is Text, and if you select this item, whatever text the frame contains only shows when you mouse over it in the PDF, or when you right-click to show it persistently. If you choose Link,the frame shows no text, but is used to link to some other page in the document. Choose External Link to jump to some page in another PDF document, and finally you may choose External Web-Link to link on the internet, or even generate an email to a specified address (your PDF viewer needs to have these capabilities for this to work).


        	is PDF Bookmarkyour text will show normally, but the frame can be used for navigation through the document with your PDF viewer.

      

    


    	Is Locked if this is selected, you cannot edit, move, or delete this frame. Something you can do is to Duplicate the frame, and the copy will not be locked.


    	Size is Locked only locks the size of the frame.


    	Send to Scrapbook sends this frame as a copy to the Scrapbook.


    	Send to Patterns if you check the chapter about the menu, under Edit > Patterns you will see an example of a pattern made from a text frame. Note that this pattern will include any background color the frame might have.


    	Send to Layer this item, not shown above, will only be seen if your document has more then one layer.


    	Level move your frame up and down above and below other objects on the layer of the page. This item will not be present if your frame is locked.


    	Convert to your choices for a text frame will be to convert to an Image frame, Outlines, or Polygon. For outlines, each glyph in the frame is converted to a vector shape, and the shapes are grouped.


    	Cut, Copy and Delete perform these operations on the entire frame and contents. If you cut or copy, you can then use Edit > Paste to make a copy on the same or another page, with the same coordinates.


    	Contents brings up a side box to select Clear, so that you can clear all the text from the frame.


    	Properties simply shows or hides the Properties palette.

  


  


  Image Frame
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    A mostly similar context menu for image frames.
  


  
    	Infohere the information we get is Image (frame), the filename but not the full path, the resolution or PPI (pixels per inch) of the original image, the PPI of the image as incorporated in the document (how it will be in the final PDF), the colorspace of the image (RGB, for example), and whether print is enabled.


    	Undo/Redojust as before


    	Get Image...brings up a file dialog to load an image.


    	Adjust Frame to Image this will enlarge or shrink the frame to include the entire image, depending on its resolution.


    	Adjust Image to Frame this changes the resolution to allow the entire image to fit the frame as it is. The default is for this to keep the image proportional, but this setting can be changed in Properties > Image tab.


    	More info...(not shown above) photographic images and other complex graphics can have other information available, such as the date and time of the photo, possibly an embedded profile, and at any rate you should see what profile is being used for this image. You should see if there are embedded paths or layers in the image. Otherwise, you can expect to see some other EXIF information that may have been saved by the camera which took the image.


    	Update Image since you can edit an image in an external editor, when you come back to Scribus you will want to update the image from the file.


    	Preview Settingsone thing you can do here is to chose to have the Image Visible or not, but also set the display resolution as Low, Normal, or Full.


    	Image Effects this allows for nondesctructive editing within Scribus. The actual image file is not changed, but only modified for display and the final PDF. Choices are Blur, Brightness, Colorize, Duoton, Tritone, Quadtone, Contrast, Grayscale, Curves, Invert, Posterize, Sharpen.


    	Edit Image... brings up the external image editor you have selected with the image loaded. This will be destructive editingthe actual file will be changed.


    	Attributes... similar to what we saw in text frames.


    	Is Locked all features locked. Frame cannot be deleted, but can be copied.


    	Size is Locked only size locked.


    	Send to Scrapbook as with text frames.


    	Send to Patterns allows using the image as a pattern.


    	Send to Layer here we see this appear, since there was more than one layer when this snapshot was taken.


    	Level as with text frames.


    	Convert to our choices for conversion are Polygon and Text Frame.


    	Cut, Copy, Delete as noted in text frames.


    	Properties again, shows/hides the Properties palette.

  


  Shapes/Polygons
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  Shapes and Polygons have identical context menus. Since neither have content in the sense of text or images, the menus are simpler. The common choices are all analogous.


  
    	Convert to choices are Bezier curve, Image Frame, Text Frame.

  


  Render Frame
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  Render frames have their own peculiarities, yet mostly have the same choices as we have already seen. The new bits are:


  
    
      	Info this starts with Render Frame, then what application you are using to generate the image, then the DPI, the State (Finished or not), and whether print is enabled.


      	Edit Source... the source for a render frame is of course text, so this brings up the editing dialog.


      	Update Image re-render the image.


      	Preview Settings since we create an image, this shares this item with image frames.

    
Note that you can't Convert a render frame to anything else.
  


  
    

  


  Vector Graphics and Groups
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  Almost all of this we have seen before. The exception is:



  
    	Ungroup this is here because, most of the time, imported vector graphics will be a group of individual elements, which Scribus will group together. If you want to edit the vector graphic, you will need to ungroup it first.

  


  If you right-click on an ungrouped collection of selected objects, you will see this same context menu, which will also contain a Group item.



  PDF Forms Elements


  Button, Text Field, Check Box, Combo Box, Listbox


  
    These can be considered specialized text frames. What sets them apart is that where a PDF option for a text frame might be Annotation Properties, for these it is Field Properties. Except for the ability to switch from one kind of form element to another using the Field Properties dialog, all of the context menu options are the same as with text frames, including conversion to the same list of choices.
  


  Text Annotation, Link Annotation


  
    These truly are text frames with PDF Options > Is PDF Annotation selected.
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