FAQ: Installing and Running Scribus

From Scribus Wiki
Revision as of 17:01, 7 June 2014 by Alevati (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Installing and running Scribus

Which Scribus should I install on my computer?

Platform

How do I get Scribus for Linux?

  • If you don't need anything fancy, use your packet manager to install Scribus (synaptics, yum, apt-get, ...). This is the preferred way to install Scribus.
  • If you want to be more up to date than your distribution is, you can add Scribus's own repositories. They are available for Debian, Ubuntu, Fedora, CentOS, Red Hat, OpenSuse, SUSE Linux Enterprise, and Mandriva. This is the preferred way to install Scribus.
  • If you want to test the newest feature (or if there are no binaries for your platform) you can compile the source code you get from sourceforge or from the (svn://scribus.net)

How do I get Scribus for OS X?

  • Installers for the stable version (Intel only, Leopard (10.5) or higher) are available on the download page
  • Snapshots of the development version are available on Sourceforge.
  • At the moment, there is no (easy) way to compile yourself Scribus for OS X
  • You can get a Ghostscript .dmg from here
  • Images (.dmg) for more recent development versions won't work on OS X 10.4. If you want to install Scribus 1.3.8 or later you will have to install it through Fink:
    • Install Fink.
    • Then install finkcommander.
    • Activate the unstable packages (fink commander > preferences > fink, Use unstable packages").
    • Install scribus-135+ from sources or binaries (if you also install qt4 from sources, it will take a long time, but it will work).

How do I get Scribus for Windows?

Which version should I use?

The current stable version is 1.4.4. The previous stable version (now abandoned) was 1.3.3.14.

As a rule of thumb: all versions that have an odd number as a second (minor) version number (1.1, 1.3, 1.5, 1.7) are unstable/development versions, all version with an even minor number are stable versions (1.0, 1.2, 1.4, 1.6, ...)
1.3.3.x is an exception and was declared stable because 1.2 was too old and 1.4 was too far away.

Stable version

1.4.4 is the stable version – use it for your normal work. Please remember that documents created with 1.4.x versions cannot be opened by previous versions.

Experimental branch

1.5 is the current experimental branch: Only for people wanting to experiment with the latest Scribus features should use it. Remember, you cannot open 1.5 in older Scribus versions.

Compatibility

Since its beginnings, Scribus has always maintained backward compatibility, so that every later version will be able to load a file from an earlier version. Because new features are added, the reverse is not true. For example, you can't load a 1.3.6 file into 1.3.3.14, but you can load 1.3.3.x files into 1.3.6+ and 1.5.

So which one should I use?

If you are still wondering, please use the stable 1.4.4. If you have purchased or plan to purchase Scribus: The Official Manual, the book was based on the 1.3.3.x series, but it can be used with later versions, too.

How do I compile Scribus?

There may be a few reasons for you to compile Scribus yourself:

  • There is no current Scribus for your platform (like Linux PPC or Mac OS X 10.4).
  • You need a fix that has been applied after the latest binary snapshot has been released.
  • You want to follow Scribus development to stay up to date and to test.

In the first case you should download a snapshot source package from Sourceforge. In all the other cases you're better off if you get the source code via subversion.

Further reading:

Dependencies

See the compilation requirements.

Install-related problems

Where is my Ghostscript?

You have successfully installed Scribus and now you see a warning that Ghostscript is missing.

One approach is to simply ignore the warning, as you only need it for EPS import and the Print Preview. Or you can install it later.

Linux

It's highly unlikely you would ever get this alert under Linux, unless you have installed Ghostscript in some quite nonstandard location. If it happens anyway, just use your package manager to install Ghostscript.

Mac OS X

Once Ghostscript has been installed, go to Scribus > Preferences > External Tools, and browse (Change...) for the gs executable (the path will be something like "/usr/local/bin/gs").

Microsoft Windows
  • First of all, you need to download the Ghostscript installer.
  • Once installed, Scribus needs to find it, which may or may not work automatically on Windows. If Scribus doesn't detect the Ghostscript executable after the installation, go to File > Preferences > External Tools, and browse ("Change...") for the gs executable. For 32-bit, its gswin32c.exe, the important thing being that "c", since there is another executable without a "c" in the file name.

Startup issues

Scribus is slow to launch. Why?

For those who are new at desktop publishing, unlike most programs, DTP applications care greatly about which fonts are installed and if the font paths are valid. So, when Scribus launches, one of the things it does is to completely and thoroughly scan your font paths and ensure they are valid. This takes time. If you have a large number of fonts (200+) or more and slow launch times are a problem, reduce the number of fonts or font paths.

The other reason is your scrapbook is filled with complex or large image files. Deleting unneeded items or saving the scrapbook under a different name and then creating a new blank scrapbook will also help reduce the startup time.

Plugins

How can I find a plug-in?

All of the stable plug-ins accepted by the devel team are in the current release. Anyone interested in creating a plug-in is invited to look at Plugin_Architecture.