Footnotes

From Scribus Wiki
Revision as of 14:40, 9 September 2013 by Jsamudio (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Other languages: Español (es)

This page is an attempt to describe the creation of footnotes in 1.5.0svn. It mainly represents a series of observations on creating and editing footnotes.

Use Edit Contents Mode

This isn't just a recommendation, it's currently the only way to create footnotes. You will not find any method in Story Editor.

Elements of Footnote Creation

  • Edit > Styles – I am mentioning this first, since even though it's not central or absolutely required for creating footnotes, probably with few exceptions you will want to create a paragraph or character style for your footnotes, even if it's just a variant of your main text style.
  • Edit > Marks – this brings up the Marks Manager dialog. Until you actually have some footnotes (one kind of Mark), you won't see anything to do here.
  • Edit > Notes Styles – here is where you will be applying your paragraph and character styles to create Notes Styles.
  • Item > Welding – for the moment, don't worry about what welding has to do with Scribus or footnotes. We'll get there soon enough.
  • Insert > Marks – this as you might expect is where the action is in actually inserting a footnote mark somewhere in the text. You might just start at this point, by beginning to create footnotes, but it's still going to be important sooner or later to understand those other aspects of footnotes.

Insert > Marks

Footnotes.png Let's just quickly show what happens here, realizing that once you get an understanding of footnotes, your workflow may not necessarily begin here. Here is a two-column layout of some sample text we'll use for our examples. Remember that you need to be Edit Contents mode to insert a footnote – you will find Insert > Marks greyed out if you're not. So double-click at the point you wish to insert a footnote.

Now select Insert > Marks > Foot/End Note. Two things happen, only one of which you will be immediately aware of – your screen focus will change to the bottom of your frame, and you see this:

Footnotes2.png

What you can't see in this screenshot is that your cursor has moved here so that you can begin making your footnote entry.

Footnotes3.png

As text is added, this space enlarges to contain however many lines you type.

Footnotes4.png
The other part you're not immediately aware of, even though you're expecting it, is that you have added the references to your footnote where you initially placed your cursor to create them.
Footnotes5.png

Welding

Don't worry, no concern about getting out your smoked glass helmet. Something you can see in the screenshots of the footnote frames above is the small yellow rectangle at the joint of our original text frame and this new footnote frame. This indicates the two frames are welded, and as you might expect you can't pull them apart. If you move one, the other moves right along with it.

This might seem like grouping, but it has some different characteristics. You can resize the main text frame, either by using the mouse or the settings in Properties > XYZ, but if you narrow it, the footnote frame also narrows. If you shorten it, the footnote frame stays right against the bottom of the shortened frame.

On the other hand, you can move the footnote frame, either with the mouse or with X-Pos and Y-Pos spinboxes, but you cannot directly edit the height or width of this welded footnote frame.

Footnotes6.png

Here we have managed to increase the height of the frame by editing the Top Distance in Properties > Text > Columns & Text Distances. As can be seen, this allows for creating a little breathing space between the main text and the footnotes. The Left Distance was also edited, but no change happens with width.

Unwelding and Variants

It turns out that what I said about moving footnote frames isn't quite true. Before we get to unwelding, let's talk about what happens with Item > Welding > Edit weld item.

  • Move weld Point – although it's clear that you can click on and then move the weld point on the page, the utility of this unclear, and it's use may be more appropriate for other kinds of marks. The relationship between the main frame and the footnote frame seems to remain the same.
  • Move Object – here the utility becomes more obvious, where now we can use the mouse to physically separate the main text and footnote frames. We see that our yellow weld rectangle is still present.
Footnotes7.png
Here we see another way to create breathing space between the text lines. You can only make this separation using the mouse on the canvas. It won't work by adjusting the spinbox settings, and here still you cannot adjust height or width of the footnote frame. Once you End Editing, the space remains constant except if you adjust the height of the main text frame, in which case the two frames come together again.

A note of caution: Close the Edit weld item dialog before doing other operations. For example, I found that trying to Insert a new page into the document caused Scribus to crash when I hadn't closed Edit weld item.

Now for some unwelding. Click Item > Welding > Unweld items.

Footnotes8.png

This looks similar to what we just did, but now see that the yellow rectangle has disappeared. Furthermore, we can now move either the main or footnote frame independently. Since there is (apparently) no method to re-weld, you might use this option thoughtfully. You may notice that with footnote frames the Lock Size button is selected in Properties > XYZ. Even if you unselect this, you will still be unable to edit the size of the footnote frame independently. Also note that even with an unwelded frame, as you add more footnotes, the frame does then enlarge to accommodate them.

Styles

Footnotes9.png By now you should have seen that the appearance of the marks in the text and the footnotes themselves may not be to your liking. To the left is the Notes Styles Editor dialog. Here some minor edits to the default settings have been made – getting rid of the ')' suffix after the marks, and changing the paragraph style of the footnotes. The paragraph style, of course, comes from using Edit > Styles just as you would for other purposes.
Footnotes10.png

I'm not necessarily advocating italics as a style for footnotes, but simply wanted to show the contrast between the main text and footnotes.

In the bottom section of the dialog, notice the settings for Auto Height and Auto Width. Here, finally, is where we can find a way to be able to edit these dimensions by unselecting these items.

Edit > Marks

Footnotes11.png The Marks Manager is something like the Outline (Windows > Outline), but only for your Marks. In addition to jumping to whatever footnote you select, you can edit your note, or even delete it from here.