Official:Compilation Requirements

From Scribus Wiki
Revision as of 17:19, 22 December 2010 by Malex (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Requirements

The programs you will need to compile Scribus 1.3.8+ are:

  1. For Scribus 1.3.x+ GCC 3.x+ is required, GCC 3.3+ is strongly recommended. The Scribus Team has tested compiling with GCC 4.1+. We recommend the newest stable GCC 4.x release for the performance benefits.
  2. GNU make
The dependencies for compilation, and also to run Scribus are:
  1. Qt 4.6.0+, both the runtime libraries and development libraries. Qt 4.2.x is not supported as 1.3.5+ relies on functions only in 4.3.x, 1.3.8 relies on functions introduced in 4.6. Qt3 is no longer required or supported with Scribus 1.3.5 or higher.
  2. Python and python-devel libraries 2.3+. Python 2.2 is not supported.
  3. Freetype2 2.1.7+. Due to various freetype2 bugs, we recommend, if your distribution/OS allows, to use 2.3.x
  4. cairo 1.4.x We recommend 1.4.10 or later for performance reasons.
  5. libxml2 2.6+.
  6. Ghostscript 8.60+ is highly recommended.
  7. Littlecms – also known as lcms in some distributions. Minimum is 1.12, 1.17+ recommended. lcms 1.12+ has support for black point compensation.
  8. libtiff 3.6.0+
  9. libjpeg

Optionally:

  • CUPS development libraries – Scribus directly supports printing with CUPS.(Linux/UNIX only).
  • tkinter – for the font sampler script
  • python-imaging libaries for font sampler script preview
  • openssl-devel (Some linux distributions enable ssl support for CUPS, notably SUSE Linux)
  • fontconfig-devel – for auto discovery of fonts on Linux, MacOSX and Unix. Not needed on Windows.
  • antiword – this is not needed at compile time for MS Word import. Scribus will detect this at run time however.
  • Podofo 0.6 or later – used to enhance the Adobe Illustrator importer.

Scribus will run under most any window manager and does not require KDE. However, drag and drop functionality will be lost without KDE.

If color management does not work, you also need at least one RGB profile and one CMYK profile installed or the color preferences and options will not appear in the menus. Scribus installs one RGB and one CMYK profile simply to enable color management, but some distributions, notably Debian, provide ICC profiles in separate packages, due to their licensing policy.

Testing suggests setting the correct "-march=" CXXFLAGS has a very beneficial effect on Scribus performance. For example, if you have a Duron or Athlon processor, using export CXXFLAGS="-march=athlon" would be of benefit. Check if your distribution sets these for you and how they are set, and for further information see:

man gcc

There are detailed notes in the BUILDING file, and packagers should look at the PACKAGING file in the sources for more details.

Using CMake

In 1.3.3.6+, we added support for CMake as an alternative to the traditional autotools. Since 1.3.5 it is mandatory, and autotools are no longer supported. Currently, building on Linux, UNIX and MacOSX is working reliably. Please see the Official:Compile_with_CMake for more details.

The default location for the Scribus executable is located in /usr/local/bin. Documentation is located in /usr/local/lib/scribus/doc

In addition for Linux/UNIX desktops, there is a desktop.config file named scribus.desktop which can be used for a menu shortcut or desktop shortcut. Simply copy this from the base directory of the installation source directory to your KDE desktop and this will launch Scribus. After dragging the file to the desktop, right click and make sure the “execute” check box is checked. This file conforms to the latest www.freedesktop.org specifications.