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Chapter 1: What you can do with Scribus
• Use Scribus to design and produce magazines, newsletters, print-advertising, brochures, 


calendars, and pretty much anything that requires text to look visually appealing on paper. 


• Scribus is also a great tool for authoring PDF documents with advanced features such as forms, 
buttons, passwords, and more. You can make your PDF documents even more 'intelligent' by 
using Javascript from within Scribus. Our tutorial focuses on how to use Scribus for 
professional-grade design of publications. It also shows a brief glimpse of how to create an 
intelligent PDF. So let's get started. 


For our project, we'll design seven pages for a magazine, including its cover page. Yet within these 
seven pages, you'll learn enough to create an entire 100-page magazine, or even a full-blown 
newspaper.
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Chapter 2: Scribus And Its Sisters


Download A New Version
First: make sure that you know what you are doing. The basic process of installing Scribus on your 
computer may have both an easy and more complex solution, so choose the one that fits your 
experience, unless you're willing to be adventuresome. In general, for those unfamiliar with 
downloading, compiling, and installing software, it would be best to seek out an already compiled 
version for your system. These exist for various Linux distros, MacOSX, OS/2 & eComStation and 
Windows (in fact, as of this writing, for Windows automatic installing of the binaries are your only 
option, and please note that the Windows versions require Win2000 or XP). 


Hints for the wary: 


• Get help from a friend who knows how to install Scribus on your platform (platform meaning 
Linux vs MacOS vs Windows) 


• Check the Scribus archives for installation help. 
• If you get stuck, send an email to the Scribus list. Here's what they will want to know: your 


platform and distro, the version of Scribus you're trying to install or work with, and of course 
the problem along with what happened, messages you got along the way, and so on. 


Easy Does It - the binaries 


Debian apt-get install scribus 


Fedora Core - 
Plan A 


use yum (must be root)
yum install scribus
All dependencies should be taken care of. 


Fedora Core - 
Plan B 


download the RPM, then install (need to be root for this) with
rpm -ivh scribus-exactly-like-the-file-says (e.g. scribus-
1.3.3.2-1.suse101.i686.rpm)
Be prepared for dependencies you need to address. The clever thing might be to 
do yum install scribus to get the dependencies addressed, then update 
rpm -Uvh ...... But if you're that clever, maybe just download with 
subversion and compile. 


Gentoo emerge scribus 


Mandriva 


use urpmi (must be root)
urpmi scribus
All dependencies should be taken care of. Use http://easyurpmi.zarb.org/ and 
add 'main' and 'contrib' to your urpmi media database ('updates' and 'plf' 
repositories are very usefull, too). 


PLD poldek -i scribus 
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Slackware 
Download an (unofficial) package from Italian Slackware Community website 
and install it (as root) with installpkg <package name> 


SUSE 
Use Yast2 or RPM, as with Fedora Core above. Alternatively, use the Open Suse 
Build Server repositories for Fedora 7, Mandriva and Suse 


(X)(K)Ubuntu Please, refer to this article. 


Mac OSX Go to this page and follow the instructions there 


Windows 2000 
or XP 


Important: Go here first to read the instructions
Then go here for the download. 


OS/2 / 
eComStation 


Important: Go here for the download. Please note the release on this platform 
is still in beta due to other software dependencies however Scribus tests ok. 
Feedback is required! 


FreeBSD 


As a port: 'cd /usr/ports/print/scribus && make install clean', or as a package: 
'pkg_add -r scribus'. 


See the freshports page and the FreeBSD Handbook for more information. 


PC-BSD 
You can download a PBI package from http://pbidir.com/packages.php?
code=591 


Compiling your Own 


Visit www.scribus.net and head to the downloads 
section. Please read the instructions in the 
documentation section on how to install Scribus for your 
platform. There is some detailed information inside your 
downloaded package, in the INSTALL and README 
files. 


We recommend using only stable versions for 
production work. If you are really brave and you want to 
help us with finding bugs and providing feedback on 
usability of new features that are a work in progress, go 
to this page to get the latest SVN version. The SVN 
version is not always stable, it is also significantly ahead 
of the stable version in its features and capabilities. Just 
follow the simple instructions in this wiki on installing from SVN. For those who don't know, SVN 
stands for Subversion, a version system and a clever way for several programmers from diverse 
geographical locations to store their software at a central repository as they dynamically work on it. 


Make sure you read the requirements page on the site. This is because Scribus needs some rather 
important files installed on your system. And don't forget the hints mentioned above. 


The Basic Process: 


• Download your file 
• Uncompress it 
• Untar it 
• Enter the directory (using the cd 


command) 
• ./configure 
• make 
• make install (as root - if you are 


installing system-wide) 
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Get Adobe Reader
Scribus is a great tool for creating PDFs. Yet not all PDF viewers are created equal, especially under 
Linux. So, head to adobe.com and download and install the latest, native version of Adobe Reader for 
your platform. As of this writing the latest version is Adobe Reader 9. 


You can also visit PDFreaders for a list of PDF readers which are Free Open Source Software, like 
Scribus. They don't have all the functions of Adobe's reader, but many are smaller and faster. 


Match Colors That Print
Finally, if you wish to design publications, you need to ensure colors you see on screen match colors 
that print. For this, you need to install a special and separate piece of software, called a Color 
Management System, or CMS. Windows and Macintosh come with a CMS built-in, called ICM and 
ColorSync, respectively. Under Linux, you need to install a free CMS, called LittleCMS. Download 
and follow the instructions at littlecms.com, or you may find that lcms (and lcms-devel) can be 
installed just as Scribus binaries are shown above. You can also install versions of this under Windows 
and Macintosh. For this tutorial, LittleCMS is not necessary, though quite helpful. 


You Can Use Your Existing Fonts Collection
Do you have a collection of fonts that you wish to use under Linux? Install your existing TrueType, 
Postscript, or OpenType format fonts under Linux. You'll find the simple steps mentioned in the 
documentation section of the Scribus site. For our tutorial, we don't need to install any special fonts. So 
you can start right away with your first sample publication. 


Sane Workflows
Our magazine is called 'FreedomYug' and it contains a lot of pictures and text. A magazine with a few 
hundred pages could also have several Scribus files, each with eight to 20 pages. So, it is best to create 
a folder for each publication. I've created one called 'Fyug'. Inside this, create at least two distinct 
folders, 'Text,' and 'Images'. You may use a plain text editor, such as Vim or Emacs in Linux, or 
Notepad in Windows. You may also use a word processor, such as Openoffice.org, author your articles 
and save them in the Text folder. Scribus can import Openoffice.org files with some limited ability to 
make use of text formatting. Later versions of Scribus (1.2.5, 1.3.3 or higher) can also import Microsoft 
Word files, but the text will lose all formatting during import. 


Similarly, scan or enhance photographs and store them in the 'Images' folder. A wide range of image 
formats can be used, including TIFF, JPEG, and PNG. 
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Chapter 3: Empty, White Spaces
A magazine or a publication design is not about text and images on the page. It is about empty, white 
spaces on the page. The text and images merely punctuate this emptiness. These 'breathing' spaces are 
important, much like gardens, parks, and other open-air sites are important to any high-density 
metropolis. So launch Scribus, go to the File menu, and click on New. For the rest of the tutorial, I will 
use the following convention to describe menu choices: File > New. 
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New Emptiness


The New command displays this dialog box
 


• Click on the 'Default Unit' drop-down box, and choose 'Millimetres (mm)' rather than the 
default 'Points'. 


• Click on the drop-down menu of 'Size' and choose 'Custom' for the page-size of our magazine. 
Enter the above dimensions for width and height. Note the level of precision beyond the 
decimal-point to the right, offered by Scribus. 


• Enter the above values for margin guides, that marks off the actual printing area, inside the 
physical paper. 


• Select Page Layout > Double Sided so you can view pages side-by-side, as in a realworld 
magazine. 


• Select 'First Page is: Right Page' Our first page will be the cover for our magazine. 
• Click 'OK' to view your first blank page in Scribus. 


Before v 1.3.3, the requestor looked slightly different. Notice the different layout of the Margin Guides 
area, also that Facing Pages is now selected by checking 'Facing Pages', and Right Page is selected by 
unchecking 'Left Page First': 
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Chapter 4: Cover Page
If you see too many gridlines on your blank page, unselect View > Show Grid. You will see blue-
colored lines marking the outer margins of your page. The concept of Scribus is quite simple: To place 
a photo on the page, first you must create an image frame and then import the photo into this frame. 
Similarly, to place text on the page, you must create a text frame first, and then insert, or type, text into 
this frame. You'll soon discover that this approach has some great advantages. 


Insert Picture


A toolbar contains all the Tools that Scribus offers. You can use this link to get your bearings, but 
remember that gliding your mouse over each icon will display a tool tip with the name of each tool. 


Click on the third one (Insert Image Frame )[keyboard: I]. This allows you to insert an image 
frame in the page. That's what you want for placing the cover picture. Drag your mouse from the top-
left of the Scribus page, to the bottom-right, or any corner to its opposite. Don't worry if you don't get it 
exactly right. 


You'll find an image frame drawn on your page, in the shape of a large rectangle, with 
black-colored diagonal lines forming a large 'X' through it . This is a traditional printing 
industry custom, to distinguish image frames from text frames. That 'X' won't ever 
print, so don't worry. 


Soul of Scribus


From the menus, go to Windows > Properties (before 1.3.x Tools > Properties). Along comes a 
dialog box that is the heart and soul of Scribus. All objects you add to the page, from image frames, 
text frames, or even actual photos, text, or lines, are all controlled from this central dialog box. Make 
sure the image frame you just created is highlighted, or selected. Usually red-colored or other colored 
square dots will mark all the four corners as a visual cue. If not, in the Toolbar, click on the first icon 


(Select Item), and just click on the image frame. The 
Properties Tool will instantly show all its details. An object must 
be selected to be modified or deleted. 


Give a human-readable label to this image frame, such as 
'CoverPhotoFrame' in the 'Name' field of Properties. In case you 
do not see the 'Name' field, just click once on the top tab, that 
says X,Y,Z. Next, precisely place the top-left of your picture 
frame on the top-left edge of your page. In the X-Pos and Y-Pos 
fields, type in the values of 0mm, each. Pos is obviously a short-
form of Position. Type in the Width and Height at 210 mm and 
280 mm respectively. Your frame is precisely placed on the page. 
While you can resize and reposition with the mouse, typing in 
values is much faster for a task like this. Properties Palette
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Get Picture


After you make sure your image frame is selected, then right-click anywhere inside this image frame. 
You will see a Context Menu pop-up right under the mouse cursor. Select Get Image from this menu 
(before 1.3.x this is Get Picture...). A file dialog box opens up for you to navigate into your FYug 
folder, and then into the images folder, so you can select the 'TitleFX.jpg' sample image. Click on the 
OK button. The image frame on your Scribus page is immediately filled with the TitleFX.jpg image. 


Nudge Picture to Left


Note the sculpture in the image is too much to the right. We must drag the picture inside the image 
frame to the left, so that the sculpture is positioned in the centre of the image frame. Extra parts of the 
picture will get automatically cropped out of view beyond the boundaries of the image frame. First, 
let's play with this positioning with the mouse. On the toolbar, click on the icon for Edit Contents of 


Frame . 


Now when you left click inside the image frame you can 
manually slide your picture around, and for some projects this 
may be accurate enough. For our project let's be very precise. 
First, make sure the image frame is selected (click Select Item on 
the toolbar then click your frame again, or try this: left-click 
outside your frame and you will see the Select Item icon become 
highlighted, then left-click inside the frame to select it). Now go back to the Properties Tool and click 
on the tab titled 'Image'. In the field marked X-Pos, just type in the value “-90mm” to move the image 
90 mm to the left. Note how the image is shifted inside the image frame.


Color Karma


At the bottom of the Properties Tool (Image tab), you may have noticed a section called 'Input 
Profiles.' This will only show if the LittleCMS on your PC is correctly installed and configured. The 
color of your images may look markedly different on your screen, and even more when you print them. 
This little area minimizes such color mismatch. From the pop-up for 'Input Profile', choose a color 
profile that closely matches your monitor. Scribus immediately re-renders the image on the screen to 
display colors according to that profile. 


The actual installation of LittleCMS and how to use it under Scribus is actually quite simple, but 
beyond the scope of this tutorial. Here are some good tips: 


1. Download a set of free profiles from the Adobe site, so you can send images between Mac, 
Windows, and Linux. 


2. Create a custom color profile of your own monitor and use that instead of any other. 


Save


You may want to save your file before proceeding. So head over to File>Save and type the name 
'Fyug.sla' for your file. Save it in the FYug folder. You can also just click on the floppy icon in the 


taskbar, right underneath the menus, to save your file.  


Properties Palette - Image Tab
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Masthead Band


The cover page of any magazine has its name emblazoned 
across the top. This is called the Masthead. Ours is titled 
“FreedomYug.” We'll start by creating a semi-transparent band 
for the Masthead. Go to File > Preferences > PDF Export 
(before 1.3.x Settings > Preferences > Display). Make sure 
this checked: “Use PDF1.4 Transparency Features” (In 1.3.x 
make sure the PDF 1.4 is chosen under Compatibility). Click 
OK. Your document now supports transparent objects.


Click the fifth tool in the Toolbar. Should you hover your 
mouse over this, the roll-over text would display “Draw 
Various Shapes” or something similar. Select the rectangle 
shape from the drop-down menu. Click anywhere near the top-centre of the page and draw a rectangle. 
Make sure the rectangle is selected, and immediately go to the Properties Tool, click on the X,Y,Z tab, 
and enter the following values: X-Pos: 30mm. Y-Pos: 0mm. Width: 150mm. Height: 33mm. Give it a 
name, such as 'MastheadBand' in the Name field. 


Then click on the Colors tab in Properties. Click the Pencil tool to select the stroke or outline 
border. Click on 'None' in the colors list. Then, click the bucket icon to select the fill color. Click on 
'Black' from the list of colors, and in the opacity field, enter 69% (if you do not see an Opacity field, 
you have not selected PDF 1.4 transparency features -- see first paragraph above in this section). You 
will see the band has turned semi-transparent, and partly shows the image through itself, in darkened 
colors. Experiment with Opacity and other colors to your taste. 


Add More Bands


Draw another rectangle towards the centre of the image. In 
the Properties Tool (X,Y,Z), give X-Pos: 93mm. Y-Pos: 
160mm. Width: 115.35mm. Height: 13.75mm. Again in 
Colors, set the stroke to 'None', and the fill with 'Black' at 
an opacity of 69%. Call this the 'HeadlineBand'. A third 
rectangle, named 'SubHeadBand' can be drawn slightly 
underneath this, at X-Pos: 100mm. y-Pos: 180mm. Width: 
109.7mm. Height: 18.35mm. The fourth and final rectangle, 
this time a little square box, will have the following 
Properties: X-Pos: 20.5mm. Y-Pos: 245mm. Width and 
Height will both be 9mm. 
Here is a shortcut you might try for a repetitive job like this. Instead of making each rectangle from 
scratch, then changing all of these parameters, after you make the first one and adjust its colors, just 
copy it: Item > Duplicate. Then all you have to adjust is its name, position, and size. 


Properties Palette - Masthead


Properties Palette - Color/Shade
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Create Colors


Hold on! Don't fill this with the same 69% Black. Let's give it a 
fresh lime green color. Go to Edit > Colors... in the menu. A dialog 
box listing existing colors displays on your screen. Click on 'New' 
and give your new color swatch a name, 'Lime Green' (if you already 
have a LimeGreen, call it LimeGreen2 or something else). In the 
second dialog-box that opens up, choose 'CMYK' as the Color 
Model. This closely follows the inks of Cyan, Magenta, Yellow, and 
Black, used in your desktop printer and in printing plants, that mix 
inks to create new colors. With the sliders at the bottom, give 
C:69%, M: 10%, Y:100%, and K: 0%. 


Click OK in this dialog box, and then click OK again in the Colors 
dialog box, where you'll notice your new color added. Go back to 
your page, click on the small square you just created, and in the 
Colors tab of Properties Tool, give it a stroke of None, and a fill of 
LimeGreen, at 100% opacity. You cover should look like the 
screenshot here, with all the bands for text. 


Locked Bands


One last thing. Select each semi-transparant band individually, and in the Properties palette, in the 
X,Y,Z tab, click on the icon of the padlock at the bottom. This ensures you accidentally do not 
move or resize each locked object. 


Similarly, lock the CoverPicture Frame as well, and the green square, using this padlock. Also, uncheck 
'Text Flows Around Frame' in the Shape tab of the Properties Tool for each of these rectangles. This 
allows text to overlap the rectangles. 
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Chapter 5: Working With Layers On A Page


Why We Need Layers


We are going to format the text for the magazine's masthead, the headline, and the subhead. Imagine if 
this magazine is published in several languages. One way to then produce this magazine would be to 
recreate the magazine layout for each language. The other way, is to have the text for each language on 
another layer. Think of layers like transparent sheets that overlap one another. You could hide or view 
layers, for example: hide the English text layer, and show the Hindi text layer. 


 
Layers bring a lot of convenience into page-design. For our 
magazine, I will keep the background image and bands in one layer, 
and have the text contained in another layer. Go to Windows > 
Layers. In the dialog box, you will see one existing layer, that 
contains all your objects so far. Uncheck the 'eye' icon, and all 
elements of this layer disappear, leaving you with your empty page. 


Double-click on the name of this layer, and change it to 'Bg Photo'. 
Click the bottom-left icon, that adds a new layer on top of the 
existing layer. Change the name of this layer to 'CoverText'. Make sure this layer is highlighted, so 
Scribus knows whatever elements you create will exist on this layer. Ensure the 'eye' icon is checked so 
you can view your layer. 


Entering Text in a Text Frame


Ensure the CoverText layer is highlighted in 


Layers. Click on the the text-frame  in 
tools (keyboard: T) and drag a text frame 
across the MastheadBand. For the moment, 
make the text frame as wide as the page and 
nearly double the height of the MastheadBand. 


Click the Story Editor   icon    in the 
Toolbar (keyboard: Ctrl+Y). This is next to 


the Edit Contents of Frame  icon. A 
dialog box displays, where you can enter the 
text you wish to have published in the text 
frame. Think of the Story Editor dialog box 
as a mini notepad or word processor for each 
text frame. This is the second-most important 
dialog box in Scribus, after the Properties Tool 
we saw earlier. Type the text: “FreedomYug” in the Story Editor. Then click on File > Save and Exit 
inside the Story Editor (File > Update Text Frame and Exit in 1.3.X). This publishes your text into the 
text frame, and exits the Story Editor. 


Layers Tool v1.3.4


Story Editor – 1.3.X
Follow link for full size
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Make Text Look Beautiful


'FreedomYug' will look attractive if the gaps between the letters 
are reduced, and if the text fits into the MastHeadBand. The 
overall gap between letters is called 'Tracking.' To reduce this 
tracking, right-click on the text frame, and from the pop-up 
menu, choose 'Show Properties'. In Shape uncheck 'Text flows 
around frame'. On the buttons at the top of this dialog box, click 
on Text. 


Tracking


From the drop-down menu of Fonts in the Properties dialog box, 
choose 'Utopia Regular' or else Times Roman or any other font 
you fancy. Make the size: 84 points. Traditionally, a point is a 
unit of measure in the printing industry. 72.27 points make an 
inch. In digital print publishing, this is rounded-off to 72 points 
make an inch. Text size is usually measured in points. Select 
'Red' from the drop-down menu next to the bucket icon, which 


stands for 'Fill Color' for our text. In the field labelled  


(Tracking in Scribus 1.2.*), enter -5 pts. Set the value of the  field (Line Spacing in Scribus 1.2.*) 
to 72 pts. You will find the gaps between the text has squeezed, and the text has changed to the color 
red. 


Note that all of these font sizes, settings, and positioning values may vary depending on which exact  
font you choose. The important thing is to fit them in the space provided, with a look that is pleasing to  
you. In particular, you may find that the text frame height may need to be much larger than you  
expect. Look for a small rectangle with an X inside in right lower corner of the frame that tells you  
there is not enough space for the text 


Troubleshooting text that won't appear 


If you are struggling to have your text appear: 


• Make sure you are operating on the layer you think you are. 
• Make sure that the Text Flows Around Frame is unchecked, not just for the frame you're 


working on, but also underlying frames. 
• Some fonts need to allow for a very generous space below them, even though there is no part of 


the character in that space. Adjusting line spacing may help this problem somewhat. 
• Note that the way various fonts display in the frame has changed from 1.2.x and 1.3.3.x 


versions, so a file saved in 1.2.x may have displayed fine, but adjustments need to be made in 
frame sizes if it is imported into a 1.3.3.x version. This is a likely issue if you import the 
Fyug.sla file from the website. And unfortunately, text display has changed again in 1.3.4+. 
Just to be clear, any more advanced version will load a file from and older version -- you may 
just see these display issues. 
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More Text, More Frames


Use the same technique, make new text frames as follows: 


Content Font (or similar) Color 


THE NEW ERA OF 
COMPUTING 


Bitstream Vera Sans 
Mono Roman 


White 


STRIKE A NEW POSE URW Palladio L Bold LimeGreen2 


WHY KHAJURAHO
NEEDS GNU/LINUX 


URW Palladio L Bold Red 


PLUS: FORGOTTEN 
VERSES
FROM THE DIGITAL 
SUTRA OF INDIA 


URW Palladio L Bold Yellow 


Adjust size, tracking and line spacing to fill the space as needed. 


And While We're At It


Here is an excerpt from Working with text frames elsewhere on the Wiki. You should find this useful 
when adjusting sizes, positions, and other settings. 


There are three ways to change the individual settings -- 


1. editing with the keyboard 
2. clicking on the up or down arrows to the right of each value. The keyboard up and down arrows 


will accomplish the same thing. 
3. using the mousewheel on each setting -- usually hovering the cursor will be enough, if not, click 


on the value first 


Also note that for 2 and 3, holding down Ctrl, Shift, or Ctrl+Shift will alter which decimal place is 
affected. In addition, when using the Properties window width and height are by default linked, but you 
need only click the chain icon to the right to unlink them. Refer to this article for more on keyboard 
shortcuts.
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Chapter 6: Design Multiple Pages


Many Unique Page Designs


This magazine's pages are 210mm x 280 mm. However, not all pages will have the same look. I need 
three pages with a layout meant for a Features article, with perhaps two columns, and a generous white 
space on the outer left or outer right edge of the page. Another page could look like a feedback form, 
which could have only rows and tables. Still another page could be the Contents page. 


Interestingly, once I decide that a Features page needs two columns, and a half-column of empty white 
space on the outer-left or outer-right, with a section name on the band on top, I want every page that 
runs a Feature story to look consistently the same. Thus, I need a 'Master Page' for Features, that 
defines all the columns and other common graphic elements for the Feature pages. I can then add as 
many pages as I wish into the actual Scribus file, from this Master Page, and add the actual text and 
photos to these pages. 


Make A Master Page


Go to Edit > Master Pages. A dialog box listing existing Master Pages opens up. You will only see one 
default Master Page, called 'Normal.' That's the one you've been using for the cover page. Click on the 
button 'New'. In the resulting dialog-box, name the Master Page 'FeatureL' and choose 'Left Page' from 
the drop-down menu. You end up with a blank page, with blue lines marking the outer margins. (v 
1.3.x: If you can't see the guides you just created go to View > Guides) 


With the 'Edit Master Pages' dialog box still showing, and your new empty pages on-screen, go to Page 
> Manage Guides, in the menus on top. We are going to add some horizontal and vertical guides, 
which are lines that won't print, but guide your eyes into placing columns of text, and graphics, with 
perfect alignment. 


Value Entry with Math Operators


The left page has a 20mm margin from the left edge. Inside this margin, I wish to leave a half-column 
of white space, of 45mm. So in the 'Manage Guides' dialog box, click on 'Add' under the 'Vertical 
Guides', and in the X-Pos field, type “20+45”. Yes, Scribus will use simple math operators in all fields 
that require a numerical entry. (You can even enter “30 mm + 1.5 in” to operate between different 
units). Add the other vertical guides at 122.5 mm and 127.5mm. Look at the numerical precision with 
which Scribus places it. Add a Horizontal guide at 265 mm. Important: click the 'Lock Guides' button at 
the bottom so your guides don't accidentally move on the page. Click OK. Your page will have guides 
similar to the screenshot here. 


Page Numbers


Add the Red band on top, using the following 
instructions. 


• Make an elongated rectangle shape frame with width(W): 107.5mm, height(H):10mm, X-Pos = 
20mm, Y-Pos = 0. 


• Go to Properties > Color to change fill color to Red, Opacity to 69%. Make sure line color is 
None. 
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Add a new text frame with the following properties: 


Font Contents Parameters 


Luxi Sans Regular KHAJURAHO 
W: 102 H: 6.5 X-Pos: 25 Y-Pos: to your liking F: 12.0pt T: 15pt 
LS: 14.4
(F = font size, T = Tracking, LS = line spacing) 


 


As you can see here, this header is constructed of a rectangle with a red background, then a 
superimposed text frame with a transparent 
background. You could also accomplish the 
same result with a text frame with a red 
background, then adjust Top and Left border 
spacing in Properties > Shape. Many ways to do things in Scribus. 


Another frame: 


Font Contents Parameters 


Luxi Sans Regular 
Ctrl+# | FREEDOMYUG | MONSOON 


2004 


W: 165 H: 8 X-Pos: 15
Y-Pos: 263.5 F: 9pt T: 5pt LS: 
10.8 


Here's something new -- this 'Ctrl+#' combination, which represents a keyboard shortcut -- this is 
how you denote automatic page numbering that will increment on each page. You will see this 
display in your text frame as only the '#' in template editing mode. 
Typing one 'Ctrl+#' allows for single-digit page numbers; for two digits, type it twice; three digits 
three times, and so on.
One might also denote this as 'Ctrl+Shift+3', but 'Ctrl+#' will likely be easier to remember.
WARNING: If you are not using a standard US keyboard you may find that this key combination 
does not work even if there is a '#' key on your keyboard. In this case in v 1.3.x go to File > 
Preferences > Keyboard Shortcuts (v 1.2.x: Settings > Keyboard Shortcuts) to see what key 
combination scribus expects and, if you don't like it, change it. I found that on my US keyboard 
laptop, I needed to change, so I made it 'Ctrl+3', and that worked. 


For more information on page numbering, please have a look at the article Pagination 


New Master Page: Right Page


To create the Features page for the right hand side, click on New in Master Pages, choose 'Right Page' 
from the drop-down menu, name the Master Page 'FeaturesR'. Bring up Page > Manage Guides, and 
enter the following for adding Vertical guides: 82.5mm, 87.5mm, 145mm. Add a Horizontal guide at 
265mm. As with FeaturesL, add the red band on top with the same dimensions, this one lining up with 
the 82.5mm vertical guide and the right margin guide. Once again, make the superimposed text frame 
containing 'KHAJURAHO', but this time Right Justify the text, and place the frame 5mm inside the 
right margin guide. 


Now, make the bottom text frame, remembering to put the page number on the outside with the 
keyboard shortcut: 


FREEDOM YUG | MONSOON 2004 | 'Ctrl+#' 


Also Right Justify this, and place the same distance from the right page edge as the other page number 
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frame was from the left page edge in FeaturesL -- you can use the math operator function in the 
requester, subtracting frame width and the distance from edge from the page width (X-Pos: 210-165-
15). 


Click the 'Close' button on the Master Pages dialog box. You find yourself back in your Scribus 
document's regular pages.


Drag-'n-Drop Pages


 Go to Tools > Page Palette (v 1.3.x: Windows > Arrange Pages)in 
the menus. In the palette, you will find your existing front cover as page 
one, and three templates in the above section, Normal, FeaturesL, and 
FeaturesR. To add another page, click and drag FeaturesL from 
'Available Templates' to the 'Document Pages' area, below-left to the 
Normal first page. Page 2 is thus automatically added, to the left side. 
Similarly, drag and drop a page 3 with FeaturesR, and page 4 with 
FeaturesL. Zoom in on the actual document pages and note the page 
numbers are automatically generated. 


Two-Columns of Text Per Page


Using the guide-lines on each page as a cue, click and drag to create a 
text frame, then use the Properties Tool to create these dimensions: W: 
120, H: 215. This will line up on the outside with one of our vertical 
guides and on the inside margin guide. For left pages, positioning will  
be X-Pos: 65, Y-Pos: 35, and on the right page, X-Pos: 25, Y-Pos: 35. 


Now, select each text frame, go to the Properties palette, click on 'Shape' and at the bottom, type '2' in 
the 'Columns' field, and '5' in the 'Gap' field. Each text frame now contains two columns. Uncheck 'Text 
flows around frame' on the 'X,Y,Z' tab of the palette, for each text frame. 


Some timesavers: 


• In either v 1.2.x or v 1.3.x, copy your first text frame (Edit > Copy or keyboard: Ctrl+C), then 
go to subsequent pages, click the page, then paste (Edit > Paste or keyboard: Ctrl+V). 
Reposition as needed for Right Page. 


• In v 1.3.x, you can also duplicate the frame (Item > Duplicate or keyboard: 
Ctrl+Alt+Shift+D) then drag the copy to the next page. Attempting to drag from page to page 
in 1.2.x may cause a crash, and in any event will not work. 


• Copy the first frame to the Scrapbook (right click > Send to Scrapbook or Item > Send to 
Scrapbook). Go to Tools > Scrapbook (1.3.x: Windows > Scrapbook) and drag the frame 
with the mouse to each page. 


• Adjust the columns features before copying for the additional pages. 


Page Palette v 1.2.5
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Use Consistent Paragraph Styles


Good publication design is about using consistent styles. The 
formatting for the main story, called the 'Body Text' must be the 
same for all pages, and all stories. Similarly, headline, captions, 
and sub-heads styles must also be consistently used throughout 
a publication or a section. Rather than manually punch in the 
specific font, size, and other settings each time, it helps to 
define the style once, and then just click on it to set a selected 
paragraph in that style. Automatic for the people. 


Define Paragraph Styles


Here is a screenshot of all the paragraph styles in my document. 
You can access the list using Edit > Paragraph Styles... from 
the menus. Let's create a new style in your document, called 
'Body Text'. Click on 'New' in the Paragraph Styles palette, and in the opening dialog box, choose your 
font, alignment of text, size, line-spacing, and other aspects. The important thing to note here is 'Align 
to Baseline Grid'. A professional feature, this ensures that text across columns align to one another. Try 
playing with it to see how it works. This kind of precise alignment of elements across a page or a 
double-spread page is what differentiates professional typography from amateur work. 


Please define paragraph styles for all possible styles: headline, sub-head, caption, box story, or 
whatever. The best way to do this is to create some sample text for each type, and once satisfied, jot 
down all its typesetting features, and manually create a paragraph style for each. 


As a starting point, here are some suggestions for settings similar to those in Freedom Yug. Note that  
these are the font selections used in the original tutorial, but your own font availability and personal  
preferences may result in changes. 


Style Font Size Other 
7Steps Luxi Sans Regular 6.0 LS: 8.4 
BodyText Georgia Regular 9.5 LS: 13.5 
BoxStory Luxi Sans Regular 8.0 LS: 10.8 
BoxStoryHeadline Luxi Sans Bold 18.0 LS: 21.6 
BoxStorySubhead Luxi Sans Bold 9.0 LS: 10.8 


GyaanBodyText Georgia Regular 9.0 
LS: 11.4, Drop Caps: 2 lines, 0 


distance 
GyaanPlainText Georgia Regular 9.0 LS: 11.4, (no Drop Caps) 
Masthead Georgia Regular 84.0 LS: 100.8 
NewStyle Georgia Regular 84.0 LS: 100.8 
PageNumbering Luxi Sans Bold 8.0 LS: 9.6 
SectionName Luxi Sans Bold 9.0 LS: 10.8 
SubHead Luxi Sans Bold 9.5 LS: 13.5 


Flow Your Text


Right-click the first text frame, on page two. From the pop-up menu, choose 'Get Text...' and find your 
way to the Text folder in FYug. Select the khajuraho.txt file, and press 'Open'. You will see the 


Edit Styles
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text flow into two columns on this page. At the bottom-right of the text frame you'll see a 'X' mark in a 
box, which means there's more text than can fit in this text frame. Click the first frame to select it, go to 
the Tools palette, and click on the second-last button with a tool-tip that displays “Link Text Frame.” 


 
From left to right: Rotate Object, Magnify, Edit Contents, Story Editor, 
Link Frames, Unlink Frames. 


Click on the text frame on the next page. Voila! Text flows from the text frame on page two, to the text 
frame on page three. Similarly, add links between frames for each additional page. 


Remember this sequence: Select frame linking from, click Link icon, select frame linking to. 


Please also note that there's a remarkable difference between 1.2.x and 1.3.x: In 1.2.x the cursor 
switches back to the "select" status after each linking operation as is indicated by the arrow icon. In 
1.3.x the cursor remains in linking mode, so if you want to stop linking frames, you have to click the 
arrow icon in the toolbar first. 


Format To Body Text


You'll notice the text on each page is in some random plain-text formatting (your default font, actually). 
Just click on the first text frame of this multi-page story. That's the one on page two. Go to the 
Properties palette, click on the 'Text' tab, and choose 'Body Text' from the paragraph styles in the drop-
down menu next to 'Style'. Note you can even choose a language from the drop-down menu below – 
this is important for correct hyphenation in multilingual documents.
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Chapter 7: Create Final Page Layouts


Make space for Photos and Headline


Arrange Pages - Document Pages  


You've got the general idea of how Scribus creates 
templates, paragraph styles, and works with text 
frames and picture frames. Time to design all the 
feature pages of the cover story. Go to page two. 
This you can do by clicking on the page icon in 
the page palette (Arrange Pages in 1.3.X), or at 
the extreme bottom of your screen, you will see a 
go forward button, a go back button, and pop-up 
list in-between where you can choose the page 
you want to visit. 


Click the text frame on page two, and in Properties, 
in 'XYZ' key-in X-Pos: 65mm, Y-Pos: 201.5, and 
Height: 48.5mm. The text frame shrinks to the 
bottom of the page. Note how the text 
automatically flows to the next page. Link the text 
frame on page three, to the subsequent text frame 
on page four, so text flows from page to page.


Page Controls  


Insert Picture


Select the picture frame icon  from Tools, just like you did for the cover page. This time, draw a 
random picture frame on the top of page two. In Properties, give it X-Pos: 20mm, Y-Pos: 35 mm, W: 
135mm, H: 100mm. Right-click this picture frame. From the pop-up menu, choose 'Get Picture...'. Go 
to the images folder inside the FYug folder, select the file 'EnterTitle.jpg' and click 'Open.' 


Resize Picture


In the Properties palette, click on the 'Image' tab, check 'Free Scaling' and then key-in X:0mm, Y:-
30mm, X-Scale and Y-Scale at 32% each. This will shift the photograph 30 mm to the left, inside the 
frame, and then scale it down to 32% for that perfect crop. 


Typeset Headline


Draw a text frame. X-Pos: 20mm, Y-Pos: 142mm, W: 165mm, H: 39mm. Enter the text, "Make 
Khajuraho More Sexy" on two lines. In the 'Text' tab, choose Georgia Roman 48 pts on line spacing of 
42 pts. You could choose Garamond or Times if you wish. Set kerning to -1.0pts. Then zoom in and 
manually kern the individual letters until you get a crisp, neatly tucked-in headline. 


Hanging Drop Cap


If you go back to Edit > Paragraph Styles... in the menus, and edit any existing style, you'll note an 
automatic drop-cap feature available, for your preferred number of lines. But let me show you how to 
create hanging drop-caps, and you'll also learn how to handle wrap-arounds the Scribus way. Take the 
'Draw Shapes' tool, draw a rectangle, at X-Pos:59, Y-Pos:200, W:19, H:24.3. Fill and stroke this with 
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'None' in 'Colors' so it does not show. Check 'Text flows around frame' and you'll see the first para of 
your article flowing around this “empty” space. Next, draw a text frame at X-Pos:52, Y-Pos: 195, W: 
24.5, H: 36. Uncheck 'Flow text around frame' for this. Using either the Story Editor or the Edit 
Contents tool, enter the letter 'D' in this text frame. In Properties, set this to Georgia Roman, 87 point, 
with leading at 104 points. Fill this with Black. Click on 'Shade' choose 'Other' from the drop-down 
manu, and type 69%. Your drop-cap is done. Should you want to select the invisible rectangle used for 
wrapping text, and end up selecting this text frame stacked on top of it, press control+shift click and 
repeatedly press until you select the correct object in the stack. 


 


Here is a detail of the page, to show what you're doing. In order to 
display the letter at this size, the text frame (the grey frame with the 
taller, narrower dimensions) needs these dimensions to allow for 
space above and below (and note that this required space has changed 
with different Scribus versions). We then use an underlying rectangle 
(shown with red outlines) to precisely block out the underlying text to 
our liking. 


This example uses URW Palladio, with appropriate adjustments in 
size, line spacing, and tracking. 
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Done!


Go to View menu and hide 
the guides, frames, margins, 
and grids or choose Preview 
Mode (only in 1.3.4cvs or 
higher). Your layout will look 
like the above screenshot. 


On page three, the sculpture 
picture frame has an invisible 
rectangle behind it, that wraps 
around the text. Just like we 
did with the drop-cap. The 
captions are just a text frame 
in the half-column. The 
generous white space at the 
bottom of the first column, is 


Here is Page 3 with 
frames highlighted. 
Note how the caption 
frame upper right lines 
up with guides, then 
uses an adjustment in 
left border to create a 
gap (Properties > 
Shape > Distances of 
Text > Left). 


Notice the use of a 
frame lower left to 
create a space for 
balance. 


Finally, while this page 
used a strategy similar 
to the hanging drop 
cap for making space 
to the left of the image, 
one could alternatively 
make this space with 
Properties > Shape > 
Edit Shape and 
editing the contour 
line. 


Page 4 Freedom Yug
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likewise just an invisible 
rectangle with 'flow text 
around frame' checked. Study 
the provided FYug.sla file for 
further details. 


Page 3 Freedom Yug  


Gradient-Filled Box Story


The body text flows to page four. A single text frame in the half-column on the left contains the story 
and photo credits. The box-story at the bottom is a text frame that is formatted with various paragraph 
styles. The gradient in the text frame is applied in the 'Colors' tab of Properties. Underneath the 'bucket' 
icon a drop-down menu with the word 'Normal' reveals 'Vertical Gradient' among others. Choose 
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LimeGreen at 40% as color#1, and CyanBlue at 20%. 


The text has a gap of 2.5mm from top, bottom, left, and right of the text frame. This is set in the 'Shape' 
tab of Properties. A red square is drawn to mark the story end.


Properties: Color v1.2.5
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Chapter 8: Design With Graphics And Freedom


Many Unique Page Designs


Page five jumps into graphics-oriented, creative freedom where page geometry is conformed to with 
defiance. Take a look at the screenshot here. It looks dramatic, but thanks to the power of Scribus, is 
quite easy to produce. 


Page 5 Freedom Yug  


Here are the steps we'll follow to create this page: 


1. Create a new Template (Master Page in  
1.3.x), copying elements from our previous 
right page template, then modifying certain 
features. 


2. Add new column guides. 
3. Turn the number 7 into a page-sized graphics 


element. 
4. Add shapes, then convert to text frames. 
5. Finish up with the remaining labels and 


graphic elements. 


Copy Elements to Template


First, start by creating a new template in Edit > Templates... (Edit > Master Pages... 
in v1.3.x). Choose a right page from the drop-down, call it '7steps'. A blank page graces 
your display. Then, click on your earlier FeatureR template, and drag the mouse from 
the top-left to the bottom-left of the page to select the red band on top with the text, 
and the page folio and page number text frame at the bottom. Click on your new 
'7steps' template. Right-click anywhere and select 'Paste.' Alternatively, go to Edit > 
Paste from the menus. The elements are pasted into the exact position they belong to, 
thanks to the intelligence coded into Scribus. Change text to 'Newbies'. 


Visual Guidance


Amazingly, the layout has 15 columns that align elements. Check the next screenshot. 
So, go to Page > Manage Guides... . Add a Vertical guide at 36mm. 


Then add 11mm to this to create another guide. Continue adding 11 mm to the result of 
the previous guide, until you read 179mm. Check 'Lock Guides' and click OK. Close Vertical guides
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the templates palette and add page five to your document, in the Pages palette, by dragging the '7steps' 
template to after page 4 in the page palette. 


Seventh Wonder


In a new text frame that you draw on the page, enter the letter '7' in Georgia Roman, at say, 200 points. 
Right-click the text frame, and from the popup menu, choose, Convert To > Outlines. The letter '7' is 
converted into a graphics outline. Align it to the top-left of your margin, and drag the lower-right to the 
second-last column, bottom-right. The graphic '7' automatically scales to fit the whole page. 


Do you want to tweak the shape of '7'? Go to the Properties palette, to the 'Shape' tab, and click on 'Edit 
Shape.' Enjoy. Finally, padlock the '7'. 


Important: For each text frame or other element that is placed on this page, please uncheck Text flows 
around frame so you don't have text jumping to another position suddenly. 


Shapes for Text


Drawing the shapes is easy. Click and hold on the square icon in Tools, and discover 
more than 16 shapes you can freely drag and draw in Scribus. Click on the 'Polygon' 
tool and you can even draw stars with as many corners as you wish and other options. 
For each shape, choose Fill 'None' and Stroke 'Black'. The thickness and style of the 
line is in the 'Line' tab of Properties, where I chose a 1 point thick solid line. Discover 
more styles and options for yourself here. The design looks good because all shapes are 
aligned to any two random vertical guides. In effect, that makes the width of each shape 
a multiple of 11mm, since the guides are all 11mm apart. 


Right-click each shape, and choose Convert To > Text Frame. Then, enter the text using the story 
editor, or type it in directly, and apply a special '7steps body text' paragraph style, defined earlier. 


Use Scrapbook for Steps


For the label 'Step 01' draw a box, fill it with a color, draw a 
text frame on top with the text 'Step 01', draw a red line to 
connect it to its relevant shape, and then group the whole label 
with its line, using Item > Group in the menus. 


Scrapbook - 1.3.X
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Chapter 9: Set Fire With SVG Graphics


Graphics R US


The flame logo is a special type of graphic, called a 'Scalable Vector Graphics' or SVG for short. It can 
be enlarged to any size without loss of quality, and even the shape of the flame can be edited in Scribus. 
Yes, even the colors are imported from the image into the Colors palette of Scribus, and colors from 
within Scribus can be applied to the image, as has been done here to multiple copies of this graphic. 
Note how the text is set on a curve created within Scribus, and the automatic drop-caps to the text 
column. 


Ignite


Start with a new Master Page, call it 'GyaanL'. Copy and paste the red band, text, and page folio and 
page number from another left-page template. Change the text to 'Education' in all-caps. In Page > 
Manage Guides, add two vertical guides at 65mm and 70mm. Lock them, and close the Master Pages 
palette. Add another page using this master page, in the Page palette. Or you could use Page > Insert... 
menu. 


From Flame to Flame


You don't need a Picture frame to place an SVG, you can do it directly. Go to File > Import... > 
Import SVG. Navigate to the 'Images' folder of FYug, and select the 'Highly-Inflammable.svg' image 
to import. A huge graphic fills the page. Just select it, and in Properties, give it the height and width of 
45 mm. Position this graphic to the top-left margin of the page. 


Check Edit > Colors... and you will find the orange color in the image has been marked and imported 
into the Colors palette. 


Colorize


Select the file, then copy and paste it right underneath the first one. In the Properties palette, type 
'+5mm' at the end of the Y position, to automatically move it down by 5 mm. Thus, copy and paste 
until you have five copies of the graphic on the page, with a 5mm gap between each one vertically. 
Select each graphic, ungroup it, select the background color, and change the color of each in the 
Properties palette. 
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Dragged Guides


From the horizontal rulers just below the taskbar and above the page, click and drag a horizontal guide 
to the bottom of each box. Toggle 'Show Guides' so in the View menu, so you can see the guide. 
Finally, draw text frames to the height of each graphic in the column on the right, and type in the text. 
Define a Paragraph style that has a drop-cap of two lines, and apply that style to each text frame. 


Page Number on Top


Did you note the problem of the last graphic overlapping the page number and the page folio text? Go 
back to the Master pages palette, copy the page folio text frame that contains the page number. Close 
the Master pages palette, go back to your page, and just paste it on top. The page number comes in 
automatically to this text. 


Text on Path


The text on the curve is pretty easy. Write the text in a text frame. Draw a curve using the 'Insert lines' 


tool . Use the tool that has a pencil with a line shaped like an 'S' around it. To draw the curve, just 
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click once at the starting point of the curve, and drag briefly to the top-right. Then release the button, 
click at the end position of the curve, and drag briefly to the bottom-left. Once you are satisfied with 
the curve shape, just right-click the mouse or press Esc and your curve is done. 


 


Select both the text frame and the curve, and select Item > Attach Text to Path. The text will follow 
the curve. You can play with alignment and other settings in the Properties palette. Rotate the whole 
curve slightly for a better fit. 


 


☺  
For a bit more on Text on a Path, check this howto 
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Chapter 10: Publishing Demands Freedom: PDF


PDF Form Authoring


The screenshot shows the GnuLinux version of Adobe Reader. Yes, a free version is available from the 
Adobe site for Gnu/Linux as well. The document you see inside it, is a scoreboard created from 
Scribus, the free desktop publishing software. The background is an SVG graphic with a tint, and the 
fields, check boxes, and even the 'Click to Submit' button has been authored inside Scribus. Yes, the 
PDF elements contain Javascript embedded from within Scribus. 


You guessed it. Scribus is a mature PDF-authoring software. Use it to create PDF forms, PDF 
documents, and you can even digitally sign your PDF documents with Scribus. 


Look carefully. The headline bands are semi-transparent. The flame shows through. Scribus supports 
PDF 1.4 transparancy too. For your convenience, this is a separate file for download: 
FyugScoreCard.sla. Also check out its PDF version. 
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Design The PDF Form Layout


The design looks dramatic, but the layout is quite simple. It has only one column, which contains all 
the questions, in one text frame, on the left. The half-column on the right contains some information in 
a text frame. The headline and the Name, Address, etc, are in a text frame that spans the entire width of 
the page. The colored bands to mark the sections are obviously colored rectangles drawn behind the 
section sub-heads. The logo in the background is just the flame from the 'inflammable' SVG graphic. 
This time it is colored to Red at 20% shade. It is kept on another Layer stacked at the back. 


Clickable PDF Elements


The real questions are, how are the text fields, number fields, check buttons, and 'submit' button drawn 
that they work interactively inside Adobe Reader or other PDF viewer programs? Use the special PDF 
tools in Windows > PDF Tools. Chances are you already have it 
open on your screen. An almost complete array of PDF elements 
can be authored in Scribus. 


 
Once drawn, use the Properties palette for some cosmetic finishes. Then right-click the PDF element, 
and choose PDF options >Field Properties. 


 


You could also double-click the PDF element to configure it for PDF options. All specific PDF form 
element features will be displayed as a dialog window. You could then for example change the form 


PDF Tools - 1.3.X
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element type (in Type field), define mouse event actions (in Action tab), format the field as a number, 
text or date field (in Format tab), define the way the field value should be validated (in Validate tab), 
or calculated (in Calculate tab)... Enjoy. 


 


☺  
Do you want more of authoring PDF forms stuff on Scribus? Then read our step-by-step how to 
on creating your first PDF form with Scribus 


PDF for Press


Scribus' greatest feature is that it can create PDF files which can be handed to a publishing house or 
printing plant for production. Yes, PDF comes in many flavours. One size does not fit all. The flavour 
for Prepress is called PDF/X-3. It basically signifies a PDF based on the Postscript Language 3, and 
contains ICC color profiles for handling independent color-managed workflows. 


To create a PDF/X-3, or a more generic flavour of PDF that works for your desktop printer, or for the 
web, click the PDF icon in the taskbar at the top. One-click PDFs are always cool! The dialog box 
contains all you need to customize your PDF. Explore. 
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Choose Your Flavour


In the dialog-box, start by clicking on the 'General' tab, and selecting PDF/X-3 from the drop-down 
menu for 'Compatibility.' It's a good idea to downsample images to 300 dpi, at the bottom left here. 


 


Color Management


In the 'Fonts' tab, choose to embed all fonts and 100% of all characters. Then click on the 'Color' tab. 
Note you can use a source ICC profile for the file, choose its rendering intent, and also choose whether 
to use the source profile of the Images, or to discard it and choose your own. If you don't understand 
this, don't worry. It is quite simple. 
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Head out to littlecms.com and read the documentation available there. Also read the documents on the 
Scribus website, and check out the links to the excellent reference material on Scribus' page. 


Press Inks


Finally, click on the 'PDF/X-3' tab. You have to choose the output profile, which is basically selecting 
the kind of ink and paper you are printing your magazine on, and giving the job a mandatory 'Info 
String'. Give the name of your file here. You can also handle some amount of trimming, which is 
changing an existing paper-size in a document to a slightly smaller size to accommodate a print-job. 
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Before sending your job to the press, please go to File > Print Preview. You can see a soft-preview of 
your file in the inks of Cyan, Magenta, Yellow, and Black, and even simulate a progressive proof on-
screen. 


Native Scribus File To Press


If you are blessed to have a Scribus-savvy printing plant, and wish to deliver a native Scribus file, go to 
File > Collect For Output. Select a folder and Scribus will copy your file, as well as put copies of all 
graphics and images, and even font files, in this directory. Transfer this folder to your press. May I 
recommend you throw in a copy of Scribus in this folder too. A clueless person can discover the joys of 
Scribus. Go ahead, this is perfectly legal, thanks to the power of GPL. 
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Chapter 11: Travel At The Speed Of Scribus


Advanced Features


Scribus has some pretty advanced and mature features that you will appreciate as you grow familiar 
with its interface. For instance, once you have dozens of pictures linked into a Scribus document, 
managing such links can be a nightmare, unless you use the Manage Pictures feature under the Extras 
menu. Broken links can then be repaired or newer versions of images can be used without having to 
manually delete and replace images. 


 
For special accents, diacritical marks, and special glyphs, edit text in a text frame, and click on Glyph... 
under the Insert menu. The complete collection of characters of a chosen font are displayed, so you can 
just point and click. Try it. 


Do you wish to quickly navigate through your pages to find a particular element? Go to the Windows 
menu, and select Outline. A structured view of your document, with all items per-page in a collapsible 
list, shows up. 


Scribus supports the Python language, so lots of people have written amazing scripts that automate 
several tasks for you, from creating custom calendars to printing out font families, all with a single 
click. That's what the Script menu on top does for you. If you know Python, you could create some 
pretty sophisticated scripts to assist your work, while you design your publication. 


Using the free tools at the site of LittleCMS, you could calibrate your monitor under Gnu/Linux, much 
like you would do yours with the Adobe Gamma utility under MacOS or Windows. Here's a screenshot 
of a monitor's profile, plotted against a CIE color model for comparison. Ain't that cool! 
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The 'Tables' button in the main Tools allows you to quickly generate tables in your layout. It is rather 
rudimentary at this moment, but it's already planned on the roadmap for Scribus 1.4. Similarly, non-
latin languages will be supported in the same time-frame. 


Finally, the greatest strength of Scribus is the set of people behind it. They work 24-hours, creating a 
new version every night. Should you get stuck, they walk you through your installation, and even assist 
you live over the IRC channel #scribus. As you continue working, and find yourself lost for a feature, 
just hop over and request them. 


We hope you found this tutorial helpful. Please add to it, improve it, and share it with others. It belongs 
to everybody.
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Chapter 12: Activities and Contributors


Wiki structure for the GET STARTED tutorial


• Contributors: --Mhanski 20:28, 26 July 2006 (CEST) 
• Status: done 
• Comment: This structure will allow us to import the whole original tutorial chapter by chapter. 


Import of the original tutorial text into the Wiki


• Contributors: mhanski, gpittman 
• Status: done, imported the whole text from OOwriter file 
• Comment: All the files belonging to the original tutorial are available at linux-delhi.org. In 


particular, the original tutorial as OOwriter file and all screenshots 


Here is a list of the Scribus operations demonstrated by the original tutorial: FreedomYUG Tutorial 
Demonstrated Tasks. 


Import of original screenshots from the original tutorial into the Wiki


• Contributors: mhanski 
• Status: done 
• Comment: All the files belonging to the original tutorial are available at linux-delhi.org. In 


particular, the original tutorial as OOwriter file and all screenshots 


First Draft of the New Introduction (who, for whom, what, for what reason)


• Contributors: mhanski, c_schaefer 
• Status: done 
• Comment: Once we decide, which sample file to use, we can add a nice screen shot of its front 


page within Scribus 


Updating of text content to 1.3.*


• Contributors: Gpittman 
• Status: mostly complete, but won't promise I won't tweak it (GP) 
• Comment: Greg has already started to update things so I'm adding him as a contributor. It 


doesn't exclude other potential contributors, this task is too huge for one person, I guess 
--Mhanski 08:11, 27 July 2006 (CEST) 


New screenshots of Scribus 1.3.*


• Contributors: --Ludi 17:42, August 3 2006 (BRT), mhanski 
• Status: done 
• Comment: done for now 
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Adding Wiki links to other Wiki articles and general wikfisation


• Contributors: Ludi 
• Status: Done 
• Comment: Ludi has started doing this stuff, adding him as a contributor --Mhanski 21:59, 1 


August 2006 (CEST) 


Recreating Freedom Yug sample magazine in 1.3.* (original content)


• Contributors: 
• Status: 
• Comment: 


Variation of Freedom Yug sample magazine (changed content)


• Contributors: 
• Status: 
• Comment: 


Creation of an entirely new sample magazine (Rembrandt)


• Contributors: C_Schaefer 
• Status: in progress 
• Comment: Front and back cover are almost finished. Lots of things to learn already by re-


creating the two pages :) I will now continue with the inside of the cover pages and then create 
another 4 pages of content. In the end, our Rembrandt mini magazine will have 8 pages/4 resp. 
2 sheet. After following all or most of the steps to be described, an average talented user should 
be able to make prolific use of Scribus. 


Creation of an entirely new sample magazine (about Scribus community)


• Contributors: 
• Status: 
• Comment: 


• I've some pictures of the scribus crew in Lyon: you can use them for the tutorial if you 
whish (a.l.e). 


Creation of an entirely new sample magazine (about using Scribus)


• Contributors: 
• Status: 
• Comment: 


• Since Scribus is not the best tool (in its actual state not even a good tool) to create a 
tutorial, i don't think it's a good idea to base a tutorial on writing a tutorial. Andreas' idea 
about a leaflet or a flyer (marketing) is imho better (a.l.e). 
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Polish version


• Contributors: See Pierwsze_kroki_ze_Scribusem:Autorzy 
• Status: done 
• Comment: the Polish version focuses on the 1.3.* version of Scribus and differs – intentionally, 


btw – from the English version 


German version


• Contributors: See Einstieg_in_Scribus:Mitwirkende 
• Status: Done 
• Comment: 


Brazilian version


• Contributors: See Ludi Maciel 
• Status: Entendendo o Scribus – Done. 
• Comment: I also have decided to focus on 1.3.3.X/1.3.X (it really makes more sense now, 


indeed). 


Russian version


• Contributors: See Вводный_курс_по_Scribus:Участники 
• Status: Вводный курс по Scribus — in progress 
• Comment: 
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