Difference between revisions of "Использование мастер-страниц"

From Scribus Wiki
Jump to navigation Jump to search
(План А готов)
Line 12: Line 12:
  
 
===План A:===
 
===План A:===
<!-- Start of table -->
+
<!-- Начало таблицы -->
 
{|  
 
{|  
<!-- Row 1 -->
+
<!-- Строка 1 -->
 
|-
 
|-
<!-- Column 1 -->
+
<!-- Столбец 1 -->
|valign="top" |Create a new document. Choose from the main menu '''Edit > Master Pages...''' (Picture 1) to launch the ''Edit Master Pages'' dialog and to change into  the '''Master Pages Edit Mode''' (Picture 2).
+
|valign="top" |Создайте новый документ. Выберите из главного меню '''Правка > Мастер-страницы...''' (Иллюстрация 1) для запуска диалога ''Правка мастер-страниц'' и перехода в '''Режим правки мастер-страниц''' (Иллюстрация 2).
  
The master page '''Normal''' is always present and cannot be deleted  &ndash; the delete button will be disabled, if the master page '''Normal''' is selected  (Picture 2). The master page  '''Normal''' can be edited, it's better though, to leave it empty to be able to insert new empty pages.
+
Мастер-страница '''Normal''' есть в документе всегда и не может быть удалена &mdash; кнопка удаления для неё отключена (Иллюстрация 2). Эта мастер-страница может быть изменена, хотя лучше оставить её в исходном виде, чтобы можно было создавать новые чистые страницы.
  
[[Image:Master pages edit tooltip.png|frame|left|Picture 2]]
+
[[Image:Master pages edit tooltip.png|frame|left|Иллюстрация 2]]
  
If you move your mouse over the buttons, you will see some helpful tooltips (Picture 2).
+
Подержав курсор мыши над кнопками, можно увидеть полезные подсказки (Иллюстрация 2).
  
Beginning from the left side:
+
Кнопки слева направо:
  
* New Master Page
+
* Добавить мастер-страницу
* Duplicate Master Page
+
* Продублировать мастер-страницу
* Import Master Page
+
* Импортировать мастер-страницу из другого документа
* Delete Master Page
+
* Удалить мастер-страницу
  
Clicking on the Button '''Add a New Master Page''' opens a window in which you may give your page a name (Picture 3).  
+
Щелчком по кнопке '''Добавить мастер-страницу''' открывается диалог, в котором задаётся имя новой мастер-страницы (Иллюстрация 3).  
  
Tip: try to pick a name that will have some meaning describing its purpose, so that if you haven't used it for a while, its name gives a clue.
+
Совет: подбирайте такое имя, которое отражало бы назначение этой мастер-страницы, так чтобы вы всегда смогли догадаться, что в ней, даже если давно не работали с этим документом.
  
[[Image:Master pages new master page.png|frame|left|Picture 3]]
+
[[Image:Master pages new master page.png|frame|left|Иллюстрация 3]]
  
After you click '''OK''' you will see the window '''Edit Master Pages''' with your new Master Page highlighted. When you have a list of Master Pages you can then click from one to the next to edit each one as desired (Picture 4).
+
После нажатия кнопки '''OK''' вы увидите окно '''Правка мастер-страниц''', где будет выбрана только что созданная мастер-страница. Вы можете переключаться между созданными мастер-страницами одиночным щелчком мышью по их названиям (Иллюстрация 4).
  
When you close the '''Edit Master Pages''' window, you return to the normal editing mode in Scribus.
+
Закрыв окно Закрыв окно диалога '''Правка мастер-страниц''', вы вернётесь в обычный режим работы со Scribus.
  
[[Image:Master pages selecting master pages.png|frame|right|Picture 4]]
+
[[Image:Master pages selecting master pages.png|frame|right|Иллюстрация 4]]
  
If you find that you need a Master Page similar to an existing one, click on '''Duplicate the selected master page''' rather than starting a new Master Page from scratch -- this can be a great time-saver.  
+
Если вам нужна новая мастер-страница, мало отличающаяся от выбранной, нажмите кнопку '''Продублировать мастер-страницу''' &mdash; этим вы сэкономите себе время на создание новой мастер-страницы с нуля.  
  
You can also copy a Master Page from another document by clicking on '''Import master pages from another document''' button, which opens the '''Import Master Page''' window (Picture 5).  
+
Вы также можете добавить в текущий документ мастер-страницу из другого документа, щёлкнув по кнопке '''Импортировать мастер-страницу из другого документа''', которая откроет окно '''Импорт мастер-страницы''' (Иллюстрация 5).  
 
{| width=550px |
 
{| width=550px |
|[[Image:Master pages import.png|frame|left|Picture 5]]
+
|[[Image:Master pages import.png|frame|left|Иллюстрация 5]]
  
|Next, click on the button '''Change...''' to search for the document containing the Master Page you would like to import.
+
|Затем щёлкните кнопку '''Изменить...''' для выбора документа, содержащего нужную мастер-страницу.
 
|}
 
|}
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages menu edit.png|frame|right|Picture 1]]
+
[[Image:Master pages menu edit.png|frame|right|Иллюстрация 1]]
  
 
|}
 
|}
Line 69: Line 69:
 
|valign="top" |
 
|valign="top" |
  
You can also create new Master Pages from the page you are editing in normal editing mode. From the menu bar select '''Page > Convert to Master Page...''' (Picture 6). This opens a window entitled '''Convert Page to Master''' in which you may give this new Master Page a name (similar to Picture 3 above).
+
You can also create new Master Pages from the page you are editing in normal editing mode. From the menu bar select '''Page > Convert to Master Page...''' (Иллюстрация 6). This opens a window entitled '''Convert Page to Master''' in which you may give this new Master Page a name (similar to Picture 3 above).
  
 
Afterward, you may then go back to '''Edit > Master Pages...''' where you will find your new Master Page in the '''Edit Master Pages''' window (Picture 4 above).
 
Afterward, you may then go back to '''Edit > Master Pages...''' where you will find your new Master Page in the '''Edit Master Pages''' window (Picture 4 above).
Line 75: Line 75:
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages convert2masterpage.png|frame|Picture 6]]
+
[[Image:Master pages convert2masterpage.png|frame|Иллюстрация 6]]
 
|}
 
|}
  
Line 89: Line 89:
 
|valign="top" |
 
|valign="top" |
 
[[Image:NewDoc_layout.png|frame|left|Picture 7]]
 
[[Image:NewDoc_layout.png|frame|left|Picture 7]]
[[Image:Master_pages_new_double_sided.png|frame|right|Picture 8 - Double Sided]]
+
[[Image:Master_pages_new_double_sided.png|frame|right|Иллюстрация - Double Sided]]
 
[[Image:Master pages new 3fold.png|frame|right|Picture 9 - 3-fold]]
 
[[Image:Master pages new 3fold.png|frame|right|Picture 9 - 3-fold]]
 
[[Image:Master pages new 4fold.png|frame|right|Picture 10 - 4-fold]]
 
[[Image:Master pages new 4fold.png|frame|right|Picture 10 - 4-fold]]
 
So how can we use these concepts with Double Sided, 3-fold and 4-fold document layouts?
 
So how can we use these concepts with Double Sided, 3-fold and 4-fold document layouts?
  
Actually, you will find that these are situations where using Master Pages is especially useful and time-saving. When you create a new document, select your desired layout(Picture 7).
+
Actually, you will find that these are situations where using Master Pages is especially useful and time-saving. When you create a new document, select your desired layout(Иллюстрация 7).
  
 
After this, create your Master Pages as explained above for Plan A or Plan B. To the right we see why the name chosen for a Master Page is especially important and helpful.
 
After this, create your Master Pages as explained above for Plan A or Plan B. To the right we see why the name chosen for a Master Page is especially important and helpful.
  
* Double Sided layout (Picture 8)
+
* Double Sided layout (Иллюстрация 8)
* 3-fold layout  (Picture 9)
+
* 3-fold layout  (Иллюстрация 9)
* 4-fold layout (Picture 10)
+
* 4-fold layout (Иллюстрация 10)
  
  
Line 117: Line 117:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Context_masterpage.jpg|frame|left|Picture 11]]
+
[[Image:Context_masterpage.jpg|frame|left|Иллюстрация 11]]
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages apply.png|frame|right|Picture 12]]
+
[[Image:Master pages apply.png|frame|right|Иллюстрация 12]]
 
|}
 
|}
  
 
<!-- End of  table -->
 
<!-- End of  table -->
Selecting either '''Page > Apply Master Page...''' (Picture 7) or '''Apply Master Page...''' from the context menu (right-click on the page - Picture 11) opens up the '''Apply Master Page''' window. From this you may choose to apply the Master page to the:
+
Selecting either '''Page > Apply Master Page...''' (Иллюстрация 7) or '''Apply Master Page...''' from the context menu (right-click on the page - Picture 11) opens up the '''Apply Master Page''' window. From this you may choose to apply the Master page to the:
  
 
* Current page
 
* Current page
Line 143: Line 143:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages insert new page.png|frame|left|Picture 13]]
+
[[Image:Master pages insert new page.png|frame|left|Иллюстрация 13]]
 
When you insert a new page (menu bar '''Page > Insert'''), you open up a window from which you can choose to add one or more pages, choose the place of insertion, and in addition decide whether these new pages will contain Master Page elements (Picture 13).  
 
When you insert a new page (menu bar '''Page > Insert'''), you open up a window from which you can choose to add one or more pages, choose the place of insertion, and in addition decide whether these new pages will contain Master Page elements (Picture 13).  
  
Line 156: Line 156:
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages 4fold newpage.png|frame|Picture 14]]
+
[[Image:Master pages 4fold newpage.png|frame|Иллюстрация 14]]
 
|}
 
|}
  

Revision as of 02:49, 4 December 2006

Главная страница

Уроки

  1. Вводный курс по Scribus
  2. Плашечные цвета
  3. Использование мастер-страниц
  4. Вёрстка статей

перевод в процессе!!!

Зачем нужны мастер-страницы

Как только вы столкнётесь с необходимостью использовать много одинаковых объектов (общих «шапок», логотипов, фоновых изображений, номеров страниц и т.д.) в одинаковых местах страниц на протяжении всего документа, вам посоветуют использовать мастер-страницы. Использование мастер-страниц позволяет избежать ненужной и нудной работы и сэкономить время. Объекты, являющиеся частью мастер-страницы, не могут изменяться в режиме обычной правки. Причиной тому является возможностью случайной нежелательной правки содержимого мастер-страницы. Мастер-страница всегда является частью документа и не может быть сохранена в отдельный файл. Вместе с тем, вы можете создать документ, содержащий наиболее часто используемые мастер-страницы и использовать его в качестве источника для новых документов (импортировать в них мастер-страницы).

Как создать мастер-страницы

План A:

Создайте новый документ. Выберите из главного меню Правка > Мастер-страницы... (Иллюстрация 1) для запуска диалога Правка мастер-страниц и перехода в Режим правки мастер-страниц (Иллюстрация 2).

Мастер-страница Normal есть в документе всегда и не может быть удалена — кнопка удаления для неё отключена (Иллюстрация 2). Эта мастер-страница может быть изменена, хотя лучше оставить её в исходном виде, чтобы можно было создавать новые чистые страницы.

Иллюстрация 2

Подержав курсор мыши над кнопками, можно увидеть полезные подсказки (Иллюстрация 2).

Кнопки слева направо:

  • Добавить мастер-страницу
  • Продублировать мастер-страницу
  • Импортировать мастер-страницу из другого документа
  • Удалить мастер-страницу

Щелчком по кнопке Добавить мастер-страницу открывается диалог, в котором задаётся имя новой мастер-страницы (Иллюстрация 3).

Совет: подбирайте такое имя, которое отражало бы назначение этой мастер-страницы, так чтобы вы всегда смогли догадаться, что в ней, даже если давно не работали с этим документом.

Иллюстрация 3

После нажатия кнопки OK вы увидите окно Правка мастер-страниц, где будет выбрана только что созданная мастер-страница. Вы можете переключаться между созданными мастер-страницами одиночным щелчком мышью по их названиям (Иллюстрация 4).

Закрыв окно Закрыв окно диалога Правка мастер-страниц, вы вернётесь в обычный режим работы со Scribus.

Иллюстрация 4

Если вам нужна новая мастер-страница, мало отличающаяся от выбранной, нажмите кнопку Продублировать мастер-страницу — этим вы сэкономите себе время на создание новой мастер-страницы с нуля.

Вы также можете добавить в текущий документ мастер-страницу из другого документа, щёлкнув по кнопке Импортировать мастер-страницу из другого документа, которая откроет окно Импорт мастер-страницы (Иллюстрация 5).

Иллюстрация 5
Затем щёлкните кнопку Изменить... для выбора документа, содержащего нужную мастер-страницу.
Иллюстрация 1


План Б:

You can also create new Master Pages from the page you are editing in normal editing mode. From the menu bar select Page > Convert to Master Page... (Иллюстрация 6). This opens a window entitled Convert Page to Master in which you may give this new Master Page a name (similar to Picture 3 above).

Afterward, you may then go back to Edit > Master Pages... where you will find your new Master Page in the Edit Master Pages window (Picture 4 above).

Иллюстрация 6


Double sided, 3-fold and 4-fold Pages

Picture 7
Иллюстрация - Double Sided
Picture 9 - 3-fold
Picture 10 - 4-fold

So how can we use these concepts with Double Sided, 3-fold and 4-fold document layouts?

Actually, you will find that these are situations where using Master Pages is especially useful and time-saving. When you create a new document, select your desired layout(Иллюстрация 7).

After this, create your Master Pages as explained above for Plan A or Plan B. To the right we see why the name chosen for a Master Page is especially important and helpful.

  • Double Sided layout (Иллюстрация 8)
  • 3-fold layout (Иллюстрация 9)
  • 4-fold layout (Иллюстрация 10)



Applying master pages

To empty document pages:

Иллюстрация 11
Иллюстрация 12

Selecting either Page > Apply Master Page... (Иллюстрация 7) or Apply Master Page... from the context menu (right-click on the page - Picture 11) opens up the Apply Master Page window. From this you may choose to apply the Master page to the:

  • Current page
  • Even pages
  • Odd pages
  • All pages
  • and you may apply to a range of pages

Select the desired Master Page from the drop-down list labeled Master Page.

Perhaps not surprisingly, the option Even pages can only be selected when the document has more than one page. Also, applying to a range of pages only applies when you have selected All pages.

Inserting as a new page:

Иллюстрация 13

When you insert a new page (menu bar Page > Insert), you open up a window from which you can choose to add one or more pages, choose the place of insertion, and in addition decide whether these new pages will contain Master Page elements (Picture 13).

Note that the Master Pages area expands according to your layout, so that in Picture 14 we see the appearance of an Insert Page window for a 4-fold layout.

Hint: Page numbering is best accomplished with Story Editor. While you are in Edit Master Page mode, create a text frame with the appropriate location for your page numbering. From the Story Editor menu, select Insert > Character > Page Number (keyboard: Ctrl+Shift+Alt+P). This appears as # in the Story Editor window, but this is not Shift+3.

For proper spacing, make at least 2 of these special characters when page numbering will be as high as 2 digits (10-99), at least 3 when page numbers need to be 100-999.


Иллюстрация 14


The first German version of this howto was published originally at the German Scribus Forum.