Difference between revisions of "Использование мастер-страниц"

From Scribus Wiki
Jump to navigation Jump to search
(терминология ёк!)
 
(11 intermediate revisions by 3 users not shown)
Line 3: Line 3:
 
{{TOC_sidebar_RU}}
 
{{TOC_sidebar_RU}}
  
==Why master pages==
 
As soon as you consider using many objects (common headers, logos, background, page numbers etc.) on the same places throughout your document, you will be well advised to use master pages. You'll avoid some unnecessary drudgery and spare much time this way. The objects belonging to master pages cannot be changed in the normal Edit Mode.  There as a good reason for it, since it could easily happen while working with a document that something on a master page would be unintentionally moved or changed. A master page always belongs to a document – it cannot be saved as a separate file. You can however create a sample file containing frequently used master pages and use it as resource to import master pages into other Scribus documents.
 
  
==How to create master pages==
+
==Зачем нужны мастер-страницы==
  
===Plan A:===
+
Как только вы столкнётесь с необходимостью использовать много одинаковых объектов (общих «шапок», логотипов, фоновых изображений, номеров страниц и т.д.) в одинаковых местах страниц на протяжении всего документа, вам посоветуют использовать мастер-страницы. Использование мастер-страниц позволяет избежать ненужной и нудной работы и сэкономить время. Объекты, являющиеся частью мастер-страницы, не могут изменяться в режиме обычной правки. Причиной тому является возможностью случайной нежелательной правки содержимого мастер-страницы. Мастер-страница всегда является частью документа и не может быть сохранена в отдельный файл. Вместе с тем, вы можете создать документ, содержащий наиболее часто используемые мастер-страницы и использовать его в качестве источника для новых документов (импортировать в них мастер-страницы).
<!-- Start of table -->
+
 
 +
==Как создать мастер-страницы==
 +
 
 +
===План A:===
 +
<!-- Начало таблицы -->
 
{|  
 
{|  
<!-- Row 1 -->
+
<!-- Строка 1 -->
 
|-
 
|-
<!-- Column 1 -->
+
<!-- Столбец 1 -->
|valign="top" |Create a new document. Choose from the main menu '''Edit > Master Pages...''' (Picture 1) to launch the ''Edit Master Pages'' dialog and to change into  the '''Master Pages Edit Mode''' (Picture 2).
+
|valign="top" |Создайте новый документ. Выберите из главного меню '''Правка > Мастер-страницы...''' (Иллюстрация 1) для запуска диалога ''Правка мастер-страниц'' и перехода в '''Режим правки мастер-страниц''' (Иллюстрация 2).
 +
 
 +
Мастер-страница '''Normal''' есть в документе всегда и не может быть удалена &mdash; кнопка удаления для неё отключена (Иллюстрация 2). Эта мастер-страница может быть изменена, хотя лучше оставить её в исходном виде, чтобы можно было создавать новые чистые страницы.
  
The master page '''Normal''' is always present and cannot be deleted  &ndash; the delete button will be disabled, if the master page '''Normal''' is selected  (Picture 2). The master page  '''Normal''' can be edited, it's better though, to leave it empty to be able to insert new empty pages.
+
[[Image:Master_pages_edit_tooltip_ru.png|frame|left|Иллюстрация 2]]
  
[[Image:Master pages edit tooltip.png|frame|left|Picture 2]]
+
Подержав курсор мыши над кнопками, можно увидеть полезные подсказки (Иллюстрация 2).
  
If you move your mouse over the buttons, you will see some helpful tooltips (Picture 2).
+
Кнопки слева направо:
  
Beginning from the left side:
+
* Добавить новую мастер-страницу
 +
* Продублировать выбранную мастер-страницу
 +
* Импортировать мастер-страницу из другого документа
 +
* Удалить выбранную мастер-страницу
  
* New Master Page
+
Щелчком по кнопке '''Добавить новую мастер-страницу''' открывается диалог, в котором задаётся имя новой мастер-страницы (Иллюстрация 3).
* Duplicate Master Page
 
* Import Master Page
 
* Delete Master Page
 
  
Clicking on the Button '''Add a New Master Page''' opens a window in which you may give your page a name (Picture 3).  
+
Совет: подбирайте такое имя, которое отражало бы назначение этой мастер-страницы, так чтобы вы всегда смогли догадаться, что в ней, даже если давно не работали с этим документом.
  
Tip: try to pick a name that will have some meaning describing its purpose, so that if you haven't used it for a while, its name gives a clue.
+
[[Image:Master_pages_new_master_page_ru.png|frame|left|Иллюстрация 3]]
  
[[Image:Master pages new master page.png|frame|left|Picture 3]]
+
После нажатия кнопки '''OK''' вы увидите окно '''Правка мастер-страниц''', где будет выбрана только что созданная мастер-страница. Вы можете переключаться между созданными мастер-страницами одиночным щелчком мышью по их названиям (Иллюстрация 4).
  
After you click '''OK''' you will see the window '''Edit Master Pages''' with your new Master Page highlighted. When you have a list of Master Pages you can then click from one to the next to edit each one as desired (Picture 4).
+
Закрыв окно диалога '''Правка мастер-страниц''', вы вернётесь в обычный режим работы со Scribus.
  
When you close the '''Edit Master Pages''' window, you return to the normal editing mode in Scribus.
+
[[Image:Master_pages_selecting_master_pages_ru.png|frame|left|Иллюстрация 4]]
  
[[Image:Master pages selecting master pages.png|frame|right|Picture 4]]
+
Если вам нужна новая мастер-страница, мало отличающаяся от выбранной, нажмите кнопку '''Продублировать мастер-страницу''' &mdash; этим вы сэкономите себе время на создание новой мастер-страницы с нуля.  
  
If you find that you need a Master Page similar to an existing one, click on '''Duplicate the selected master page''' rather than starting a new Master Page from scratch -- this can be a great time-saver.  
+
Вы также можете добавить в текущий документ мастер-страницу из другого документа, щёлкнув по кнопке '''Импортировать мастер-страницу из другого документа''', которая откроет окно '''Импорт мастер-страницы''' (Иллюстрация 5).
  
You can also copy a Master Page from another document by clicking on '''Import master pages from another document''' button, which opens the '''Import Master Page''' window (Picture 5).
 
 
{| width=550px |
 
{| width=550px |
|[[Image:Master pages import.png|frame|left|Picture 5]]
+
|[[Image:Master_pages_import_ru.png|frame|right|Иллюстрация 5]]
  
|Next, click on the button '''Change...''' to search for the document containing the Master Page you would like to import.
+
|Затем щёлкните кнопку '''Изменить...''' для выбора документа, содержащего нужную мастер-страницу.
 
|}
 
|}
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages menu edit.png|frame|right|Picture 1]]
+
[[Image:Master_pages_menu_edit_ru.png|frame|right|Иллюстрация 1]]
  
 
|}
 
|}
Line 57: Line 60:
 
<!-- End of  table -->
 
<!-- End of  table -->
  
===Plan B:===
+
===План Б:===
  
 
<!-- Start of table -->
 
<!-- Start of table -->
Line 66: Line 69:
 
|valign="top" |
 
|valign="top" |
  
You can also create new Master Pages from the page you are editing in normal editing mode. From the menu bar select '''Page > Convert to Master Page...''' (Picture 6). This opens a window entitled '''Convert Page to Master''' in which you may give this new Master Page a name (similar to Picture 3 above).
+
Вы можете создавать новые мастер-страницы из обычной редактируемой страницы документа. В меню выберите пункт '''Страница > Преобразовать в мастер-страницу...''' (Иллюстрация 6). Вслед за этим появится диалоговое окно '''Преобразовать в мастер-страницу''', в которое можно дать название новой мастер-странице (наподобие Иллюстрации 3 вверху).
  
Afterward, you may then go back to '''Edit > Master Pages...''' where you will find your new Master Page in the '''Edit Master Pages''' window (Picture 4 above).
+
После этого вы можете вернуться в меню '''Правка > Мастер-страницы...''' и в диалоге '''Правка мастер-страниц''' найти свежесозданную мастер-страницу (Иллюстрация 4 вверху).
  
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages convert2masterpage.png|frame|Picture 6]]
+
[[Image:Master_pages_convert2masterpage_ru.png|frame|Иллюстрация 6]]
 
|}
 
|}
  
 
<!-- End of  table -->
 
<!-- End of  table -->
  
==Double sided, 3-fold and 4-fold Pages==
+
==Двухсторонние страницы, страницы с двумя и тремя фальцовками==
  
 
<!-- Start of table -->
 
<!-- Start of table -->
Line 85: Line 88:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:NewDoc_layout.png|frame|left|Picture 7]]
+
[[Image:NewDoc_layout_ru.png|frame|left|Иллюстрация 7]]
[[Image:Master_pages_new_double_sided.png|frame|right|Picture 8 - Double Sided]]
+
[[Image:Master_pages_new_double_sided_ru.png|frame|right|Иллюстрация - Double Sided]]
[[Image:Master pages new 3fold.png|frame|right|Picture 9 - 3-fold]]
+
[[Image:Master_pages_new_3fold_ru.png|frame|right|Иллюстрация 9 - 3-fold]]
[[Image:Master pages new 4fold.png|frame|right|Picture 10 - 4-fold]]
+
[[Image:Master_pages_new_4fold_ru.png|frame|right|Иллюстрация 10 - 4-fold]]
So how can we use these concepts with Double Sided, 3-fold and 4-fold document layouts?
+
Как мы можем использовать эти концепции с двухсторонними страницами, а также страницами с двумя и тремя фальцовками?
  
Actually, you will find that these are situations where using Master Pages is especially useful and time-saving. When you create a new document, select your desired layout(Picture 7).
+
Вы заметите, что именно в таких случаях использование мастер-страниц особенно экономит время. При создании нового документа выберите подходящий макет (Иллюстрация 7). После этого создайте мастер-страницы согласно Плану А или Плану Б. На иллюстрации справа вы увидите, почему правильно выбранные названия мастер страниц так важны.
 
 
After this, create your Master Pages as explained above for Plan A or Plan B. To the right we see why the name chosen for a Master Page is especially important and helpful.
 
 
 
* Double Sided layout (Picture 8)
 
* 3-fold layout  (Picture 9)
 
* 4-fold layout (Picture 10)
 
  
 +
* двухсторонний макет (Иллюстрация 8)
 +
* макет с двумя фальцовками (Иллюстрация 9)
 +
* макет с тремя фальцовками (Иллюстрация 10)
  
 
|}
 
|}
Line 104: Line 104:
 
<!-- End of  table -->
 
<!-- End of  table -->
  
==Applying master pages==
+
==Применение мастер-страниц==
  
===To empty document pages:===
+
===К чистым страницам документа:===
  
 
<!-- Start of table -->
 
<!-- Start of table -->
Line 114: Line 114:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Context_masterpage.jpg|frame|left|Picture 11]]
+
[[Image:Context_masterpage_ru.png|frame|left|Иллюстрация 11]]
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages apply.png|frame|right|Picture 12]]
+
[[Image:Master_pages_apply_ru.png|frame|right|Иллюстрация 12]]
 
|}
 
|}
  
 
<!-- End of  table -->
 
<!-- End of  table -->
Selecting either '''Page > Apply Master Page...''' (Picture 7) or '''Apply Master Page...''' from the context menu (right-click on the page - Picture 11) opens up the '''Apply Master Page''' window. From this you may choose to apply the Master page to the:
+
Через пункт меню '''Страница > Применить мастер-страницу...''' (Иллюстрация 7) или '''Применить мастер-страницу...''' в контекстном меню (щелчком правой клавишей мыши по странице - Иллюстрация 11) открывается  окно '''Применение мастер-страницы'''. В нём вы можете выбрать, к чему применить мастер-страницу:
  
* Current page
+
* к текущей странице;
* Even pages
+
* к чётным страницам;
* Odd pages
+
* к нечётным страницам;
* All pages
+
* ко всем страницам;
* and you may apply to a range of pages
+
* к диапазону страниц.
  
Select the desired Master Page from the drop-down list labeled '''Master Page'''.
+
Выберите нужную мастер-страницу из раскрывающегося списка '''Мастер-страница'''.
  
Perhaps not surprisingly, the option '''Even pages''' can only be selected when the document has more than one page. Also, applying to a range of pages only applies when you have selected '''All pages'''.
+
Вряд ли вас удивит, что вариант '''Чётные страницы''' доступен только если в документе больше одной страницы. Кроме того, диапазон можно указать только в том случае, когда выбран вариант '''Все страницы'''.
  
===Inserting as a new page:===
+
===Вставка в качестве новых страниц:===
 
<!-- Start of table -->
 
<!-- Start of table -->
 
{|  
 
{|  
Line 140: Line 140:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages insert new page.png|frame|left|Picture 13]]
+
[[Image:Master_pages_insert_new_page_ru.png|frame|left|Иллюстрация 13]]
When you insert a new page (menu bar '''Page > Insert'''), you open up a window from which you can choose to add one or more pages, choose the place of insertion, and in addition decide whether these new pages will contain Master Page elements (Picture 13).  
+
При вставке новой страницы (меню '''Страница > Вставить''') открывается диалог, в котором можно выбрать количество добавляемых страниц, откуда начинать вставку и автоматически применяемые мастер-страницы, если в них есть необходимость (Иллюстрация 13).  
  
Note that the '''Master Pages''' area expands according to your layout, so that in Picture 14 we see the appearance of an '''Insert Page''' window for a 4-fold layout.
+
Обратите внимание на то, что область '''Мастер-страницы''' изменяется согласно макету документа. На Иллюстрации 14 изображён диалог вставки страницы в документ, использующий макет '''Три фальцовки'''.
  
'''Hint:'''
+
'''Совет:'''
Page numbering is best accomplished with Story Editor. While you are in Edit Master Page mode, create a text frame with the appropriate location for your page numbering. From the Story Editor menu, select '''Insert > Character > Page Number''' (keyboard: '''Ctrl+Shift+Alt+P'''). This appears as <font color="red">#</font> in the Story Editor window, but this is not Shift+3.
+
Пагинацию лучше всего делать в Story Editor. Находясь в режиме редактирования мастер-страницы, создайте текстовый блок на месте предполагаемого номера страниц. Из меню Story Editor выберите '''Вставка > Символ > Номер страницы''' (или используйте комбинацию клавиш '''Ctrl+Shift+Alt+P'''). В окне Story Editor появится символ <font color="red">#</font>, но это будет не символ, получаемый по Shift+3.
 
 
For proper spacing, make at least 2 of these special characters when page numbering will be as high as 2 digits (10-99), at least 3 when page numbers need to be 100-999.
 
  
 +
Если количество страниц в документе двухзначное (10-99), введите хотя бы два таких спецсимвола, а если трёхзначное, т.е. 100-999 - хотя бы три.
  
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages 4fold newpage.png|frame|Picture 14]]
+
[[Image:Master_pages_4fold_newpage_ru.png|frame|Иллюстрация 14]]
 
|}
 
|}
  
 
<!-- End of  table -->
 
<!-- End of  table -->
  
<div style="text-align:center;background-color:#065682;color:white">
+
<div style="text-align:center;background-color:#5599bb;color:white">
 
 
With many thanks to the original author, Roswitha Ott aka Uchiki, who kindly contributed the first German version of this howto to the Scribus Public Wiki.
 
  
</div>
+
[[Arbeiten mit Musterseiten| '''Первая версия этой статьи на немецком''']] была опубликована на немецкоязычном форуме по Scribus. </div>

Latest revision as of 17:32, 6 November 2008

Главная страница

Уроки

  1. Вводный курс по Scribus
  2. Плашечные цвета
  3. Использование мастер-страниц
  4. Вёрстка статей


Зачем нужны мастер-страницы

Как только вы столкнётесь с необходимостью использовать много одинаковых объектов (общих «шапок», логотипов, фоновых изображений, номеров страниц и т.д.) в одинаковых местах страниц на протяжении всего документа, вам посоветуют использовать мастер-страницы. Использование мастер-страниц позволяет избежать ненужной и нудной работы и сэкономить время. Объекты, являющиеся частью мастер-страницы, не могут изменяться в режиме обычной правки. Причиной тому является возможностью случайной нежелательной правки содержимого мастер-страницы. Мастер-страница всегда является частью документа и не может быть сохранена в отдельный файл. Вместе с тем, вы можете создать документ, содержащий наиболее часто используемые мастер-страницы и использовать его в качестве источника для новых документов (импортировать в них мастер-страницы).

Как создать мастер-страницы

План A:

Создайте новый документ. Выберите из главного меню Правка > Мастер-страницы... (Иллюстрация 1) для запуска диалога Правка мастер-страниц и перехода в Режим правки мастер-страниц (Иллюстрация 2).

Мастер-страница Normal есть в документе всегда и не может быть удалена — кнопка удаления для неё отключена (Иллюстрация 2). Эта мастер-страница может быть изменена, хотя лучше оставить её в исходном виде, чтобы можно было создавать новые чистые страницы.

Иллюстрация 2

Подержав курсор мыши над кнопками, можно увидеть полезные подсказки (Иллюстрация 2).

Кнопки слева направо:

  • Добавить новую мастер-страницу
  • Продублировать выбранную мастер-страницу
  • Импортировать мастер-страницу из другого документа
  • Удалить выбранную мастер-страницу

Щелчком по кнопке Добавить новую мастер-страницу открывается диалог, в котором задаётся имя новой мастер-страницы (Иллюстрация 3).

Совет: подбирайте такое имя, которое отражало бы назначение этой мастер-страницы, так чтобы вы всегда смогли догадаться, что в ней, даже если давно не работали с этим документом.

Иллюстрация 3

После нажатия кнопки OK вы увидите окно Правка мастер-страниц, где будет выбрана только что созданная мастер-страница. Вы можете переключаться между созданными мастер-страницами одиночным щелчком мышью по их названиям (Иллюстрация 4).

Закрыв окно диалога Правка мастер-страниц, вы вернётесь в обычный режим работы со Scribus.

Иллюстрация 4

Если вам нужна новая мастер-страница, мало отличающаяся от выбранной, нажмите кнопку Продублировать мастер-страницу — этим вы сэкономите себе время на создание новой мастер-страницы с нуля.

Вы также можете добавить в текущий документ мастер-страницу из другого документа, щёлкнув по кнопке Импортировать мастер-страницу из другого документа, которая откроет окно Импорт мастер-страницы (Иллюстрация 5).

Иллюстрация 5
Затем щёлкните кнопку Изменить... для выбора документа, содержащего нужную мастер-страницу.
Иллюстрация 1


План Б:

Вы можете создавать новые мастер-страницы из обычной редактируемой страницы документа. В меню выберите пункт Страница > Преобразовать в мастер-страницу... (Иллюстрация 6). Вслед за этим появится диалоговое окно Преобразовать в мастер-страницу, в которое можно дать название новой мастер-странице (наподобие Иллюстрации 3 вверху).

После этого вы можете вернуться в меню Правка > Мастер-страницы... и в диалоге Правка мастер-страниц найти свежесозданную мастер-страницу (Иллюстрация 4 вверху).

Иллюстрация 6


Двухсторонние страницы, страницы с двумя и тремя фальцовками

Иллюстрация 7
Иллюстрация - Double Sided
Иллюстрация 9 - 3-fold
Иллюстрация 10 - 4-fold

Как мы можем использовать эти концепции с двухсторонними страницами, а также страницами с двумя и тремя фальцовками?

Вы заметите, что именно в таких случаях использование мастер-страниц особенно экономит время. При создании нового документа выберите подходящий макет (Иллюстрация 7). После этого создайте мастер-страницы согласно Плану А или Плану Б. На иллюстрации справа вы увидите, почему правильно выбранные названия мастер страниц так важны.

  • двухсторонний макет (Иллюстрация 8)
  • макет с двумя фальцовками (Иллюстрация 9)
  • макет с тремя фальцовками (Иллюстрация 10)


Применение мастер-страниц

К чистым страницам документа:

Иллюстрация 11
Иллюстрация 12

Через пункт меню Страница > Применить мастер-страницу... (Иллюстрация 7) или Применить мастер-страницу... в контекстном меню (щелчком правой клавишей мыши по странице - Иллюстрация 11) открывается окно Применение мастер-страницы. В нём вы можете выбрать, к чему применить мастер-страницу:

  • к текущей странице;
  • к чётным страницам;
  • к нечётным страницам;
  • ко всем страницам;
  • к диапазону страниц.

Выберите нужную мастер-страницу из раскрывающегося списка Мастер-страница.

Вряд ли вас удивит, что вариант Чётные страницы доступен только если в документе больше одной страницы. Кроме того, диапазон можно указать только в том случае, когда выбран вариант Все страницы.

Вставка в качестве новых страниц:

Иллюстрация 13

При вставке новой страницы (меню Страница > Вставить) открывается диалог, в котором можно выбрать количество добавляемых страниц, откуда начинать вставку и автоматически применяемые мастер-страницы, если в них есть необходимость (Иллюстрация 13).

Обратите внимание на то, что область Мастер-страницы изменяется согласно макету документа. На Иллюстрации 14 изображён диалог вставки страницы в документ, использующий макет Три фальцовки.

Совет: Пагинацию лучше всего делать в Story Editor. Находясь в режиме редактирования мастер-страницы, создайте текстовый блок на месте предполагаемого номера страниц. Из меню Story Editor выберите Вставка > Символ > Номер страницы (или используйте комбинацию клавиш Ctrl+Shift+Alt+P). В окне Story Editor появится символ #, но это будет не символ, получаемый по Shift+3.

Если количество страниц в документе двухзначное (10-99), введите хотя бы два таких спецсимвола, а если трёхзначное, т.е. 100-999 - хотя бы три.

Иллюстрация 14


Первая версия этой статьи на немецком была опубликована на немецкоязычном форуме по Scribus.