Arbeiten mit Bildrahmen

From Scribus Wiki
Revision as of 22:17, 30 March 2007 by Uchiki (talk | contribs)
Jump to: navigation, search
Dieser Artikel gehört zur Kategorie Deutsche HOWTOs.
Installation Anwendungsfragen PDF-Export DTP Sonstiges

Dieser Artikel ist eine Zusammenstellung über das Arbeiten mit Bildrahmen. Scribus kann zwar größtenteils intuitiv benutzt werden, trotzdem findest Du hier vielleicht Funktionen die Du bisher nicht gefunden hast – oder einen direkteren Weg zum Ziel.

Bildrahmen erzeugen

Erzeuge einen Bildrahmen durch:

  1. Klicke auf das Symbol Bildrahmen einfügen in der Werkzeug-Menüleiste
  2. Über Menü > Einfügen > Bildrahmen
  3. Tastaturkürzel: I

Dies ermöglicht Dir mit der Maus den Bildrahmen zu platzieren und auf die gewünschte Größe zu bringen (der Cursor verwandelt sich in ein kleines Bild): Die linke Maustaste gedrückt halten und diagonal über die Seite ziehen. Der Mausklick bestimmt eine Ecke des Rahmens ohne die diagonal gegenüberliegende Ecke festzulegen. Als Rechtshänder zieht man üblicherweise von der linken oberen Ecke zur unteren rechten Ecke, aber Du kannst auch in eine beliebige Richtung ziehen.

Kontextmenü

Durch Anklicken des Bildrahmens mit der rechten Maustaste aktiviert man das Kontextmenü – dieses enthält einige häufig benutzte Funktionen für Bildrahmen. Eine wichtige Funktion ist die Möglichkeit einen Bildrahmen in einen anderen Rahmentyp zu konvertieren.

Größe und Position des Bildrahmens

Hier wirst Du feststellen daß die Eigenschaftenpalette ein unentbehrliches Werkzeug für die Arbeit mit Scribus ist. Falls Du sie nicht schon offen hast, öffne sie über Menü > Fenster > Eigenschaften oder über das Kontextmenü. (Version 1.2.4: Werkzeuge > Eigenschaften). Der X,Y,Z-Abschnitt zeigt ganz exakte Informationen über die X,Y-Position der linken oberen Ecke des Rahmens sowie über eine mögliche Drehung des Rahmens. Beachte das diese Informationen nur für den markierten Rahmen angezeigt werden (sichtbar als rote Strichline). Beim Neuanlegen eines Rahmens wird dieser automatisch markiert. Die Markierung wird aufgehoben indem irgendwo außerhalb des Rahmens auf die Seite geklickt wird – wieder markiert wird der Rahmen durch Klicken innerhalb des Rahmens. Um einen Rahmen zu bearbeiten, zu verschieben oder zu löschen muß er markiert sein.

Ein Bild in den Rahmen laden

Wen Du einen Bildrahmen neu anlegst ist er leer – außer einem X zwischen den gegenüberliegenden Ecken um anzuzeigen daß kein Bild geladen ist.

Importierbare Bildformate sind TIFF, JPEG, PNG, GIF, XPM und EPS. Du kannst auch ein PDF-Dokument importieren, allerdings wird nur die erste Seite in den Rahmen geladen (um dieses Problem zu umgehen siehe den grünen Kasten unten). Schaue auch in das Scribus Handbuch Hilfe > Handbuch für Scribus (oder auf der Tastatur F1) siehe dann unter Documentation > Importing (bisher in Englisch) zur Handhabung der verschiedenen Formate.

Lade ein Bild in den Rahmen indem Du auf den Eintrag Bild laden im Kontextmenü klickst, oder über Menü > Datei > Importieren > Bild laden... (Tastatur: Alt+D+I). Standardmäßig wird das Bild in seiner tatsächlichen Größe geladen, mit der linken oberen Bildecke in der linken oberen Ecke des Bildrahmens. Natürlich kannst Du jetzt den Rahmen größenmäßig an das Bild anpassen, aber in den meisten Fällen wirst Du das Bild an den Rahmen anpassen wollen. Wenn Du weißt wie groß der Rahmen sein soll dann lese den nächsten Abschnitt und gehe anschließend zu Eigenschaften: Bild-Abschnitt.

Was ist mit SVGs?

SVGs sind ein OpenSource-Vektorgraphikformat (Scalable Vector Graphics), und eigentlich ein ideales Graphikformat für DTP. SVGs werden nicht in einen Bildrahmen importiert, sondern können in Scribus direkt importiert werden: Menü > Datei > Importieren > SVG importieren... SVGs können in der Größe verändert und verschoben werden, ein paar Bearbeitungsmöglichkeiten es gibt auch. Einige Merkmale des Dateiformates werden in Scribus noch nicht unterstützt. Bis jetzt kann ein SVG nur in einen Scribus-Bildrahmen geladen werden wenn Du zuvor ein Vektor-Zeichenprogramm wie Inkscape oder Sodipodi benutzt hast um das SVG in eines der linksstehenden Formate abzuspeicheren.

Wenn Du das machst, solltest Du die Bildgröße höher (höherer DPI-Wert) als die Standardwerte setzen, um eine Verpixelung in Deinem Scribus-Dokument zu vermeiden.

Mehrere Seiten eines PDFs importieren

Das ist zur Zeit nur mit Fremdsoftware wie z.B. Adobe Acrobat möglich. Es gibt ein OpenSource/Freeware Programm namens pdftk welches Deine mehrseitigen PDFs in Einzelseiten zerlegen kann. Denke daran daß Scribus aus einem mehrseitigen Dokument mehrere Einzelseiten-PDFs auf einen Schlag erzeugen kann – im Dialog zum PDF-Export findest Du diese Option.

Eigenschaften: X,Y,Z-Abschnitt – Größenänderung und Verschieben

Eigenschaften: XYZ-Abschnitt

Mit der Maus im Rahmen: Mit der Eigenschaftenpalette:
  1. Klicke und verschiebe irgendwo innerhalb des Rahmens um ihn zu verschieben. Rahmen konnen auch außerhalb der Seite platziert werden oder von einer Seite zur einer anderen gezogen werden (abhängig von der jeweiligen Scribus-Version)
  2. Klicke und verschiebe eines der kleinen roten Rechtecke auf dem Rahmenrand
Es gibt drei Möglichkeiten die Einstellungen zu ändern:
  1. die Werte mit der Tastatur ändern
  2. mit der Maus auf den Auf-Abpfeil rechts neben den Wertefeldern klicken. Die Auf-Abpfeile auf der Tastatur bewirken dasselbe
  3. das Mausrad auf den Wertefeldern benutzen – normalerweise reicht es den Mauscursor über das Wertefeld zu bewegen, falls das nicht geht: zuerst in das Wertefeld klicken

Beachte für die Punkte 2 und 3: gleichzeitiges Drücken von Strg, Umschalt oder Strg+Umschalt wechselt zwischen den Dezimalstellen (funktioniert auch mit den Pfeilen auf der Tastatur):

Ohne Taste: 1. Stelle links vom Dezimalpunkt

Strg: 2. Stelle links vom Dezimalpunkt

Umschalt: 1. Stelle rechts vom Dezimalpunkt

Strg+Umschalt: 2. Stelle rechts vom Dezimalpunkt

Die Felder für Breite und Höhe des Rahmens sind standardmäßig verbunden (wenn in einem Feld der Wert geändert wird, ändert sich der Wert im verbundenen Feld auch) kenntlich durch das geschlossene Kettensymbol an der rechten Seite. Mausklick darauf und die Verbindung wird gelöst (offenes Kettensymbol) und vice versa.


Zusätzliche Hilfe

  • Wenn Du den Menüpunkt Seite > Am Raster ausrichten (Version 1.2.4: Ansicht > Am Raster ausrichten) anhakst, "rasten" Deine Rahmen am Raster ein. Mit Ansicht > Raster anzeigen kannst Du die Anzeige des Rasters an- und ausschalten. (Das Raster wird bei einem PDF-Export nicht mitexportiert). Den Abstand der Rasterlinien veränderst Du über Datei > Allgemeine Einstellungen > Hilfslinien (Version 1.2.4: Einstellungen > Voreinstellungen > Hilfslinien).
  • Wenn Du den Menüpunkt Seite > An Hilfslinien ausrichten (Version 1.2.4: Ansicht > An Hilfslinien ausrichten) anhakst, "rasten" Deine Rahmen an den Hilfslinien ein. Mit Ansicht > Hilfslinien anzeigen kannst Du die Anzeige der Hilfslinien an- und ausschalten. (Wie das Raster werden die Hilfslinien bei einem PDF-Export nicht mitexportiert). Die Hilfslinien bearbeiten bzw. neue hinzufügen kannst Du über Seite > Hilfslinien bearbeiten oder Datei > Allgemeine Einstellungen > Hilfslinien.

Eigenschaften: Bild-Abschnitt

Hat Dein Rahmen nun die richtige Größe, klicke auf An Rahmen anpassen. Bei nachfolgenden Änderungen der Rahmengröße wird der Inhalt dann automatisch mitskaliert. Klickst Du dagegen auf Freie Skalierung ermöglicht das Teile des Bildes wegzulassen, den sichtbaren Ausschnitt zu verschieben und den Anzeigemaßstab (in Prozentangaben) zu verändern.

Bild skalieren oder verschieben

Für Anleitungen zum vergrößern/verkleinern oder verschieben eines Rahmens siehe weiter oben: Eigenschaften: X,Y,Z-Abschnitt

Mit der Maus im Rahmen: Mit der Eigenschaftenpalette:
  1. Drücke die Tasten Strg+Alt+Umschalt. Klicke auf das Bild – mit gedrückter linker Maustaste kannst Du das Bild innerhalb des Rahmens bewegen (der Rahmen bleibt wo er ist). Sobald Du die Tasten losläßt, bewegst Du wieder den Rahmen.
  2. Doppelklicke auf das Bild und verschiebe es mit gedrückter linker Maustaste (der Cursor verwandelt sich in ein Handsymbol).
  3. Klickst Du auf das Symbol Rahmeninhalt bearbeiten in der Werkzeug-Symbolleiste (Tastatur: E) funktioniert das als wenn Du die Tasten Strg+Alt+Umschalt gedrückst hältst, jedoch bleibst Du im Bildbewegungsmodus solange bis Du wieder auf das Auswahlwerkzeug in der Werkzeug-Symbolleiste oder außerhalb des Rahmens auf die Seite klickst.

Das Verschieben eines Bildes innerhalb des Bildrahmens funktioniert nur wenn die Option Freie Skalierung aktiviert ist.

  • Die Größe des Bildes kann nicht mit der Maus im Rahmen geändert werden
Wie im X,Y,Z-Abschnitt gibt es drei Möglichkeiten die Einstellungen zu ändern:
  1. die Werte mit der Tastatur ändern
  2. mit der Maus auf den Auf-Abpfeil rechts neben den Wertefeldern klicken. Die Auf-Abpfeile auf der Tastatur bewirken dasselbe
  3. das Mausrad auf den Wertefeldern benutzen – normalerweise reicht es den Mauscursor über das Wertefeld zu bewegen, falls das nicht geht: zuerst in das Wertefeld klicken

Beachte für die Punkte 2 und 3: gleichzeitiges Drücken von Strg, Umschalt oder Strg+Umschalt wechselt zwischen den Dezimalstellen (funktioniert auch mit den Pfeilen auf der Tastatur):

Ohne Taste: 1. Stelle links vom Dezimalpunkt

Strg: 2. Stelle links vom Dezimalpunkt

Umschalt: 1. Stelle rechts vom Dezimalpunkt

Strg+Umschalt: 2. Stelle rechts vom Dezimalpunkt

Die Felder für X-Größe und Y-Größe sowie X-dpi und Y-dpi des Bildes sind standardmäßig verbunden (wenn in einem Feld der Wert geändert wird, ändert sich der Wert im verbundenen Feld auch) kenntlich durch das geschlossene Kettensymbol an der rechten Seite. Mausklick darauf und die Verbindung wird gelöst (offenes Kettensymbol) und vice versa.

X-Position und Y-Position bezeichnet die Position des Bildes innerhalb des Rahmens – bei negativen Werten wird die Hintergrundfarbe (wenn vorhanden) des Rahmens sichtbar.

X-Größe und Y-Größe, X-dpi aktuell und Y-dpi aktuell: Standardmäßig miteinander verbundene Felder, ein Klick auf das Kettensymbol löst die Verbindung. Klar ist, das der Maßstab und der DPI-Wert in Abhängigkeit zueinander stehen, aber für hochqualitative Ausdrucke muß man wissen daß der Ausgabe-DPI-Wert von grundlegender Bedeutung ist um schlechte Ergebnisse zu vermeiden. Bei einem PDF für das Web oder eine Bildschirmpräsentation kann ein niedrigerer DPI-Wert genügen. Auf dieser Seite findest Du hierzu weitere Informationen.

Zusätzliche Hilfe

Das Kontextmenü (Rechtsklick in den Rahmen) > Info zeigt ein paar Basisinformationen über das Bild an – Dateiname, Farbraum etc. Der Menüpunkt Extras > Bilderverwaltung kann auch nützlich sein.

Bildrahmen drehen

Mit der Maus:

Klicke auf das Symbol Objekt drehen in der Werkzeug-Symbolleiste (Tastatur: R) und anschließend in den Rahmen und drehe mit gedrückter linker Maustaste den Rahmen in den gewünschten Winkel.

Mit der Eigenschaftenpalette: (X,Y,Z.-Abschnitt):

Wie beim Größenändern und verschieben hast Du die gleichen drei Möglichkeiten den Wert im Feld Drehung zu ändern. Direkt darunter befindet sich ein Symbol (sieht aus wie ein Fünfer auf einer Würfelseite) mit dem Du den Ursprungspunkt (um diesen wird der Rahmen gedreht) auswählen kannst: die Mitte oder eine der vier Ecken.

Bildrahmen kopieren und ähnliches

Es gibt mehrere Möglichkeiten Rahmen zu kopieren oder an eine andere Stelle zu bewegen.

  1. Rahmen können mit Kopieren und Einfügen (Tastatur: STRG+C, Strg+V) sowie Auschneiden und Einfügen (Tastatur: Strg+X, Strg+V) oder auch über das Menü Bearbeiten und das Kontextmenü (Rechtsklick in den Rahmen) kopiert bzw. verschoben werden. Um den kopierten oder ausgeschnittenen Rahmen in eine andere Seite einzufügen gehe zu der gewünschten Seite, klicke darauf und füge den Rahmen ein – er wird an der exakt gleichen Stelle erscheinen wie auf der Ursprungsseite.
  2. Mit dem Menüpunkt Objekt > Duplizieren (Tastatur: Strg+D) erzeugst Du ein Duplikat des markierten Rahmens. Der neu erzeugte Rahmen liegt leicht verschoben über dem Original (im Vordergrund)
  3. Mit dem Menüpunkt Objekt > Mehrfach Duplizieren kannst Du gleich mehrere Duplikate des markierten Rahmens erzeugen. Beim Klicken auf Objekt > Mehrfach Duplizieren erscheint ein Fenster in das Du die gewünschte Anzahl Duplikate und den Versatz der neu erzeugten Rahmen festlegen kannst. Du kannst das auch für nur ein Duplikat verwenden wenn Du hierfür den Versatz vorher festlegen willst. Der hier eingestellte Wert wird auch für Objekt > Duplizieren verwendet.
  4. Schließlich gibt es noch die Bibliothek – Menüpunkt Objekt > In Bibliothek speichern oder über das Kontextmenü (Rechtsklick in den Rahmen). Beim Aufruf dieser Funktion kannst Du einen Namen für diesen Rahmen vergeben. Dies speichert eine Kopie des Rahmens mit seinem Inhalt in die Bibliothek. Um einen gespeicherten Rahmen aus der Bibliothek zu holen wähle Fenster > Bibliothek aus dem Menü. Das gewünschte Objekt kann aus dem sich öffnenden Bibliothekfenster auf eine Dokumentseite gezogen werden.

Tip: Die Bibliothek kann als Datei gespeichert werden und in ein anderes Dokument geladen werden. Das ist sehr nützlich für Objekte die Du immer wieder verwendest.

Wenn Du ein wenig mit den Rahmen herumexperimentierst wirst Du feststellen daß Du Rahmen sogar außerhalb der Dokumentseite platzieren, kopieren, duplizieren und bearbeiten kannst. Diese Rahmen außerhalb der Dokumentseite werden auch mit dem Dokument gespeichert. Wenn Du versucht aus so einem Dokument ein PDF zu exportieren wird die Druckvorstufenüberprüfung den Fehler Objekt außerhalb einer Seite melden – klicke auf Fehler ignorieren und das PDF wird ohne diese Rahmen erzeugt. Bei Dokumenten mit sehr vielen Seiten kannst Du leicht den Überblick über diese "Off-Dokument"-Objekte verlieren!

Anordnung und Ebenen

Rahmen im Allgemeinen (nicht nur Bildrahmen), sind zweidimensional – Du bearbeitest und bewegst sie im Arbeitsbereich ähnlich als wenn Du Notizzettel anbringst bzw. wieder entfernst. Wie tatsächliche Notizzettel werden sie auf der Dokumentseite einer nach dem anderen übereinandergelegt. Die Anordnung ist also einer (der neuere) über dem anderen (dem älteren, vorhergehenden). Im X,Y,Z-Abschnit der Eigenschaftenpalette gibt es unter Anordung zwei Paare Auf/Abpfeile. Das linke Pfeilpaar bringt das markierte Objekt um eine Stufe nach oben oder unten, das rechte Pfeilpaar bringt das markierte Objekt ganz nach oben oder ganz nach unten. Die Zahl daneben steht für die Stufe auf der sich das Objekt befindet. Wenn Du ein Objekt ganz nach unten schiebst ist die Zahl 0; die Zahl die angezeigt wird wenn Du ein Objekt ganz nach oben schiebst enspricht also der Anzahl Objekte in Deinem Dokument. Die Anordnung der Objekte bestimmt auch was sichtbar ist und was nicht (ein transparenter Rahmen läßt das darunterliegende Objekt "durchscheinen", ein Rahmen mit Füllfarbe natürlich nicht).

Eigenschaften: Der Rest vom X,Y,Z-Abschnitt

Die übrigen Buttons im X,Y,Z-Abschnitt der Eigenschaftenpalette haben folgende Funktionen:

  1. Spiegelt den markierten Rahmen horizontal bzw. vertikal
  2. Sperrt den markierten Rahmen – Alles ist gesperrt: Größe, Position, Inhalt.

Kopieren und Einfügen von gesperrten Rahmen kann unvorhergesehene Effekte haben.

  1. Größensperrung, die roten Rechtecke an denen man den Rahmen zur Größenänderung anfaßt sind weg.
  2. Legt fest ob der Rahmen gedruckt werden soll oder nicht. Eventuell ist der Rahmen oder der Inhalt nur dazu da, Dir oder jemand anderen etwas mitzuteilen oder an etwas zu erinnern; er soll aber nicht auf dem Ausdruck erscheinen. Der nicht zu druckende Rahmen könnte auch als Platzhalter benutzt werden.

Eigenschaften: Form-Abschnitt

Pfade bearbeiten

Klicke auf den Form-Abschnitt in der Eigenschaftenpalette. Ganz oben ist ein Button mit einem Quadrat (oder was zuletzt benutzt wurde) in der Mitte. Wenn Du diesen Button klickst, kannst Du eine andere Form aus der aufklappenden Liste auswählen. Wenn Du darunter auf Form bearbeiten klickst, gelangst Du zum Pfade-Fenster und kannst die Form verändern.

Eine andere Möglichkeit einen nicht rechteckigen Bildrahmen zu bekommen:

Du kannst das Polygon-Werkzeug in der Werkzeug-Menüleiste benutzen um ein gleichmäßiges Polygon zu erzeugen. (die Benutzung des Werkzeuges wird in einem andern Kapitel detailiert erklärt). Das Polygon kann über das Kontextmenü (Rechtsklick in das Polygon) Umwandeln in > Bildrahmen in einen Bildrahmen umgewandelt werden.

Abgerundete Ecken

Damit kannst Du einstellen ob, und wie stark die Ecken des Bildrahmens abgerundet werden sollen. Bei negativen Werten werden die Ecken "nach innen" abgerundet.

Text umfließt Rahmen

Hiermit bestimmst Du was mit Text passiert der unter dem markierten Rahmen liegt.

Erinnerst Du dich an: Anordnung und Ebenen?

Wenn Du einen Bildrahmen neu anlegst hat die Bounding Box (des Bildes) und der Objektumriss die gleiche Größe und Position. Aber klicke auf Form bearbeiten und Du kannst die Größe, Position und Form des Objektumrisses nach Deinen Wünschen abändern wenn Du vorher die Option Objektumriss benutzen angehakt hast.


Objektumriss benutzen

Hier ist ein Beispiel:

Text umfließt den Bildrahmen

Hier sehen wir daß die Form des Bildes – die Bounding Box – (die gestrichelte rote Linie), und der Objektumriss (hellgrau gestrichelte Linie) sich unterscheiden. Die Bounding Box hat immer eine rechteckige Form. (Als Bounding Box wird das kleinstmögliche Rechteck um die Form bezeichnet)

Bearbeiteter Objektumriss eines Bildes

Eigenschaften: Linien-Abschnitt

Mit der Linie eines Bildrahmens ist der Rand des Rahmens gemeint. Die Standard-Farbeinstellung für diese Linie ist Keine. Ganz gleich welche Einstellungen hier im Linien-Abschnitt gemacht werden, solange Du keine Linienfarbe setzt ist nichts zu sehen. Die verschiedenen Einstellungsmöglichkeiten für Linien sind selbsterklärend – wenn eine Einstellung ausgegraut ist, erscheint sie nicht im Rahmen.


Eigenschaften: Farben-Abschnitt

Wie schon oben bemerkt, steht die Linienfarbe (Stiftsymbol: Linienfarbe bearbeiten) für den Rand des Rahmens, Standardeinstellung ist Keine.

Füllfarbe steht für die Hintergrundfarbe des Rahmensbearbeiten (Eimersymbol: Füllfarbe bearbeiten). Stellst Du die Füllfarbe auf Keine wird der Hintergrund des Rahmens transparent.

Tonwert steht für die Farbsättigung: 0% entspricht einem neutralen Grau. Mit Deckkraft regelst Du das Maß der Tranzparenz – 100% entspricht volle Deckkraft, 0% entspricht volle Transparenz. Achtung: Manche PDF-Versionen und auch manche PDF-Betrachter unterstützen keine Tranzparenz.

Überdrucken Version 1.3.4 und höher

Erklärung für Überfüllen Überdrucken siehe hier.

Beachte das es keine Beschränkung für die Anzahl an Farben gibt die in der Farbauswahl angezeigt werden können. Du bist aber auch nicht gezwungen alle Farben die in der Standardeinstellung vorhanden sind anzuzeigen. Über den Menüpunkt Bearbeiten > Farben... kanst Du Farben hinzufügen, bearbeiten oder entfernen. Das Entfernen unbenutzter Farben kann das Arbeiten mit Scribus beschleunigen und reduziert die Größe der Sla-datei.