Difference between revisions of "Arbeiten mit Textrahmen"

From Scribus Wiki
Jump to: navigation, search
Line 15: Line 15:
  
 
Mit der Maus kann der Text Rahmen plaziert und in der Grösse angepasst werden. Halten Sie die linke Maustatse gedrückt und ziehen Sie den Rahmen diagonal über die Seite auf. Der Klick legt die eine Ecke des Text Rahmens fest, die gegenüberliegende Ecke ergibt sich wenn Sie die Maustaste loslassen. Gewöhnlich sollten Sie mit der linken oberen Ecke anfangen, Scribus erlaubt es aber auch mit jeder beliebigen Ecke anzufangen.
 
Mit der Maus kann der Text Rahmen plaziert und in der Grösse angepasst werden. Halten Sie die linke Maustatse gedrückt und ziehen Sie den Rahmen diagonal über die Seite auf. Der Klick legt die eine Ecke des Text Rahmens fest, die gegenüberliegende Ecke ergibt sich wenn Sie die Maustaste loslassen. Gewöhnlich sollten Sie mit der linken oberen Ecke anfangen, Scribus erlaubt es aber auch mit jeder beliebigen Ecke anzufangen.
 
  
 
'''Löschen'''
 
'''Löschen'''
Line 41: Line 40:
 
'''''Mit dem Eigenschaften-Dialog:'''''
 
'''''Mit dem Eigenschaften-Dialog:'''''
  
 
+
Es existieren drei Wege um die Einstellungen eines Rahmens zu bearbeiten:
 
 
Es existieren drei Wege um die Einstellungen eines Rahmens zu bearbeiten --
 
  
 
# mit der Tastatur
 
# mit der Tastatur
 
 
# Klicken Sie mit der Maus einen der ab- oder auf-Pfeile rechts neben jeder Einstellung an. Die Pfeiltasten auf der Tastatur haben denselben Effekt.
 
# Klicken Sie mit der Maus einen der ab- oder auf-Pfeile rechts neben jeder Einstellung an. Die Pfeiltasten auf der Tastatur haben denselben Effekt.
 
 
# Mit dem Mausrad. Gewöhnlich reicht es aus den Cursor über dem entsprechenden Feld zu plazieren, u.U. muss das Feld aber auch angeklickt werden.
 
# Mit dem Mausrad. Gewöhnlich reicht es aus den Cursor über dem entsprechenden Feld zu plazieren, u.U. muss das Feld aber auch angeklickt werden.
  
Line 54: Line 49:
 
<HIER GEHTS WEITER>
 
<HIER GEHTS WEITER>
  
Also note that for 2 and 3, holding down Ctrl, Shift, or Ctrl+Shift (works with up and down arrow keys also) will alter which decimal place is affected. In addition, when using the Properties window width and height are by default linked, but you need only click the chain icon to the right to unlink them.
+
''Also note that for 2 and 3, holding down Ctrl, Shift, or Ctrl+Shift (works with up and down arrow keys also) will alter which decimal place is affected. In addition, when using the Properties window width and height are by default linked, but you need only click the chain icon to the right to unlink them.''
 +
 
 +
 
  
  

Revision as of 20:20, 3 January 2007

Dieser Artikel gehört zur Kategorie Deutsche HOWTOs.
Installation Anwendungsfragen PDF-Export DTP Sonstiges

Übersetzung im Gange

Dieser Artikel sammelt Tätigkeiten in Bezug auf Text-Rahmen.

Erstellen

Ein Text-Rahmen kann auf mehrere Arten erstellt werden:

  1. Klicken auf das Insert Text Frame Icon in der Werkzeugleiste
  2. oder über das Menü Einfügen > Text Rahmen
  3. Mittels Tastatur: T, oder Alt+N, T.

Mit der Maus kann der Text Rahmen plaziert und in der Grösse angepasst werden. Halten Sie die linke Maustatse gedrückt und ziehen Sie den Rahmen diagonal über die Seite auf. Der Klick legt die eine Ecke des Text Rahmens fest, die gegenüberliegende Ecke ergibt sich wenn Sie die Maustaste loslassen. Gewöhnlich sollten Sie mit der linken oberen Ecke anfangen, Scribus erlaubt es aber auch mit jeder beliebigen Ecke anzufangen.

Löschen

Ein selektierter Rahmen kann durch drücken der Delete - Taste gelöscht werden. Die Tastenkombination Ctrl+X schneidet den Rahmen aus und hält ihn in der Zwischenablage vor.

Kontext Menü

Ein Klick mit der rechten Maustaste auf einen Rahmen öffnet dessen Kontext-Menü. Hier finden sich einge der gebräuchlichsten Funktionen, so z.B. auch die Möglichekeit, einen Text Rahmen in einen anderen Typ Rahmen umzuwandeln.

Grösse und Position

Properties: XYZ Tab

Sie werden feststellen, dass der Eigenschaften-Dialog ein unverzichtbares Werkzeug in Scribus ist. Wenn er nicht schon geöffnet ist, öffnen Sie ihn über das Menü Fenster > Eigenschaften. In Scribus Version 1.2.4 findet sich dieser Punkt unter Werkzeuge >Eigenschaften. Der XYZ-Reiter des Eigenschaften-Dialogs zeigt sehr präzise die Position der linken oberen Ecke des aktuell selektierten Rahmens auf der Seite an. Hier finden sich auch Höhe, Breite sowie der Rotations-Winkel des Rahmens. Beachten Sie, dass diese Informationen nur für den aktuell ausgewählten Rahmen angezeigt werden. Direkt nach Erstellung eines Rahmens ist dieser immer ausgewählt, sichtbar duch die gestrichelte rote Linie. Ein Linksklick ausserhalb des Rahmens hebt die Auswahl auf, ein Klick in den Rahmen wählt ihn wieder aus. Um einen Rahmen mittels der Eigenschaften-Palette verändern zu können, muss der entsprechende Rahmen angewählt sein.

Grösse und Position ändern

Mit der Maus:

  1. Klicken Sie an eine beliebige Stelle in den Rahmen und verschieben Sie ihn bei gedrückter Maustaste. Rahmen können auch ausserhalb der Seite positioniert werden. Abhängig von der Scribus-Version ist auch ein Fluss von einer Seite auf die nächste möglich.
  2. Klicken Sie eines der kleinen Rechtecke in der Umrandung an und ziehen Sie mit der Maus um die Grösse des Rahmens zu verändern


Mit dem Eigenschaften-Dialog:

Es existieren drei Wege um die Einstellungen eines Rahmens zu bearbeiten:

  1. mit der Tastatur
  2. Klicken Sie mit der Maus einen der ab- oder auf-Pfeile rechts neben jeder Einstellung an. Die Pfeiltasten auf der Tastatur haben denselben Effekt.
  3. Mit dem Mausrad. Gewöhnlich reicht es aus den Cursor über dem entsprechenden Feld zu plazieren, u.U. muss das Feld aber auch angeklickt werden.


<HIER GEHTS WEITER>

Also note that for 2 and 3, holding down Ctrl, Shift, or Ctrl+Shift (works with up and down arrow keys also) will alter which decimal place is affected. In addition, when using the Properties window width and height are by default linked, but you need only click the chain icon to the right to unlink them.



Beachten Sie für die zweite und dritte Methode auch, dass das gleichzeitige Drückn von Ctrl, Shift oder Crl+Shift Einfluss auf die zu ändernde Dezimal-Stelle nimmt.



Some Additional Help

  • From the Menu, Page > Snap to Grid (v1.2.4: View > Snap to Grid) will cause your frame to "stick" to the grid lines on the page. View > Show Grid toggles the grid on and off. (The grid does not print or become part of a PDF.) If you want to adjust the line spacing of the grid, go to File > Preferences > Guides.
  • From the Menu, Page > Snap to Guides (v1.2.4: View > Snap to Guides) will cause your frame to "stick" to guide lines on the page. View > Show Guides toggles them on and off. (Like the grid, guides do not print or become part of a PDF.) If you want to edit or add guides, go to Page > Manage Guides or File > Preferences > Guides.

Rotation

With the mouse:

Click the Rotate Item icon on the toolbar (keyboard: R), then click inside the frame and drag-rotate to desired angle.

With the Properties window:

Just like resizing and repositioning, you have the same three ways to change the rotation digitally. There is also an icon just below (looks something like one of a pair of dice) to alter the point around which rotation takes place -- center or one of the four corners.

Copying Frames and Similar Operations

There are several different ways to copy or move frames.

  1. You should be familiar with Copy and Paste (keyboard: Ctrl+C, Ctrl+V) and Cut and Paste (keyboard: Ctrl+X, Ctrl+V) -- also accessible from Edit on the menu, and from the Context Menu (right-click in frame). To paste to another page, move to that page, click on it, then paste -- the frame will have the same coordinates as on the original page.
  2. There is also Duplicate (keyboard: Ctrl+Alt+Shift+D) Item > Duplicate. This makes a copy which is slightly offset from the original, and on a layer above it.
  3. There is Multiple Duplicate, Item > Multiple Duplicate, which brings up a requestor to automatically create as many copies as you wish, with a sequential adjustable offset. You can also use this for a single duplication when you want to set the offset. Note that once you set the offset here, Item > Duplicate will use this same offset.
  4. It's also possible to drag an item with the right mouse button. After releasing the button, a dialog asks to either copy or move the item or to cancel the operation.
  5. Finally, there is the Scrapbook, Item > Send to Scrapbook (v1.3.x) or from Context Menu (right-click in frame). This will make a named copy of the selected frame and its contents to the Scrapbook. To retrieve a saved item from Scrapbook, select from the menu Windows > Scrapbook (in v1.2.4, Tools > Scrapbook), to bring up a requestor to paste an item to a page. Also note that you can save your entire Scrapbook to a file, which can then be loaded and used in another document.

Experimentation will show you that frames can even be outside the document boundaries and still be copied, duplicated and manipulated in various ways. They will even be saved with the document in these locations. If you try to generate a PDF, you will receive error messages about objects not being on the page; if ignored, the PDF will not have these objects. Furthermore, especially in a large multipage document, you may lose track of these off-document objects.

Entering/Editing Text in the Frame

Story Editor

With a text frame selected, click the Story Editor icon on the toolbar (keyboard: Ctrl+Y), or Menu item Edit > Edit Text...; this is also available in the Context Menu (right-click in frame). The Story Editor is the most efficient way to manually enter text. The text will display with the correct font color, but the font face and spacing will not be reflected in the Story Editor's display. If the font color is similar to the background color in Story Editor, you may change the background color as desired: Story Editor menu Settings > Background....

The many features of Story Editor will be covered in detail elsewhere (also see Properties: Text Tab below - layout is different but features are the same). For this brief introduction, note that a large array of text features are completely under your control in Story Editor, including font face, color, spacing, kerning, justification, and more. Note that changing a setting will only modify text that you have selected (highlighted) and any subsequently entered text.

Take the time to learn how to create and use Styles, which will save time when you are repetitively using a font with a specific set of features.

Editing from the main page

Click the Edit Contents of Frame icon on the toolbar (keyboard: E). When you click inside the frame, you will see a blinking vertical cursor where you may add or edit text. You may also select (highlight) text and change the highlighted text features in Properties > Text. As you can see the choices are analogous to those in the Story Editor.

Editing All the text in the frame

If not already selected, click the Select item icon on the toolbar (keyboard: C | note that if you are in Edit Contents of Frame mode, pressing C will enter text in the frame). Now select the frame whose text you wish to edit. At this point if you make changes in Properties: Text, all text in the frame will be modified.

Special Characters, Foreign Language Accented Characters

There is the potential ability to insert foreign language accented characters, special symbols not found on the keyboard, typographic symbols (such as typographic quotation marks, em dash, en dash, variably sized spaces, for example), and ligatures. This capability can be found either in the main menu or Story Editor menu under Insert > Glyph, Insert > Character, Insert > Quote, Insert > Spaces & Breaks, and Insert > Ligature.

  • If your special character fails to display, this most often means that it is not available in your chosen font. Just because it shows in Story Editor does not mean it will show on the page.
  • Also see Typography.

Loading Text from a File

Load text from a file from the Context Menu (right click in frame) > Get Text, or from the menu File > Import > Get Text. You may also Append Text (Get Text will replace whatever is already in the frame). You may also load a file into Story Editor.

There are also the special files of "lorem ipsum" text, that can most easily be accessed from the Context Menu (right-click in frame), under Sample Text (from Menu: Insert > Sample Text). Scribus has this in several language versions, in addition to Latin.

Linking One Frame to Another

Text may be continued from one frame to another, on the same page or different pages.

First make sure the first frame is selected, then click the Link Text Frames icon on the toolbar (keyboard: N), then click the second frame -- that's it. If you have a third or more frames to also link, continue clicking to continue linking further frames. Remember that the links go in the order that you click from one to the next.

Note that frames can be linked before or after they have any content.

Unlink Text Frames is operationally similar -- click the first frame, then the Unlink icon, then the frames to unlink.

Levels & Layers

Frames in general, not just text frames, represent a two-dimensional space that you manipulate and move around your workspace, much like a small note you can attach and detach. Like small physical notes, they are laid down, one by one, on the page, new ones on a layer over the previous ones. The small box labeled Level in the XYZ tab of Properties allows you to move the selected frame up or down layers; the arrows with bars will move all the way to the top or bottom. Since the background of your frame may be opaque or transparent, the level the frame is at will affect how much of the frame can be visible in relationship to other overlapping or underlying frames.

XYZ Tab: The Rest

The remaining buttons in the XYZ tab do the following:

  1. Flip the selected frame horizontally or vertically
  2. Lock a frame in place. Everything about your frame is locked -- size, position, contents. Copying and pasting a locked frame may produce unexpected results.
  3. Lock the size of the frame only. Note that the editing tabs disappear from the corners and sides.
  4. Enable/disable printing of the frame. Why? You may want to have a frame on the page that's a message to yourself or someone else, yet not be part of the printed finished work. Or the frame may just be a space-saver for some other purpose.

Properties: Shape Tab

Properties: Shape Tab
Edit Shape requester
v 1.3.3.3

Click the Shape tab in Properties. Near the top is a button with a square in the center. If you click that button, you may quickly switch to one of a group of set shapes from your original rectangle. In addition, if you click Edit Shape, you now have full vector-editing control of your shape.


Another angle on shapes and text frames:

You may also use the Polygon tool on the toolbar (use will be described in detail in another section) to create a regular polygon, which may then be converted using the Context Menu (right-click in the polygon) to Convert To > Text Frame. Note that before you enter text, you may want to change the background color of the frame.

Round Corners

Causes an adjustable degree of rounding of the Text Frame corners. Also note the effect of negative values.

Distance of Text

Columns, Gap: Set the number of columns inside the frame and the gap between columns.

Top, Bottom, Left, and Right adjust the space from the edge of the frame to the text inside.

Tabulators: For setting tab stops within your frame.

Text Flows Around Frame

Use this to determine what happens with text underneath the selected frame.
Remember Levels & Layers?

When you create an image frame, the Bounding Box (of the image) and the Contour Line are the same size and position. But click on Edit Shape... and you can change this Contour Line's size, position, and shape as desired -- just check the box for Edit Contour Line.

Close-up in Shape Tab
Here is an example with an image frame, but this could just as well be a text frame:

Textflows example.jpg

Properties: Text Tab

The top two buttons are straightforward: font face and style. Remember that if you are in Select Item mode, as opposed to Edit Contents mode, changes in the font settings will change all the text in the frame. To modify only some of the text, switch to Edit Contents mode (keyboard: E), then highlight the text you wish to modify.


Properties: Text Tab

Next is a block of six requestors with number values:

  1. Left top is font size
  2. Left middle is the space between lines of text. When you are in Select Item mode, this will automatically change as you adjust font size (but can be adjusted afterward independently), in Edit Contents mode it will not. See Working with Story Editor: Font Size and Line Spacing about the different ways that font size and line spacing adjustments interact.
    You may change the degree of automatic line spacing in File > Preferences > Typography.
  3. Left bottom is the width of characters -- note that height remains constant
  4. Right top raises (positive values) or lowers selected characters from the baseline. This adjustment is not present in Story Editor.
  5. Right middle is kerning: the distance between characters
  6. Right bottom adjusts height of characters -- note that width remains constant, and that characters remain on the baseline.

As described above in Resizing, Repositioning, there are three ways to change these values.


There are two color buttons next, the top referring to the outline and/or shadow if selected (see below, items 8 and 9), and the bottom to the fill color. Aside from the hue, you may also adjust saturation - click on the number for a list of choices.


A row of buttons follows, so from left to right:

  1. Underline, including spaces between words. Adjustable line width, vertical position. No adjustments in v1.2.4
  2. Underline, characters only. Adjustable line width, vertical position. Not available in v1.2.4
  3. Subscript. You may also want or need to adjust size. For v1.2.4, adjustments are in Effects > Preferences > Typography
  4. Superscript. Size is separately adjusted. For v1.2.4, adjustments are in Effects > Preferences > Typography
  5. All caps. Applies to letters. Not available in v1.2.4
  6. All small caps. Letters only; sizes of other characters and capitalized letters not affected.
  7. Strikethrough. Line width and position adjustable. No adjustments in v1.2.4
  8. Adds an outline to the font, width adjustable. No adjustments in v1.2.4
  9. Creates a shadow, in essence a duplication of the character, just "behind" it, position adjustable. You may have both an outline and a shadow, but both will have the same color and shade. Not available in v1.2.4
  10. Reverse (horizontal mirror image) of selected letters.

The next row of buttons selects justification. The rightmost button forces every line to be fully justified, which can produce unexpected results.


The Style button allows for easy application of a set of font features. There are no default styles, these are user-created. See the Menu item Edit > Paragraph Styles... or Edit > Line Styles... to create a New style, or Save and Import styles.

For more on styles, see Working with Story Editor:Styles.

Lastly, the Language button chooses a language for automatic hyphenation.

Properties: Line Tab

The Line of a Text Frame refers to the border of the frame. The first thing to be aware of is that the default setting for Line Color is None, so regardless of the settings in the Line Tab, nothing will show until the Line Color is set.

Otherwise, the various settings for Line are straightforward. If a setting is greyed-out, it does not apply to frames.

Properties: Color Tab

As noted above, the Line Color refers to the border of the frame, with the default being None.

Fill Color means background color of the frame. None for a Fill Color means that the background is transparent. Text Color can be set in the Text Tab in Properties, or in Story Editor.

Shade refers to saturation of the color, so that 0% should represent a neutral grey scale color. Opacity refers to the relative opacity/transparency, with 100% being totally opaque, 0% totally transparent. It is worth noting at this point that some PDF versions and some PDF viewers do not support transparency.

Overprinting versions 1.3.4 and above

Knockout versus Overprinting are described here.

Please note that you are not limited to colors you see displayed in the Color Tab, nor are you compelled to have all these choices. See the Menu item Edit > Colors to add, edit, or remove colors. Removing colors can simplify the use of Scribus, and does reduce saved file size.

See also: