Difference between revisions of "CMake Build Options"

From Scribus Wiki
Jump to: navigation, search
(1.5.x.svn+)
(1.5.x.svn+: reorganized and added WANT_CPP11)
Line 9: Line 9:
  
 
== 1.5.x.svn+ ==
 
== 1.5.x.svn+ ==
 +
*'''APPLICATION_CONFIG_DIR : PATH ''' : specify the user configuration directory at compile time
 +
*'''APPLICATION_DATA_DIR : PATH''' : specify the user data directory at compile time
 
*'''CMAKE_INSTALL_PREFIX:PATH''': PATH : destination folder of bin file cmake result (ex : -DCMAKE_INSTALL_PREFIX:PATH=~/bin/scribus)
 
*'''CMAKE_INSTALL_PREFIX:PATH''': PATH : destination folder of bin file cmake result (ex : -DCMAKE_INSTALL_PREFIX:PATH=~/bin/scribus)
*'''WITH_PODOFO : BOOL''': Enable support for PDF embedded in AI import
+
*'''WANT_DEBUG : BOOL''' : Turn on debugging and turn off stripping of debug information
*'''WANT_DEBUG : BOOL''': Turn on debugging and turn off stripping of debug information
+
*'''WANT_RELEASEWITHDEBUG : BOOL''' : Set release mode but keep debugging information
*'''WANT_RELEASEWITHDEBUG : BOOL''': Set release mode but keep debugging information
+
*'''WANT_DISTROBUILD ''' : Turn off RPATH (SET(CMAKE_SKIP_RPATH TRUE) and SET(CMAKE_INSTALL_RPATH ""))
*'''WANT_DISTROBUILD ''': Turn off RPATH (SET(CMAKE_SKIP_RPATH TRUE) and SET(CMAKE_INSTALL_RPATH ""))
 
 
*'''WANT_NORPATH ''': Turn off RPATH (SET(CMAKE_SKIP_RPATH TRUE) and SET(CMAKE_INSTALL_RPATH ""))
 
*'''WANT_NORPATH ''': Turn off RPATH (SET(CMAKE_SKIP_RPATH TRUE) and SET(CMAKE_INSTALL_RPATH ""))
 
*'''WANT_NO_EXAMPLES (1.4.2+, 1.5.0+) : BOOL ''': Set this to not install the scripter examples scripts
 
*'''WANT_NO_EXAMPLES (1.4.2+, 1.5.0+) : BOOL ''': Set this to not install the scripter examples scripts
 
*'''WANT_NO_TEMPLATES (1.4.2+, 1.5.0+) :  BOOL''': Set this to not install the document templates
 
*'''WANT_NO_TEMPLATES (1.4.2+, 1.5.0+) :  BOOL''': Set this to not install the document templates
*'''WANT_VERSIONING (prior to 1.4.0, and higher) : BOOL''': Add version tags to the installation directories for installations allowing multiple versions to be installed
+
*'''WANT_VERSIONING (prior to 1.4.0, and higher) : BOOL''' : Add version tags to the installation directories for installations allowing multiple versions to be installed
*'''APPLICATION_CONFIG_DIR : PATH ''': specify the user configuration directory at compile time
 
*'''APPLICATION_DATA_DIR : PATH ''': specify the user data directory at compile time
 
 
*'''WANT_NOHEADERINSTALL : BOOL''': Do not install the headers (if you don't intend to develop with Scribus, turn this off)
 
*'''WANT_NOHEADERINSTALL : BOOL''': Do not install the headers (if you don't intend to develop with Scribus, turn this off)
 +
*'''WANT_GUI_LANG: STRING''' : Select GUI languages <ref>all the language codes in Scribus/resources/translations [http://scribus.net/websvn/listing.php?repname=Scribus&path=%2Ftrunk%2FScribus%2Fresources%2Ftranslations%2F&rev=19203&peg=19203#a847116522ac316fba521094ab7e6e329 link]</ref> to install. Useful for speeding up regular build processes or limiting install size, eg: WANT_GUI_LANG="en_GB;de;fr"
 +
*'''WANT_SVNVERSION : BOOL ''': Adds the SVN version to the "About" dialog.
 +
*'''WANT_CPP11 : BOOL ''': Enable C++11 compiler features (was only necessary for 1.5.2svn)
 +
*'''WANT_CCACHE : BOOL ''': Enable support for ccache
 +
*'''WANT_LIB64 : BOOL ''': Add a "64" suffix when searching for libraries. Useful when a system has both 32 and 64 bit libraries and Scribus is being built against the 64 bit libraries
 +
*'''WANT_CPP11 : BOOL ''':
 
*'''WANT_HUNSPELL: BOOL ''': Turn on hunspell spelling support (1.4.2 and higher)(libhunspell-dev has to be installed)  
 
*'''WANT_HUNSPELL: BOOL ''': Turn on hunspell spelling support (1.4.2 and higher)(libhunspell-dev has to be installed)  
*'''WANT_GUI_LANG: STRING''' : Select GUI languages <ref>all the language codes in Scribus/resources/translations [http://scribus.net/websvn/listing.php?repname=Scribus&path=%2Ftrunk%2FScribus%2Fresources%2Ftranslations%2F&rev=19203&peg=19203#a847116522ac316fba521094ab7e6e329 link]</ref> to install. Useful for speeding up regular build processes or limiting install size, eg: WANT_GUI_LANG="en_GB;de;fr"
+
*'''WITH_PODOFO : BOOL''': Enable support for PDF embedded in AI import
*'''WANT_SVNVERSION=1''': Adds the SVN version to the "About" dialog.
+
*'''WANT_GRAPHICSMAGICK: BOOL ''': use graphicsmagick libraries for advanced file formats imports exports
*'''WANT_GRAPHICSMAGICK: BOOL''': use graphicsmagick libraries for advanced file formats imports exports
+
*'''WITH_BOOST : BOOL ''': Enable support for the Boost library
*'''WANT_CCACHE : BOOL''': Enable support for ccache
+
*'''WANT_NOOSG : BOOL ''': Disable OSG support even if found on the system
*'''WITH_BOOST : BOOL''': Enable support for the Boost library
 
*'''WANT_NOOSG : BOOL''': Disable OSG support even if found on the system
 
*'''WANT_LIB64 : BOOL''': Add a "64" suffix when searching for libraries. Useful when a system has both 32 and 64 bit libraries and Scribus is being built against the 64 bit libraries
 
  
 
== Deprecated / From Previous Versions ==
 
== Deprecated / From Previous Versions ==

Revision as of 13:27, 24 November 2016

Announcement: This page contains CMake Build Options


These are the options for the CMake command line supported by Scribus.

See Building_SVN_versions_with_CMake on how to use them.


1.5.x.svn+

  • APPLICATION_CONFIG_DIR : PATH  : specify the user configuration directory at compile time
  • APPLICATION_DATA_DIR : PATH : specify the user data directory at compile time
  • CMAKE_INSTALL_PREFIX:PATH: PATH : destination folder of bin file cmake result (ex : -DCMAKE_INSTALL_PREFIX:PATH=~/bin/scribus)
  • WANT_DEBUG : BOOL : Turn on debugging and turn off stripping of debug information
  • WANT_RELEASEWITHDEBUG : BOOL : Set release mode but keep debugging information
  • WANT_DISTROBUILD  : Turn off RPATH (SET(CMAKE_SKIP_RPATH TRUE) and SET(CMAKE_INSTALL_RPATH ""))
  • WANT_NORPATH : Turn off RPATH (SET(CMAKE_SKIP_RPATH TRUE) and SET(CMAKE_INSTALL_RPATH ""))
  • WANT_NO_EXAMPLES (1.4.2+, 1.5.0+) : BOOL : Set this to not install the scripter examples scripts
  • WANT_NO_TEMPLATES (1.4.2+, 1.5.0+) : BOOL: Set this to not install the document templates
  • WANT_VERSIONING (prior to 1.4.0, and higher) : BOOL : Add version tags to the installation directories for installations allowing multiple versions to be installed
  • WANT_NOHEADERINSTALL : BOOL: Do not install the headers (if you don't intend to develop with Scribus, turn this off)
  • WANT_GUI_LANG: STRING : Select GUI languages [1] to install. Useful for speeding up regular build processes or limiting install size, eg: WANT_GUI_LANG="en_GB;de;fr"
  • WANT_SVNVERSION : BOOL : Adds the SVN version to the "About" dialog.
  • WANT_CPP11 : BOOL : Enable C++11 compiler features (was only necessary for 1.5.2svn)
  • WANT_CCACHE : BOOL : Enable support for ccache
  • WANT_LIB64 : BOOL : Add a "64" suffix when searching for libraries. Useful when a system has both 32 and 64 bit libraries and Scribus is being built against the 64 bit libraries
  • WANT_CPP11 : BOOL :
  • WANT_HUNSPELL: BOOL : Turn on hunspell spelling support (1.4.2 and higher)(libhunspell-dev has to be installed)
  • WITH_PODOFO : BOOL: Enable support for PDF embedded in AI import
  • WANT_GRAPHICSMAGICK: BOOL : use graphicsmagick libraries for advanced file formats imports exports
  • WITH_BOOST : BOOL : Enable support for the Boost library
  • WANT_NOOSG : BOOL : Disable OSG support even if found on the system

Deprecated / From Previous Versions

  • WANT_QT3SUPPORT: BOOL: Turn on Qt3 support in Qt when building, defaults to off, we don't need Qt3 support
  • WANT_QTARTHUR : BOOL: Turn on Qt Arthur as the rendering library (DEPRECATED WITH 1.5.x)
  • WITH_ASPELL : BOOL : Turn on aspell spelling support (OBSOLETE: starting from v. 1.4.2, Hunspell is used for spellchecking)
  • WANT_CAIRO : BOOL : Turn on using cairo as the rendering library, (DEPRECATED WITH 1.5.x)
  • WANT_SYSTEM_CAIRO=1 : Removes the internal cairo,(may not be necessary). See Resolved Bug 9753
  • WANT_QT4MAC_COCOA : BOOL : Where the OSX build machine supports Carbon and Cocoa, use Cocoa

Qt5-Specific

  • USE_QT5 : BOOL : Use Qt5 instead of Qt4 (DEPRECATED with versions later than september 2013)
  • QT_PREFIX : PATH : path for Qt5 libs (for example : -DQT_PREFIX="/opt/qt5/bin" or -DQT_PREFIX="/usr/local/Qt-5.2.0" or -DQT_PREFIX=/home/username/Qt/5.2.0/gcc_64 when installed with default setting via installer found on www.qt-project.org/downloads)

Other

(Read http://www.scribus.net/svn/Scribus/trunk/Scribus/BUILDING)

If any of your libraries are in non-standard locations you will need to provide some extra arguments to CMake to ensure that CMake and gcc can find all the required files. Where /path/to/libfoo is the path to the the directory the library was installed to, eg /usr/local or /home/fred/libfoo (not the 'lib' subdirectory the actual .so files are in), you can use the following extra arguments to CMake to help it find the library:

  -DCMAKE_INCLUDE_PATH=/path/to/libfoo/include
  -DCMAKE_LIBRARY_PATH=/path/to/libfoo/lib

If you have multiple custom paths to specify, use a ; path separator, eg:

  -DCMAKE_INCLUDE_PATH=/path/to/libfoo/include;/path/to/libalice/include

OS X Specific

  • BUILD_OSX_BUNDLE : Set some options relating to building the OSX bundle
  • WANT_UNIVERSAL_BUNDLE : BOOL : Attempt to build a PPC/Intel binary bundle for OSX


References

  1. all the language codes in Scribus/resources/translations link