Difference between revisions of "Complex tables in Scribus"

From Scribus Wiki
Jump to navigation Jump to search
m (idem)
 
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
{{TIP Index}}  
 
{{TIP Index}}  
  
Scribus provides the ability to create tables. Unfortunately, scribus tables are nothing more than combined text frames, and it is a bit hard to work with them. If you need to have more complex tables, here is a workaround:
+
Scribus provides the ability to create tables. Unfortunately, scribus tables are nothing more than combined text frames, and it is a bit hard to work with them. If you need to have more complex tables, here is a reliable workaround:
  
 
# Create your table in either OpenOffice.org Writer or Calc.
 
# Create your table in either OpenOffice.org Writer or Calc.
# Copy the table items you need on a page in scribus (this means: not the whole spreadheet in Calc) to the clipboard, create a new OpenOffice.org Draw document, and paste from the clipboard.
+
# Copy the table items you need in scribus (this means: not the whole spreadheet in Calc) to the clipboard, create a new OpenOffice.org Draw document, and use '''Edit > Paste Special > GDI Metafile''' to insert the table as a vector file into Draw.
# Export the ''selection'' to SVG.
+
# Use '''File > Export''' to export the graphic as an EPS file. Make sure that ''Selection'' is checked in the export dialog, because otherwise the whole page will be exported.
# Open the SVG in Inkscape and save the ''selection'' to EPS. Note that the table might need some editing in Inkscape, e.g. adjusting rows or columns.
+
# Now import the EPS file as a vector drawing in Scribus via '''File > Import > Import Vector File'''.
# Import the EPS into scribus. This can happen either by using File > Import or by creating a picture frame and "Get Picture" from the context menu. The first option will allow you to edit the EPS as a scribus vector object.
 
 
 
This approach works perfectly with OpenOffice.org 1.1.x, but there are still problems with the beta versions of OO.o 2.0.
 
 
 
You may ask for the reason to use such a complicated procedure, since OO.o can export SVG and EPS, and scribus can import both formats, and even OO.o Draw files. Try this yourself and you will understand the reason why. OO.o's SVG and EPS export is far from perfect, and so is scribus' import of SVG and *.sxd. It is hard to predict in which cases import in scribus will work. So, save yourself some time, anger and swearing, and follwow the steps above. They always work, at least as much as I can tell.
 
 
 
''Contributed by Christoph Schäfer''
 
 
 
Alternative way (requires Inkscape) :
 
 
 
# In Writer select the whole table.
 
# Export to PDF and be sure to check the "selection" box in the export dialog box.
 
# Fire up Inkscape, then import the PDF. (Side tip: In case you want to edit the PDF you can ungroup it in Inkscape and then do anything you want to it.)
 
# Save the file in Inkscape, using its native SVG format.
 
# In Scribus go to File > Import > Get Vector File.
 
# Select the SVG and place it into your Scribus page.
 
 
 
''fired up by John Jason Jordan''
 

Latest revision as of 00:06, 18 October 2009

This article is part of the Tips & Tricks series.
Installation Usage PDF issues Other

Scribus provides the ability to create tables. Unfortunately, scribus tables are nothing more than combined text frames, and it is a bit hard to work with them. If you need to have more complex tables, here is a reliable workaround:

  1. Create your table in either OpenOffice.org Writer or Calc.
  2. Copy the table items you need in scribus (this means: not the whole spreadheet in Calc) to the clipboard, create a new OpenOffice.org Draw document, and use Edit > Paste Special > GDI Metafile to insert the table as a vector file into Draw.
  3. Use File > Export to export the graphic as an EPS file. Make sure that Selection is checked in the export dialog, because otherwise the whole page will be exported.
  4. Now import the EPS file as a vector drawing in Scribus via File > Import > Import Vector File.