Difference between revisions of "How to legally obtain spot colour palettes for use in Scribus 1.3.3.x and later versions"

From Scribus Wiki
Jump to: navigation, search
Line 21: Line 21:
 
|  novice   
 
|  novice   
 
|}
 
|}
 
+
==Introduction==
 
As long as no open standard for spot colours exists, Scribus users will have to buy a colour book by one of the colour manufacturers and insert the values and names of spot colours directly into Scribus. For serious work, colour books will be a requirement anyway, but that's another topic.
 
As long as no open standard for spot colours exists, Scribus users will have to buy a colour book by one of the colour manufacturers and insert the values and names of spot colours directly into Scribus. For serious work, colour books will be a requirement anyway, but that's another topic.
 
There is, however, another way to legally obtain commercial spot colours palettes and use them in Scribus. All you need is a commercial program that contains those palettes. Older versions of CorelDraw e.g. contain Pantone, Toyo and more palettes from the major colour vendors and can be obtained for a reasonable price. You can either run them yourselves under Windows or OS/X, install them on another PC you can access legally or even use another version – you a have a licence anyway.
 
There is, however, another way to legally obtain commercial spot colours palettes and use them in Scribus. All you need is a commercial program that contains those palettes. Older versions of CorelDraw e.g. contain Pantone, Toyo and more palettes from the major colour vendors and can be obtained for a reasonable price. You can either run them yourselves under Windows or OS/X, install them on another PC you can access legally or even use another version – you a have a licence anyway.
  
In the drawing program:  
+
==EPS is the key==
 +
'''In the drawing program:'''
 
#Draw as much vector objects as one spot colour palette contains.  
 
#Draw as much vector objects as one spot colour palette contains.  
 
#Apply each spot colour to one object – most palettes aren't huge, so this is feasible.  
 
#Apply each spot colour to one object – most palettes aren't huge, so this is feasible.  
 
#Export the drawing as EPS. Be careful not to convert the spot colours into CMYK during export.
 
#Export the drawing as EPS. Be careful not to convert the spot colours into CMYK during export.
  
In Scribus:
+
'''In Scribus:'''
 
#Create a new document and use File > Import > EPS/PS. In Scribus 1.3.4 or later you can import colours directly from EPS files: Go to Edit > Colours, click »Remove unused« and then »Import«. Select »Others (*.eps, *.ps, *.ai)« in the file dialog. In both cases you'll see all the spot colours with their correct names listed in the colour dialog after importing the file.  
 
#Create a new document and use File > Import > EPS/PS. In Scribus 1.3.4 or later you can import colours directly from EPS files: Go to Edit > Colours, click »Remove unused« and then »Import«. Select »Others (*.eps, *.ps, *.ai)« in the file dialog. In both cases you'll see all the spot colours with their correct names listed in the colour dialog after importing the file.  
 
#Now delete the imported drawing and save the file under an appropriate name, e.g. pantoneu.sla.  
 
#Now delete the imported drawing and save the file under an appropriate name, e.g. pantoneu.sla.  
Line 38: Line 39:
  
 
From Scribus 1.3.4 onwards you can even skip the step of saving a sla file first, since Scribus can import colours from EPS files directly.
 
From Scribus 1.3.4 onwards you can even skip the step of saving a sla file first, since Scribus can import colours from EPS files directly.
 +
 +
==See also==
 +
* [[How to use spot colours with Scribus]]

Revision as of 22:58, 7 December 2006

This article is part of the HOWTOs series.
Installation Usage PDF issues Imposition Other


Requirements:   
Operating System:   any supported system  
Scribus Version:   1.3.3.*
DTP skills:   novice

Introduction

As long as no open standard for spot colours exists, Scribus users will have to buy a colour book by one of the colour manufacturers and insert the values and names of spot colours directly into Scribus. For serious work, colour books will be a requirement anyway, but that's another topic. There is, however, another way to legally obtain commercial spot colours palettes and use them in Scribus. All you need is a commercial program that contains those palettes. Older versions of CorelDraw e.g. contain Pantone, Toyo and more palettes from the major colour vendors and can be obtained for a reasonable price. You can either run them yourselves under Windows or OS/X, install them on another PC you can access legally or even use another version – you a have a licence anyway.

EPS is the key

In the drawing program:

  1. Draw as much vector objects as one spot colour palette contains.
  2. Apply each spot colour to one object – most palettes aren't huge, so this is feasible.
  3. Export the drawing as EPS. Be careful not to convert the spot colours into CMYK during export.

In Scribus:

  1. Create a new document and use File > Import > EPS/PS. In Scribus 1.3.4 or later you can import colours directly from EPS files: Go to Edit > Colours, click »Remove unused« and then »Import«. Select »Others (*.eps, *.ps, *.ai)« in the file dialog. In both cases you'll see all the spot colours with their correct names listed in the colour dialog after importing the file.
  2. Now delete the imported drawing and save the file under an appropriate name, e.g. pantoneu.sla.
  3. Next, close all docs again. Go to Edit > Colours, choose the palette Scribus Small from the drop down menu. Remove all colours except Black (Scribus needs at least one colour to work). Then click »Import« and select the pantoneu.sla file. Now you can see all the spot colours in the colour list. Finally, click »Save Colour set« and save your new palette e.g. as Pantone Solid Uncoated.

From now on your spot colours will be available for you in any project. If want to reuse your palette on another computer, just store the file Pantone Solid Uncoated from your .scribus folder on a USB stick or a floppy disk and copy it to the respective directory on the other computer.

From Scribus 1.3.4 onwards you can even skip the step of saving a sla file first, since Scribus can import colours from EPS files directly.

See also