How to legally obtain spot colour palettes for use in Scribus 1.3.3.x and later versions

From Scribus Wiki
Jump to: navigation, search
This article is part of the HOWTOs series.
Installation Usage PDF issues Imposition Other


Requirements:   
Operating System:   any supported system  
Scribus Version:   1.3.3.*
DTP skills:   novice

Introduction

As long as no open standard for spot colours exists, Scribus users will have to buy a colour book by one of the colour manufacturers and insert the values and names of spot colours directly into Scribus. For serious work, colour books will be a requirement anyway, but that's another topic. There is, however, another way to legally obtain commercial spot colours palettes and use them in Scribus. All you need is a commercial program that contains those palettes. Older versions of CorelDraw e.g. contain Pantone, Toyo and more palettes from the major colour vendors and can be obtained for a reasonable price. You can either run them yourselves under Windows or OS/X, install them on another PC you can access legally or even use another version – you a have a licence anyway.

EPS is the key

In the drawing program:

  1. Draw as much vector objects as one spot colour palette contains.
  2. Apply each spot colour to one object – most palettes aren't huge, so this is feasible.
  3. Export the drawing as EPS. Be careful not to convert the spot colours into CMYK during export.

In Scribus:

  1. Create a new document and use File > Import > EPS/PS. In Scribus 1.3.4 or later you can import colours directly from EPS files: Go to Edit > Colours, click »Remove unused« and then »Import«. Select »Others (*.eps, *.ps, *.ai)« in the file dialog. In both cases you'll see all the spot colours with their correct names listed in the colour dialog after importing the file.
  2. Now delete the imported drawing and save the file under an appropriate name, e.g. pantoneu.sla.
  3. Next, close all docs again. Go to Edit > Colours, choose the palette Scribus Small from the drop down menu. Remove all colours except Black (Scribus needs at least one colour to work). Then click »Import« and select the pantoneu.sla file. Now you can see all the spot colours in the colour list. Finally, click »Save Colour set« and save your new palette e.g. as Pantone Solid Uncoated.

From now on your spot colours will be available for you in any project. If want to reuse your palette on another computer, just store the file Pantone Solid Uncoated from your .scribus folder on a USB stick or a floppy disk and copy it to the respective directory on the other computer.

From Scribus 1.3.4 onwards you can even skip the step of saving a sla file first, since Scribus can import colours from EPS files directly.

Getting and Using Pantone COLOR BRIDGE® Palettes Legally

Believe it or not, it's possible to download and use Pantone swatches in Scribus legally. While the palettes can't be distributed with Scribus, users can get them from Pantone directly for free. Below you'll find the steps necessary to obtain the palettes.

  1. Create a member account at myPantone.
  2. Once you are logged in, follow this link.
  3. There you'll find download links for Windows and OS X. Linux users can download the Windows version.
  4. If you want to use the palettes on Linux, you need a current version of WINE.
  5. Unzip/unstuff the installer. Windows and OS X users can now follow the usual install procedures. On Linux with WINE installed, either double-click the file "PANTONEcolorbridge.exe" or run wine PANTONEcolorbridge.exe in a console. WINE should now launch the installer. You can always click forward until the end of the installation procedure. If you don't have any of the selected applications available, you should see a dialog like this:

Pt-installer.png

  1. Next, go to .wine/drive_c/Programs/PANTONE(R) color bridge(TM)/ in your $HOME directory, where you will find the swatches in different formats, among them EPS. You can now load them into Scribus as described above. In Scribus 1.3.5, things have even become easier: just copy the EPS (or AI) files to ~lib/scribus/swatches, where ~ indicates your installation directory. Upon the next start, the palettes will be available in Scribus.

IS THIS LEGAL?

While we are no lawyers, we think it is, otherwise, this information wouldn't be available here. Let's just quote Pantone's stance from the download page mentioned above:

The installers provided below will install Application Support files for your favorite graphic software applications. These files will allow you to import PANTONE Colors with CMYK simulation data consistent with the printed PANTONE color bridge coated, uncoated or PANTONE color bridge coated EURO guide. If your graphic software does not appear within the Easy Install, we have provided EPS and TIFF files, which can be utilized within most graphic applications using a color selection tool such as the eyedropper. We have also provided a folder with the Easy Install libraries for each application, in the event that you need to proceed with a manual install.

See also

(c) 2007 Christoph Schäfer
The content of this page is licensed under the Free Documentation License.