Difference between revisions of "Import Publisher to Scribus"

From Scribus Wiki
Jump to navigation Jump to search
Line 17: Line 17:
  
 
Alternately, it may be better to export the plain text content from the Publisher document (you can use MS Word to save it as plain text, or you can use OO.o to open a word doc and save an OO.o doc so Scribus can preserve some of the text formatting), then recreate the document from that and the images used in the original.
 
Alternately, it may be better to export the plain text content from the Publisher document (you can use MS Word to save it as plain text, or you can use OO.o to open a word doc and save an OO.o doc so Scribus can preserve some of the text formatting), then recreate the document from that and the images used in the original.
 +
 +
There are also some [http://anne.julienne.org/P2S/Pub2Scribus.pdf "Publisher to Scribus"] tutorials with tips on how to reproduce BorderArt and Clip Art when switching from Publisher to Scribus.

Revision as of 22:56, 1 December 2006

This article is part of the HOWTOs series.
Installation Usage PDF issues Imposition Other

Scribus does not support importing Microsoft Publisher documents. There are no current plans to add support for it. The reasons are here: FAQ-Importing FAQ

You may be able to import an approximation of the document by following this process:

  • Open your document in Publisher
  • Go to menu Edit --> Select All (Ctrl+A)
  • Go to menu Edit --> Copy (Ctrl+C)
  • Open Microsoft Word
  • Go to menu Edit --> Paste (Ctrl+V)
  • Save your Word document (eg. file.doc)
  • Open it in OpenOffice
  • In OpenOffice go to File --> Save as in OpenOffice Writer format (eg. file.sxw)
  • In OpenOffice with sxw file go to File --> Save as in OpenOffice Draw format (eg. file.sxd)
  • In Scribus File --> Import --> OpenOffice Draw file

Alternately, it may be better to export the plain text content from the Publisher document (you can use MS Word to save it as plain text, or you can use OO.o to open a word doc and save an OO.o doc so Scribus can preserve some of the text formatting), then recreate the document from that and the images used in the original.

There are also some "Publisher to Scribus" tutorials with tips on how to reproduce BorderArt and Clip Art when switching from Publisher to Scribus.