Praca w Edytorze artykułów

From Scribus Wiki
Revision as of 18:12, 15 December 2006 by RvX (talk | contribs)
Jump to: navigation, search
edytuj

Strona główna

Jak to zrobić

  1. Pierwsze kroki ze Scribusem
  2. Praca z ramkami tekstowymi
  3. Praca z ramkami graficznymi
  4. Praca ze stronami wzorcowymi
  5. Praca w Edytorze artykułów
  6. Tekst na krzywej
  7. Scribus w Ubuntu Linux
  8. Klik i Scribus działa
  9. Instalacja za pomocą Cmake
  10. Tworzenie spisu treści
  11. Formularze PDF
  12. Kolory dodatkowe
  13. Obrazek ze ścieżką odcięcia

Porady i triki

  1. Instalacja profili ICC
  2. Dodawanie fontów
  3. Import grafik EPS
  4. Zawieszone spójniki
  5. Twój pierwszy artykuł
  6. Tworzenie hiperłączy

Często zadawane pytania

  1. Zarządzanie kolorami
  2. Skąd pobrać Scribusa?
  3. Podgląd wydruku nie działa
  4. Scribus dla MacOSX?
  5. Dodawanie fontów
  6. Scribus po polsku
  7. Type 1 i ligatury
  8. Automatyczne numery stron
  9. Interlinia w Scribusie
  10. Pierwsze kroki z DTP
  11. Skalowanie obrazka w ramce
  12. Export do PDF/X-3
  13. Ligatury i cyfry nautyczne?
  14. Pomoc w rozwoju Scribusa
  15. Przykładowe dokumenty
  16. Zgłaszanie błędów
  17. Słowniki dzielenia na sylaby


Tłumaczenie w toku Edytor artykułów jest narzędziem używanym do ręcznego wprowadzania tekstu do ramki tekstowej. Jego zadaniem jest wyświetlanie tekstu przy użyciu jak najmniejszej liczby atrybutów obrazu(?).

Edytor artykułów posiada kilka standardowych funkcji:
  • Justowanie (ale nie naświetli łamania zawijanego tekstu)
  • Kolor pisma
  • Podkreślenie
  • Indeks górny
  • Indeks dolny
  • Przekreślenie
Edytor artykułów nie wyświetla następujących cech ramki tekstowej:
  • Krój pisma
  • Stopień pisma
  • Podcinanie
  • Interlinia
  • Kapitaliki
  • Obrys
  • Cieniowanie tekstu
  • Wersaliki

Otwieranie Edytora artykułów

Mając zaznaczoną ramkę tekstową, kliknij ikonę Edytor artykułów w pasku narzędzi (skrót klawiszowy: Ctrl+Y), pozycję w menu Edycja > Edytuj tekst...; narzędzie jest również dostępne w menu kontekstowym (kliknięcie prawym przyciskiem myszy, podczas gdy kursor jest nad ramką)

Ustawienia

This is the last item on the Story Editor's Menu, but contains basic display functions that may be important as you begin to edit. Jest to ostatnia pozycja w menu Edytora artykułów, ale zawiera podstawowe funkcje wyświetlania, które mogą się przydać zwłaszcza wówczas, gdy zaczynasz edycję tekstu.

Ustawienia > Tło... pozwala Ci dostosować tło, które jest wyświetlane tylko w oknie Edytora artykułów Zapewne zechcesz skorzystać z tego w momencie, gdy np. kolor Twojego tekstu jest biały lub bardzo jasny. Zmiana tła sprawi, że będzie bardziej widoczny.

Ustawienia > Font edytora... zmieni font, ale znowu tylko w oknie Edytora artykułów, zwyczajnie jako sprawa własnych upodobań(?)

Ustawienia > Inteligentne zaznaczanie tekstu jest kluczem (?). Domyślnym zachowaniem programu podczas podwójnego kliknięcia jest zaznaczenie wyrazu wraz z pierwszym następującym po nim odstępem. "Inteligentne" zaznaczanie zaznaczy sam wyraz, bez następującego po nim odstępu.

Edytor artykułów - 1.3.X

Zaczynamy pracę

W wielu przypadkach możesz po prostu chcieć natychmiast zacząć wprowadzanie tekstu. Cechy, które będzie posiadał Twój tekst, czyli font, jego rozmiar, interlinia, itd. w większości będą niewidoczne dopóki nie zapiszesz swojej pracy i zamkniesz Edytora artykułów. Pomimo to, odnoszą się do tego różne opcje powyżej obszaru roboczego.

Nawet jeśli po raz pierwszy używasz Scribusa, wyświetlone będą wartości domyślne, które możesz zmieniać ręcznie wedle potrzeb. Pamietaj o tym, że przy zmianie ustawień, takich jak np. font, zostaną one zastosowane jedynie do tekstu, który później wprowadzisz, a nie do wcześniej wprowadzonego. Jeśli życzysz zmienić cechy fontu dla tekstu już wprowadzonego, musisz najpierw podświetlić tekst (kliknij i przeciągnij kursorem myszy albo użyj klawisza Shift i strzałek kierunkowych), a dopiero wtedy zmienić cechy, które zamierzasz zmienić. Aby zmienić domyślne ustawienia tekstu, musisz opuścić Edytora artykułów i przejść do Plik > Konfiguracja > Narzędzia, a następnie kliknąć ikonę ramki tekstowej.


Różne ustawienia właściwości tekstu są przedstawione w części artykułu Praca z ramkami tekstowymi dotyczącej zakładki Tekst. Pomimo niewielkich różnic w układzie Edytora artykułów, jego funkcje są takie same. Zauważ, że jedna opcja modyfikująca, której nie posiada Edytor artykułów, służy do przesuwania linii pisma.

Style/Style akapitów

Po pierwsze, zwróć uwagę na to, że w Scribusie nie ma domyślnych stylów, wszystkie są tworzone przez użytkownika. Style odnoszą się do zbioru własności tekstu, fontu, jego rozmiaru i wszystkich ustawień, które możesz zmienić w Edytorze artykułów, a które możesz zastosować zarówno przed jak i po wprowadzeniu tekstu. Jest to szczególnie użyteczne w przypadku gdy wielokrotnie wykorzystujesz te same ustawienia w swoim tekście -- zapewne jednego stylu dla nagłówków, kolejnego dla tekstu właściwego.

Okno dialogowe Edytuj style v1.3.3.6

Możesz stworzyć swoje style w Edytorze artykułów poprzez Edycja > Style, lub prosto przez kliknięcie na wskaźniku Bez stylu na lewo od obszaru roboczego, gdzie ukaże się opcja Edytuj style... W głównym oknie programu można to znaleźć w Edycja > Style akapitów. (Edycja > Style linii... nie ma zastosowania dla tekstu. Małe okno otwiera się z intuicyjnie rozmieszczonymi na przyciskach funkcjami). Kliknięcie na Nowy otwiera duże okno i prawdopodobnie pierwszą rzeczą, na która trzeba zwrócić uwagę jest domyślna nazwa Nowy styl, którą niewątpliwie będziesz chciał zmienić na coś bardziej opisowego(?). Możesz stworzyć dowolną liczbę stylów, a co bardzo istotne, mogą być one zachowane do pliku, który możesz importować gdy uruchamiasz program po raz kolejny, a ich nazwy będą automatycznie zachowane w dokumencie Scribusa.

Jak wskazuje na to nazwa zaznaczenia, Style akapitów, styl jest stosowany do całego akapitu tekstu od jednej karetki do następnej(?). Zobaczysz , że po zastosowaniu stylu i dalszej kontynuacji pisania, ostatnio ustawiony styl jest przenoszony do następnego akapitu, dopóki go nie zmienisz. Po utworzenia listy stylów, możesz już skoncentrować się na pisaniu tekstu bez zwracania uwagi na styl, a następnie poprawić style, gdy skończysz pisać. Aby to zrobić, kliknij przycisk odpowiedzialny za style, obok przycisku justowania, lub na rozwijanym menu Bez stylu na lewo od obszaru roboczego , w tym czasie ukazuje się lista ze stylami do Twojego wyboru.

To avoid some frustration, note that when you are in the main window you may also change styles in the Text Tab of Properties, but when you are in the Select Item mode (the default when you exit Story Editor or start Scribus), changing the style will change the style for the entire frame. Click to Edit Contents of Frame mode to change only individual paragraphs (where the cursor is flashing).

W celu uniknięcia lekkiej frustracji, zauważ, że gdy jesteś w głównym oknie programu, możesz również zmienić style w zakładce Tekst okna Właściwości, ale kiedy masz aktywny tryb Zaznacz obiekt (domyślny tryb przy zamykaniu Edytora artykułów lub uruchomienia Scribusa), zmiana stylu zmieni go dla całej ramki. Kliknij na tryb Edytuj zawartość ramki aby zmienić tylko pojedyncze akapity (w miejscu gdzie miga kursor).

Jak wstawić inicjały opuszczone?

Inicjałów opuszczonych nie znajdziesz w żadnym z menu. Ta opcja jest zlokalizowana w oknie dialogowym tworzenia/edytowania stylów. Kliknij aby utworzyć nowy lub edytować stary styl, kolejno: kliknij, aby określić inicjały opuszczone, po czym możesz dostosować liczbę linii, jaką zajmie inicjał opuszczony oraz poziomy odstęp pomiędzy nim a tekstem. Jest jeszcze "drobna" możliwość podwyższenia lub opuszczenia linii pisma dla inicjałów opuszczonych, ale mogą wystąpić problemy z ich wyświetlaniem.

Wcięcie, wcięcie pierwszego wiersza

At the bottom of the Edit Styles requester are widgets to adjust the indentation for the first line of each paragraph, and you may also indent subsequent lines after the first for a hanging indentation. Either slide the arrow indicators or adjust the numerical values. Na dole okna z edycją stylów znajdują się kontrolki do dostosowywania wcięcia dla pierwszej linii każdego akapitu i możesz także zdefiniować następujące linie po pierwszej....................... Obojętnie czy będziesz naciskał na strzałki przy wartościach liczbowych czy sam podasz wartości liczbowe.

Stopień pisma oraz interlinia

Są pewne niedogodności dotyczące stopnia pisma oraz interlinii. W Edytorze artykułów', kiedy zmieniasz stopień pisma, nie nastąpi automatyczna zmiana interlinii, więc jeśli stopień pisma jest zwiększony oprócz pewnego punktu, znaki na przylegającej linii będą na siebie zachodzić. Będziesz wtedy musiał to dostosować ręcznie. Jest to przeciwieństwo zachowania(?) w głównym oknie, podczas używania Właściwości > Tekst podczas gdy jesteś w trybie Zaznacz obiekt. Tu zmiana w stopniu pisma powoduje automatyczny przyrost wartości interlinii i oczywiście zmieni ten parametr dla całej ramki. Stopień automatycznej interlinii można ustawić w Plik > Konfiguracja > Typografia > Automatyczna interlinia. W przypadku, gdy masz aktywny tryb Edytuj zawartość ramki, zachowanie programu będzie takie samo, jak podczas pracy w Edytorze artykułów, np. zmiana w stopniu pisma nie zmieni automatycznie interlinii i ręczne dostosowanie może okazać się koniecznością.

Jeśli ustawisz styl akapitu, zobaczysz, że modyfikacja stopnia pisma dostosuje wartość interlinii, więc używanie stylów jest innym sposobem na uproszczenie tych czynności.

Podsumowując, w momencie, gdy próbujesz stworzyć ramkę, w której będzie zmieniany stopień pisma oraz interlinia, prawdopodobnie będziesz musiał ręcznie wprowadzać zmiany wartości interlinii. W pewnym stopniu możesz tego uniknąć lub przynajmniej ułatwić ten proces przy użyciu stylów.