Difference between revisions of "Praca ze stronami wzorcowymi"

From Scribus Wiki
Jump to: navigation, search
(Plan A:)
(Plan A:)
Line 39: Line 39:
 
[[Image:Master pages new master page.png|frame|left|Picture 3]]
 
[[Image:Master pages new master page.png|frame|left|Picture 3]]
  
After you click '''OK''' you will see the window '''Edit Master Pages''' with your new Master Page highlighted. When you have a list of Master Pages you can then click from one to the next to edit each one as desired (Picture 4).
+
Po kliknięciu na '''OK''' w oknie '''Edytuj strony wzorcowe''' wyświetli się zaznaczona, nowa strona wzorcowa. Jeśli masz już listę stron wzorcowych, możesz wybrać kliknięciem dowolną stronę z listy, aby rozpocząć jej edycję (Obrazek 4).
  
When you close the '''Edit Master Pages''' window, you return to the normal editing mode in Scribus.
+
Po zamknięciu okna '''Edytuj strony wzorcowe''' znajdziesz się ponownie w normalnym trybie edycji w Scribusie.
  
 
[[Image:Master pages selecting master pages.png|frame|right|Picture 4]]
 
[[Image:Master pages selecting master pages.png|frame|right|Picture 4]]
  
If you find that you need a Master Page similar to an existing one, click on '''Duplicate the selected master page''' rather than starting a new Master Page from scratch -- this can be a great time-saver.  
+
Jeśli będziesz potrzebował strony wzorcowej podobnej do już istniejącej strony, kliknij na przycisk klonowania wybranych stron wzorcowych, zamiast rozpoczynać pracę od zera.
  
You can also copy a Master Page from another document by clicking on '''Import master pages from another document''' button, which opens the '''Import Master Page''' window (Picture 5).  
+
Możesz również skopiować stronę wzorcową z innego dokumentu klikając na przycisk '''Importuj strony wzorcowe z innego dokumentu''', który otwiera okienko '''Importuj stronę wzorcową''' (Obrazek 5).  
 
{| width=550px |
 
{| width=550px |
|[[Image:Master pages import.png|frame|left|Picture 5]]
+
|[[Image:Master pages import.png|frame|left|Obrazek 5]]
  
|Next, click on the button '''Change...''' to search for the document containing the Master Page you would like to import.
+
|Następnie kliknij na przycisk '''Zmień...''', aby poszukać dokumentu zawierającego strony wzorcowe, które chciałbyś zaimportować.  
 
|}
 
|}
 
<!-- Column 2 -->
 
<!-- Column 2 -->

Revision as of 11:23, 29 November 2006

edytuj

Strona główna

Jak to zrobić

  1. Pierwsze kroki ze Scribusem
  2. Praca z ramkami tekstowymi
  3. Praca z ramkami graficznymi
  4. Praca ze stronami wzorcowymi
  5. Praca w Edytorze artykułów
  6. Tekst na krzywej
  7. Scribus w Ubuntu Linux
  8. Klik i Scribus działa
  9. Instalacja za pomocą Cmake
  10. Tworzenie spisu treści
  11. Formularze PDF
  12. Kolory dodatkowe
  13. Obrazek ze ścieżką odcięcia

Porady i triki

  1. Instalacja profili ICC
  2. Dodawanie fontów
  3. Import grafik EPS
  4. Zawieszone spójniki
  5. Twój pierwszy artykuł
  6. Tworzenie hiperłączy

Często zadawane pytania

  1. Zarządzanie kolorami
  2. Skąd pobrać Scribusa?
  3. Podgląd wydruku nie działa
  4. Scribus dla MacOSX?
  5. Dodawanie fontów
  6. Scribus po polsku
  7. Type 1 i ligatury
  8. Automatyczne numery stron
  9. Interlinia w Scribusie
  10. Pierwsze kroki z DTP
  11. Skalowanie obrazka w ramce
  12. Export do PDF/X-3
  13. Ligatury i cyfry nautyczne?
  14. Pomoc w rozwoju Scribusa
  15. Przykładowe dokumenty
  16. Zgłaszanie błędów
  17. Słowniki dzielenia na sylaby

Tłumaczenie w toku!

Po co są strony wzorcowe

W momencie zaczniesz planować użycie wielu powtarzających się obiektów (nagłówki, loga, tło, numery stron itd.) w tych samych miejscach na stronach dokumentu, zrobisz najlepiej stosując strony wzorcowe. Oszczędzisz sobie w ten sposób wiele czasu i niepotrzebnego mozołu. Obiektów znajdujących się na stronach wzorcowych nie da się zmienić w normalnym trybie edycji strony. Ograniczenie to pozwala uniknąć przypadkowego przesunięcia lub usunięcia obiektu na stronach wzorcowych. Strona wzorcowa jest zawsze związana z dokumentem – nie można jej zapisać w oddzielnym pliku. Możesz jednak utworzyć plik zawierający często używane strony wzorcowe i korzystać z niego jako źródła importu stron wzorcowych do innych dokumentów Scribusa.

Jak utworzyć strony wzorcowe

Plan A:

Picture 1

Utwórz nowy dokument. Wybierz z głównego menu Edycja > Strony wzorcowe... (Obrazek 1), aby wystartować okienko dialogowe o nazwie Edytuj strony wzorcowe (Obrazek 2).

Strona wzorcowa o nazwie Normalna jest zawsze dostępna i nie można jej usunąć – przycisk usuwania zostanie wyłączony po wybraniu tej strony (Obrazek 2). Stronę wzorcową Normalna można co prawda edytować, lepiej jednak zostawić ją pustą, aby można było dodawać puste strony.

Picture 2

Po najechaniu myszą na przyciski pojawią się pomocne podpowiedzi (Obrazek 2).

Zaczynając od lewej strony:

  • Nowa strona wzorcowa
  • Klonowanie strony wzorcowej
  • Import strony wzorcowej
  • Usuwanie strony wzorcowej

Po kliknięciu na przycisk Dodaj nową stronę wzorcową pojawi się okienko, w którym będziesz mógł podać nazwę strony (Obrazek 3).

Rada: wybierz nazwę, która będzie odpowiadała przeznaczeniu strony wzorcowej, tak abyć nawet po dłuższym czasie wiedział, do czego ona służy.

Picture 3

Po kliknięciu na OK w oknie Edytuj strony wzorcowe wyświetli się zaznaczona, nowa strona wzorcowa. Jeśli masz już listę stron wzorcowych, możesz wybrać kliknięciem dowolną stronę z listy, aby rozpocząć jej edycję (Obrazek 4).

Po zamknięciu okna Edytuj strony wzorcowe znajdziesz się ponownie w normalnym trybie edycji w Scribusie.

Picture 4

Jeśli będziesz potrzebował strony wzorcowej podobnej do już istniejącej strony, kliknij na przycisk klonowania wybranych stron wzorcowych, zamiast rozpoczynać pracę od zera.

Możesz również skopiować stronę wzorcową z innego dokumentu klikając na przycisk Importuj strony wzorcowe z innego dokumentu, który otwiera okienko Importuj stronę wzorcową (Obrazek 5).

Obrazek 5
Następnie kliknij na przycisk Zmień..., aby poszukać dokumentu zawierającego strony wzorcowe, które chciałbyś zaimportować.


Plan B:

You can also create new Master Pages from the page you are editing in normal editing mode. From the menu bar select Page > Convert to Master Page... (Picture 6). This opens a window entitled Convert Page to Master in which you may give this new Master Page a name (similar to Picture 3 above).

Afterward, you may then go back to Edit > Master Pages... where you will find your new Master Page in the Edit Master Pages window (Picture 4 above).

Picture 6


Podwójne strony, składanka potrójna i poczwórna

Picture 7
Picture 8 - Double Sided
Picture 9 - 3-fold
Picture 10 - 4-fold

So how can we use these concepts with Double Sided, 3-fold and 4-fold document layouts?

Actually, you will find that these are situations where using Master Pages is especially useful and time-saving. When you create a new document, select your desired layout (Picture 7).

After this, create your Master Pages as explained above for Plan A or Plan B. To the right we see why the name chosen for a Master Page is especially important and helpful.

  • Double Sided layout (Picture 8)
  • 3-fold layout (Picture 9)
  • 4-fold layout (Picture 10)



Stosowanie stron wzorcowych

Do pustych stron dokumentu:

Picture 11
Picture 12

Selecting either Page > Apply Master Page... (Picture 6) or Apply Master Page... from the context menu (right-click on the page - Picture 11) opens up the Apply Master Page window. From this you may choose to apply the Master page to the:

  • Current page
  • Even pages
  • Odd pages
  • All pages
  • and you may apply to a range of pages

Select the desired Master Page from the drop-down list labeled Master Page.

Perhaps not surprisingly, the option Even pages can only be selected when the document has more than one page. Also, applying to a range of pages only applies when you have selected All pages.

Wstawianie nowych stron:

Picture 13

When you insert a new page (menu bar Page > Insert), you open up a window from which you can choose to add one or more pages, choose the place of insertion, and in addition decide whether these new pages will contain Master Page elements (Picture 13).

Note that the Master Pages area expands according to your layout, so that in Picture 14 we see the appearance of an Insert Page window for a 4-fold layout.

Wskazówka: Page numbering is best accomplished with Story Editor. While you are in Edit Master Page mode, create a text frame with the appropriate location for your page numbering. From the Story Editor menu, select Insert > Character > Page Number (keyboard: Ctrl+Shift+Alt+P). This appears as # in the Story Editor window, but this is not Shift+3.

For proper spacing, make at least 2 of these special characters when page numbering will be as high as 2 digits (10-99), at least 3 when page numbers need to be 100-999.


Picture 14


The first German version of this howto was published originally at the German Scribus Forum.