Difference between revisions of "Praca ze stronami wzorcowymi"

From Scribus Wiki
Jump to: navigation, search
(Plan A:)
m (Small corrections.)
 
(12 intermediate revisions by one other user not shown)
Line 4: Line 4:
  
 
==Po co są strony wzorcowe==
 
==Po co są strony wzorcowe==
W momencie zaczniesz planować użycie wielu powtarzających się obiektów (nagłówki, loga, tło, numery stron itd.) w tych samych miejscach na stronach dokumentu, zrobisz najlepiej stosując strony wzorcowe. Oszczędzisz sobie w ten sposób wiele czasu i niepotrzebnego mozołu. Obiektów znajdujących się na stronach wzorcowych nie da się zmienić w normalnym trybie edycji strony. Ograniczenie to pozwala uniknąć przypadkowego przesunięcia lub usunięcia obiektu na stronach wzorcowych. Strona wzorcowa jest zawsze związana z dokumentem – nie można jej zapisać w oddzielnym pliku. Możesz jednak utworzyć plik zawierający często używane strony wzorcowe i korzystać z niego jako źródła importu stron wzorcowych do innych dokumentów Scribusa.
+
Gdy będziesz planował użycie wielu powtarzających się obiektów (nagłówki, loga, tło, numery stron itd.) w tych samych miejscach na wielu stronach dokumentu, zrobisz to najlepiej stosując strony wzorcowe. Oszczędzisz sobie w ten sposób wiele czasu i niepotrzebnej pracy. Obiektów znajdujących się na stronach wzorcowych nie da się zmienić w normalnym trybie edycji strony. Ograniczenie to pozwala uniknąć przypadkowego przesunięcia lub usunięcia obiektu na stronach wzorcowych. Strona wzorcowa jest zawsze związana z dokumentem – nie można jej zapisać w oddzielnym pliku. Możesz jednak utworzyć plik zawierający często używane strony wzorcowe i korzystać z niego jako źródła importu stron wzorcowych do innych dokumentów Scribusa.
  
 
==Jak utworzyć strony wzorcowe==
 
==Jak utworzyć strony wzorcowe==
Line 16: Line 16:
 
|valign="top" |
 
|valign="top" |
 
[[Image:Strony wzorcowe menu edycja.png|frame|left|Obrazek 1]]
 
[[Image:Strony wzorcowe menu edycja.png|frame|left|Obrazek 1]]
Utwórz nowy dokument. Wybierz z głównego menu '''Edycja > Strony wzorcowe...''' (Obrazek 1), aby wystartować okienko dialogowe o nazwie '''Edytuj strony wzorcowe''' (Obrazek 2).
+
Utwórz nowy dokument. Wybierz z głównego menu '''Edycja > Strony wzorcowe...''' (Obrazek 1), aby wystartować okienko dialogowe o nazwie '''Edytuj strony wzorcowe''' (Obrazek 2). Od tej chwili Scribus znajduje się w trybie edycji stron wzorcowych.
  
 
Strona wzorcowa o nazwie '''Normalna''' jest zawsze dostępna i nie można jej usunąć – przycisk usuwania zostanie wyłączony po wybraniu tej strony (Obrazek 2).  Stronę wzorcową '''Normalna''' można co prawda edytować,  lepiej jednak zostawić ją pustą, aby można było dodawać puste strony.
 
Strona wzorcowa o nazwie '''Normalna''' jest zawsze dostępna i nie można jej usunąć – przycisk usuwania zostanie wyłączony po wybraniu tej strony (Obrazek 2).  Stronę wzorcową '''Normalna''' można co prawda edytować,  lepiej jednak zostawić ją pustą, aby można było dodawać puste strony.
Line 33: Line 33:
 
Po kliknięciu na przycisk '''Dodaj nową stronę wzorcową''' pojawi się okienko, w którym będziesz mógł podać nazwę strony (Obrazek 3).  
 
Po kliknięciu na przycisk '''Dodaj nową stronę wzorcową''' pojawi się okienko, w którym będziesz mógł podać nazwę strony (Obrazek 3).  
  
Rada: wybierz nazwę, która będzie odpowiadała przeznaczeniu strony wzorcowej, tak abyć nawet po dłuższym czasie wiedział, do czego ona służy.
+
Rada: wybierz nazwę, która będzie odpowiadała przeznaczeniu strony wzorcowej, tak abyś nawet po dłuższym czasie wiedział, do czego ona służy.
  
[[Image:Master pages new master page.png|frame|left|Obrazek 3]]
+
[[Image:Strony wzorcowe nowa strona.png|frame|left|Obrazek 3]]
  
 
Po kliknięciu na '''OK'''  w oknie '''Edytuj strony wzorcowe''' wyświetli się zaznaczona, nowa strona wzorcowa. Jeśli masz już listę stron wzorcowych, możesz wybrać kliknięciem dowolną stronę z listy, aby rozpocząć jej edycję (Obrazek 4).
 
Po kliknięciu na '''OK'''  w oknie '''Edytuj strony wzorcowe''' wyświetli się zaznaczona, nowa strona wzorcowa. Jeśli masz już listę stron wzorcowych, możesz wybrać kliknięciem dowolną stronę z listy, aby rozpocząć jej edycję (Obrazek 4).
Line 41: Line 41:
 
Po zamknięciu okna '''Edytuj strony wzorcowe''' znajdziesz się ponownie w normalnym trybie edycji w Scribusie.
 
Po zamknięciu okna '''Edytuj strony wzorcowe''' znajdziesz się ponownie w normalnym trybie edycji w Scribusie.
  
[[Image:Master pages selecting master pages.png|frame|right|Obrazek 4]]
+
[[Image:Strony wzorcowe 4.png|frame|right|Obrazek 4]]
  
 
Jeśli będziesz potrzebował strony wzorcowej podobnej do już istniejącej strony, kliknij na przycisk klonowania wybranych stron wzorcowych, zamiast rozpoczynać pracę od zera.
 
Jeśli będziesz potrzebował strony wzorcowej podobnej do już istniejącej strony, kliknij na przycisk klonowania wybranych stron wzorcowych, zamiast rozpoczynać pracę od zera.
Line 47: Line 47:
 
Możesz również skopiować stronę wzorcową z innego dokumentu klikając na przycisk '''Importuj strony wzorcowe z innego dokumentu''', który otwiera okienko '''Importuj stronę wzorcową''' (Obrazek 5).  
 
Możesz również skopiować stronę wzorcową z innego dokumentu klikając na przycisk '''Importuj strony wzorcowe z innego dokumentu''', który otwiera okienko '''Importuj stronę wzorcową''' (Obrazek 5).  
 
{| width=550px |
 
{| width=550px |
|[[Image:Master pages import.png|frame|left|Obrazek 5]]
+
|[[Image:Strony wzorcowe 5.png|frame|left|Obrazek 5]]
  
|Następnie kliknij na przycisk '''Zmień...''', aby poszukać dokumentu zawierającego strony wzorcowe, które chciałbyś zaimportować.  
+
|Następnie kliknij na przycisk '''Zmień...''', aby poszukać dokumentu zawierającego strony wzorcowe, które chciałbyś. Po znalezieniu dokumentu możesz wybrać jedną z dostępnych w nim stron wzorcowych i kliknąć '''Importuj'''.
 
|}
 
|}
 
<!-- Column 2 -->
 
<!-- Column 2 -->
Line 74: Line 74:
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages convert2masterpage.png|frame|Obrazek 6]]
+
[[Image:Strony wzorcowe 6.png|frame|Obrazek 6]]
 
|}
 
|}
  
Line 87: Line 87:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:NewDoc_layout.png|frame|left|Obrazek 7]]
+
[[Image:Strony wzorcowe 7.png|frame|left|Obrazek 7]]
[[Image:Master_pages_new_double_sided.png|frame|right|Obrazek 8 - Podwójna strona]]
+
[[Image:Strony wzorcowe 8.png|frame|right|Obrazek 8 - Podwójna strona]]
[[Image:Master pages new 3fold.png|frame|right|Obrazek 9 - Składanka potrójna]]
+
[[Image:Strony wzorcowe 9.png|frame|right|Obrazek 9 - Składanka potrójna]]
[[Image:Master pages new 4fold.png|frame|right|Obrazek 10 - Składanka poczwórna]]
+
[[Image:Strony wzorcowe 10.png|frame|right|Obrazek 10 - Składanka poczwórna]]
 
Zapytasz pewnie, w jaki sposób zastosować te procedury do podwónych stron oraz składanke potrójnych i poczwórnych?
 
Zapytasz pewnie, w jaki sposób zastosować te procedury do podwónych stron oraz składanke potrójnych i poczwórnych?
  
Line 116: Line 116:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Context_masterpage.jpg|frame|left|Obrazek 11]]
+
[[Image:Strony wzorcowe 11.png|frame|left|Obrazek 11]]
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages apply.png|frame|right|Obrazek 12]]
+
[[Image:Strony wzorcowe 12.png|frame|right|Obrazek 12]]
 
|}
 
|}
  
Line 142: Line 142:
 
<!-- Column 1 -->
 
<!-- Column 1 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages insert new page.png|frame|left|Obrazek 13]]
+
[[Image:Strony wzorcowe 13.png|frame|left|Obrazek 13]]
 
Kiedy wstawiasz do dokumentu nową stronę ('''Strona > Wstaw'''), pojawia się okno dialogowe, w którym możesz wybrać ilość stron do wstawienia, miejsce, gdzie zostaną wstawione i zdecydować, czy strony te zawierać będą elementy strony wzorcowej (Obrazek 13).  
 
Kiedy wstawiasz do dokumentu nową stronę ('''Strona > Wstaw'''), pojawia się okno dialogowe, w którym możesz wybrać ilość stron do wstawienia, miejsce, gdzie zostaną wstawione i zdecydować, czy strony te zawierać będą elementy strony wzorcowej (Obrazek 13).  
  
Line 152: Line 152:
 
<!-- Column 2 -->
 
<!-- Column 2 -->
 
|valign="top" |
 
|valign="top" |
[[Image:Master pages 4fold newpage.png|frame|Obrazek 14]]
+
[[Image:Strony wzorcowe 14.png|frame|Obrazek 14]]
 
|}
 
|}
  

Latest revision as of 17:18, 22 February 2013

edytuj

Strona główna

Jak to zrobić

  1. Pierwsze kroki ze Scribusem
  2. Praca z ramkami tekstowymi
  3. Praca z ramkami graficznymi
  4. Praca ze stronami wzorcowymi
  5. Praca w Edytorze artykułów
  6. Tekst na krzywej
  7. Scribus w Ubuntu Linux
  8. Klik i Scribus działa
  9. Instalacja za pomocą Cmake
  10. Tworzenie spisu treści
  11. Formularze PDF
  12. Kolory dodatkowe
  13. Obrazek ze ścieżką odcięcia

Porady i triki

  1. Instalacja profili ICC
  2. Dodawanie fontów
  3. Import grafik EPS
  4. Zawieszone spójniki
  5. Twój pierwszy artykuł
  6. Tworzenie hiperłączy

Często zadawane pytania

  1. Zarządzanie kolorami
  2. Skąd pobrać Scribusa?
  3. Podgląd wydruku nie działa
  4. Scribus dla MacOSX?
  5. Dodawanie fontów
  6. Scribus po polsku
  7. Type 1 i ligatury
  8. Automatyczne numery stron
  9. Interlinia w Scribusie
  10. Pierwsze kroki z DTP
  11. Skalowanie obrazka w ramce
  12. Export do PDF/X-3
  13. Ligatury i cyfry nautyczne?
  14. Pomoc w rozwoju Scribusa
  15. Przykładowe dokumenty
  16. Zgłaszanie błędów
  17. Słowniki dzielenia na sylaby

Po co są strony wzorcowe

Gdy będziesz planował użycie wielu powtarzających się obiektów (nagłówki, loga, tło, numery stron itd.) w tych samych miejscach na wielu stronach dokumentu, zrobisz to najlepiej stosując strony wzorcowe. Oszczędzisz sobie w ten sposób wiele czasu i niepotrzebnej pracy. Obiektów znajdujących się na stronach wzorcowych nie da się zmienić w normalnym trybie edycji strony. Ograniczenie to pozwala uniknąć przypadkowego przesunięcia lub usunięcia obiektu na stronach wzorcowych. Strona wzorcowa jest zawsze związana z dokumentem – nie można jej zapisać w oddzielnym pliku. Możesz jednak utworzyć plik zawierający często używane strony wzorcowe i korzystać z niego jako źródła importu stron wzorcowych do innych dokumentów Scribusa.

Jak utworzyć strony wzorcowe

Plan A:

Obrazek 1

Utwórz nowy dokument. Wybierz z głównego menu Edycja > Strony wzorcowe... (Obrazek 1), aby wystartować okienko dialogowe o nazwie Edytuj strony wzorcowe (Obrazek 2). Od tej chwili Scribus znajduje się w trybie edycji stron wzorcowych.

Strona wzorcowa o nazwie Normalna jest zawsze dostępna i nie można jej usunąć – przycisk usuwania zostanie wyłączony po wybraniu tej strony (Obrazek 2). Stronę wzorcową Normalna można co prawda edytować, lepiej jednak zostawić ją pustą, aby można było dodawać puste strony.

Obrazek 2


Po najechaniu myszą na przyciski pojawią się pomocne podpowiedzi (Obrazek 2).

Zaczynając od lewej strony:

  • Nowa strona wzorcowa
  • Klonowanie strony wzorcowej
  • Import strony wzorcowej
  • Usuwanie strony wzorcowej

Po kliknięciu na przycisk Dodaj nową stronę wzorcową pojawi się okienko, w którym będziesz mógł podać nazwę strony (Obrazek 3).

Rada: wybierz nazwę, która będzie odpowiadała przeznaczeniu strony wzorcowej, tak abyś nawet po dłuższym czasie wiedział, do czego ona służy.

Obrazek 3

Po kliknięciu na OK w oknie Edytuj strony wzorcowe wyświetli się zaznaczona, nowa strona wzorcowa. Jeśli masz już listę stron wzorcowych, możesz wybrać kliknięciem dowolną stronę z listy, aby rozpocząć jej edycję (Obrazek 4).

Po zamknięciu okna Edytuj strony wzorcowe znajdziesz się ponownie w normalnym trybie edycji w Scribusie.

Obrazek 4

Jeśli będziesz potrzebował strony wzorcowej podobnej do już istniejącej strony, kliknij na przycisk klonowania wybranych stron wzorcowych, zamiast rozpoczynać pracę od zera.

Możesz również skopiować stronę wzorcową z innego dokumentu klikając na przycisk Importuj strony wzorcowe z innego dokumentu, który otwiera okienko Importuj stronę wzorcową (Obrazek 5).

Obrazek 5
Następnie kliknij na przycisk Zmień..., aby poszukać dokumentu zawierającego strony wzorcowe, które chciałbyś. Po znalezieniu dokumentu możesz wybrać jedną z dostępnych w nim stron wzorcowych i kliknąć Importuj.


Plan B:

Możesz również utworzyć stronę wzorcową ze strony, którą edytujesz w normalnym trybie edycji. Wybierz w menu Strona > Zamień na stronę wzorcową... (Obrazek 6). Pojawi się okienko zatytułowane Zamień stronę na stronę wzorcową, w którym będziesz mógł nadać nazwę nowej stronie wzorcowej (podobne do przedstawionego na obrazku 3).

Następnie możesz otworzyć dialog Edycja > Strony wzorcowe..., aby zobaczyć twoją nową stronę wzorcową (Obrazek 4).

Obrazek 6


Podwójne strony, składanka potrójna i poczwórna

Obrazek 7
Obrazek 8 - Podwójna strona
Obrazek 9 - Składanka potrójna
Obrazek 10 - Składanka poczwórna

Zapytasz pewnie, w jaki sposób zastosować te procedury do podwónych stron oraz składanke potrójnych i poczwórnych?

Tak naprawdę właśnie w tych sytacjach strony wzorcowe okażą się szczególnie przydatne i oszczędzą ci dużo czasu. Podczas tworzenia nowego dokumentu, wybierz pożądany układ strony (Obrazek 7).

Następnie utwórz swoje strony wzorcowe, jak to opisano w Planie A lub Planie B. Na zrzutach ekranowych po prawej stronie widać, dlaczego nazwy nadawane stronom wzorcowym są szczególnie ważne i pomocne.

  • Układ podwójnych stron (Obrazek 8)
  • Układ składanki potrójnej (Obrazek 9)
  • Układ składanki poczwórnej (Obrazek 10)



Stosowanie stron wzorcowych

Do pustych stron dokumentu:

Obrazek 11
Obrazek 12

Wybór z menu punktu Strona > Zastosuj stronę wzorcową... (Obrazek 6) lub punktu Zastosuj stronę wzorcową... z menu kontekstowego (prawy klik na stronie - Obrazek 11) spowoduje wyświetlenie okienka Zastosuj stronę wzorcową. Tutaj możesz zastosować stronę wzorcową do:

  • aktualnej strony
  • parzystych stron
  • nieparzystych stron
  • wszystkich stron
  • i do zakresu stron

Stronę wzorcową do zastosowania wybrać można z listy rozwijalnej o nazwie Strona wzorcowa.

Pewnie nie zaskoczy nikogo, że opcję Strony parzyste wybrać można tylko wtedy, kiedy dokument zawiera więcej niż jedną stronę. Również zastosowanie strony wzorcowej do zakresu stron będzie możliwe tylko po wybraniu opcji Wszystkie strony.

Wstawianie nowych stron:

Obrazek 13

Kiedy wstawiasz do dokumentu nową stronę (Strona > Wstaw), pojawia się okno dialogowe, w którym możesz wybrać ilość stron do wstawienia, miejsce, gdzie zostaną wstawione i zdecydować, czy strony te zawierać będą elementy strony wzorcowej (Obrazek 13).

Zauważ, że obszar zatytułowany Strony wzorcowe zmienia się w zależności od układu strony, np. obrazek 14 pokazuje wygląd okna Wstaw stronę dla składanki poczwórnej.

Wskazówka: Numerację stron najlepiej dodaje się w Edytorze artykułów. W trakcie edycji strony wzorcowej utwórz na niej ramkę tekstową w miejscu, w którym pojawiać się będą numery stron. Wewnątrz Edytora artykułów wybierz z menu Wstaw > Znak > Numer strony (skrót klawiszowy: Ctrl+Shift+Alt+P). Od strony 10 należy wstawić dwa ( ##) numery stron, a od strony 100 trzy (###) etc. Typowy przypadek, w którym przyda ci się funkcja duplikowania stron wzorcowych.

Obrazek 14


Pierwsza, niemieckojęzyczna wersja tego artykułu opublikowana została w niemieckim Scribus Forum.