Praca ze stronami wzorcowymi

From Scribus Wiki
Revision as of 12:07, 29 November 2006 by Mhanski (talk | contribs) (Podwójne strony, składanka potrójna i poczwórna)
Jump to: navigation, search
edytuj

Strona główna

Jak to zrobić

  1. Pierwsze kroki ze Scribusem
  2. Praca z ramkami tekstowymi
  3. Praca z ramkami graficznymi
  4. Praca ze stronami wzorcowymi
  5. Praca w Edytorze artykułów
  6. Tekst na krzywej
  7. Scribus w Ubuntu Linux
  8. Klik i Scribus działa
  9. Instalacja za pomocą Cmake
  10. Tworzenie spisu treści
  11. Formularze PDF
  12. Kolory dodatkowe
  13. Obrazek ze ścieżką odcięcia

Porady i triki

  1. Instalacja profili ICC
  2. Dodawanie fontów
  3. Import grafik EPS
  4. Zawieszone spójniki
  5. Twój pierwszy artykuł
  6. Tworzenie hiperłączy

Często zadawane pytania

  1. Zarządzanie kolorami
  2. Skąd pobrać Scribusa?
  3. Podgląd wydruku nie działa
  4. Scribus dla MacOSX?
  5. Dodawanie fontów
  6. Scribus po polsku
  7. Type 1 i ligatury
  8. Automatyczne numery stron
  9. Interlinia w Scribusie
  10. Pierwsze kroki z DTP
  11. Skalowanie obrazka w ramce
  12. Export do PDF/X-3
  13. Ligatury i cyfry nautyczne?
  14. Pomoc w rozwoju Scribusa
  15. Przykładowe dokumenty
  16. Zgłaszanie błędów
  17. Słowniki dzielenia na sylaby

Tłumaczenie w toku!

Po co są strony wzorcowe

W momencie zaczniesz planować użycie wielu powtarzających się obiektów (nagłówki, loga, tło, numery stron itd.) w tych samych miejscach na stronach dokumentu, zrobisz najlepiej stosując strony wzorcowe. Oszczędzisz sobie w ten sposób wiele czasu i niepotrzebnego mozołu. Obiektów znajdujących się na stronach wzorcowych nie da się zmienić w normalnym trybie edycji strony. Ograniczenie to pozwala uniknąć przypadkowego przesunięcia lub usunięcia obiektu na stronach wzorcowych. Strona wzorcowa jest zawsze związana z dokumentem – nie można jej zapisać w oddzielnym pliku. Możesz jednak utworzyć plik zawierający często używane strony wzorcowe i korzystać z niego jako źródła importu stron wzorcowych do innych dokumentów Scribusa.

Jak utworzyć strony wzorcowe

Plan A:

Picture 1

Utwórz nowy dokument. Wybierz z głównego menu Edycja > Strony wzorcowe... (Obrazek 1), aby wystartować okienko dialogowe o nazwie Edytuj strony wzorcowe (Obrazek 2).

Strona wzorcowa o nazwie Normalna jest zawsze dostępna i nie można jej usunąć – przycisk usuwania zostanie wyłączony po wybraniu tej strony (Obrazek 2). Stronę wzorcową Normalna można co prawda edytować, lepiej jednak zostawić ją pustą, aby można było dodawać puste strony.

Picture 2

Po najechaniu myszą na przyciski pojawią się pomocne podpowiedzi (Obrazek 2).

Zaczynając od lewej strony:

  • Nowa strona wzorcowa
  • Klonowanie strony wzorcowej
  • Import strony wzorcowej
  • Usuwanie strony wzorcowej

Po kliknięciu na przycisk Dodaj nową stronę wzorcową pojawi się okienko, w którym będziesz mógł podać nazwę strony (Obrazek 3).

Rada: wybierz nazwę, która będzie odpowiadała przeznaczeniu strony wzorcowej, tak abyć nawet po dłuższym czasie wiedział, do czego ona służy.

Picture 3

Po kliknięciu na OK w oknie Edytuj strony wzorcowe wyświetli się zaznaczona, nowa strona wzorcowa. Jeśli masz już listę stron wzorcowych, możesz wybrać kliknięciem dowolną stronę z listy, aby rozpocząć jej edycję (Obrazek 4).

Po zamknięciu okna Edytuj strony wzorcowe znajdziesz się ponownie w normalnym trybie edycji w Scribusie.

Picture 4

Jeśli będziesz potrzebował strony wzorcowej podobnej do już istniejącej strony, kliknij na przycisk klonowania wybranych stron wzorcowych, zamiast rozpoczynać pracę od zera.

Możesz również skopiować stronę wzorcową z innego dokumentu klikając na przycisk Importuj strony wzorcowe z innego dokumentu, który otwiera okienko Importuj stronę wzorcową (Obrazek 5).

Obrazek 5
Następnie kliknij na przycisk Zmień..., aby poszukać dokumentu zawierającego strony wzorcowe, które chciałbyś zaimportować.


Plan B:

Możesz również utworzyć stronę wzorcową ze strony, którą edytujesz w normalnym trybie edycji. Wybierz w menu Strona > Zamień na stronę wzorcową... (Obrazek 6). Pojawi się okienko zatytułowane Zamień stronę na stronę wzorcową, w którym będziesz mógł nadać nazwę nowej stronie wzorcowej (podobne do przedstawionego na obrazku 3).

Następnie możesz otworzyć dialog Edycja > Strony wzorcowe..., aby zobaczyć twoją nową stronę wzorcową (Obrazek 4).

Obrazek 6


Podwójne strony, składanka potrójna i poczwórna

Obrazek 7
Obrazek 8 - Podwójna strona
Picture 9 - Składanka potrójna
Picture 10 - Składanka poczwórna

Zapytasz pewnie, w jaki sposób zastosować te procedury do podwónych stron oraz składanke potrójnych i poczwórnych?

Tak naprawdę właśnie w tych sytacjach strony wzorcowe okażą się szczególnie przydatne i oszczędzą ci dużo czasu. Podczas tworzenia nowego dokumentu, wybierz pożądany układ strony (Obrazek 7).

Następnie utwórz swoje strony wzorcowe, jak to opisano w Planie A lub Planie B. Na zrzutach ekranowych po prawej stronie widać, dlaczego nazwy nadawane stronom wzorcowym są szczególnie ważne i pomocne.

  • Układ podwójnych stron (Obrazek 8)
  • Układ składanki potrójnej (Obrazek 9)
  • Układ składanki poczwórnej (Obrazek 10)



Stosowanie stron wzorcowych

Do pustych stron dokumentu:

Picture 11
Picture 12

Selecting either Page > Apply Master Page... (Picture 6) or Apply Master Page... from the context menu (right-click on the page - Picture 11) opens up the Apply Master Page window. From this you may choose to apply the Master page to the:

  • Current page
  • Even pages
  • Odd pages
  • All pages
  • and you may apply to a range of pages

Select the desired Master Page from the drop-down list labeled Master Page.

Perhaps not surprisingly, the option Even pages can only be selected when the document has more than one page. Also, applying to a range of pages only applies when you have selected All pages.

Wstawianie nowych stron:

Picture 13

When you insert a new page (menu bar Page > Insert), you open up a window from which you can choose to add one or more pages, choose the place of insertion, and in addition decide whether these new pages will contain Master Page elements (Picture 13).

Note that the Master Pages area expands according to your layout, so that in Picture 14 we see the appearance of an Insert Page window for a 4-fold layout.

Wskazówka: Page numbering is best accomplished with Story Editor. While you are in Edit Master Page mode, create a text frame with the appropriate location for your page numbering. From the Story Editor menu, select Insert > Character > Page Number (keyboard: Ctrl+Shift+Alt+P). This appears as # in the Story Editor window, but this is not Shift+3.

For proper spacing, make at least 2 of these special characters when page numbering will be as high as 2 digits (10-99), at least 3 when page numbers need to be 100-999.


Picture 14


The first German version of this howto was published originally at the German Scribus Forum.