Difference between revisions of "Solucionando problemas de visualização do Adobe Reader no FC6"

From Scribus Wiki
Jump to navigation Jump to search
 
(6 intermediate revisions by the same user not shown)
Line 1: Line 1:
 +
Versão em [[Fedora Core 6 - Troubleshooting|'''inglês''']].
 
[[Category:PT]]
 
[[Category:PT]]
 
[[Category:Dicas]]
 
[[Category:Dicas]]
 
{{Dicas}}
 
{{Dicas}}
  
 
+
{| style="background-color:#ffffff;color:barkblue;border:1px solid #ffc9c9;padding:1em;width:50%;text-align:center"
Certifique-se de instalar a útlima versão estável do Scribus antes de continuar.
+
|| [[Image:Important.png|left]]
 +
||'''Nota:'''<font size="1">
 +
Certifique-se de instalar a útlima versão estável do Scribus antes de continuar. Pacotes atualizados podem ser encontrados no repositório '''Extras'''.<br> Use o comando <code>yum install scribus</code> ou utilize seu gerenciador de pacotes favorito.</font>
 +
|}
  
 
==Impressão==
 
==Impressão==
A impressão diretamente através do Scribus pode não funcionar no Fedora Core 6 se o mesmo método e configurações do Fedora Core 5 forem utilizados. Aparentemente, um mesnagem de erro é gerada e não há a impressão.
+
A impressão diretamente através do Scribus pode não funcionar no Fedora Core 6 se o mesmo método e configurações do Fedora Core 5 forem utilizados. Aparentemente, uma mensagem de erro é gerada e não há a impressão.
  
 
Para corrigir isso, marque a caixa '''Comando alternativo de impressão''' e entre com o seguinte texto na caixa '''Comando''':
 
Para corrigir isso, marque a caixa '''Comando alternativo de impressão''' e entre com o seguinte texto na caixa '''Comando''':
  
<tt>lp -d''nome-da-sua-impressora''</tt>
+
<code>lp -d''nome-da-sua-impressora''</code>
  
Por exemplo, minha impressora chama-se ''Laser'', então:
+
Por exemplo, a minha impressora chama-se ''Laser'', então:
  
<tt>lp -dlaser</tt>
+
<code>lp -dlaser</code>
  
 
==Adobe Reader==
 
==Adobe Reader==
As versões tar.gz ou .rpm do Adobe Reader 7.08 não funcionará.  
+
As versões tar.gz ou .rpm do Adobe Reader 7.08 não funcionarão.  
Você precisará corrigir o problema editando o binário '''acroread''' do diretório <code>/usr/bin</code> num editor de texto como o Kate (como super-usuário, claro)
+
Você precisará corrigir o problema editando o binário '''acroread''' do diretório <code>/usr/bin</code> num editor de texto como o Kate (como super-usuário, claro). Use o Mini CLI (pressione '''Alt+F2''' e digite '''kdesu kate''').
  
Este arquivo é ligado ao original, mas lembre-se que você estará editando O original.
+
Este arquivo será ligado ao original, mas lembre-se que você estará editando _O Original_.
  
 
Há duas linhas a serem editadas:
 
Há duas linhas a serem editadas:
  
Procure pela linha abaixo(por volta da linha 418):
+
Procure pela linha abaixo (por volta da linha 418):
 +
 
 
<code>
 
<code>
 
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
 
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
</code>
+
</code><br>
 
E altere para:
 
E altere para:
<code>
+
<code><br>
 
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
 
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
 
</code>
 
</code>
  
outra linha fica próxima da linha 643:
+
A outra linha fica próxima da 643:
 +
 
 
<code>
 
<code>
 
MIN_GTK_VERSION="240"
 
MIN_GTK_VERSION="240"
</code>
+
</code><br>
 
Altere-a para:
 
Altere-a para:
<code>
+
<code><br>
 
MIN_GTK_VERSION="2040"
 
MIN_GTK_VERSION="2040"
 
</code>
 
</code>
 +
 
Salve o arquivo e pronto.
 
Salve o arquivo e pronto.
  
Você ainda pode tentar outra coisa, ao invés da última alteração (linha 644):
+
Você ainda pode tentar outra coisa (próximo à linha 644), ao invés da última alteração:
 +
 
 
<code>
 
<code>
 
check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION"  
 
check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION"  
</code>
+
</code><br>
 
Mude-a para:
 
Mude-a para:
<code>
+
<code><br>
#check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION"  
+
<nowiki>#</nowiki>check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION"  
 
</code>
 
</code>
 +
 
Desse modo ele não checará a versão GTK usada.
 
Desse modo ele não checará a versão GTK usada.
  

Latest revision as of 16:55, 30 January 2007

Versão em inglês.

Este artigo é parte da seção de Dicas.
Instalação Uso Questões sobre PDF Outros
Voltar para a página principal
Important.png
Nota:

Certifique-se de instalar a útlima versão estável do Scribus antes de continuar. Pacotes atualizados podem ser encontrados no repositório Extras.
Use o comando yum install scribus ou utilize seu gerenciador de pacotes favorito.

Impressão

A impressão diretamente através do Scribus pode não funcionar no Fedora Core 6 se o mesmo método e configurações do Fedora Core 5 forem utilizados. Aparentemente, uma mensagem de erro é gerada e não há a impressão.

Para corrigir isso, marque a caixa Comando alternativo de impressão e entre com o seguinte texto na caixa Comando:

lp -dnome-da-sua-impressora

Por exemplo, a minha impressora chama-se Laser, então:

lp -dlaser

Adobe Reader

As versões tar.gz ou .rpm do Adobe Reader 7.08 não funcionarão. Você precisará corrigir o problema editando o binário acroread do diretório /usr/bin num editor de texto como o Kate (como super-usuário, claro). Use o Mini CLI (pressione Alt+F2 e digite kdesu kate).

Este arquivo será ligado ao original, mas lembre-se que você estará editando _O Original_.

Há duas linhas a serem editadas:

Procure pela linha abaixo (por volta da linha 418):

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
E altere para:
echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

A outra linha fica próxima da 643:

MIN_GTK_VERSION="240"
Altere-a para:
MIN_GTK_VERSION="2040"

Salve o arquivo e pronto.

Você ainda pode tentar outra coisa (próximo à linha 644), ao invés da última alteração:

check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION"
Mude-a para:
#check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION"

Desse modo ele não checará a versão GTK usada.

Se nada disso funcionar, tente o seguinte (usando a linha de comando):

export GTK_IM_MODULE=xim
acroread

Se funcionar, você pode então modificar o Script acroread adicionando:

# "SCIM hack"
# check if we have a scim GTK module load, and overwrite it to avoid crash

if [ $GTK_IM_MODULE = "scim" ]; then

 export GTK_IM_MODULE=xim
fi

Logo antes das linhas a seguir, próxima a linha 648:

#
# Setup configuration specific environment variables
#