Difference between revisions of "Trabajar con marcos de texto"

From Scribus Wiki
Jump to: navigation, search
(Entering/Editing Text in the Frame)
(Ingresar y editar texto en el marco)
Line 82: Line 82:
 
Con un marco de texto seleccionado, clic en el icono del [[Toolbars#Toolbar_Icons:_Modify_Objects| '''Editor interno''']] en la barra de herramientas (teclas rápidas: Ctrl+Y), o en el menú '''Editar > Editar texto...'''; esto también está diponible desde el menú contextual (clic secundario sobre el marco). El '''Editor interno''' es la manera más eficiente de ingresar texto manualmente. El texto se mostrará con el color de fuente correcto, pero la fuente tipográfica utilizada y el espaciado no se verán reflejados en la ventana del '''Editor interno'''. Si el color de la fuente es similar al color de fondo en el Editor interno, puede cambiar el color de fondo a su gusto: en el menú del '''Editor interno''': '''Configuraciones > Fondo...'''.
 
Con un marco de texto seleccionado, clic en el icono del [[Toolbars#Toolbar_Icons:_Modify_Objects| '''Editor interno''']] en la barra de herramientas (teclas rápidas: Ctrl+Y), o en el menú '''Editar > Editar texto...'''; esto también está diponible desde el menú contextual (clic secundario sobre el marco). El '''Editor interno''' es la manera más eficiente de ingresar texto manualmente. El texto se mostrará con el color de fuente correcto, pero la fuente tipográfica utilizada y el espaciado no se verán reflejados en la ventana del '''Editor interno'''. Si el color de la fuente es similar al color de fondo en el Editor interno, puede cambiar el color de fondo a su gusto: en el menú del '''Editor interno''': '''Configuraciones > Fondo...'''.
  
The many features of  [[Working_with_Story_Editor| '''Story Editor''']] will be covered in detail elsewhere (also see [[Working_with_text_frames#Properties:_Text_Tab| Properties: Text Tab]] below - layout is different but features are the same). For this brief introduction, note that a large array of text features are completely under your control in Story Editor, including font face, color, spacing, kerning, justification, and more. Note that changing a setting will only modify text that you have selected (highlighted) and any subsequently entered text.
+
Las muchas caracter&iacute;sticas del [[Working_with_Story_Editor| '''Editor interno''']] ser&aacute;n cubiertas en detalle en otro art&iacute;culo (vea m&aacute;s abajo tambi&eacute;n [[Working_with_text_frames#Properties:_Text_Tab| Ventana Propiedades: Solapa Texto]] - con un orden distinto, pero son las mismas caracter&iacute;sticas). Para esta somera introducci&oacute;n, sepa que una gran cantidad de caracter&iacute;sticas de texto est&aacute;n completamente bajo su control en el '''Editor interno''', incluyendo la fuente ha utilizar, su color, interlineado,espaciado, justificado y m&aacute;s. Note que cambiar una caracter&iacute;stica solo modificar&aacute; el texto que tenga seleccionado (<i>"pintado"</i>) y cualquier texto ingresado subsecuentemente..
  
Take the time to learn how to create and use Styles, which will save time when you are repetitively using a font with a specific set of features.
+
T&oacute;mese su tiempo para aprender a utilizar los ''Estilos'', le ahorrar&aacute;n tiempo cuando tenga que utilizar repetidamente una misma fuente con un set espec&iacute;fico de caracter&iacute;sticas.
  
'''''Editing from the main page'''''
+
'''''Editando en la p&aacute;gina'''''
  
Click the [[Toolbars#Toolbar_Icons:_Modify_Objects| '''Edit Contents of Frame''']] icon on the toolbar (keyboard: E). When you click inside the frame, you will see a blinking vertical cursor where you may add or edit text. You may also select (highlight) text and change the highlighted text features in Properties > Text. As you can see the choices are analogous to those in the '''Story Editor'''.
+
Clic en el icono [[Toolbars#Toolbar_Icons:_Modify_Objects| '''Editar contenido del marco''']] de la barra de herramientas (tecla r&aacute;pida: E). Cuando haga clic dentro del marco de texto, aparecer&aacute; un cursor vertical parpadeante indicando la posici&oacute;n en la que se puede agregar o editar texto. Tambi&eacute;n puede seleccionar (<i>"pintar"</i>) texto y cambiar las caracter&iacute;sticas del texto seleccionado en la solapa '''Texto''', de la '''Ventana de Propiedades'''. Como se ve, las opciones son an&aacute;logas a aquellas que aparencen en el '''Editor interno'''.
  
 
'''''Editing All the text in the frame'''''
 
'''''Editing All the text in the frame'''''

Revision as of 16:01, 28 November 2008

Template:HOWTO ES Index

Este artículo intenta ser una compilación de las operaciones relacionadas con marcos de texto.

All Working with pages:

Working with text frames
Working with Story Editor
Working with image frames
Working with Master Pages
Working with Scribus: How to begin

Creación

Puede crear un marco de texto de las siguientes maneras:

  1. Clic en el icono Insertar marco de texto de la barra de herramientas.
  2. o seleccionar Insertar > Marco de texto desde el menú
  3. o con el teclado: T, o Alt+N, T.

Luego, podrá utilizar el ratón para situar y dimensionar el marco: mantenga el clic y arrastre diagonalmente en la página. El clic define uno de los vértices del marco y al soltar, luego de arrastrar, queda definido el vértice opuesto por el centro. Lo más convencional es empezar haciendo clic en la esquina superior izquierda, pero se puede empezar desde cualquier esquina.

Borrado

Para eliminar un marco seleccionado presione la tecla Suprimir del teclado o, alternativamente, Ctrl+X.

Creación automática de marcos de texto

También puede crear marcos de texto automáticamente (en versiones 1.3.3.x y superiores). Aquí una vista del lado derecho de la ventana Nuevo Documento:
Vista parcial de la ventana Nuevo Documento, v1.3.3.x
Seleccione el número de páginas deseadas, el número de columnas, y el espacio entre columnas (calle). Clic en Aceptar. Sus páginas serán creadas con marcos de texto ocupando el espacio permitido por los márgenes del documento. Además, los marcos quedan automáticamente vinculados, de manera que cuando importe un texto, automáticamente fluirá a través del siguiente marco/página según sea necesario.
Autotextframe.png Note también que luego de haber hecho esto, cuando se solicite Página > Insertar, las páginas agregadas seguirán automaáticamente este esquema de marcos de texto.

Menú contextual

Hacer clic con el botón secundario del ratón sobre el marco de texto hace aparecer el menú contextual, que contiene varias operaciones comunes con marcos, una de las importantes es la capacidad de convertir un marco de texto en otro tipo de marco.

Tamaño y posición

Solapa XYZ de la ventana Propiedades

En este punto encontrará que la ventana de Propiedades es un elemento indispensable para trabajar con Scribus. Si no está a la vista, ábralo desde el elemento del menú Ventana > Propiedades o presionando F2. En la versión 1.2.4 se encuentra en el menú Herramientas > Propiedades.

Por defecto, la solapa XYZ de la ventana de Propiedades muestra información muy precisa sobre las coordenadas (X,Y) del vértice superior izquierdo, del ancho y alto del marco y de la rotación del mismo. Note que la información que se muestra es sólo sobre el marco seleccionado - que se muestra con un reborde punteado de color rojo. Un marco queda automáticamente seleccionado al momento de crearlo. Deseleccione un marco haciendo clic en cualquier lugar libre del documento y se vuelve a seleccionar haciendo clic con el botón principal sobre el objeto requerido. Un marco debe estar seleccionado para poder ser modificado o reposicionado.

Redimensionado, Reposicionado

Con el ratón:

  1. Haga clic y arrastre desde cualquier lugar dentro del marco para cambiar su ubicación. Los marcos pueden ser inclusive ubicados fuera de la página, o atravesando de una página a otra (dependiendo de la versión de Scribus que se esté utilizando).
  2. Haga clic y arrastre desde cualquiera de los pequeños rectángulos rojos ubicados en las esquinas y en los puntos medio de cada lado del marco, para redimensionarlo.

Con la ventana de Propiedades:

Hay tres maneras de cambiar los valores individuales de cada campo

  1. editar desde el teclado
  2. utilizar las flechitas arriba y abajo que aparecen a la derecha de cada valor. Las flechas arriba y abajo del teclado cumplen la misma función.
  3. usar la ruedita de ratón en cada valor -- normalmente posicionando el puntero del ratón sobre el campo es suficiente, si no, deberá hacer clic en él primero.

Note que para los ítems 2 y 3, mantener presionados Ctrl, May o Ctrl+May (también funciona con las flechas arriba y abajo del teclado) define qué posición decimal es afectada por la modificación. Además, cuando se utiliza la ventana de Propiedades, los valores de ancho y alto están vinculados por defecto (al modificar un valor, el otro también se modifica, proporcionalmente), pero, con solo un clic en el icono de cadena que está a la derecha, quedan desvinculados y se pueden modificar los valores independientemente uno del otro.

Algo de ayuda adicional

  • Ir al Menú Página > Ajustar a cuadrícula (v1.2.4: Vista > Ajustar a cuadrícula) provoca que el marco se "pegue" a las líneas de la cuadrícula de la página. Vista > Mostrar cuadrícula alterna entre hacer visible la cuadrícula (cuando aparece el tick a su izquierda) y oculatarla. (La cuadrícula no es imprimible ni forma parte de los PDF cuando se exporta). Si desea ajustar la separación de las líneas de las cuadrícula, vaya a Archivo > Preferencias... > Guías.
  • Ir al Menú Página > Ajustar a guías (v1.2.4: Vista > Ajustar a guías) provoca que el marco se "pegue" a las líneas guía de la página. Vista > Mostrar guías alterna entre hacerlas visibles y ocultarlas. (Como con la cuadrícula, las guías no son imprimibles ni se vuelven parte de los PDF creados desde Scribus). Si desea editar o agregar guías, vaya a Página > Organizar guías... o Archivo > Preferencias... > Guías.

Rotación

Con el ratón:

Clic en el icono de Rotar objeto en la barra de herramientas (tecla rápida: R), luego clic dentro del marco y arrastrar para rotar hasta el ángulo deseado.

Con la ventana de Propiedades:

Al igual que al redimensionar y reposicionar, hay tres caminos para cambiar la rotación digitalmente. Hay también un icono justo debajo (similar a un dado) para cambiar el Punto base, o sea, el punto que queda fijo cuando se realiza la rotación -- el centro o alguno de los cuatro vértices.

Copiar marcos y operaciones similares

Hay varias formas diferentes de copiar o mover marcos.

  1. Seguramente esté familiarizado con Copiar y Pegar (teclas rápidas: Ctrl+C, Ctrl+V) y con Cortar y Pegar (teclas rápidas: Ctrl+X, Ctrl+V) -- a los que también se puede acceder desde Editar en el menú, y desde el menú contextual (clic secundario sobre el marco). Para pegar en otra página, vaya hasta esa página, haga clic en ella y luego pegue -- el marco pegado tendrá las mismas coordenadas que el original en su página.
  2. También está la opción de Duplicar (teclas rápidas: Ctrl+Alt+Shift+D) Objeto > Duplicar. Con esto se logra una copia que se ubica apenas desfazado hacia abajo y hacia la derecha con respecto al original, y superpuesto a él.
  3. El Duplicado Múltiple, Objeto > Duplicado Múltiple, abre un cuadro de díalogo que permite, al Aceptar, crear tantas copias como desee (Número de copias) con un desplazamiento horizontal y vertical de cada copia con respecto a la anterior que se define en los campos Desplazamiento horizontal y Desplazamiento vertical, respectivamente. Se puede utilizar este comando para una única copia, cuando se desee definir de antemano la posición de la misma con respecto al original. Note que una vez configurado el desplazamiento en este cuadro de diálogo, queda como valor por defecto para el comando Objeto > Duplicar.
  4. También es posible arrastrar un elemento con el botón secundario del ratón. Luego de soltar el botón, aparece un menú contextual donde se puede elegir Copiar aquí, Mover aquí o Cancelar.
  5. Finalmente, está el Álbum de recortes, Objeto > Enviar al álbum de recortes (v1.3.x) o desde el menú contextual (botón secundario sobre el marco). Esto generará una copia del marco seleccionado y su contenido en el Álbum de recortes. A esa copia se le asigna un nombre en el cuadro de diálogo Nueva entrada. Para recuperar alguno de los elementos guardados en el Álbum de recortes, seleccione desde el menú Ventanas > Álbum de recortes (en v1.2.4, Herramientas > Álbum de recortes), para abrir la ventana desde la que se puede arrastrar a la página el objeto deseado. También note que se puede guardar el Álbum de recortes completo como un archivo, para luego utilizar en otro documento.

Experimentando notará que los marcos pueden estar fuera de los límites del documento y aún así podrán ser copiados, duplicados y manipulados de varias maneras. Inclusive podrán ser guardados con el documento en esas ubicaciones. Si intenta generar un PDF, recibirá un mensaje de error referido a los objetos que se encuentran fuera de la página; si ignora este mensaje el PDF se creará sin esos objetos. Además, especialmente en los documentos multipágina largos, le puede perder la pista a esos objetos que se encuentran fuera del documento.

Ingresar y editar texto en el marco

Editor interno

Con un marco de texto seleccionado, clic en el icono del Editor interno en la barra de herramientas (teclas rápidas: Ctrl+Y), o en el menú Editar > Editar texto...; esto también está diponible desde el menú contextual (clic secundario sobre el marco). El Editor interno es la manera más eficiente de ingresar texto manualmente. El texto se mostrará con el color de fuente correcto, pero la fuente tipográfica utilizada y el espaciado no se verán reflejados en la ventana del Editor interno. Si el color de la fuente es similar al color de fondo en el Editor interno, puede cambiar el color de fondo a su gusto: en el menú del Editor interno: Configuraciones > Fondo....

Las muchas características del Editor interno serán cubiertas en detalle en otro artículo (vea más abajo también Ventana Propiedades: Solapa Texto - con un orden distinto, pero son las mismas características). Para esta somera introducción, sepa que una gran cantidad de características de texto están completamente bajo su control en el Editor interno, incluyendo la fuente ha utilizar, su color, interlineado,espaciado, justificado y más. Note que cambiar una característica solo modificará el texto que tenga seleccionado ("pintado") y cualquier texto ingresado subsecuentemente..

Tómese su tiempo para aprender a utilizar los Estilos, le ahorrarán tiempo cuando tenga que utilizar repetidamente una misma fuente con un set específico de características.

Editando en la página

Clic en el icono Editar contenido del marco de la barra de herramientas (tecla rápida: E). Cuando haga clic dentro del marco de texto, aparecerá un cursor vertical parpadeante indicando la posición en la que se puede agregar o editar texto. También puede seleccionar ("pintar") texto y cambiar las características del texto seleccionado en la solapa Texto, de la Ventana de Propiedades. Como se ve, las opciones son análogas a aquellas que aparencen en el Editor interno.

Editing All the text in the frame

If not already selected, click the Select item icon on the toolbar (keyboard: C | note that if you are in Edit Contents of Frame mode, pressing C will enter text in the frame). Now select the frame whose text you wish to edit. At this point if you make changes in Properties: Text, all text in the frame will be modified.

Special Characters, Foreign Language Accented Characters

There is the potential ability to insert foreign language accented characters, special symbols not found on the keyboard, typographic symbols (such as typographic quotation marks, em dash, en dash, variably sized spaces, for example), and ligatures. This capability can be found either in the main menu or Story Editor menu under Insert > Glyph, Insert > Character, Insert > Quote, Insert > Spaces & Breaks, and Insert > Ligature.

  • If your special character fails to display, this most often means that it is not available in your chosen font. Just because it shows in Story Editor does not mean it will show on the page.
  • Also see Typography.

Loading Text from a File

Load text from a file from the Context Menu (right click in frame) > Get Text, or from the menu File > Import > Get Text. You may also Append Text (Get Text will replace whatever is already in the frame). You may also load a file into Story Editor.

There are also the special files of "lorem ipsum" text, that can most easily be accessed from the Context Menu (right-click in frame), under Sample Text (from Menu: Insert > Sample Text). Scribus has this in several language versions, in addition to Latin.

Linking One Frame to Another

Text may be continued from one frame to another, on the same page or different pages.

Here are the steps:

  • Select the first frame
  • Click the Link Text Frames icon on the toolbar (keyboard: N)
  • Click the second frame -- that's it.
  • Continue clicking to continue linking further frames. Remember that the links go in the order that you click from one to the next. When you are finished, click the Link icon or click outside of the linked frames to stop linking.
  • To add more frames later, select the linked frames, then the Link icon, then the frame(s) you want to add. Newly added frames always are appended at the end.

Note that frames can be linked before or after they have any content.

Unlink Text Frames is operationally similar -- click the first frame, then the Unlink icon, then the frames to unlink.

Levels & Layers

Frames in general, not just text frames, represent a two-dimensional space that you manipulate and move around your workspace, much like a small note you can attach and detach. Like small physical notes, they are laid down, one by one, on the page, new ones on a layer over the previous ones. The small box labeled Level in the XYZ tab of Properties allows you to move the selected frame up or down layers; the arrows with bars will move all the way to the top or bottom. Since the background of your frame may be opaque or transparent, the level the frame is at will affect how much of the frame can be visible in relationship to other overlapping or underlying frames.

XYZ Tab: The Rest

The remaining buttons in the XYZ tab do the following:

  1. Flip the selected frame horizontally or vertically
  2. Lock a frame in place. Everything about your frame is locked -- size, position, contents. Copying and pasting a locked frame may produce unexpected results.
  3. Lock the size of the frame only. Note that the editing tabs disappear from the corners and sides.
  4. Enable/disable printing of the frame. Why? You may want to have a frame on the page that's a message to yourself or someone else, yet not be part of the printed finished work. Or the frame may just be a space-saver for some other purpose.

Properties: Shape Tab

Properties: Shape Tab
Edit Shape requester
v 1.3.3.3

Click the Shape tab in Properties. Near the top is a button with a square in the center. If you click that button, you may quickly switch to one of a group of set shapes from your original rectangle. In addition, if you click Edit Shape, you now have full vector-editing control of your shape.


Another angle on shapes and text frames:

You may also use the Polygon tool on the toolbar (use will be described in detail in another section) to create a regular polygon, which may then be converted using the Context Menu (right-click in the polygon) to Convert To > Text Frame. Note that before you enter text, you may want to change the background color of the frame.

Round Corners

Causes an adjustable degree of rounding of the Text Frame corners. Also note the effect of negative values.

Distance of Text

Columns, Gap: Set the number of columns inside the frame and the gap between columns.

Top, Bottom, Left, and Right adjust the space from the edge of the frame to the text inside.

Tabulators: For setting tab stops within your frame.

Text Flows Around Frame

Use this to determine what happens with text underneath the selected frame.
Remember Levels & Layers?

When you create an image frame, the Bounding Box (of the image) and the Contour Line are the same size and position. But click on Edit Shape... and you can change this Contour Line's size, position, and shape as desired -- just check the box for Edit Contour Line.

Close-up in Shape Tab
Here is an example with an image frame, but this could just as well be a text frame:

Textflows example.jpg

Properties: Text Tab

The top two buttons are straightforward: font face and style. Remember that if you are in Select Item mode, as opposed to Edit Contents mode, changes in the font settings will change all the text in the frame. To modify only some of the text, switch to Edit Contents mode (keyboard: E), then highlight the text you wish to modify.


Properties: Text Tab

Next is a block of six requestors with number values:

  1. Left top is font size
  2. Left middle is the space between lines of text. When you are in Select Item mode, this will automatically change as you adjust font size (but can be adjusted afterward independently), in Edit Contents mode it will not. See Working with Story Editor: Font Size and Line Spacing about the different ways that font size and line spacing adjustments interact.
    You may change the degree of automatic line spacing in File > Preferences > Typography.
  3. Left bottom is the width of characters -- note that height remains constant
  4. Right top raises (positive values) or lowers selected characters from the baseline. This adjustment is not present in Story Editor.
  5. Right middle is kerning: the distance between characters
  6. Right bottom adjusts height of characters -- note that width remains constant, and that characters remain on the baseline.

As described above in Resizing, Repositioning, there are three ways to change these values.


There are two color buttons next, the top referring to the outline and/or shadow if selected (see below, items 8 and 9), and the bottom to the fill color. Aside from the hue, you may also adjust saturation - click on the number for a list of choices.


A row of buttons follows, so from left to right:

  1. Underline, including spaces between words. Adjustable line width, vertical position. No adjustments in v1.2.4
  2. Underline, characters only. Adjustable line width, vertical position. Not available in v1.2.4
  3. Subscript. You may also want or need to adjust size. For v1.2.4, adjustments are in Effects > Preferences > Typography
  4. Superscript. Size is separately adjusted. For v1.2.4, adjustments are in Effects > Preferences > Typography
  5. All caps. Applies to letters. Not available in v1.2.4
  6. All small caps. Letters only; sizes of other characters and capitalized letters not affected.
  7. Strikethrough. Line width and position adjustable. No adjustments in v1.2.4
  8. Adds an outline to the font, width adjustable. No adjustments in v1.2.4
  9. Creates a shadow, in essence a duplication of the character, just "behind" it, position adjustable. You may have both an outline and a shadow, but both will have the same color and shade. Not available in v1.2.4
  10. Reverse (horizontal mirror image) of selected letters.

The next row of buttons selects justification. The rightmost button forces every line to be fully justified, which can produce unexpected results.


The Style button allows for easy application of a set of font features. There are no default styles, these are user-created. See the Menu item Edit > Paragraph Styles... or Edit > Line Styles... to create a New style, or Save and Import styles.

For more on styles, see Working with Story Editor:Styles.

Lastly, the Language button chooses a language for automatic hyphenation.

Properties: Line Tab

The Line of a Text Frame refers to the border of the frame. The first thing to be aware of is that the default setting for Line Color is None, so regardless of the settings in the Line Tab, nothing will show until the Line Color is set.

Otherwise, the various settings for Line are straightforward. If a setting is greyed-out, it does not apply to frames.

Properties: Color Tab

As noted above, the Line Color refers to the border of the frame, with the default being None.

Fill Color means background color of the frame. None for a Fill Color means that the background is transparent. Text Color can be set in the Text Tab in Properties, or in Story Editor.

Shade refers to saturation of the color, so that 0% should represent a neutral grey scale color. Opacity refers to the relative opacity/transparency, with 100% being totally opaque, 0% totally transparent. It is worth noting at this point that some PDF versions and some PDF viewers do not support transparency.

Overprinting versions 1.3.4 and above

Knockout versus Overprinting are described here.

Please note that you are not limited to colors you see displayed in the Color Tab, nor are you compelled to have all these choices. See the Menu item Edit > Colors to add, edit, or remove colors. Removing colors can simplify the use of Scribus, and does reduce saved file size.

See also: