Difference between revisions of "Trabajar con marcos de texto"

From Scribus Wiki
Jump to: navigation, search
(Properties: Shape Tab)
(Ventana Propiedades: Shape Tab)
Line 154: Line 154:
 
# Habilitar/deshabilitar la impresión del marco. ¿Por qué? Puede que necesite tener en la página un mensaje para usted u otra persona, pero que no forme parte del trabajo impreso final. Otro uso puede ser al colocar dos marcos superpuestos con diferente contenido cada uno, para luego imprimir alternadamente cada uno.
 
# Habilitar/deshabilitar la impresión del marco. ¿Por qué? Puede que necesite tener en la página un mensaje para usted u otra persona, pero que no forme parte del trabajo impreso final. Otro uso puede ser al colocar dos marcos superpuestos con diferente contenido cada uno, para luego imprimir alternadamente cada uno.
  
==Ventana Propiedades: Shape Tab==
+
==Ventana Propiedades: Solapa Forma==
[[Image:properties_shape_v1331.jpg|left|thumb|200px|Properties: Shape Tab]]
+
[[Image:Propiedades_forma_v13312.jpg|left|thumb|200px|Ventana Propiedades: solapa Forma]]
  
[[Image:Editshape.jpg|thumb|right|Edit Shape requester<br>v 1.3.3.3]]
+
[[Image:EditarForma.jpg|thumb|right|162px|Ventana Editar Forma<br>v 1.3.3.12]]
  
Click the Shape tab in Properties. Near the top is a button with a square in the center. If you click that button, you may quickly switch to one of a group of set shapes from your original rectangle. In addition, if you click Edit Shape, you now have full vector-editing control of your shape.
+
Dibuje un rectángulo. Verá que en la parte superior de la '''solapa forma''' de la '''Ventana Propiedades''' hay un botón con un cuadrado en el centro. Si hace clic en este botón, se puede cambiar rápidamente a otra de las formas que se despliegan. Además, si hace clic en ''Editar Forma...'', se abre una ventana que permite un control vectorial total sobre la forma seleccionada.
  
  

Revision as of 14:59, 27 March 2009

Template:HOWTO ES Index

Este artículo intenta ser una compilación de las operaciones relacionadas con marcos de texto.

All Working with pages:

Working with text frames
Working with Story Editor
Working with image frames
Working with Master Pages
Working with Scribus: How to begin

Creación

Puede crear un marco de texto de las siguientes maneras:

  1. Clic en el icono Insertar marco de texto de la barra de herramientas.
  2. o seleccionar Insertar > Marco de texto desde el menú
  3. o con el teclado: T, o Alt+N, T.

Luego, podrá utilizar el ratón para situar y dimensionar el marco: mantenga el clic y arrastre diagonalmente en la página. El clic define uno de los vértices del marco y al soltar, luego de arrastrar, queda definido el vértice opuesto por el centro. Lo más convencional es empezar haciendo clic en la esquina superior izquierda, pero se puede empezar desde cualquier esquina.

Borrado

Para eliminar un marco seleccionado presione la tecla Suprimir del teclado o, alternativamente, Ctrl+X.

Creación automática de marcos de texto

También puede crear marcos de texto automáticamente (en versiones 1.3.3.x y superiores). Aquí una vista del lado derecho de la ventana Nuevo Documento:
Vista parcial de la ventana Nuevo Documento, v1.3.3.x
Seleccione el número de páginas deseadas, el número de columnas, y el espacio entre columnas (calle). Clic en Aceptar. Sus páginas serán creadas con marcos de texto ocupando el espacio permitido por los márgenes del documento. Además, los marcos quedan automáticamente vinculados, de manera que cuando importe un texto, automáticamente fluirá a través del siguiente marco/página según sea necesario.
Autotextframe.png Note también que luego de haber hecho esto, cuando se solicite Página > Insertar, las páginas agregadas seguirán automaáticamente este esquema de marcos de texto.

Menú contextual

Hacer clic con el botón secundario del ratón sobre el marco de texto hace aparecer el menú contextual, que contiene varias operaciones comunes con marcos, una de las importantes es la capacidad de convertir un marco de texto en otro tipo de marco.

Tamaño y posición

Solapa XYZ de la ventana Propiedades

En este punto encontrará que la ventana de Propiedades es un elemento indispensable para trabajar con Scribus. Si no está a la vista, ábralo desde el elemento del menú Ventana > Propiedades o presionando F2. En la versión 1.2.4 se encuentra en el menú Herramientas > Propiedades.

Por defecto, la solapa XYZ de la ventana de Propiedades muestra información muy precisa sobre las coordenadas (X,Y) del vértice superior izquierdo, del ancho y alto del marco y de la rotación del mismo. Note que la información que se muestra es sólo sobre el marco seleccionado - que se muestra con un reborde punteado de color rojo. Un marco queda automáticamente seleccionado al momento de crearlo. Deseleccione un marco haciendo clic en cualquier lugar libre del documento y se vuelve a seleccionar haciendo clic con el botón principal sobre el objeto requerido. Un marco debe estar seleccionado para poder ser modificado o reposicionado.

Redimensionado, reposicionado

Con el ratón:

  1. Haga clic y arrastre desde cualquier lugar dentro del marco para cambiar su ubicación. Los marcos pueden ser inclusive ubicados fuera de la página, o atravesando de una página a otra (dependiendo de la versión de Scribus que se esté utilizando).
  2. Haga clic y arrastre desde cualquiera de los pequeños rectángulos rojos ubicados en las esquinas y en los puntos medio de cada lado del marco, para redimensionarlo.

Con la ventana de Propiedades:

Hay tres maneras de cambiar los valores individuales de cada campo

  1. editar desde el teclado
  2. utilizar las flechitas arriba y abajo que aparecen a la derecha de cada valor. Las flechas arriba y abajo del teclado cumplen la misma función.
  3. usar la ruedita de ratón en cada valor -- normalmente posicionando el puntero del ratón sobre el campo es suficiente, si no, deberá hacer clic en él primero.

Note que para los ítems 2 y 3, mantener presionados Ctrl, May o Ctrl+May (también funciona con las flechas arriba y abajo del teclado) define qué posición decimal es afectada por la modificación. Además, cuando se utiliza la ventana de Propiedades, los valores de ancho y alto están vinculados por defecto (al modificar un valor, el otro también se modifica, proporcionalmente), pero, con solo un clic en el icono de cadena que está a la derecha, quedan desvinculados y se pueden modificar los valores independientemente uno del otro.

Algo de ayuda adicional

  • Ir al Menú Página > Ajustar a cuadrícula (v1.2.4: Vista > Ajustar a cuadrícula) provoca que el marco se "pegue" a las líneas de la cuadrícula de la página. Vista > Mostrar cuadrícula alterna entre hacer visible la cuadrícula (cuando aparece el tick a su izquierda) y oculatarla. (La cuadrícula no es imprimible ni forma parte de los PDF cuando se exporta). Si desea ajustar la separación de las líneas de las cuadrícula, vaya a Archivo > Preferencias... > Guías.
  • Ir al Menú Página > Ajustar a guías (v1.2.4: Vista > Ajustar a guías) provoca que el marco se "pegue" a las líneas guía de la página. Vista > Mostrar guías alterna entre hacerlas visibles y ocultarlas. (Como con la cuadrícula, las guías no son imprimibles ni se vuelven parte de los PDF creados desde Scribus). Si desea editar o agregar guías, vaya a Página > Organizar guías... o Archivo > Preferencias... > Guías.

Rotación

Con el ratón:

Clic en el icono de Rotar objeto en la barra de herramientas (tecla rápida: R), luego clic dentro del marco y arrastrar para rotar hasta el ángulo deseado.

Con la ventana de Propiedades:

Al igual que al redimensionar y reposicionar, hay tres caminos para cambiar la rotación digitalmente. Hay también un icono justo debajo (similar a un dado) para cambiar el Punto base, o sea, el punto que queda fijo cuando se realiza la rotación -- el centro o alguno de los cuatro vértices.

Copiar marcos y operaciones similares

Hay varias formas diferentes de copiar o mover marcos.

  1. Seguramente esté familiarizado con Copiar y Pegar (teclas rápidas: Ctrl+C, Ctrl+V) y con Cortar y Pegar (teclas rápidas: Ctrl+X, Ctrl+V) -- a los que también se puede acceder desde Editar en el menú, y desde el menú contextual (clic secundario sobre el marco). Para pegar en otra página, vaya hasta esa página, haga clic en ella y luego pegue -- el marco pegado tendrá las mismas coordenadas que el original en su página.
  2. También está la opción de Duplicar (teclas rápidas: Ctrl+Alt+Shift+D) Objeto > Duplicar. Con esto se logra una copia que se ubica apenas desfazado hacia abajo y hacia la derecha con respecto al original, y superpuesto a él.
  3. El Duplicado Múltiple, Objeto > Duplicado Múltiple, abre un cuadro de díalogo que permite, al Aceptar, crear tantas copias como desee (Número de copias) con un desplazamiento horizontal y vertical de cada copia con respecto a la anterior que se define en los campos Desplazamiento horizontal y Desplazamiento vertical, respectivamente. Se puede utilizar este comando para una única copia, cuando se desee definir de antemano la posición de la misma con respecto al original. Note que una vez configurado el desplazamiento en este cuadro de diálogo, queda como valor por defecto para el comando Objeto > Duplicar.
  4. También es posible arrastrar un elemento con el botón secundario del ratón. Luego de soltar el botón, aparece un menú contextual donde se puede elegir Copiar aquí, Mover aquí o Cancelar.
  5. Finalmente, está el Álbum de recortes, Objeto > Enviar al álbum de recortes (v1.3.x) o desde el menú contextual (botón secundario sobre el marco). Esto generará una copia del marco seleccionado y su contenido en el Álbum de recortes. A esa copia se le asigna un nombre en el cuadro de diálogo Nueva entrada. Para recuperar alguno de los elementos guardados en el Álbum de recortes, seleccione desde el menú Ventanas > Álbum de recortes (en v1.2.4, Herramientas > Álbum de recortes), para abrir la ventana desde la que se puede arrastrar a la página el objeto deseado. También note que se puede guardar el Álbum de recortes completo como un archivo, para luego utilizar en otro documento.

Experimentando notará que los marcos pueden estar fuera de los límites del documento y aún así podrán ser copiados, duplicados y manipulados de varias maneras. Inclusive podrán ser guardados con el documento en esas ubicaciones. Si intenta generar un PDF, recibirá un mensaje de error referido a los objetos que se encuentran fuera de la página; si ignora este mensaje el PDF se creará sin esos objetos. Además, especialmente en los documentos multipágina largos, le puede perder la pista a esos objetos que se encuentran fuera del documento.

Ingresar y editar texto en el marco

Editor interno

Con un marco de texto seleccionado, clic en el icono del Editor interno en la barra de herramientas (teclas rápidas: Ctrl+Y), o en el menú Editar > Editar texto...; esto también está diponible desde el menú contextual (clic secundario sobre el marco). El Editor interno es la manera más eficiente de ingresar texto manualmente. El texto se mostrará con el color de fuente correcto, pero la fuente tipográfica utilizada y el espaciado no se verán reflejados en la ventana del Editor interno. Si el color de la fuente es similar al color de fondo en el Editor interno, puede cambiar el color de fondo a su gusto: en el menú del Editor interno: Configuraciones > Fondo....

Las muchas características del Editor interno serán cubiertas en detalle en otro artículo (vea más abajo también Ventana Propiedades: Solapa Texto - con un orden distinto, pero son las mismas características). Para esta somera introducción, sepa que una gran cantidad de características de texto están completamente bajo su control en el Editor interno, incluyendo la fuente ha utilizar, su color, interlineado,espaciado, justificado y más. Note que cambiar una característica solo modificará el texto que tenga seleccionado ("pintado") y cualquier texto ingresado subsecuentemente..

Tómese su tiempo para aprender a utilizar los Estilos, le ahorrarán tiempo cuando tenga que utilizar repetidamente una misma fuente con un set específico de características.

Editando en la página

Clic en el icono Editar contenido del marco de la barra de herramientas (tecla rápida: E). Cuando haga clic dentro del marco de texto, aparecerá un cursor vertical parpadeante indicando la posición en la que se puede agregar o editar texto. También puede seleccionar ("pintar") texto y cambiar las características del texto seleccionado en la solapa Texto, de la Ventana de Propiedades. Como se ve, las opciones son análogas a aquellas que aparencen en el Editor interno.

Editando TODO el texto en un marco

Si aún no está seleccionado, haga clic en el icono Seleccionar objeto en la barra de herramientas (tecla rápida: C | note que si ya se encuentra en el modo de edición del contenido del marco, presionar C hará que ingrese esa letra en el marco de texto.). Luego, seleccione el marco cuyo texto desee editar. En este punto, si hace cambios en la solapa Texto de la ventana Propiedades, todo el texto del marco será modificado.

Caracteres especiales, caracteres acentuados

Existe la capacidad de insertar caracteres acentuados y de lenguas extranjeras, caracteres especiales que no aparezcan en el teclado, símbolos tipográficos (como, por ejemplo, las comillas tipográficas, guiones largos, guiones cortos, espacios duros de distintos tamaños, etc.), y ligaduras. Esta capacidad se puede encontrar tanto en el menú principal como en el Editor interno, yendo a Insertar > Caracter..., Insertar > Caracter, Insertar > Comillado, Insertar > Espacios y rupturas, e Insertar > Ligaduras.

  • Si el caracter especial elegido no se muestra en el marco, es muy posible que se deba a que el mismo no está disponible en la fuente tipográfica elegida. Que el caracter especial se muestre en el Editor interno no significa que se verá en la página.
  • Vea también Typography.

Cargar texto desde un archivo

Para cargar texto desde un archivo:

  • Desde el menú Archivo > Importar > Obtener texto....
  • Con las teclas rápidas: Ctrl + D.
  • A través del menú contextual (clic secundario en el marco) > Obtener texto...
  • También se puede Añadir texto... (Archivo > Importar > Añadir texto...). En este caso el texto obtenido reemplazará a cualquiera que ya estuviera en el marco de texto.
  • Además se puede cargar un archivo de texto dentro del Editor interno (Archivo > Cargar desde archivo...).

Existen también archivos especiales con el texto "lorem ipsum", a los que se puede acceder facilmente desde la opción Texto de ejemplo en el menú contextual (o desde el menú: Insertar > Texto de ejemplo). Este texto de ejemplo está disponible en muchos idiomas, además de la versión en latín.

Al usar columnas: el problema de las líneas de texto desparejas

Si coloca texto en un marco con dos o más columnas, puede pasar que las líneas de texto de las diferentes columnas no queden alineadas entre sí. Esto ocurre especialmente cuando se utilizan marcos de texto con marcos de imagen superpuestos. También puede suceder cuando se tienen dos marcos de texto independientes, colocados uno al lado del otro.

Aquí hay un video (en inglés) que muestra como solucionar este problema (versión 1.3.3.x):

Scribus Video: Drop caps, baseline, text frame columns

El problema se ve así:
use Vista > Mostrar cuadrícula de línea de base para ver esas líneas
La solución se ve así:
Baseline2.png Baseline3.png

Para solucionar este problema en la versión 1.3.3.x, vaya a Editar > Estilos de párrafo en el menú principal, o Editar > Editar estilos... en el Editor interno. Luego al botón Nuevo, si está creando un estilo nuevo, o al botón Editar si va a modificar un estilo ya existente y, dentro del apartado Distancias (arriba a la izquierda), haga clic y mantenga presionado en el icono a la izquierda del campo de interlineado, y en el menú desplegable elija Alinear a la cuadrícula de la línea de base.

Ahora puede volver al Editor interno y aplicar el estilo en el o los párrafos en los que se desee. Otra alternativa es hacer lo mismo a través de la solapa Texto de la ventana Propiedades.

Defina o ajuste el espaciado para la cuadrícula de la línea de base en Archivo > Preferencias > Guías para los próximos documentos que vaya a crear o en Archivo > Configuración del documento > Guías para el documento actual.

Vinculando un marco con otro

El texto puede fluír de un marco a otro, en la misma o en diferentes páginas.

Estos son los pasos:

  • Seleccione el primer marco de texto
  • Clic en el icono de enlazar marcos de texto en la caja de herramientas (tecla rápida: N)
  • Clic en el segundo marco -- y eso es todo.
  • Continúe haciendo clic para continuar vinculando marcos adicionales. Tenga presente que la vinculación se realiza en el orden en que hace clic de un marco a otro. Cuando finalice, haga clic en el icono de enlazar marcos de texto o fuera de los marcos de texto para terminar el enlazado de los mismos.
  • Para agregar más marcos posteriormente, seleccione los marcos enlazados, luego el icono de enlazar marcos de texto y luego el/los marco(s) que desee agregar. Los nuevos marcos agregados siempre van al final en el orden del flujo de texto.

Note que los marcos pueden ser enlazados antes o después de que tengan contenido.

Desenlazar marcos de texto funciona de manera similar -- primero se hace clic en el primer marco, luego el icono de Desenlazar y luego los marcos a desvincular.

Niveles y capas

Los marcos en general, no sólo los marcos de texto, representan un espacio bidimensional que se puede manipular y mover por todo el espacio de trabajo, como si fuera una pequeña nota adhesiva que se puede pegar y despegar. Del mismo modo que las notas verdaderas, los marcos son colocados, uno a uno en la página, los más recientes en una "capa" por encima de los anteriores. El pequeño cuadro titulado Nivel en la solapa XYZ de la ventana Propiedades premite mover el marco seleccionado hacia arriba o hacia abajo en el orden de apilamiento; las flechas con barras lo mueven hacia los extremos (arriba o abajo). Ya que el fondo del marco seleccionado puede ser opaco o transparente, el niven en el que el marco está podría afectar la visibilidad en ralación a los demás marcos superpuestos o subyacentes.

El resto de la pestaña XYZ

Los restantes botones de la pestaña XYZ hacen lo siguiente:

  1. Espejos horizontales o verticales del marco seleccionado.
  2. Bloquear el marco en el lugar. Todo lo referido al marco queda bloqueado -- tamaño, posición, contenido. Copiar y pegar un marco bloqueado puede producir resultados inesperados.
  3. Bloquear solamente el tamaño del marco. Note que desaparecen los marcadores de selección de las esquinas y de los medio lados.
  4. Habilitar/deshabilitar la impresión del marco. ¿Por qué? Puede que necesite tener en la página un mensaje para usted u otra persona, pero que no forme parte del trabajo impreso final. Otro uso puede ser al colocar dos marcos superpuestos con diferente contenido cada uno, para luego imprimir alternadamente cada uno.

Ventana Propiedades: Solapa Forma

Ventana Propiedades: solapa Forma
Ventana Editar Forma
v 1.3.3.12

Dibuje un rectángulo. Verá que en la parte superior de la solapa forma de la Ventana Propiedades hay un botón con un cuadrado en el centro. Si hace clic en este botón, se puede cambiar rápidamente a otra de las formas que se despliegan. Además, si hace clic en Editar Forma..., se abre una ventana que permite un control vectorial total sobre la forma seleccionada.


Another angle on shapes and text frames:

You may also use the Polygon tool on the toolbar (use will be described in detail in another section) to create a regular polygon, which may then be converted using the Context Menu (right-click in the polygon) to Convert To > Text Frame. Note that before you enter text, you may want to change the background color of the frame.

Round Corners

Causes an adjustable degree of rounding of the Text Frame corners. Also note the effect of negative values.

Distance of Text

Columns, Gap: Set the number of columns inside the frame and the gap between columns.

Top, Bottom, Left, and Right adjust the space from the edge of the frame to the text inside.

Tabulators: For setting tab stops within your frame.

Text Flows Around Frame

Use this to determine what happens with text underneath the selected frame.
Remember Levels & Layers?

When you create an image frame, the Bounding Box (of the image) and the Contour Line are the same size and position. But click on Edit Shape... and you can change this Contour Line's size, position, and shape as desired -- just check the box for Edit Contour Line.

Close-up in Shape Tab
Here is an example with an image frame, but this could just as well be a text frame:

Textflows example.jpg

Ventana Propiedades: solapa Texto

The top two buttons are straightforward: font face and style. Remember that if you are in Select Item mode, as opposed to Edit Contents mode, changes in the font settings will change all the text in the frame. To modify only some of the text, switch to Edit Contents mode (keyboard: E), then highlight the text you wish to modify.


Properties: Text Tab

Next is a block of six requestors with number values:

  1. Left top is font size
  2. Left middle is the space between lines of text. When you are in Select Item mode, this will automatically change as you adjust font size (but can be adjusted afterward independently), in Edit Contents mode it will not. See Working with Story Editor: Font Size and Line Spacing about the different ways that font size and line spacing adjustments interact.
    You may change the degree of automatic line spacing in File > Preferences > Typography.
  3. Left bottom is the width of characters -- note that height remains constant
  4. Right top raises (positive values) or lowers selected characters from the baseline. This adjustment is not present in Story Editor.
  5. Right middle is kerning: the distance between characters
  6. Right bottom adjusts height of characters -- note that width remains constant, and that characters remain on the baseline.

As described above in Resizing, Repositioning, there are three ways to change these values.


There are two color buttons next, the top referring to the outline and/or shadow if selected (see below, items 8 and 9), and the bottom to the fill color. Aside from the hue, you may also adjust saturation - click on the number for a list of choices.


A row of buttons follows, so from left to right:

  1. Underline, including spaces between words. Adjustable line width, vertical position. No adjustments in v1.2.4
  2. Underline, characters only. Adjustable line width, vertical position. Not available in v1.2.4
  3. Subscript. You may also want or need to adjust size. For v1.2.4, adjustments are in Effects > Preferences > Typography
  4. Superscript. Size is separately adjusted. For v1.2.4, adjustments are in Effects > Preferences > Typography
  5. All caps. Applies to letters. Not available in v1.2.4
  6. All small caps. Letters only; sizes of other characters and capitalized letters not affected.
  7. Strikethrough. Line width and position adjustable. No adjustments in v1.2.4
  8. Adds an outline to the font, width adjustable. No adjustments in v1.2.4
  9. Creates a shadow, in essence a duplication of the character, just "behind" it, position adjustable. You may have both an outline and a shadow, but both will have the same color and shade. Not available in v1.2.4
  10. Reverse (horizontal mirror image) of selected letters.

The next row of buttons selects justification. The rightmost button forces every line to be fully justified, which can produce unexpected results.


The Style button allows for easy application of a set of font features. There are no default styles, these are user-created. See the Menu item Edit > Paragraph Styles... or Edit > Line Styles... to create a New style, or Save and Import styles.

For more on styles, see Working with Story Editor:Styles.

Lastly, the Language button chooses a language for automatic hyphenation.

Properties: Line Tab

The Line of a Text Frame refers to the border of the frame. The first thing to be aware of is that the default setting for Line Color is None, so regardless of the settings in the Line Tab, nothing will show until the Line Color is set.

Otherwise, the various settings for Line are straightforward. If a setting is greyed-out, it does not apply to frames.

Properties: Color Tab

As noted above, the Line Color refers to the border of the frame, with the default being None.

Fill Color means background color of the frame. None for a Fill Color means that the background is transparent. Text Color can be set in the Text Tab in Properties, or in Story Editor.

Shade refers to saturation of the color, so that 0% should represent a neutral grey scale color. Opacity refers to the relative opacity/transparency, with 100% being totally opaque, 0% totally transparent. It is worth noting at this point that some PDF versions and some PDF viewers do not support transparency.

Overprinting versions 1.3.4 and above

Knockout versus Overprinting are described here.

Please note that you are not limited to colors you see displayed in the Color Tab, nor are you compelled to have all these choices. See the Menu item Edit > Colors to add, edit, or remove colors. Removing colors can simplify the use of Scribus, and does reduce saved file size.

See also: