Difference between revisions of "Trabalhando com o Editor de História"

From Scribus Wiki
Jump to navigation Jump to search
Line 36: Line 36:
 
|}
 
|}
 
==Abrindo o Editor de História==
 
==Abrindo o Editor de História==
With a text frame selected, click the [[Toolbars#Toolbar_Icons:_Modify_Objects| '''Story Editor''']] icon on the toolbar (keyboard: Ctrl+Y), or Menu item '''Edit > Edit Text...'''; this is also available in the Context Menu (right-click in frame).
+
Com um qadro de texto selecionado, clique com o botão direito mouse sobre o quadro e selecione a opção '''Editar Texto''' (também acessível pelo menu '''Editar > Editar Texto''' ou pelo teclado '''Ctrl+Y''').
  
 
==Settings==
 
==Settings==

Revision as of 18:19, 6 August 2006

Este artigo é parte da seção de Dicas.
Instalação Uso Questões sobre PDF Outros
Voltar para a página principal

Versão em inglês.

Other Working with pages:

Working with text frames
Working with image frames
Working with Scribus: How to begin

Story Editor is the editing window used to manually enter text into a text frame. It is currently mainly meant to display the text content, with only some minimal display features enabled.

Story Editor will show some kind of depiction of:
  • Justification (but not reflecting word wrap line breaks)
  • Font color
  • Underline
  • Superscript
  • Subscript
  • Strikethrough
Story Editor does not display the following text frame features:
  • Font face
  • Font size
  • Kerning
  • Line spacing
  • All Caps, or small caps
  • Outline
  • Shadow
  • Drop Caps

Abrindo o Editor de História

Com um qadro de texto selecionado, clique com o botão direito mouse sobre o quadro e selecione a opção Editar Texto (também acessível pelo menu Editar > Editar Texto ou pelo teclado Ctrl+Y).

Settings

This is the last item on the Story Editor's Menu, but contains basic display functions that may be important as you begin to edit.

Settings > Background... allows you to adjust the background, but only in the Story Editor display. You would use this, for example, if your text is white or very pale. Changing the background will make it more visible.

Settings > Display Font... will change the font, but again, only in the Story Editor display, simply as a matter of personal taste.

Settings > Smart text selection is a toggle. The default behavior when double-clicking on a word is to select the word and the first aftercoming space. "Smart" selection will select only the word, without the aftercoming space.

Story Editor - 1.3.X - click to full size

Getting Started

In many cases, you may simply want to immediately start entering text. The features that your text will have, font, its size, line spacing, and so on will mostly not be visible until you save your entry and exit Story Editor. Nonetheless they are indicated in the various requestors above the text entry area.

Even if this is the first time you are using Scribus, there will be default settings displayed which you may change manually as needed. Keep in mind that if you change settings, such as font for example, this will only apply to text that you subsequently enter, not that you have already entered. If you wish to change font features for text already entered, you must highlight the text (click-drag the mouse, or Shift+arrows) first, then change the feature(s) you wish to alter.

To change the default text settings, you must leave Story Editor, and go to File > Preferences > Tools, then click on the Text Frame icon. In 1.2.4, this is in Settings > Preferences > Tools.

The various settings for text properties are discussed in the Text Tab section of Working with text frames. There is a slightly different layout in Story Editor, but features are the same. Note that one adjustment missing in Story Editor is for shifting the baseline of characters.

Styles

First note that there are no default styles in Scribus, they are all user created. Styles refers to a collection of text features, font, its size, and any of the other settings you can change in Story Editor, which you can apply either before or after entering text. This is especially useful when you are making use of a list of various settings repetitively in your text -- one style for headings perhaps, then another for the body afterward.

Edit Styles requestor v1.3.3.2

You can create your styles in Story Editor under Edit > Styles, or simply by clicking on the No Style indicator to the left of the text entry area, where an option will present to Edit. In the main window, this is found under Edit > Paragraph Styles. (Edit > Line Styles does not apply to text.) A small window opens with intuitive operations indicated on its buttons. Clicking New opens a large window, and perhaps the first thing to note is that it has the default name New Style, which you will no doubt want to change to something more descriptive. You may create any number of styles, and more importantly, these can be saved to a file that you may import when you subsequently run Scribus. In addition, these styles and their names will be automatically saved with your Scribus document.

As the selection name Paragraph Styles indicates, a style is applied to an entire paragraph of text, from just after one carriage return to the next. You will see that once you apply a Style and then continue typing, the last Style is carried over to the next paragraph until you change it. Once you have created a list of styles, you can then focus on typing in text without regard to style, then fix the styles when you are finished. To do this, click on the style button next to the justification buttons, or on the No Style indicator to the left of the text window, at which time a list presents itself for your choice.

To avoid some frustration, note that when you are in the main window you may also change styles in the Text Tab of Properties, but when you are in the Select Item mode (the default when you exit Story Editor or start Scribus), changing the style will change the style for the entire frame. Click to Edit Contents of Frame mode to change only individual paragraphs (where the cursor is flashing).

How do I do Drop Caps?

You will not find Drop Caps on any of the menus. It is located on the requester for creating/editing styles. Click to make a new or edit an old style, then click to indicate drop caps, after which you can adjust the number of lines the dropped cap takes up, and the horizontal spacing between it and the text. There is some slight ability to raise or lower the baseline for drop caps, but there may be display problems.

Font Size and Line Spacing

There are some peculiarities about font size and line spacing. In Story Editor when you change font size, there will not be an automatic change in line spacing, so if the font size is increased beyond a certain point, characters on adjacent lines will overlap each other. You will then need to manually adjust. This is in contrast to the behavior in the main window when using Properties > Text when you are in Select Item mode. Here a change in font size produces an automatic increase in line spacing, and of course will change this parameter for the entire frame. The degree of automatic line spacing can be set in File > Preferences > Typography > Automatic Line Spacing. When you are in Edit Contents of Frame mode, the behavior will be the same as with Story Editor, ie, a change in font size will not automatically change line spacing, and manual adjustment may be necessary.

So, in summary, when you are trying to create a frame in which there are changes in font size and line spacing, you will likely need to manually change line spacing. To some extent you can avoid this or at least facilitate the process by using Styles.