Difference between revisions of "Trabalhando com o Editor de História"

From Scribus Wiki
Jump to navigation Jump to search
Line 78: Line 78:
 
You will not find Drop Caps on any of the menus. It is located on the requester for creating/editing styles. Click to make a new or edit an old style, then click to indicate drop caps, after which you can adjust the number of lines the dropped cap takes up, and the horizontal spacing between it and the text. There is some ''slight'' ability to raise or lower the baseline for drop caps, but there may be display problems.
 
You will not find Drop Caps on any of the menus. It is located on the requester for creating/editing styles. Click to make a new or edit an old style, then click to indicate drop caps, after which you can adjust the number of lines the dropped cap takes up, and the horizontal spacing between it and the text. There is some ''slight'' ability to raise or lower the baseline for drop caps, but there may be display problems.
  
==Font Size and Line Spacing==
+
==Tamanho de fonte e espaçamento==
  
There are some peculiarities about font size and line spacing. In '''Story Editor''' when you change font size, there will not be an automatic change in line spacing, so if the font size is increased beyond a certain point, characters on adjacent lines will overlap each other. You will then need to manually adjust. This is in contrast to the behavior in the main window when using '''Properties > Text''' <font color="red">''when you are in '''Select Item''' mode.''</font> Here a change in font size produces an automatic increase in line spacing, and of course will change this parameter for the entire frame. The degree of automatic line spacing can be set in '''File > Preferences > Typography > Automatic Line Spacing'''. When you are in '''Edit Contents of Frame''' mode, the behavior will be the same as with Story Editor, ie, a change in font size will '''not''' automatically change line spacing, and manual adjustment may be necessary.  
+
Há algumas peculiaridades sobre o tamanho da fonte e o espaçamento de linha. No '''Editor de História''', quando você altera o tamanho da fonte, não haverá alteração automática do espaçamento de linha, então, caso o tamanho da fonte exceda um certo ponto, os caracteres de uma linha poderão se sobrepor a outra. Você precisará alterar manualmente a configuração.
 +
Já na paleta de propriedades, na janela principal, o espaçamento de texto é alterado automáticamente (no modo de seleção de item). O nível de espaçamento automático de linha pode ser definido através do menu '''Arquivo > Preferências > Tipografia > Espaçamento automático de linha'''. Caso você alterne para o mode de edição de quadro, o comportamento será o mesmo que o do Editor de História.
  
So, in summary, when you are trying to create a frame in which there are changes in font size and line spacing, you will likely need to manually change line spacing. To some extent you can avoid this or at least facilitate the process by using Styles.
+
Então, resumindo, quando você estiver tentando criar um quadro de texto que necessita de alterações no tamanho da fonte e espaçamento de linha, você terá de editar as opções manualmente. Você facilitar este processo utilizando os estilos de parágrafo.

Revision as of 19:28, 6 August 2006

Este artigo é parte da seção de Dicas.
Instalação Uso Questões sobre PDF Outros
Voltar para a página principal

Versão em inglês.

Other Working with pages:

Working with text frames
Working with image frames
Working with Scribus: How to begin

Story Editor is the editing window used to manually enter text into a text frame. It is currently mainly meant to display the text content, with only some minimal display features enabled.

Story Editor will show some kind of depiction of:
  • Justification (but not reflecting word wrap line breaks)
  • Font color
  • Underline
  • Superscript
  • Subscript
  • Strikethrough
Story Editor does not display the following text frame features:
  • Font face
  • Font size
  • Kerning
  • Line spacing
  • All Caps, or small caps
  • Outline
  • Shadow
  • Drop Caps

Abrindo o Editor de História

Com um qadro de texto selecionado, clique com o botão direito mouse sobre o quadro e selecione a opção Editar Texto (também acessível pelo menu Editar > Editar Texto ou pelo teclado Ctrl+Y).

Configurações

Este é o último item no menu do Editor de História, porém contem funções básicas de exibição que podem ser importantes enquanto você edita o texto.

Configurações > Plano de Fundo... Permite que você ajuste o fundo, mas somente do Editor de História. Você poderia usar essa função para facilitar a visualização do texto caso ele seja muito claro, por exemplo. Alterar a cor de fundo faz com que a visualização seja mais fácil (fundo escuro letras claras ou o inverso).

Configurações > Exibir Fonte.... Altera a fonte que é exibida no Editor de História. Apenas para preferências próprias.

Configurações > Seleção Inteligente de Texto. É uma opção que pode-se alternar entre habilitar ou desabilitar a seleção inteligente. O comportamento padrão quando clicando sobre uma palavra duas vezes é a seleção desta palavra e seu espaço subseqüente. A seleção "inteligente" irá selecionar apenas a palavra, sem o espaço posterior.

Editor de História - 1.3.X - clique para ampliar

Iniciando

Em muitos casos, você pode simplesmente querer iniciar a adição de texto imediatamente. Os recursos que o seu texto terá como tipo de fonte, tamanho, espaçamento entre linhas etc, não serão visualizados até que você salve sua entrada e atualize o quado de texto. Ainda sim, eles estarão disponíveis através dos diversos ícones de configurações disponíveis na barra de edição do próprio editor de história.

Mesmo que esta seja a primeira vez que você esteja usando o Scribus, haverá configurações padrões que você pode alterar manualmente se preciso. Lembre-se de que se você alterar as configurações, como a fonte, por exemplo, esta configuração apenas será aplicada ao texto que for adicionado posteriormente. Se você quiser alterar as configurações de um texto já adicionado, você deve primeiro selecioná-lo (clique-segure e arraste com o botão direito do mouse sobre o texto ou use as teclas Shift+ Setas Direcionais), só depois altere as configuraçõesque você deseja.

Para alterar as configurações padrões de texto, você deve deixar o Editor de História e ir ao menu Arquivo > Preferências > Ferramentas então clicar no botão quadro de texto File:Button-Text.png (no 1.2.X, Configurações > Preferências > Ferramentas).

As diversas opções de propriedades de texto foram discutidas em outras artigos:

Há pequenas diferenças de layout no Editor de História, mas os recursos são os mesmos. Note que uma opção que o Edito de História não têm, é a opção de posicionamento da pauta (linha base) dos caracteres.

Estilos

Note que não há estilos padrão no Scribus, eles são criados apenas pelo usuário. Estilo refere-se a coleção de configurações de texto (cor, tamanho, fonte...) que você pode alterar no editor de história e são aplicados tanto antes como depois de se adicionar um texto. Isto é especialmente últil quando você está fazendo uso de uma lista de várias configurações por diversas vezes em seu texto -- talvez, um estilo para o cabeçalho, outro para o corpo.

Editor de Estilos - 1.3.X

Você pode criar os seus estilos no Editor de Histório através do menu Editar > Estilos ou simplesmente clicando no indicador Sem estilo à esquerda da área de texto (uma opção para Editar será apresentada). Esta opção fica no menu Editar > Estilos de Parágrafos na janela principal do Scribus. Os estilos de linha não se aplicam ao texto. Uma pequena janela abre-se com operações intuitivas indicadas através de botões. Clicando em Novo, uma janela maior irá aparecer e, provavelmente, a primeira coisa que você notará é que o estilo possui o nome padrão Novo Estilo que você sem dúvida vair querer alterar para algo mais descritivo. Você pode criar qualquer número de estilos, e o mais importante; eles podem ser salvos em um arquivo para uso posterior. Adicionalmente, esses estilos serão salvos no seu documento.

As the selection name Paragraph Styles indicates, a style is applied to an entire paragraph of text, from just after one carriage return to the next. You will see that once you apply a Style and then continue typing, the last Style is carried over to the next paragraph until you change it. Once you have created a list of styles, you can then focus on typing in text without regard to style, then fix the styles when you are finished. To do this, click on the style button next to the justification buttons, or on the No Style indicator to the left of the text window, at which time a list presents itself for your choice.

To avoid some frustration, note that when you are in the main window you may also change styles in the Text Tab of Properties, but when you are in the Select Item mode (the default when you exit Story Editor or start Scribus), changing the style will change the style for the entire frame. Click to Edit Contents of Frame mode to change only individual paragraphs (where the cursor is flashing).

How do I do Drop Caps?

You will not find Drop Caps on any of the menus. It is located on the requester for creating/editing styles. Click to make a new or edit an old style, then click to indicate drop caps, after which you can adjust the number of lines the dropped cap takes up, and the horizontal spacing between it and the text. There is some slight ability to raise or lower the baseline for drop caps, but there may be display problems.

Tamanho de fonte e espaçamento

Há algumas peculiaridades sobre o tamanho da fonte e o espaçamento de linha. No Editor de História, quando você altera o tamanho da fonte, não haverá alteração automática do espaçamento de linha, então, caso o tamanho da fonte exceda um certo ponto, os caracteres de uma linha poderão se sobrepor a outra. Você precisará alterar manualmente a configuração. Já na paleta de propriedades, na janela principal, o espaçamento de texto é alterado automáticamente (no modo de seleção de item). O nível de espaçamento automático de linha pode ser definido através do menu Arquivo > Preferências > Tipografia > Espaçamento automático de linha. Caso você alterne para o mode de edição de quadro, o comportamento será o mesmo que o do Editor de História.

Então, resumindo, quando você estiver tentando criar um quadro de texto que necessita de alterações no tamanho da fonte e espaçamento de linha, você terá de editar as opções manualmente. Você facilitar este processo utilizando os estilos de parágrafo.