Praca w Edytorze artykułów

From Scribus Wiki
Jump to: navigation, search

Update.png Ten artykuł wymaga aktualizacji. Sprawdź anglojęzyczną część Scribus Wiki.

Inne Języki: (ENG)

edytuj

Strona główna

Jak to zrobić

  1. Pierwsze kroki ze Scribusem
  2. Praca z ramkami tekstowymi
  3. Praca z ramkami graficznymi
  4. Praca ze stronami wzorcowymi
  5. Praca w Edytorze artykułów
  6. Tekst na krzywej
  7. Scribus w Ubuntu Linux
  8. Klik i Scribus działa
  9. Instalacja za pomocą Cmake
  10. Tworzenie spisu treści
  11. Formularze PDF
  12. Kolory dodatkowe
  13. Obrazek ze ścieżką odcięcia

Porady i triki

  1. Instalacja profili ICC
  2. Dodawanie fontów
  3. Import grafik EPS
  4. Zawieszone spójniki
  5. Twój pierwszy artykuł
  6. Tworzenie hiperłączy

Często zadawane pytania

  1. Zarządzanie kolorami
  2. Skąd pobrać Scribusa?
  3. Podgląd wydruku nie działa
  4. Scribus dla MacOSX?
  5. Dodawanie fontów
  6. Scribus po polsku
  7. Type 1 i ligatury
  8. Automatyczne numery stron
  9. Interlinia w Scribusie
  10. Pierwsze kroki z DTP
  11. Skalowanie obrazka w ramce
  12. Export do PDF/X-3
  13. Ligatury i cyfry nautyczne?
  14. Pomoc w rozwoju Scribusa
  15. Przykładowe dokumenty
  16. Zgłaszanie błędów
  17. Słowniki dzielenia na sylaby


Wstęp

Edytor artykułów jest narzędziem używanym do ręcznego wprowadzania tekstu do ramki tekstowej. Aktualnie jego głównym przeznaczeniem jest wyświetlanie zawartości tekstowej, a nie atrybutów tekstu.

Edytor artykułów wyświetla następujące atrybuty tekstu:
  • Justowanie (bez wyświetlania zawijania wierszy tekstu)
  • Kolor pisma
  • Podkreślenie
  • Indeks górny
  • Indeks dolny
  • Przekreślenie
Edytor artykułów nie wyświetla następujących atrybutów ramki tekstowej:
  • Krój pisma
  • Stopień pisma
  • Podcinanie
  • Interlinia
  • Kapitaliki
  • Obrys
  • Cieniowanie tekstu
  • Inicjały opuszczone

Otwieranie Edytora artykułów

Mając zaznaczoną ramkę tekstową, kliknij na ikonę Edytor artykułów w pasku narzędzi (skrót klawiszowy: Ctrl+Y) lub wybierz z menu pozycję Edycja > Edytuj tekst.... Narzędzie jest również dostępne w menu kontekstowym (kliknięcie prawym przyciskiem myszy, podczas gdy kursor jest nad ramką).

Ustawienia

Jest to ostatnia pozycja w menu Edytora artykułów, ale zawiera podstawowe funkcje wyświetlania, które mogą się przydać zwłaszcza wówczas, gdy zaczynasz edycję tekstu.

  • Ustawienia > Tło... pozwala Ci dostosować tło, które jest wyświetlane tylko w oknie Edytora artykułów Zapewne zechcesz skorzystać z tego w momencie, gdy np. kolor Twojego tekstu jest biały lub bardzo jasny. Zmiana tła sprawi, że będzie bardziej widoczny.
  • Ustawienia > Font edytora... pozwala przystosować wyświetlany font do własnych upodobań – ustawienie to dotyczy tylko okna Edytora artykułów.
  • Włączenie opcji Ustawienia > Inteligentne zaznaczanie tekstu spowoduje, że po podwónym kliknięciu na wyrazie zostanie on zaznaczony bez następującej po nim spacji. Domyślnym zachowaniem programu podczas podwójnego kliknięcia jest zaznaczenie wyrazu wraz z następującą po nim spacją.
Edytor artykułów - 1.3.X

Zaczynamy pracę

W wielu przypadkach po prostu zaczniesz wprowadzać tekst. Atrybuty tekstu, czyli font, jego rozmiar, interlinia, itd. będą w większości niewidoczne, dopóki nie zapiszesz swojej pracy i nie zamkniesz Edytora artykułów. Pomimo to można je zmieniać za pomocą ikon znajdujących się powyżej obszaru roboczego.

Nawet jeśli po raz pierwszy używasz Scribusa, wyświetlone będą wartości domyślne, które możesz zmieniać ręcznie wedle potrzeb. Pamietaj o tym, że przy zmianie ustawień, takich jak np. font, zostaną one zastosowane jedynie do tekstu, który później wprowadzisz, a nie do wcześniej wprowadzonego. Jeśli chcesz zmienić atrybuty już wprowadzonego tekstu, musisz najpierw go zaznaczyć (kliknij i przeciągnij kursorem myszy albo użyj klawisza Shift i strzałek kierunkowych), a dopiero po tym zmienić pożądane atrybuty. Aby zmienić domyślne ustawienia tekstu, musisz opuścić Edytor artykułów, wybrać z menu Plik > Konfiguracja > Narzędzia a następnie kliknąć ikonę ramki tekstowej.


Możliwości zmiany ustawień właściwości tekstu przedstawione sa w części artykułu Praca z ramkami tekstowymi dotyczącej zakładki Tekst. Pomimo niewielkich różnic w układzie Edytora artykułów, jego funkcje są takie same. Zauważ, że jedyna opcja modyfikująca, której nie posiada Edytor artykułów, służy do przesuwania linii pisma.

Style/Style akapitów

Po pierwsze, zwróć uwagę na to, że w Scribusie nie ma domyślnych stylów, wszystkie są tworzone przez użytkownika. Style odnoszą się do zbioru właściwości tekstu: fontu, jego rozmiaru i wszystkich ustawień, które możesz zmienić w Edytorze artykułów, a które możesz zastosować zarówno przed jak i po wprowadzeniu tekstu. Jest to szczególnie użyteczne w przypadku, gdy wielokrotnie wykorzystujesz te same ustawienia w swoim tekście – zapewne jednego stylu dla nagłówków, kolejnego dla tekstu właściwego.

Okno dialogowe Edytuj style v1.3.3.6

Możesz stworzyć swoje style w Edytorze artykułów poprzez Edycja > Style, lub prosto przez kliknięcie na wskaźniku Bez stylu na lewo od obszaru roboczego, gdzie ukaże się opcja Edytuj style... W głównym oknie programu można to znaleźć w Edycja > Style akapitów. (Edycja > Style linii... nie ma zastosowania dla tekstu). Zobaczysz okienko dialogowe zawierające przyciski odpowiadające ich przeznaczeniu. Kliknięcie na Nowy otwiera następne okno i prawdopodobnie pierwszą rzeczą, na która trzeba zwrócić uwagę, jest domyślna nazwa Nowy styl, którą niewątpliwie będziesz chciał zmienić na coś bardziej opisowego. Możesz stworzyć dowolną liczbę stylów, a co bardzo istotne, mogą być one zachowane do pliku, który możesz importować, gdy uruchamiasz program po raz kolejny, a ich nazwy będą automatycznie zachowane w dokumencie Scribusa.

Jak wskazuje na to nazwa Style akapitów, styl ten stosowany jest do całego akapitu, czyli tekstu zawartego pomiędzy dwiema karetkami. Zobaczysz, że po zastosowaniu stylu i wznowieniu pisania, ostatnio ustawiony styl stosowany będzie do następnych akapitów, dopóki go nie zmienisz. Po utworzenia listy stylów, możesz już skoncentrować się na pisaniu tekstu bez zwracania uwagi na styl, a style zmienić po zakończeniu wprowadzaniu tekstu. Kliknij na menu rozwijalnym styli obok ikon wyrównania, lub na menu rozwijalnym Bez stylu na lewo od obszaru roboczego , aby wyświetlić listę wszystkich dostępnych styli.

Zwróć uwagę, że gdy jesteś w głównym oknie programu, możesz również zmieniać style w zakładce Tekst okna Właściwości, ale kiedy włączysz tryb zaznaczania obiektów (domyślny tryb przy zamykaniu Edytora artykułów lub po uruchomieniu Scribusa), zmiana stylu dotyczyć będzie całej ramki. Kliknij na ikonę Edytuj zawartość ramki, aby móc stosować style do pojedynczych akapitów (tych zawierających migający kursor).

Jak wstawić inicjały opuszczone?

Inicjałów opuszczonych nie znajdziesz w żadnym z menu. Ta opcja dostępna jest tylko w oknie dialogowym tworzenia/edytowania stylów. Aby dodać inicjały opuszczone do styly akapitu, zakreśl pole wyboru inicjałów opuszczonych, a następnie określ ilość wierszy, jaką zajmie inicjał opuszczony oraz poziomy odstęp pomiędzy nim a tekstem. Jest jeszcze możliwość podwyższenia lub opuszczenia linii pisma dla inicjałów opuszczonych, ale mogą wystąpić problemy z ich wyświetlaniem.

Wcięcie, wcięcie pierwszego wiersza

Na dole okna z edycją stylów znajdują się kontrolki do dostosowywania wcięcia dla pierwszego wiersza każdego akapitu, możesz także zdefiniować następnych wierszy. Można to zrobić zarówno za pomocą strzałek obok pól zawierających ich wartość, jak też przez bezpośrednie wpisanie ich wartości.

Stopień pisma oraz interlinia

Istnieją pewne niedogodności dotyczące stopnia pisma oraz interlinii. Po zmianie stopnia pisma w Edytorze artykułów nie nastąpi automatyczna zmiana interlinii, więc jeśli stopień pisma przekroczy pewną wielkość, znaki w sasiadujących wierszach będą na siebie zachodzić. Będziesz musiał ręcznie zmienić interlinię. Automaczyne dopasowywanie interlinii działa natomiast w głównym oknie Scribusa, kiedy zmieniasz stopień pisma za pomocą palety Właściwości > Tekst w trybie zaznaczania obiektów. Tu zmiana w stopniu pisma powoduje automatyczny przyrost wartości interlinii i oczywiście zmieni ten parametr dla całej ramki. Wielkość automatycznej interlinii można ustawić w menu Plik > Konfiguracja > Typografia > Automatyczna interlinia. W przypadku, gdy włączony jest tryb Edytuj zawartość ramki, zachowanie programu będzie takie samo, jak podczas pracy w Edytorze artykułów, tzn. zmiana stopnia pisma nie zmieni automatycznie interlinii i ręczne dostosowanie może okazać się koniecznością.

Jeśli ustawisz styl akapitu, zobaczysz, że zmiana stopnia pisma pociągnie za sobą dopawosanie się wartości interlinii, więc używanie stylów jest innym sposobem na uproszczenie tych czynności.

Podsumowując, w momencie, gdy próbujesz stworzyć ramkę, w której będzie zmieniany stopień pisma oraz interlinia, prawdopodobnie będziesz musiał ręcznie wprowadzać zmiany wartości interlinii. W pewnym stopniu możesz tego uniknąć lub przynajmniej ułatwić ten proces przez użycie stylów akapitów.