Working with Scribus: How to begin

From Scribus Wiki
Jump to: navigation, search
This article is part of the HOWTOs series.
Installation Usage PDF issues Imposition Other

This article presumes that you have in some way successfully downloaded Scribus, installed it, and have started it up, and now stare at the screen saying, "Now what do I do?".

If you find your way to the Scribus mailing list, you will read over and again that Scribus is a "layout program." It is not designed primarily with the features of a wordprocessor, such as OpenOffice.org's Writer, or Word, or WordPerfect. Rather, imagine someone working in design, wanting to do the layout for an advertisement, someone wanting to do an attractive, informative newsletter, a newspaper, a brochure, or even a book where the design and layout are in need of precise control.
A layout like this is hard to achieve in a word processor!

In professional printing, the decisions about what is being printed and what this content is being printed on are quite separate decisions. The layout person is first of all concerned about the layout of that content, and then about the type of paper or other stock it is printed on, how many colors are desired, the type of printing equipment being utilised, and so on. Scribus is mainly about that layout part, but in the process will be able to produce something which can be taken to a professional printing business and meet their needs.

For the more casual user, Scribus is perfectly happy to work with a PC of whatever type, and print the results on a home printer, either color or black and white.

Lest we not forget, the output of Scribus need never reach the printed page. Scribus will make PDFs, which can be used for a presentation projected on a screen, or create PDF forms, and increasingly, PDFs are a desirable medium for the internet.

Philosophically Speaking...

Here are some elementary features of Scribus:

  • The starting place of Scribus is the Document. Although it may seem counterintuitive, the Document (A4, USLetter, or whatever) is only a space within which to work. It is shown in white (or the color of your choice), but in reality has no color, and cannot be assigned a color.
  • On this Document working space are placed objects, most of which are called frames. If they are text frames, they may contain text and so-called in-line objects, image frames contain only images. There are also shape, polygon, and line frames. One kind of frame can be converted to another, but once converted loses its previous features. For example, an image frame converted to a text frame loses the image it may have contained.
    A layout in Scribus with visible frames, guides, grids, and margins

If you are looking at this example cover to the right, you may think this is impossible -- I just said a Document workspace has no color. What this example shows is that a frame can be as large as the Document space, so it is a page-sized frame which has this grey color.

  • These frames can be freely moved around the page (and for advanced versions of Scribus, off the page, and slid from one page to another), resized, and the contents manipulated. Thus, the idea of Scribus is to manipulate the layout of your Document with a high level of precision – placement, resolution, color management – so that work can be done at a professional level.
  • Another powerful feature for layout work is the ability to work in layers. Thus, in our example to the right, we have the page-sized grey frame, with all the other frames set on top of it. If we need to, we can move objects up and down layers -- resulting in objects being totally visible, partially visible, or completely hidden.
  • Some things on the screen never appear in the final work. These are margin indicators, guides, and grid lines, which are simply used to help align objects on the page and with respect to each other.
  • Some other things which one might expect would always print are not required to do so. Objects may be hidden from view or visible yet not print or end up in the final product (PDF). This feature is, in fact, quite useful.

OK, So Begin

Scribus 1.4.x

You can immediately know you are working with these versions by the fact that, when you startup Scribus, you automatically get the New Document requester, which also will allow you to alternatively open a pre-existing file. You also get several additional options, including starting with more than one page.

Scribus new doc 133 en.png

The most advanced SVN version is currently 1.5.0svn, which looks a little different from this.

Scribus 1.5.0

If you wish to try out the features for the upcoming stable release, you may install the development version: Scribus 1.5.0. In some Linux distributions' repositories it is labeled with the -ng tag (new generation). You can also download and compile your own on Linux (see this page for instructions), and snapshots are available on Sourceforge for Windows and MacOSX.

Please note that the development version may include incomplete features and bugs: use it with caution. One thing you won't be able to do is load a file saved with 1.5.0 using earlier versions.

The evolution of the File Format

With each release the files have a number of parameters for your work that were not a part of earlier versions. The biggest effect on the user is that current Scribus releases can load files created with older versions, but will only save it in the newer format. Unfortunately, older versions cannot load newer files, and an error will result.

So, if you need to share Scribus files with someone else, use the same version they do.

An Issue That Will Arise When Switching Formats

As Scribus continues to be developed, there has been a change in the display of text inside text frames. For a given font, the characters may be displayed closer to the top border of the frame, and there may be differences in the required space below the character as well as some differences in line spacing. Therefore, expect some tweaking of text frames when you load old files in newer versions of Scribus (even if the developers try hard to minimize those differences; also notice that they are more likely to happen if you're using releases which are not defined as stable).

This is another reason to stay with the same Scribus version while working on an individual project, and for that matter, not updating your version while you are working on something important -- you will still be able to do your work, but will add these additional fixes.

You've Got Your Workspace, Your Scribus, What Are You Waiting For?

It's time to make some frames:

Working with text frames

and

Working with image frames

Or try our tutorial Get Started with Scribus.

Have fun!

About Columns

This is a common source of confusion, sometimes consternation, with those new to Scribus. New users frequently want to assign a "columns property" to a Document page, but as stated above, the page is just your workspace, defining the boundaries of what your project will be.

Two ways to create and work in a columns environment

  • Text frames can have columns. Once you have a text frame, you will find this can be set in the Properties Tool, in the Shape Tab, Properties > Shape, where you will set the number of columns and the gap between columns. Perhaps needless to say, setting too many columns for the size of your frame can get quite ugly. If you are tired of setting this repeatedly, you can make columns a default feature of your text frames. In versions 1.2.x, go to Settings > Preferences > Tools. In versions 1.3.x, go to File > Preferences > Tools. If you have a document open while setting preferences, the new settings will apply to future documents, not the current one. In versions 1.3.x, you can modify this feature of the current document in File > Document Setup.... (In 1.2.x, there are a very limited number of parameters in File > Document Setup....)
  • You can also use the column guides feature of the page (maybe the source of confusion for some), but these are just guides. Once you have guides (or even without them), you can make text frames arranged in columns on the page, then link from one frame to the next for text flow. This allows you to use columns of varying width, an unusual arrangement, or atypical linking pattern.

Making the Most of Scribus

Scribus is a complex piece of software, and not surprisingly we frequently get feedback on the Scribus List from those who have been struggling to manually carry out some operation for which there are built-in tools. This section will serve to try to help you be aware of these tools as you begin your projects.

Document and Workspace

Two adjustments here can serve to make using Scribus easier. The first is the units of the display. For the best precision of placement and utility of the various spin boxes, consider using small units, such as millimeters (mm) or points (pt). This can be quickly set or reset using the widget in the lower left corner of the main window, which shows the current units of display. Set the units for future Documents in File > Preferences > Document.

Secondly, be aware that the placement of your Document on the workspace background (scratch space) is adjustable. Go to File > Document Setup > Display or File > Preferences > Display to adjust where your Document sits in this Scratch Space.

Grids and Guides

Designing the layout of a Document involves creating an aesthetically pleasing distribution of elements, and this in turn requires precise placement and alignment of various objects on the page. Using Grids and Guides will help with making best use of the space you have available and help with precise placement.

The default behavior is for Grids and Guides to be hidden. Show them with View > Show Grid and View > Show Guides. You will find adjustments of the Grid in File > Document Setup > Guides, where you can also specify whether to show or hide Grid and Guides. If you want to change settings for all future Documents, go to File > Preferences > Guides. If you have activated View > Guides with the default settings you will see there are no Guides to see. You must create these with Page > Manage Guides, where you can make as many horizontal and vertical Guides as you wish.

Also be aware of Page > Snap to Grid and Page > Snap to Guides which will help by "magnetically" attaching an object to the Grid or Guides.

Layers

Many Documents because of their simplicity will gain nothing from the use of Layers, yet it is good to remember that this capability exists. In a complex layout with many different kinds of elements, use of Layers will allow you to focus on one Layer of objects without concern about disturbing those on another Layer. An entire Layer can be made invisible and what's more can be excluded from printing, a feature perhaps very useful for a collection of annotations which will not become part of the ultimate output.

Learn more about the whys and hows of Layers here and here.

Master Pages

You may be creating a Document in which there are a collection of set elements such as headings, borders, or page numbers, which will be constant from page to page. You might be setting up Master Pages for a weekly or monthly newsletter. Master Pages, once created and edited, remain as a constant background feature, on top of which editable elements are placed. A Document can have more than one kind of Master Page, but each page can only use one kind.

See Working with Master Pages and Get Started With Scribus:6.


(c) Gregory Pittman, 2006, 2007 The content of this page is licensed under the Free Documentation License.