Trabalhando com quadros de texto

From Scribus Wiki
Jump to: navigation, search
Este artigo é parte da seção de Tutoriais.
Instalação Uso Questões sobre PDF DTP Outros
Voltar para a página principal

Versão em inglês.

A intenção deste artigo é listar as operações pertencentes aos quadros de texto.

Criação

Para criar um quadro de texto:

  1. Clique no ícone de quadro de texto na barra de ferramentas.
  2. Selecione o menu Inserir > Quadro de texto.
  3. Pelo teclado: T ou Alt+N, T.

Isto habilitará o seu mouse à posicionar e redimensionar o quadro de texto. Clique e segure o esquerdo botão do mouse e então arraste-o diagonalmente na página. O clique determina um canto do quadro, você deve arrastá-lo no sentido oposto a esse ponto (na diagonal).

Para apagar:
Apague um texto selecionado pressionando a tecla Delete ou, alternativamente, Ctrl+X.

Menu de contexto

Clique com o botão direito do mouse no quadro para que o menu de contexto/propriedades apareça. Ele contém várias operações comuns de quadro, sendo uma das mais importantes a função para converter quadros de texto em outros tipos de quadros.

Tamanho e Posicionamento

Propriedades: Aba XYZ

Nesse momento você achará que a Paleta de Propriedades é uma ferramenta indispensável para trabalhar com o Scribus. Se ela não estiver sendo mostrada, mostre-a através do menu Janelas > Propriedades. A aba XYZ mostra informações precisas sobre a posição espacial do quadro no eixo X e Y, a largura e altura do quadro e sua rotação. Note que essas informações apenas estão disponíveis quando um item está selecionado.

Redimensionar e posicionar

Com o mouse:

  1. Clique e arraste em qualquer lugar do quadro para deslocá-lo. Os quadros podem ser posicionados até mesmo fora da página ou entre elas, dependendo da versão do Scribus que você estiver usando;
  2. Clique e arraste qualquer um dos pequenos retângulos vermelhos dispostos sobre a borda do quadro para redimensioná-lo.

Usando a paleta de propriedades:
Existem três modos de alterar as configurações:

  1. Editando através do teclado.
  2. Alterando os valores pelas setas ao lado de cada valor.
  3. Usando a roda do mouse em cada valor --normalmente deixar o cursor sobre o valor já é o suficiente, se não, clique primeiro sobre o valor.

Nas opções 2 e 3, segurar a tecla Ctrl, Shift ou Ctrl+Shift, dará uma precisão decimal ao deslocamento. Veja mais em Atalhos de teclado por tecla. Os valores são proporcionais por padrão. Se você deseja alterá-los em um proporção diferente da original, desmarque as "correntes".

Usando a grade e a guia como auxílio:

  • No menu Página selecione Atrair para a grade (v1.2.4: menu Visualizar > Atrair para a grade) para que os quadros fiquem "grudados" às linhas de grade na página. Exiba ou oculte a grade através do menu Visualizar > Mostrar grade (a grade não é impressa ou se torna parte de um PDF, ela serve apenas como referência).

Você pode ajustar os espaçamentos de pauta da grade pelo menu Arquivo > Preferências > Guias.

  • No menu Página selecione Atrair para a guia (v1.2.4: menu Visualizar > Atrair para a guia) para que os quadro fiquem "grudados" às linhas de guia na página. Exiba ou oculte a grade através do menu Visualizar > Mostrar guia (a guia também não é impressa ou se torna parte de um PDF).

Você pode ajustar a guia pelo menu Arquivo > Preferências > Guias ou em Página > Gerenciar guias.

Rotação

Com o mouse:
Clique no ícone de rotação na barra de ferramentas (Tecla R) e em seguida dentro do quadro. Rotacione no ângulo desejado.

Com a paleta de propriedades:
Funciona da mesma forma que a descrita no item acima. Note que há ainda a opção de escolher qual ponto de rotação será utilizado (o conjunto de botões de seleção).

Copiando quadros e operações similares

Há diversas maneiras de copiar ou mover quadros.

  1. O tradicional copiar, recortar e colar (Teclas Ctrl+C, Ctrl+R e Ctrl+V), acessíveis pelo menu Editar ou pelo menu de contexto. Para colar em um página diferente da selecionada, vá até a página que você deseja adicionar o item e então cole-o — o quadro terá as mesmas coordenadas que na página original.
  2. A opção duplicar (Teclas Ctrl+Alt+Shift+D) Editar > Duplicar. Isto cria uma cópia do objeto original na camada acima do objeto copiado.
  3. O menu Item > Duplicações Múltiplas para criar quantas copias automáticas você quiser do mesmo objeto com uma diferença seqüencial de deslocamento. Você também pode usar esse item para determinar o deslocamento de uma única cópia (assim a opção Item > Duplicar irá usar o mesmo deslocamento).
  4. E por fim, o bloco de rascunhos -- Item > Enviar para o bloco de rascunhos (v1.3.x) ou pelo menu de contexto. Isto criará uma cópia nomeada do quadro selecionado e de seu conteúdo no bloco de rascunhos. Para obter um item salvo no bloco, selecione o menu Janelas > Bloco de rascunhos (Ferramentas > Bloco de rascunhos no v1.2.4) para exibir os itens em seu bloco.

Note que você também pode salvar todo o conteúdo do bloco de rascunhos em um arquivo separado que poderá ser carregado e usado em um outro documento.

A prática o mostrará que até mesmo quadros que estão fora das páginas ainda podem ser copiados, duplicados e manipulados em diversas maneiras. Eles serão salvos na posição em que estão. Se você tentar gerar um PDF, você receberá um aviso que objetos estão fora da página, e, caso você o ignore, o PDF não terá esses objetos. Além disso, especialmente em grandes documentos com múltiplas páginas, você pode perder o controle desses objetos que não fazem parte do documento.

Edição do texto

Editor de História/Texto:
Com um quadro de texto selecionado, clique no botão do Editor de História na barra de ferramentas (Teclas Ctrl+Y). O Editor de História é o modo mais eficiente de editar o texto. Ele exibirá as cores corretamente, mas não renderizará a face da fonte (não nessa versão de desenvolvimento atual).

Há diversas opções que são acessadas diretamente no Editor de História, como cor, espaçamento, estilos em geral, tipo de fonte, alinhamento etc.

Você também pode criar estilos de texto em vez de configurar manualmente cada parágrafo. Esse recurso é muito eficaz e veloz, além de oferecer uma opção de padronização dos estilos do documento, mantendo a consistência da composição.

Editando a partir da página principal:

Clique no ícone Editar Conteúdos na barra de ferramentas (Tecla E) e clique dentro do quadro que você deseja editar (você pode clicar duas vezes dentro do quadro também). O cursor piscante aparecerá.
Você também pode selecionar e alterar as propriedades do texto/seleção através da aba Texto dentro da paleta de Propriedades.

Editando todo o texto no próprio quadro:

Se o quadro não estiver selecionado, clique no ícone de seleção de itens na barra de ferramentas (Tecla C - se você já estiver no modo de edição de texto ele interpretará isso como uma letra) e selecione o texto que você deseja editar. Se nesse momento você alterar alguma configuração através da paleta de propriedades, todo o texto no quadro será modificado.

Caracteres especiais e acentos de línguas estrangeiras

Você pode inserir acentos de línguas estrangeiras, símbolos especiais não disponíveis no seu teclado além de outros caracteres (como quebras, espaços, ligaduras, marcas de comentários etc). Essas opções estão disponíveis dentro do meu Inserir.

  • Se o você não consegue ver um caractere selecionado, provavelmente a fonte que você está usando não o suporte (só porque ele é exibido no editor de história não significa que ele será visto na página).

Carregando um texto a partir de um arquivo

Carregue um texto através do meu de contexto/propriedades (clique com o botão direito no quadro) na opção Obter Texto ou através do menu Arquivo > Importar > Obter Texto. Você também pode usar a opção Acrescentar Texto (o seu texto fica ligado ao arquivo fonte).

O problema de linhas desiguais em colunas

Se você colocar um texto num quadro com duas ou mais colunas, talvez você note que as linhas em uma coluna não se alinham com a coluna seguinte, especialmente quando um quadro de texto é sobreposto a um quadro de imagem. Este problema também pode ser observado quando dois quadros de textos distintos são posicionados lado a lado.

Clique no link abaixo para assistir a uma captura de tela demostrando como corrigir o problema (versão 1.3.3.x):

Scribus Screencast
Drop caps, baseline, text frame columns
Creating and customizing a drop cap. Also introduces baseline and text frame columns.

O problema é como este abaixo:
Use o menu Visualizar > Mostrar pauta para ver as linhas
A solução fica assim:
Baseline2.png Baseline3.png

Também é possível aplicar um estilo personalizado, neste caso, no estilo de parágrafo. Use o menu Editar > Editar estilos para abrir o editor (versões depreciadas). Selecione o estilo a ser editado (ou crie um novo usando o botão Novo) e selecione Estilo de parágrafo. Dentro da caixa Distâncias e alinhamento, você verá um botão que diz Espaçamento fixo de linha. Clique nele e selecione a opção Alinhar à pauta (ou similar). Salve o estilo e aplique-o ao quadro em questão usando o Editor de História (Editor de texto em versões passadas) ou através da paleta Propriedades, aba Texto.

Na versão 1.3.3.x, use o menu Editar > Estilos de parágrafos ou Editar > Estilos no Editor de História. Clique e segure o ícone próximo ao item de espaçamento de linha (esquerda superior à caixa Distâncias). Escolha a opção Alinhar à pauta.

Ajuste o espaçamento da pauta em Arquivo > Preferências > Guias (só afeta arquivos criados após a alteração) ou Arquivo > Configurações do Documento > Guias (para o documento atual apenas).

Ligando um quadro ao outro

O texto pode continuar de um quadro para outro na mesma ou diferentes páginas. Para isso é preciso que você conecte os quadros.
Primeiro selecione o quadro de "origem" e clique no ícone Conectar Quadros (Tecla N), agora clique no quadro a ser conectado --"destino", pronto. Se você quiser ligar mais quadros, você terá de fazer o mesmo que dito acima porém, em vez de selecionar o primeiro quadro, você deve selecionar o segundo e conectar ao terceiro, do terceiro para o quarto, do quarto para o quinto e assim vai.

Níveis e camadas

Quadros em geral, não apenas quadros de texto, são representados em um espaço bidimensional no eixo X e Y. Cada quadro é disposto como um bloco de notas — cada folha é posta uma sobre a outra — sendo que essas folhas podem ter sua posição alterada, deixando a primeira folha no fundo e a última no início, por exemplo. Esse controle é feito pela janela de Níveis (dentro do menu Janelas).

Ainda sim, para uma melhor organização dos items, você pode criar um conjunto de camadas para que cada conjunto de objetos seja disposto em diferentes níveis de camada (níveis entre camadas) e objetos (níveis de diferentes objetos na mesma camada).

XYZ: Outras funções

Alguns botões e suas funções:

  1. Espelha o quadro selecionado na horizontal ou na vertical.
  2. Trava o quadro (tamanho, posicionamento, conteúdo etc.
  3. Trava o tamanho do quadro (note que os retângulos vermelhos desaparecem).
  4. Habilita ou desabilita a impressão. Por que? Bem, você pode querer ter um quadro em uma página que é um lembrete ou uma anotação qualquer que você não queira imprimir, com anotações de cores, tamanhos, contatos etc.

Propriedades: Aba forma

Propriedades: Aba forma

No topo da janela há um botão com um quadrado no centro. Se você clicar nesse botão, uma janela de seleção com múltiplas formas aparecerá, dando outras opções de forma. Você ainda tem a opção de Editar forma através de uma ferramenta de edição vetorial, dando controle total de sua forma.

Uma outra visão sobre formas e quadro de textos:

Você também pode usar a ferramenta Polígono na barra de ferramentas para criar um polígono regular que posteriormente pode ser convertido usando o menu de contexto (Converter em > Quadro de texto).

Cantos arredondados:

Essa opção tornará os cantos do quadro arredondados, inclusive com valores negativos.

Espaçamento de texto:

Colunas, lacunas - Define o número de colunas dentro do quadro e o espaço entre elas.

Topo, Fundo, Esquerdo, e Direita - ajusta o espaço entre a borda do quadro e o texto.

Tabulação - Para inserir paradas em seu quadro.

O texto flui ao redor do quadro:

Use isto para determinar o comportamento do texto "abaixo" do quadro selecionado.

Propriedades: Aba texto

As duas caixas no topo são a de seleção de fonte e estilo, respectivamente. Lembre-se que se você estiver no modo de seleção de item (e não no modo edição de item), as alterações nas configurações da fonte serão aplicadas em todo o texto do quadro. Para modificar apenas um trecho do texto, alterne para o modo de edição de conteúdo (Tecla E) e então selecione o período de texto que você deseja modificar.


Propriedades: Aba texto

As seis caixas com opções de valores são:

  1. Tamanho da fonte (tT).
  2. Espaçamento entre linhas.
  3. Largura de caracteres (<T>).
  4. Posicionamento do texto na pauta (^T).
  5. Entre-letras (A|V).
  6. Altura de caracteres (IT).

A baixo existem dois botões de seleção de cores em seqüência:

  1. Cor da linha.
  2. Cor de preenchimento.

E uma série de botões de estilo:

  1. Sublinhado (incluindo os espaços).
  2. Sublinhado (apenas caracteres).
  3. Subescrito (Efeitos > Preferências > Tipografia no v1.2.4).
  4. Sobrescrito (Efeitos > Preferências > Tipografia no v1.2.4).
  5. Todas caixa alta (não disponível no v1.2.4).
  6. Todas caixa alta "pequenas" (os tamanhos das letras maiúsculas não são alterados).
  7. Tachado (posição da linha e comprimento ajustáveis no v1.3.x).
  8. Sombra (não disponível no v.1.2.4).
  9. Revertido (espelhado horizontal).

Logo abaixo você pode ver a série de ícones que determinam o alinhamento do texto (direita, centralizado, esquerda, justificado e forçado).


O botão de estilo permite aplicar estilos pré-definidos pelo o usuário (criados préviamente). Esses estilos podem ser criados através do menu Editar > Estilos de Parágrafos ou Editar > Estilos de linhas.

O último botão indica qual idioma deve ser usado para a hifenização automática.

Propriedades: Aba linha

A linha de um quadro de texto se refere a borda do quadro. A primeira coisa que você deve notar é que o valor padrão da cor de linha é nenhum. Você precisa determinar uma cor para poder configurar a linha ou então as alterações não serão aplicadas.

Propriedades: Aba cores

Como dito acima, a cor da linha se refere a cor da borda do quadro, sendo que seu valor padrão é nenhum.

A cor de preenchimento nada mais é que a cor de fundo do quadro. O valor nenhum indica que o fundo do quadro é transparente. A cor do texto pode se definida na aba texto ou através do editor de texto.

  • Intensidade é a saturação da cor, então 0% representaria uma escala cinza neutro.
  • Opacidade é relativo a quantidade do pigmento, sendo que 100% seria totalmente opaco e 0% completamente transparente.

Vale notar que algumas versões de PDF não suportam a transparência de cores, então fique atento.


Overprinting - versões 1.3.4 e posteriores.

Os métodos Knockout X Overprinting estão descritos aqui (em inglês).

Note que você não está limitado apenas a paleta de cores padrão do Scribus. Você pode criar, editar e remover essas cores através do menu Editar > Cores. Remover cores pode simplificar o uso do Scribus além de diminuir o tamanho total dos documentos.

Relacionados