Difference between revisions of "Arbeiten mit dem Story Editor"

From Scribus Wiki
Jump to: navigation, search
m
m (Stile/Absatzstile)
 
(5 intermediate revisions by 2 users not shown)
Line 2: Line 2:
 
[[Category:DE]]
 
[[Category:DE]]
  
Der '''Story Editor''' ist das Werkzeug um Text in einen Textrahmen einzufügen.
+
Der '''Story Editor''' ist das Werkzeug, um Text in einen Textrahmen einzufügen.
In der jetzigen Form ist er hauptsächlich dazu da den Textinhalt anzuzeigen, mit nur einigen wenigen
+
In der jetzigen Form ist er hauptsächlich dazu da, den Textinhalt anzuzeigen, mit nur einigen wenigen
Möglichkeiten auch die Textformatierungen darzustellen.
+
Möglichkeiten, auch die Textformatierungen darzustellen.
  
 
{| cellpadding="15px" |
 
{| cellpadding="15px" |
 
| valign="top" |Der '''Story Editor''' kann folgende Textformatierungen anzeigen:
 
| valign="top" |Der '''Story Editor''' kann folgende Textformatierungen anzeigen:
  
* Ausrichtung -Linksbündig, Zentriert, Rechtsbündig- (er zeigt aber keinen Zeilenumbruch an)  
+
* Ausrichtung – Linksbündig, Zentriert, Rechtsbündig – (er zeigt aber keinen Zeilenumbruch an)  
 
* Schriftfarbe
 
* Schriftfarbe
 
* Unterstrichener Text
 
* Unterstrichener Text
Line 24: Line 24:
 
* Zeilenabstand
 
* Zeilenabstand
 
* Kapitälchen
 
* Kapitälchen
* Umriss
+
* Umriß
 
* Schlagschatten
 
* Schlagschatten
 
* Initialen
 
* Initialen
Line 31: Line 31:
 
==Den Story Editor öffnen==
 
==Den Story Editor öffnen==
  
Markiere einen Textrahmen und klicke auf das '''Story Editor'''-Symbol in der Werkzeug-Menüleiste (Tastatur: '''Strg+Y'''), oder wähle den Menüpunkt '''Bearbeiten > Text bearbeiten...'''; auch über das Kontextmenü (Rechtsklick in den Textrahmen kannst Du den '''Story Editor''' aufrufen.
+
Markiere einen Textrahmen und klicke auf das '''Story Editor'''-Symbol in der Werkzeug-Menüleiste (Tastatur: '''Strg+Y'''), oder wähle den Menüpunkt '''Bearbeiten > Text bearbeiten...'''; du kannst den '''Story Editor''' auch über das Kontextmenü (Rechtsklick in den Textrahmen > Text bearbeiten) aufrufen.
  
 
==Einstellungen==
 
==Einstellungen==
  
Dies ist zwar der letzte Eintrag in der Menüleiste des Story Editors, aber er enthält grundlegende Anzeigefunktionen die Du evtl. ändern willst bevor Du Text eingibst.
+
Dies ist zwar der letzte Eintrag in der Menüleiste des Story Editors, aber er enthält grundlegende Anzeigefunktionen, die du evtl. ändern willst, bevor du Text eingibst.
  
'''Einstellungen > Hintergrund...''' ermöglicht Dir die Hintergrundfarbe ''nur für die Anzeige im Story Editor'' einzustellen. Nützlich ist das z.B. wenn Deine Textfarbe weiß oder sehr hell ist - eine geänderte Hintergrundfarbe macht Deinen Text besser sichtbar.
+
'''Einstellungen > Hintergrund...''' ermöglicht dir, die Hintergrundfarbe ''nur für die Anzeige im Story Editor'' einzustellen. Nützlich ist das z.B. wenn deine Textfarbe weiß oder sehr hell ist – eine geänderte Hintergrundfarbe macht deinen Text besser sichtbar.
  
'''Einstellungen > Schriftart...''' ändert die Schriftart, ''aber wieder nur für die Anzeige im Story Editor''. Welche Schriftart Du bevorzugst ist eine Frage des persönlichen Geschmacks.
+
'''Einstellungen > Schriftart...''' ändert die Schriftart, ''aber wieder nur für die Anzeige im Story Editor''. Welche Schriftart du bevorzugst, ist eine Frage des persönlichen Geschmacks.
  
'''Einstellungen > Intelligente Textmarkierung'''  ist ein An/Aus-Schalter. Standardmäßig wird beim Doppelklicken auf ein Wort das gesamte Wort und das erste Leerzeichen dahinter markiert. "Smart" markiert nur das Wort, ohne Leerzeichen dahinter.
+
'''Einstellungen > Intelligente Textmarkierung'''  ist ein An-/Aus-Schalter. Standardmäßig wird beim Doppelklicken auf ein Wort das gesamte Wort und das erste Leerzeichen dahinter markiert. "Smart" markiert nur das Wort, ohne Leerzeichen dahinter.
  
  
Line 48: Line 48:
 
==Loslegen==
 
==Loslegen==
  
Meistens wirst Du einfach sofort loslegen und Text eingeben wollen. Die Eigenschaften die Dein Text haben wird, Schriftart, Schriftgröße, Zeilenabstand usw. werden größtenteils nicht sichtbar bevor Du Deinen Text speicherst und den Story Editor verläßt. Trotzdem kannst Du diese Eigenschaften in den diversen Schaltflächen und Wertefeldern oberhalb des Texteingabebereiches einstellen.
+
Meistens wirst du einfach sofort loslegen und Text eingeben wollen. Die Eigenschaften, die dein Text haben wird, Schriftart, Schriftgröße, Zeilenabstand usw., werden größtenteils nicht sichtbar, bevor du deinen Text speicherst und den Story Editor verläßt. Trotzdem kannst du diese Eigenschaften in den diversen Schaltflächen und Wertefeldern oberhalb des Texteingabebereiches einstellen.
  
Selbst wenn Du Scribus zum ersten Mal benutzt, wirst Du einige der Standardeinstellungen ändern wollen. Denke daran, daß wenn Du Einstellungen änderst, z.B. die Schriftart, dies nur auf nachfolgend eingegebenen Text wirkt, nicht aber auf schon eingegebenen Text. Wenn Du die Schriftart für schon eingegebenen Text ändern willst, mußt Du erst den Text markieren (mit gedrückter Maustaste über den Text ziehen oder '''Umschalt+Pfeiltasten)''', und dann die gewünschte Einstellung(en) ändern.
+
Selbst wenn du Scribus zum ersten Mal benutzt, wirst du einige der Standardeinstellungen ändern wollen. Denke daran, daß wenn du Einstellungen änderst, z.B. die Schriftart, dies nur auf nachfolgend eingegebenen Text wirkt, nicht aber auf schon eingegebenen Text. Wenn du die Schriftart für schon eingegebenen Text ändern willst, mußt du erst den Text markieren (mit gedrückter Maustaste über den Text ziehen oder '''Umschalt+Pfeiltasten)''', und dann die gewünschte(n) Einstellung(en) ändern.
  
Um die Standardeinstellungen zu ändern gehe über das Menü zu '''Datei > Allgemeine Einstellungen > Werkzeuge''', dort klicke auf das Textrahmensymbol und setze die gewünschten Einstellungen. In Version 1.2.4 ist die Menüfolge '''Einstellungen > Voreinstellungen > Werkzeuge'''.
+
Um die Standardeinstellungen zu ändern, gehe über das Menü zu '''Datei > Allgemeine Einstellungen > Werkzeuge'''. Klicke dort auf das Textrahmensymbol und setze die gewünschten Einstellungen. In Version 1.2.x ist die Menüfolge '''Einstellungen > Voreinstellungen > Werkzeuge'''.
  
Die verschiedenen Einstellungen für die Texteigenschaften sind im Abschnitt [[Arbeiten mit Textrahmen#Properties:_Text_Tab|Text Tab]] im [[Arbeiten mit Textrahmen|HowTo Arbeiten mit Textrahmen]] erläutert. Im Story Editor ist die Anordnung anders, aber die Funktionen sind die gleichen. Beachte das die Einstellungsmöglichkeit für die Art des Zeilenabstandes (Fest, Automatisch, Am Grundlinienraster ausrichten) im Story Editor fehlt.
+
Die verschiedenen Einstellungen für die Texteigenschaften sind im Abschnitt [[Arbeiten mit Textrahmen#Properties:_Text_Tab|Text Tab]] im [[Arbeiten mit Textrahmen|HowTo Arbeiten mit Textrahmen]] erläutert. Im Story Editor ist die Anordnung anders, aber die Funktionen sind die gleichen. Beachte, daß die Einstellungsmöglichkeit für die Art des Zeilenabstandes (Fest, Automatisch, Am Grundlinienraster ausrichten) im Story Editor gegenwärtig noch fehlt.
  
  
 
==Stile/Absatzstile==
 
==Stile/Absatzstile==
  
In Scribus gibt es keine vordefinierten bzw. standardmäßigen Stile - alle Stile werden vom Benutzer angelegt. Stil bedeutet eine "Sammlung" von Texteigenschaften wie Schriftart, Schriftgröße, sowie alle Einstellungen die Du im Story Editor ändern kannst, und die Du anwenden kannst bevor oder nachdem Du Text eingegeben hast. Dies ist besonders nützlich wenn Du Stile für wiederkehrende Elemente machst - ein Stil für Überschriften, einer für den nachfolgenden Text etc.
+
In Scribus gibt es noch keine vordefinierten bzw. standardmäßig vorhandenen Stile – alle Stile werden vom Benutzer angelegt. Stil bedeutet eine "Sammlung" von Texteigenschaften wie Schriftart, Schriftgröße usw., sowie alle Einstellungen, die du im Story Editor ändern kannst und die du anwenden kannst, bevor oder nachdem du Text eingegeben hast. Dies ist besonders nützlich, wenn du Stile für wiederkehrende Elemente erstellst – ein Stil für Überschriften, einer für den nachfolgenden Text etc.
 
   
 
   
 
[[Image:SE-StilvorlagenBearbeiten.png|thumb|320px|Stilvorlagen bearbeiten v1.3.3.7]]
 
[[Image:SE-StilvorlagenBearbeiten.png|thumb|320px|Stilvorlagen bearbeiten v1.3.3.7]]
  
Eigene Stile erstellst Du ganz einfach im Story Editor-Menü unter '''Bearbeiten > Stilvorlagen bearbeiten...''', oder Du klickst auf den Eintrag '''kein Stil''' im linken, vom Texteingabebereich abgetrennten Teil des Story Editors. Ein kleines Fenster klappt auf und bietet oben eine Auswahl (nur falls schon Stile definiert wurden), und unten die Option '''Stile bearbeiten...'''. Im Hauptfenster findest Du dies unter dem Menüpunkt '''Bearbeiten > Absatzstile...'''. (''Bearbeiten > Linienstile... , dies hat keinen Einfluß auf den Text - damit kann für den Rand des Textrahmen ein neuer Linienstil kreiert werden''). Nun öffnet sich ein kleines Fenster '''Stilvorlagen bearbeiten''' mit selbsterklärenden Schaltflächen. Ein Klick auf '''Neu''' öffnet ein größeres Fenster - das erste was Du bemerkst: der neue Stil hat den Namen '''Neue Stilvorlage''' - sicher willst Du das sofort in einen aussagekräftigeren Namen ändern. Du kannst soviele Stilvorlagen anlegen wie Du willst, und wichtiger noch: diese Stile werden automatisch mit dem Scribus-Dokument gespeichert - Du kannst sie also bei späteren Arbeitssitzungen wieder aufrufen und auch in ein anderes Dokument importieren.
+
Eigene Stile erstellst du ganz einfach im Story Editor-Menü unter '''Bearbeiten > Stilvorlagen bearbeiten...''', oder du klickst auf den Eintrag '''kein Stil''' im linken, vom Texteingabebereich abgetrennten Teil des Story Editors. Ein kleines Fenster klappt auf und bietet oben eine Auswahl (nur falls schon Stile definiert wurden) und unten die Option '''Stile bearbeiten...'''. Im Hauptfenster findest du dies unter dem Menüpunkt '''Bearbeiten > Absatzstile...'''. (''Bearbeiten > Linienstile... , dies hat keinen Einfluß auf den Text – damit kann für den Rand des Textrahmen ein neuer Linienstil kreiert werden''). Nun öffnet sich ein kleines Fenster '''Stilvorlagen bearbeiten''' mit selbsterklärenden Schaltflächen. Ein Klick auf '''Neu''' öffnet ein größeres Fenster – das erste was du bemerkst: der neue Stil hat den Namen '''Neue Stilvorlage''' – sicher willst du das sofort in einen aussagekräftigeren Namen ändern. Du kannst so viele Stilvorlagen anlegen, wie du willst, und wichtiger noch: diese Stile werden automatisch mit dem Scribus-Dokument gespeichert – du kannst sie also bei späteren Arbeitssitzungen wieder aufrufen und auch in ein anderes Dokument importieren.
  
Wie die Bezeichnung '''Absatzstile''' schon sagt, wirken die Stile immer auf einen ganzen Absatz. Einen neuen Absatz erhälst Du mit der Enter-Taste, dabei wird der Absatzstil des vorangegangenen Absatzes beibehalten - solange bis Du das änderst. Wenn Du schon eine ganze Liste an Absatzstilen definiert hast, kannst Du Deinen Text einfach eingeben ohne auf die Formatierung zu achten und anschließend den einzelnen Absätzen den gewünschten Stil zuweisen. Dazu klickst Du im Story Editor auf das Auswahlfeld rechts neben den Textausrichtungsschaltflächen, oder den Eintrag '''kein Stil''' im linken, vom Texteingabebereich abgetrennten Teil des Story Editors und wählst aus der Liste den gewünschten Stil aus.
+
Wie die Bezeichnung '''Absatzstile''' schon sagt, werden die Stile immer auf einen ganzen Absatz angewendet. Einen neuen Absatz erhältst du mit der Enter-Taste; dabei wird der Absatzstil des vorangegangenen Absatzes beibehalten, und zwar so lange, bis du das änderst. Wenn du schon eine Reihe Absatzstile definiert hast, kannst du deinen Text einfach eingeben, ohne auf die Formatierung zu achten und anschließend einzelnen Absätzen den gewünschten Stil zuweisen. Dazu klickst du im Story Editor auf das Auswahlfeld rechts neben den Textausrichtungsschaltflächen oder den Eintrag '''kein Stil''' im linken, vom Texteingabebereich abgetrennten Teil des Story Editors und wählst aus der Liste den gewünschten Stil aus.
  
 
{|
 
{|
| bgcolor="pink" |Um Frustrationen zu vermeiden: auch im Hauptfenster kannst Du über den Text-Abschnitt der Eigenschaftenpalette den Stil ändern, beachte aber wenn Du dich im Objekt-Auswahlmodus befindest (bist Du automatisch wenn Du den Story Editor verläßt oder Scribus gestartet hast), führt die Änderung des Stiles nicht nur zur Änderung eines Absatzes, sondern ändert den Stil im '''gesamten Rahmen'''. Klicke auf das Symbol '''Rahmeninhalt bearbeiten''' (Tastatur: '''E''') in der Werkzeug-Menüleiste um für einzelne Absätze den Stil zu ändern. (Mit der Maus in den betreffenden Absatz klicken)
+
| bgcolor="pink" |Um Frustrationen zu vermeiden: Auch im Hauptfenster kannst du über den Textreiter der Eigenschaftenpalette den Stil ändern. Beachte aber folgendes: Wenn du dich im Objekt-Auswahlmodus befindest (das bist du automatisch, wenn du den Story Editor verläßt oder Scribus gestartet hast), führt die Änderung des Stiles nicht nur zur Änderung eines Absatzes, sondern ändert den Stil im '''gesamten Rahmen'''. Klicke auf das Symbol '''Rahmeninhalt bearbeiten''' (Tastatur: '''E''') in der Werkzeug-Menüleiste, um für einzelne Absätze den Stil zu ändern. (Mit der Maus in den betreffenden Absatz klicken)
 
|}
 
|}
  
==Wie mache ich Initialen?==
+
==Wie erstelle ich Initialen?==
  
Du wirst Initialen in keinem der Menüs finden - nur im Stilvolagen-Bearbeitungsfenster sind sie vorhanden. Unterhalb der Abstandseinstellungen kannst Du die Option '''Initialen''' anhaken, damit aktivierst Du auch die beiden Einstellmöglichkeiten darunter: die Anzahl der Zeilen (Höhe des Initials), und der horizontale Abstand zwischen Initial und dem Text. Es gibt noch die Möglichkeit für die Initialen den Abstand des Grundlinienrasters zu erhöhen oder herunterzusetzen, aber das kann zu Anzeigeproblemen in diesem Fenster führen.
+
Du wirst Initialen in keinem der Menüs finden – nur im Stilvorlagen-Bearbeitungsfenster sind sie vorhanden. Unterhalb der Abstandseinstellungen kannst du die Option '''Initialen''' markieren; damit aktivierst du auch die beiden Einstellmöglichkeiten darunter: die Anzahl der Zeilen (Höhe des Initials) und der horizontale Abstand zwischen dem Initial und dem Text. Es gibt außerdem noch die Möglichkeit, für die Initialen den Abstand des Grundlinienrasters zu erhöhen oder herunterzusetzen, aber das kann zu Anzeigeproblemen in diesem Fenster führen.
  
 
==Einzug, hängender Einzug==
 
==Einzug, hängender Einzug==
  
Unterhalb der Einstellungen für Zeichen, Abstände und Initialen befindet sich ein Schieberegler um den Einzug für die erste Zeile eines Absatzes festzulegen. Einen Einzug für die nachfolgenden Zeilen eines Absatzes (hängender Einzug) kannst Du hier auch einstellen (Beachte die Tooltips). Verschiebe entweder die blauen Dreiecke oder ändere die Werte in den Wertefeldern unter dem Schieberegler.
+
Unterhalb der Einstellungen für Zeichen, Abstände und Initialen befindet sich ein Schieberegler um den Einzug für die erste Zeile eines Absatzes festzulegen. Einen Einzug für die nachfolgenden Zeilen eines Absatzes (hängender Einzug) kannst du hier auch einstellen (Beachte die Tooltips). Verschiebe entweder die blauen Dreiecke oder ändere die Werte in den Wertefeldern unter dem Schieberegler.
 
 
  
 
==Schriftgröße und Zeilenabstand==
 
==Schriftgröße und Zeilenabstand==
  
 
Es gibt ein paar Besonderheiten bei der Schriftgröße und dem Zeilenabstand:
 
Es gibt ein paar Besonderheiten bei der Schriftgröße und dem Zeilenabstand:
Wenn Du im Story Editor die Schriftgröße änderst wird nicht automatisch der Zeilenabstand angepaßt - wenn die Schriftgröße über einen gewissen Punkt hinaus vergrößert wird, dann überlappen sich die Buchstaben der untereinanderstehenden Zeilen gegenseitig. Du mußt den Zeilenabstand dann manuell einstellen. Im Gegensatz dazu steht das Verhalten im Hauptfenster wenn Du über den Text-Abschnitt der Eigenschaftenpalette die Schriftgröße änderst <font color="red">(''wenn Du im '''Objekt-Auswahlmodus''' bist'')</font>. Hier wird beim Ändern der Schriftgröße der Zeilenabstand automatisch auch geändert - und dies wirkt natürlich wieder auf den gesamten Rahmen. Das Maß des automatischen Zeilenabstandes kann in den Allgemeinen Einstellungen ('''Datei > Allgemeine Einstellungen > Typographie > Automatischer Zeilenabstand''' eingestellt werden. Befindest Du Dich im Modus '''Rahmeninhalt bearbeiten''' funktioniert dies wie im Story Editor, d.h. eine Veränderung der Schriftgröße bewirkt nicht automatisch eine Veränderung des Zeilenabstandes - hier ist wieder manuelles Ändern abgesagt.
+
Wenn du im Story Editor die Schriftgröße änderst, wird nicht automatisch der Zeilenabstand angepaßt: Wenn die Schriftgröße über einen gewissen Punkt hinaus vergrößert wird, dann überlappen sich die Buchstaben der untereinanderstehenden Zeilen gegenseitig. Du mußt den Zeilenabstand dann manuell einstellen. Im Gegensatz dazu steht das Verhalten im Hauptfenster, wenn du über den Text-Abschnitt der Eigenschaftenpalette die Schriftgröße änderst <font color="red">(''wenn du im '''Objekt-Auswahlmodus''' bist'')</font>. Hier wird beim Ändern der Schriftgröße auch automatisch der Zeilenabstand geändert, und dies wirkt sich natürlich wieder auf den gesamten Rahmen aus. Das Maß des automatischen Zeilenabstandes kann in den Allgemeinen Einstellungen ('''Datei > Allgemeine Einstellungen > Typographie > Automatischer Zeilenabstand''' eingestellt werden. Befindest du dich im Modus '''Rahmeninhalt bearbeiten''', funktioniert dies wie im Story Editor, d.h. eine Veränderung der Schriftgröße bewirkt nicht automatisch eine Veränderung des Zeilenabstandes &ndash; hier ist wieder manuelles Ändern angesagt.
  
Wenn Du einen Absatzstil anlegst, siehst Du daß eine Änderung der Schriftgröße auch den Zeilenabstand ändert, Stile sind also eine Möglichkeit dies zu vereinfachen.
+
Wenn du einen Absatzstil anlegst, siehst du, daß eine Änderung der Schriftgröße auch den Zeilenabstand ändert. Stile sind also eine Möglichkeit, dies zu vereinfachen.
  
Zusammenfassend: wenn Du in einem Textrahmen Schriftgröße und Zeilenabstand veränderst, wirst Du wahrscheinlich den Zeilenabstand manuell einstellen müssen. Bis zu einem gewissen Grad kannst Du das vermeiden oder Dir zumindest erleichtern indem Du Absatzstile verwendest.
+
Zusammenfassung: Wenn du in einem Textrahmen Schriftgröße und Zeilenabstand veränderst, wirst du wahrscheinlich den Zeilenabstand manuell einstellen müssen. Bis zu einem gewissen Grad kannst du das vermeiden oder zumindest erleichtern, indem du Absatzstile verwendest.

Latest revision as of 23:49, 19 July 2007

Dieser Artikel gehört zur Kategorie Deutsche HOWTOs.
Installation Anwendungsfragen PDF-Export DTP Sonstiges

Der Story Editor ist das Werkzeug, um Text in einen Textrahmen einzufügen. In der jetzigen Form ist er hauptsächlich dazu da, den Textinhalt anzuzeigen, mit nur einigen wenigen Möglichkeiten, auch die Textformatierungen darzustellen.

Der Story Editor kann folgende Textformatierungen anzeigen:
  • Ausrichtung – Linksbündig, Zentriert, Rechtsbündig – (er zeigt aber keinen Zeilenumbruch an)
  • Schriftfarbe
  • Unterstrichener Text
  • Hochgestellter Text
  • Tiefgestellter Text
  • Durchgestrichener Text
Der Story Editor zeigt folgende Textformatierungen nicht an:
  • Schriftart
  • Schriftgröße
  • Zeichenbreite und Zeichenhöhe
  • Zeichenabstand
  • Zeilenabstand
  • Kapitälchen
  • Umriß
  • Schlagschatten
  • Initialen

Den Story Editor öffnen

Markiere einen Textrahmen und klicke auf das Story Editor-Symbol in der Werkzeug-Menüleiste (Tastatur: Strg+Y), oder wähle den Menüpunkt Bearbeiten > Text bearbeiten...; du kannst den Story Editor auch über das Kontextmenü (Rechtsklick in den Textrahmen > Text bearbeiten) aufrufen.

Einstellungen

Dies ist zwar der letzte Eintrag in der Menüleiste des Story Editors, aber er enthält grundlegende Anzeigefunktionen, die du evtl. ändern willst, bevor du Text eingibst.

Einstellungen > Hintergrund... ermöglicht dir, die Hintergrundfarbe nur für die Anzeige im Story Editor einzustellen. Nützlich ist das z.B. wenn deine Textfarbe weiß oder sehr hell ist – eine geänderte Hintergrundfarbe macht deinen Text besser sichtbar.

Einstellungen > Schriftart... ändert die Schriftart, aber wieder nur für die Anzeige im Story Editor. Welche Schriftart du bevorzugst, ist eine Frage des persönlichen Geschmacks.

Einstellungen > Intelligente Textmarkierung ist ein An-/Aus-Schalter. Standardmäßig wird beim Doppelklicken auf ein Wort das gesamte Wort und das erste Leerzeichen dahinter markiert. "Smart" markiert nur das Wort, ohne Leerzeichen dahinter.


Story Editor - 1.3.3.7

Loslegen

Meistens wirst du einfach sofort loslegen und Text eingeben wollen. Die Eigenschaften, die dein Text haben wird, Schriftart, Schriftgröße, Zeilenabstand usw., werden größtenteils nicht sichtbar, bevor du deinen Text speicherst und den Story Editor verläßt. Trotzdem kannst du diese Eigenschaften in den diversen Schaltflächen und Wertefeldern oberhalb des Texteingabebereiches einstellen.

Selbst wenn du Scribus zum ersten Mal benutzt, wirst du einige der Standardeinstellungen ändern wollen. Denke daran, daß wenn du Einstellungen änderst, z.B. die Schriftart, dies nur auf nachfolgend eingegebenen Text wirkt, nicht aber auf schon eingegebenen Text. Wenn du die Schriftart für schon eingegebenen Text ändern willst, mußt du erst den Text markieren (mit gedrückter Maustaste über den Text ziehen oder Umschalt+Pfeiltasten), und dann die gewünschte(n) Einstellung(en) ändern.

Um die Standardeinstellungen zu ändern, gehe über das Menü zu Datei > Allgemeine Einstellungen > Werkzeuge. Klicke dort auf das Textrahmensymbol und setze die gewünschten Einstellungen. In Version 1.2.x ist die Menüfolge Einstellungen > Voreinstellungen > Werkzeuge.

Die verschiedenen Einstellungen für die Texteigenschaften sind im Abschnitt Text Tab im HowTo Arbeiten mit Textrahmen erläutert. Im Story Editor ist die Anordnung anders, aber die Funktionen sind die gleichen. Beachte, daß die Einstellungsmöglichkeit für die Art des Zeilenabstandes (Fest, Automatisch, Am Grundlinienraster ausrichten) im Story Editor gegenwärtig noch fehlt.


Stile/Absatzstile

In Scribus gibt es noch keine vordefinierten bzw. standardmäßig vorhandenen Stile – alle Stile werden vom Benutzer angelegt. Stil bedeutet eine "Sammlung" von Texteigenschaften wie Schriftart, Schriftgröße usw., sowie alle Einstellungen, die du im Story Editor ändern kannst und die du anwenden kannst, bevor oder nachdem du Text eingegeben hast. Dies ist besonders nützlich, wenn du Stile für wiederkehrende Elemente erstellst – ein Stil für Überschriften, einer für den nachfolgenden Text etc.

Stilvorlagen bearbeiten v1.3.3.7

Eigene Stile erstellst du ganz einfach im Story Editor-Menü unter Bearbeiten > Stilvorlagen bearbeiten..., oder du klickst auf den Eintrag kein Stil im linken, vom Texteingabebereich abgetrennten Teil des Story Editors. Ein kleines Fenster klappt auf und bietet oben eine Auswahl (nur falls schon Stile definiert wurden) und unten die Option Stile bearbeiten.... Im Hauptfenster findest du dies unter dem Menüpunkt Bearbeiten > Absatzstile.... (Bearbeiten > Linienstile... , dies hat keinen Einfluß auf den Text – damit kann für den Rand des Textrahmen ein neuer Linienstil kreiert werden). Nun öffnet sich ein kleines Fenster Stilvorlagen bearbeiten mit selbsterklärenden Schaltflächen. Ein Klick auf Neu öffnet ein größeres Fenster – das erste was du bemerkst: der neue Stil hat den Namen Neue Stilvorlage – sicher willst du das sofort in einen aussagekräftigeren Namen ändern. Du kannst so viele Stilvorlagen anlegen, wie du willst, und wichtiger noch: diese Stile werden automatisch mit dem Scribus-Dokument gespeichert – du kannst sie also bei späteren Arbeitssitzungen wieder aufrufen und auch in ein anderes Dokument importieren.

Wie die Bezeichnung Absatzstile schon sagt, werden die Stile immer auf einen ganzen Absatz angewendet. Einen neuen Absatz erhältst du mit der Enter-Taste; dabei wird der Absatzstil des vorangegangenen Absatzes beibehalten, und zwar so lange, bis du das änderst. Wenn du schon eine Reihe Absatzstile definiert hast, kannst du deinen Text einfach eingeben, ohne auf die Formatierung zu achten und anschließend einzelnen Absätzen den gewünschten Stil zuweisen. Dazu klickst du im Story Editor auf das Auswahlfeld rechts neben den Textausrichtungsschaltflächen oder den Eintrag kein Stil im linken, vom Texteingabebereich abgetrennten Teil des Story Editors und wählst aus der Liste den gewünschten Stil aus.

Um Frustrationen zu vermeiden: Auch im Hauptfenster kannst du über den Textreiter der Eigenschaftenpalette den Stil ändern. Beachte aber folgendes: Wenn du dich im Objekt-Auswahlmodus befindest (das bist du automatisch, wenn du den Story Editor verläßt oder Scribus gestartet hast), führt die Änderung des Stiles nicht nur zur Änderung eines Absatzes, sondern ändert den Stil im gesamten Rahmen. Klicke auf das Symbol Rahmeninhalt bearbeiten (Tastatur: E) in der Werkzeug-Menüleiste, um für einzelne Absätze den Stil zu ändern. (Mit der Maus in den betreffenden Absatz klicken)

Wie erstelle ich Initialen?

Du wirst Initialen in keinem der Menüs finden – nur im Stilvorlagen-Bearbeitungsfenster sind sie vorhanden. Unterhalb der Abstandseinstellungen kannst du die Option Initialen markieren; damit aktivierst du auch die beiden Einstellmöglichkeiten darunter: die Anzahl der Zeilen (Höhe des Initials) und der horizontale Abstand zwischen dem Initial und dem Text. Es gibt außerdem noch die Möglichkeit, für die Initialen den Abstand des Grundlinienrasters zu erhöhen oder herunterzusetzen, aber das kann zu Anzeigeproblemen in diesem Fenster führen.

Einzug, hängender Einzug

Unterhalb der Einstellungen für Zeichen, Abstände und Initialen befindet sich ein Schieberegler um den Einzug für die erste Zeile eines Absatzes festzulegen. Einen Einzug für die nachfolgenden Zeilen eines Absatzes (hängender Einzug) kannst du hier auch einstellen (Beachte die Tooltips). Verschiebe entweder die blauen Dreiecke oder ändere die Werte in den Wertefeldern unter dem Schieberegler.

Schriftgröße und Zeilenabstand

Es gibt ein paar Besonderheiten bei der Schriftgröße und dem Zeilenabstand: Wenn du im Story Editor die Schriftgröße änderst, wird nicht automatisch der Zeilenabstand angepaßt: Wenn die Schriftgröße über einen gewissen Punkt hinaus vergrößert wird, dann überlappen sich die Buchstaben der untereinanderstehenden Zeilen gegenseitig. Du mußt den Zeilenabstand dann manuell einstellen. Im Gegensatz dazu steht das Verhalten im Hauptfenster, wenn du über den Text-Abschnitt der Eigenschaftenpalette die Schriftgröße änderst (wenn du im Objekt-Auswahlmodus bist). Hier wird beim Ändern der Schriftgröße auch automatisch der Zeilenabstand geändert, und dies wirkt sich natürlich wieder auf den gesamten Rahmen aus. Das Maß des automatischen Zeilenabstandes kann in den Allgemeinen Einstellungen (Datei > Allgemeine Einstellungen > Typographie > Automatischer Zeilenabstand eingestellt werden. Befindest du dich im Modus Rahmeninhalt bearbeiten, funktioniert dies wie im Story Editor, d.h. eine Veränderung der Schriftgröße bewirkt nicht automatisch eine Veränderung des Zeilenabstandes – hier ist wieder manuelles Ändern angesagt.

Wenn du einen Absatzstil anlegst, siehst du, daß eine Änderung der Schriftgröße auch den Zeilenabstand ändert. Stile sind also eine Möglichkeit, dies zu vereinfachen.

Zusammenfassung: Wenn du in einem Textrahmen Schriftgröße und Zeilenabstand veränderst, wirst du wahrscheinlich den Zeilenabstand manuell einstellen müssen. Bis zu einem gewissen Grad kannst du das vermeiden oder zumindest erleichtern, indem du Absatzstile verwendest.