Spot Colour Palettes in Scribus

From Scribus Wiki
Jump to: navigation, search

Introduction

As long as no Free and open standard for spot colours exists, Scribus users will have to buy a colour fan from a colour manufacturer and insert the values and names of spot colours directly into Scribus. For serious work, colour fans will be a requirement anyway, but that's another topic. There are, however, other ways to legally obtain commercial digital spot colour palettes and use them in Scribus.

Colour vendors handle access to their digital colour swatches differently. Pantone makes most, if not all of its digital palettes available for free download.

Getting and Using Pantone COLOR BRIDGE® and Pantone Goe® Palettes

It's possible to download and use Pantone swatches in Scribus legally. While the palettes can't be distributed with Scribus, users can get them from Pantone directly for free:

1. Create a member account at myPantone.

2. Once you are logged in, follow these links: http://www.pantone.com/pages/pantone/pantone.aspx?ca=12&pg=19887 and http://www.pantone.com/pages/MYP_mypantone/mypInfo.aspx?pg=20576&ca=75.

3. There you'll find download links for Windows and OS X. Linux users can download the Windows version.

4. If you want to use the palettes on Linux, you need a current version of WINE.

5. Unzip/unstuff the installer. Windows and OS X users can now follow the usual install procedures. On Linux with WINE installed, either double-click the file "PANTONEcolorbridge.exe"/"PANTONE(R) Goe(TM) digital libraries.exe" or run wine PANTONEcolorbridge.exe/wine PANTONE(R) Goe(TM) digital libraries.exe in a console. WINE should now launch an installer. You can always click forward until the end of the installation procedure. If you don't have any of the selected applications available, you should see a dialog like this:

Pt-installer.png

6. Next, go to .wine/drive_c/Programs/PANTONE(R) color bridge(TM)/ or .wine/drive_c/Programme/Pantone/PANTONE(R) Goe(TM) digital libraries in your $HOME directory, where you will find the swatches in different formats, among them EPS. You can now load them into Scribus as described below.

In Scribus 1.3.5, things have even become easier: just copy the EPS (or AI) files to ~lib/scribus/swatches, where ~ indicates your installation directory. The palettes will be immediately available in Scribus via Edit > Colors, provided, of course, that all open documents are closed.

Is this legal?

While we are no lawyers, we think it is. Otherwise, this information wouldn't be available here. Let's just quote Pantone's stance from the download page mentioned above:

The installers provided below will install Application Support files for your favorite graphic software applications. These files will allow you to import PANTONE Colors with CMYK simulation data consistent with the printed PANTONE color bridge coated, uncoated or PANTONE color bridge coated EURO guide. If your graphic software does not appear within the Easy Install, we have provided EPS and TIFF files, which can be utilized within most graphic applications using a color selection tool such as the eyedropper. We have also provided a folder with the Easy Install libraries for each application, in the event that you need to proceed with a manual install.

Other Vendors

Trumatch, Focoltone, Toyo, DIC, HKS and others have no similar offerings, but at least the ~100 basic HKS colours are available from the websites of many German printers.

If you happen to own a licence to a commercial graphics program that ships with spot colour palettes, you can use these, at least if the license permits this. Please note that you will most likely have to install the program to access the palettes. On Linux this may or may not work with the help of WINE.

Other colour vendors offer their palettes for Photoshop, AutoCAD or others. Swatchbooker (see below) can convert most of these files to Scribus XML files that an be used in 1.3.5+:

  • Sherwin Williams (paints, USA) Photoshop and AutoCAD files.
  • Dulux (paints and finishes, New Zealand) AutoCAD files
  • Dunn Edwards (paints, USA) Photoshop and AutoCAD files
  • Sto AG (paints and coatings, Germany), CorelDraw, Photoshop and AutoCAD files
  • Sikkens (paints, Italy), ArchiCAD, AutoCAD, Corel and Photoshop files
  • Orafol (adhesive graphic films, Germany), Corel, Adobe CS2+, Freehand files

File:Free-palettes.tar.bz2.gz is a set of Free colour palettes (Fedora, LaTeX Beamer, OpenSUSE, Oxygen, Ubuntu and 3 OpenOffice.org palettes). After download, remove ".gz" from the file and extract it.

Direct Import

Scribus 1.3.3.x

In Scribus 1.3.3.x direct import is only possible via the EPS file format. Create a new document and use File > Import > EPS/PS (Pantone’s freely available Color Bridge palettes contain EPS files, among others). Now delete the imported drawing and save the file under an appropriate name, e.g. pantone-cb-eu.sla. Next, close all docs again. Go to Edit > Colours, choose the palette "Scribus Small" from the drop down menu. Remove all colours except Black (Scribus needs at least one colour to work). Then click "Import" and select the panton-cb-eu.sla file. Now you can see all the spot colours in the colour list. Finally, click "Save Colour set" and save your new palette e.g. as "Pantone Solid Uncoated."

From now on your spot colours will be available for you in any project. If want to reuse your palette on another computer, just store the file Pantone Solid Uncoated from your .scribus folder on a USB stick or a floppy disk and copy it to the respective directory on the other computer.

Scribus 1.3.5+

From Scribus 1.3.5 onwards you can even skip the step of saving a sla file first, since Scribus can import colours from EPS files directly via Edit > Colours > Import. Moreover, since version 1.3.5, Scribus can also import palettes in Adobe’s Illustrator (AI) format(s).

Using Swatchbooker

In 2008, Olivier Berten started an extremely useful project called Swatchbooker. While still in its infancy, it’s already possible to convert a large number of commercial colour palettes. As of this writing, Swatchbooker supports files shipped with products from Adobe (aco, acb, act, ase, acf, bcf, clr), AutoCAD (acb), Corel (cpl), QuarkXPress (qcl, cui), among others. The best news for Scribus users is that Swatchbooker can convert any of these formats to Scribus XML colour palettes.

Scribus 1.3.3.x

Open a colour palette in Swatchbooker and save it as a Scribus XML file:

Swb-save.png

Then open the XML file, as well as the file scribus13.rc in your home directory in a text editor. Next, copy all lines that start with <COLOR to the clipboard. Finally, paste the content of the clipboard to the scribus13.rc file, above or below the colour list whose content starts with <COLOR as well. Save the file, and the spot colours will be available in Scribus.

Scribus 1.3.5+

In Scribus 1.3.5+ the process of conversion is as easy as it gets. Just convert the colour palettes with Swatchbooker as described above, then copy the resulting xml file to the directory ~/lib/scribus/swatches in your installation folder. Scribus will then read the colours and list the new palette for selection in the dialog Edit > Colours:

Colour-sel.png


(c) 2007/2009 Christoph Schäfer

The content of this page is licensed under the Free Documentation License.