Вводный курс по Scribus:5

From Scribus Wiki
Jump to: navigation, search
 Вводный курс по Scribus 2006
Авторы современной версии:   Авторы вики Scribus
Автор исходного текста:   Niyam Bhushan, 2004
Лицензия:   GNU Free Documentation License, Version 1.2
    
 Глава 5
edit

Главная страница

Вступление

  1. Что вы можете делать при помощи Scribus
  2. Перед началом работы
  3. Изначальный вакуум
  4. Обложка
  5. Работа со слоями страницы
  6. Макетирование нескольких страниц
  7. Создание конечного макета
  8. Макетирование с графикой
  9. Зажгите огонь графикой в SVG
  10. Публикации нужны свободные PDF
  11. Путешествие на скорости Scribus
  12. Участники
  13. GNU Free Documentation Licence

Зачем нужны слои

В публикации нам будет необходимо провести сложную работу по форматированию. Это надо сделать с текстом указаний на первой странице со сведениями об издании, шапки (заголовка), подрубрики (подзаголовка). Это сложная работа, особенно если издание будет на нескольких языках и если необходимо для каждого языка осуществлять монтаж (форматирование). Вместо этого можно использовать для текста на разных языках, свои раздельные слои. Можно скрывать и показывать слои разных языков. Такой подход удобен при макетировании страниц. На один уровень можно разместить фоновый рисунок, на другой - текст. Таким образом мы получим текст на фоне рисунка. Перейдите в пункт меню Окна>Слои. В открывшемся окне вы увидите уже существующие слои, которые содержат все ваши объекты. Если вы снимите галочку с "глаза", все объекты этого слоя исчезнут, у вас останется пустая страница. Чтобы изменить название слоя, кликните в него и введите свое название. Внизу крайняя кнопка служит для создания нового слоя, следующая кнопка для удаления текущего слоя. Объекты которые вы размещаете на странице будут располагаться на текущем слое, который в данный момент выделен в этом окне.

Вставка текста в текстовые блоки

Чтобы вставить текстовый блок 1.Нажмите на кнопку "Вставить текстовый блок" на панели инструментов 2.Выберите пункт меню Вставка>Текстовый блок 3.Используйте клавиатурную комбинацию T, или Alt+N, T Это позволит вам с помощью мыши расположить и установить размер текстового блока. Кликните мышью и перетащите диагонально удерживаю кнопку, располагая блок на странице. То место страницы в котором вы кликнули мышью будет одним углом блока, там где вы отпустили кнопку мыши - другим. Чтобы удалить текстовый блок необходимо сделать его активным кликнув по нему и потом нажать кнопку Delete, или комбинацию Ctrl+X.

Автоматическое создание текстовых блоков

Вы можете создавать текстовые блоки автоматически. Эта функция предусмотрена в окне создания нового документа (называется Автосоздание текстовых рамок) Выберите необходимое число страниц (также в окне создания нового документа), число столбцов и величину интервала. После того как вы нажмете ОК, будет создано заданное количество страниц с текстовыми блоками заполняющими пространство страниц. Более того эти текстовые блоки будут связаны друг с другом, так что когда вы будете вставлять текст он будет перетекать на следующую страницу (текстовый блок следующей страницы). (Подробнее о том как связывать блоки см. "Макетирование нескольких страниц" Вводный курс по Scribus:6) Заметьте, когда вы будете добавлять страницы к уже имеющимся (меню Страница>Вставить), новые появляющиеся страницы будут содержать текстовый блок заданного стиля.

Размер и расположение текстового блока

Чтобы задать размер и позицию текстового как и любого другого блока, используется окно Свойства. Чтобы его открыть выберите меню Окна>Свойства. В появившемся окне указаны свойства текущего блока, обведенного красным контуром (чтобы его выделить надо кликнуть по нему мышью). Во вкладке XYZ этого окна показана точная информация о координатах X и Y верхнего левого угла блока, ширине и высоте блока, угле поворота относительно вертикали. Изменить размер блока можно перетаскиванием контура (над маленькими прямоугольниками), или задав размеры в окне свойств (можно изменять в окошках значений размеры при помощи колесика мышки, если это делать при нажатых клавишах Ctrl, Shift, или Ctrl+Shift, разрядность изменений будет разной) Следует обратить внимание на кнопку с иконкой цепи. Если она нажата (по умолчанию она нажата), ширина и высота связаны друг с другом (изменение одной величины приводит к пропорциональному изменению другой). Если кнопка отпущена, значит ширина и высота не связаны. В меню Страница>Прилипание к сетке можно установить свойство прилипания к сетке страницы. Чтобы увидеть сетку страницы необходимо установить свойство "показать сетку" (Вид>Показать сетку)(по умолчанию это сделано). Эта сетка не будет отображаться в итоговом документе PDF, поскольку не является его частью. Задать свойства сетки можно в меню Файл>Настроить Scribus>Направляющие В меню Страница>Прилипание к направляющим можно установить свойство прилипания к направляющим страницы. Чтобы увидеть направляющие страницы необходимо установить свойство "показать направляющие" (Вид>Показать направляющие)(по умолчанию это сделано). Эти направляющие не будет отображаться в итоговом документе PDF, поскольку не является его частью. Задать свойства направляющих можно в меню Файл>Настроить Scribus>Направляющие

Копирование блоков и подобные операции

Один из путей копирования блоков его дублирование (клавиатурная комбинация Ctrl+Alt+Shift+D)Объект>Продублировать. Эта операция создает практически офсетную копию, находящуюся на более высоком слое. Используя команду продублировать многократно Объект>Продублировать многократно можно создать сколь угодно большое количество копий. Если перетягивать объект правой кнопкой мыши, то после того как ее отпустить можно в появившемся запросе выбрать создание копии, перетаскивание данного объекта или завершение операции. Для копирования объектов можно использовать Альбом (меню "Объект>Передать в альбом" или в контекстном меню "Передать в альбом"). Это создает поименованную копию блока и его содержимого в Альбоме. Чтобы получить копию из альбома следует выбрать меню Окна>Альбом Объекты с которыми осуществляется работа могут находиться не только на странице, но и за её границами. При сохранении документа, сохраняется все объекты, даже если они находятся за границами страницы. Это позволяет расширить пространство рабочего стола, временно помещая за границы страницы объекты. Когда создается файл публикации PDF для находящихся за пределами страницы объектов будут получины сообщения об ошибках. Если пропустить эти ошибки, то полученный файл PDF, не будет включать эти объекты.

Ввод и редактирование текста в блоке

Story Editor (Редактор материала) Если у вас выбран текстовый блок нажмите клавишу "Изменить текст в Story Editor" (клавиатурная комбинация Ctrl+Y), или выберите в меню Правка>Изменить текст; это также доступно и в контекстном меню. Редактор материала Story Editor наиболее эффективный способ ввода текста. Вводимый текст будет иметь соотвествующий тексту в блоке цвет, другие свойства, такие как гарнитура, расстояние между символами, не отображаются в тексте набираемом в Story Editor. Если вы хотите изменить цвет заднего фона в Story Editor выберите меню Параметры>Фон. Свойства которые можно изменять в Story Editor, можно изменять на вкладке Текст окна Свойства (см. Размер и расположение текстового блока). Чтобы облегчить себе работу в Скрибусе используйте Стили окна Story Editor. Они позволяют сохранить комплекс свойств связав их с определенным именем Стиля, с целью повторного их использования в дальнейшем. Можно редактировать текстовый блок непосредственно на главной странице, для этого используйте кнопку "Изменить содержимое блока" панели инструментов (клавиатурная комбинация "E"). Когда вы кликните в блок, вы увидите мигающий курсор в том месте, куда будет производиться ввод текста, или осуществляться редактирование. Вместо использования этой кнопки того же результата можно добиться двойным кликом в текстовом блоке. Изменить свойства редактируемого таким образом текста можно используя окно Свойства>Текст (см.Размер и расположение текстового блока) Чтобы редактировать весь текст целиком данного текстового блока, следует сначало выбрать текстовый блок (вокруг него появиться красная рамка). Для этого нажмите кнопку Выбрать объект (клавиатурная комбинация "C"). После этого если вы будете изменять свойства на вкладке Текст окна Свойства (см.Размер и расположение текстового блока), изменения будут применяться ко всему тексту блока.

Специальные символы, акцентуированные символы иностранных языков

Существует возможность вставлять в текстовый блок специальные символы, символы иностранных языков, которые не представлены на клавиатуре, типографские знаки (такие как длинное тире, короткое тире, символы различного размера и т.п.). Для этого используйте главное меню Вставка>Символ, Вставка>Символ..., Вставка>Кавычки, Вставка>Пробелы и разрывы, Вставка>Лигатура. Если специальные символы не отображаются, чаще всего это означает, что они не доступны в данном выбранном шрифте. То что отображается в Story Editor, не обязательно проявиться на странице.

Загрузка текста из файла

Чтобы загрузить текст из файла, в контекстном меню текстового блока выберите Получить текст, или из меню Файл>Импортировать>Получить текст. Эта команда заменяет все что ранее находилось в текстовом блоке на текст из файла. Чтобы добавить текст следует выбирать вместо Получить текст, Добавить текст. Файл можно также загрузить и в Story Editor. Чтобы посмотреть каким будет форматирование в текстовом блоке можно использовать вставку шаблонного текста (в контекстном меню текстового блока пункт Шаблонный текст; в меню Вставка>Шаблонный текст. Скрибус имеет шаблонный текст на нескольких языках, в том числе на русском языке.

Проблема расходящихся строк в колонках

Размещая текст в фрейме с несколькими колонками, вы иногда можете столкнуться с тем что строки соседних колонок не лежат на одной линии. Это часто происходит при совмещении блока изображения с текстовым блоком, или если вы разместите рядом два текстовых блока. Чтобы решить эту проблему применяйте абзацные стили. Создать абзацный стиль можно в меню Правка>Абзацные стили. Чтобы создать или изменить стиль в Story Editor, для этого выберите меню Правка>Изменить стили. В появившемся окне Правка стилей, вы можете создать новый стиль, нажав кнопку Новый. В окне Правка стилей в блоке Расстояния нажмите крайне левую кнопку интерлиньяж (рядом с ней также находиться окно ввода значения) и выберите "Выровнять по сетке базовой линии"

Уровни и слои

Небольшой блок кнопок "Уровень", расположенный на вкладке "XYZ" окна "Свойства" позволяет перемещать выбранный блок на более высокий или низкий слой, стрелки с линией предела дают возможность переместить блок на самый верхний или самый нижний слой. Поскольку фон блока может быть как прозрачным, так и не прозрачным, его перемещение между слоями может изменить то какая часть блока будет видимой, какая будет перекрываться другими непрозрачными блоками. Другие кнопки вкладки XYZ 1.Перевернуть по горизонтали или перевернуть по вертикали 2.Заблокировать блок на месте. При нажатии этой кнопки, замыкании замочка, блокируются такие свойства блока как размер, расположение, содержимое. 3.Заблокировать размер объекта. При нажатии этой кнопки возможность изменять размер исчезает. 4.Включить или отключить экспорт объекта. Вы можете разместить на странице блок с вспомогательной для себя или для третьего лица информацией, которая не будет частью готовой работы. Можно использовать эту кнопку если на странице располагаются блоки с идентичным содержимом на разных языках, и вы желаете иметь две публикации для этих языков.

Свойства:вкладки Очертания

Вкладка очертания находится в окне Свойства. Первая, самая верхняя кнопка с изображением прямоугольника в центре позволяет выбрать одно из нескольких типовых очертаний для текущего текстового блока. Более того если нажать кнопку Изменить очертания... появится возможность с помощью векторного редактора изменить очертания. Можно также использовать инструмент построения многоугольников (кнопки панели инструментов Добавить фигуру, Добавить многоугольник) чтобы создать обычный многоугольник, который затем преобразовать командами из контекстного меню в блок, в том числе текстовый блок (Преобразовать в>Текстовый блок). Следует заметить, что прежде чем после такого преобразования вводить текст необходимо изменить цвет фона полученного текстового блока. Окно ввода значения "закругленные углы" позволяет закруглить углы текущего текстового блока, допускаются и отрицательные значения. Расстояние до текста. Окна ввода "Столбцов", "Интервал" определяют количество колонок в текстовом блоке, и интервал между колонками. Окна ввода Сверху, Снизу, Слева, Справа определяют расстояние от края текстового блока до текста расположенного внутри него. Кнопка Табуляторы... устанавливает пункты табуляторов в текстовом блоке.

Обтекание блока текстом

Этот пример относится к случаю если текстовый блок находится на более низком уровне чем блок изображения. После создания блока изображения граница изображения и рамка блока изображения имеют одинаковые размеры и поэтому текст обтекающий блок изображения непосредственно соприкасается с самим изображением. Чтобы создать контур вокруг блока изображения на вкладке Очертания окна Свойства блока изображения во-первых поставте отметку Текст обтекает блок. После этого текст находящийся на нижнем уровне будет обтекать данный блок. Далее необходимо отметить пункт Контурная линия. Для изменения вида и размера контурной линии нажмите кнопку "Изменить очертания" этой же вкладки. В появившемся окне Узлы необходимо отметить пункт "Изменить контурную линия". Вокруг текущего блока появится синяя рамка с круглыми отметками углов. Перетаскивая эту рамку вы можете создать контур любого размера.

Свойства:вкладка Текст

Первые два поля ввода показывают гарнитуру шрифта и его стиль.В зависимости от того в каком режиме находится Скрибус, "Выбрать объект" (клавиатурная комбинация "С", при этом нажата первая кнопка панели инструментов (со стрелкой)) или "Изменить содержимое блока" (клавиатурная комбинация "Е", седьмая кнопка панели инструментов с конца) изменяться будет соответственно либо весь текст блока, либо вновь вводимый. Чтобы изменить некоторую часть текста следует перейти в режим "Изменить содержимое блока" и произвести выделение этой части. Далее во вкладке Текст идут поля:

1. Кегль шрифта.

2. Левое среднее поле ввода показывает межстрочное расстояние. Если вы находитесь в режиме Выбрать объект значение поля Межстрочное расстояние автоматически изменяется при изменении кегля шрифта (размера шрифта), в режиме "Изменить содержимое блока" изменение кегля шрифта не отражается на межстрочном расстоянии. Настройка автоматического межстрочного расстояния производится в меню Файл>Настроить Scribus...>Типографика. Если несколько секунд нажать на иконку межстрочного расстояния расположенную рядом с полем ввода значения, появится список режимов межстрочного расстояния: "Фиксированный интерлиньяж", "Автоматический интерлиньяж", "Выровнять по линии шрифта". Первый вариант установлен по умолчанию. Автоматический интерлиньяж означает, что межстрочное расстояние будет установлено автоматически "Выровнять по линии шрифта" устанавливает выравнивание строк текста по сетке базовых линий. Расстояние между базовыми линиями сетки устанавливается в меню Файл>Настроить Scribus...>Направляющие.

3. Левое нижнее поле ввода "Изменяемая ширина символов"- его изменение не влечет изменение высоты шрифта.

4. Правое верхнее поле поднимает (при положительных значениях) или опускает выбранные символы по отношению к базовой линии.

5. Правое среднее поле "Ручной трекинг" - кернинг или слияние - расстояние между символами.

6. Правое нижнее поле "Изменяемая высота символов" - при этом ширина символов остается неизменной, а сами символы остаются на базовой линии.


На вкладке Текст также можно найти два поля для установки цвета. Верхнее для установки цвета обводки текста и/или отбрасываемой им тени если она выбрана (смотри ниже пункты 8 и 9). Нижнее поле устанавливает цвет текста. Кроме определения цвета можно установить также его насыщенность, для этого кликните на проценте насыщения возле поля задания цвета. Ниже расположенный ряд кнопок слева направо:

1.Подчеркивание текста, включая интервалы между словами. Можно изменять толщину и вертикальную позицию(смещение).

2.Подчеркивание только символов. Можно изменять толщину и вертикальную позицию(смещение).

3.Нижний индекс.

4.Верхний индекс.

5.Все капителью (прописными буквами).

6.Малая капитель (маленькие заглавные).

7.Вычеркнутый текст. Можно изменять толщину и вертикальную позицию(смещение).

8.Контур. Применяет контур к символам. Можно изменять толщину.

9.Оттененный текст. Создает тень для символов, что фактически означает их дублирование сзади. Смещение по горизонтали (X-смещение) и по вертикали (Y-смещение) можно изменять.

10.Написание справа налево (отраженный по горизонтали текст) выбранных символов. Возможно применить только ко всему тексту, н не к отдельному параграфу.


Следующий ряд кнопок определяет выравнивание. Самая левая кнопка определяет принудительное выравнивание по ширине, что может привести к непредсказуемым результатам. Ниже расположены поля выбора стиля и языка. Последнее определяет автоматический перенос. В версии Скрибуса 1.3.4 выбор языка производится п меню Файл>Настройки документа>Перенос слов для редактируемого документа и в меню Файл>Настроить Scribus>Перенос слов для всех документов которые будут редактироваться в программе. В версии 1.3.4 выбрать язык можно и для каждого стиля в менеджере стилей.

Свойства: вкладка Линии

Параметры этой вкладки относятся к границам блока. Прежде всего следует упомянуть, что по умолчанию Цвет линии установлен в Никакого, поэтому какие бы установки не делались на данной вкладке, ничто не будет отражено на странице, пока не будет установлен какой-либо иной Цвет линии. Цвет линии устанавливается во вкладке Цвета, где помимо кнопки Изменить свойства цвета линии имеется кнопка Изменить свойства заливки блока или многоугольника. Если поля установок затемнены их невозможно применить к блоку.

Свойства: вкладка Цвета

Кнопка Изменить свойства цвета линии определяет параметры границы блока, по-умолчанию установлена в Никакой. Свойства заливки определяет цвет заливки блока. Значение Никакой для заливки означает прозрачный. Цвет текста можно установить на вкладке Текст, или в Story Editor. Поле Тень определяет насыщенность цвета, поэтому 0% отображается в нейтрально серый цвет. Для поля Непрозрачность 100% означает непрозрачный, 0% полностью прозрачный. Следует оговориться, что некоторые версии PDF, и их просмотрщиков не поддерживают прозрачность. Вы не ограничены в своем выборе цветов только теми, которые указаны на данной вкладке. Добавить, редактировать, удалить цвета можно в меню Правка>Цвета... Удаление цветов упрощает использование Scribus и уменьшает размер файла.