Lavorare con le pagine mastro

From Scribus Wiki
Jump to: navigation, search

Altre lingue: Deutsch English Polski Português Русский

Tutte le pagine della serie Lavorare con...:

Lavorare con Scribus: come iniziare
Lavorare con le cornici di testo
Lavorare con l'editor interno
Lavorare con le cornici immagine
Lavorare con le pagine mastro

Perché usare le pagine mastro

In molti documenti, certi elementi compaiono nelle stesse posizioni in molte o in tutte le pagine: questo può accadere con intestazioni, loghi, sfondo, numeri di pagina, ecc. Per evitare di dover inserire questi elementi ripetitivi in ogni pagina, una a una, è consigliabile usare le pagine mastro.
Una pagina mastro è un modello che fa da "base" per le normali pagine del documento: il contenuto della pagina mastro viene inserito automaticamente in tutte le pagine (normali) a cui la pagina mastro è applicata. Quando vi sono elementi identici su molte pagine, l'uso delle pagine mastro per inserirli può far risparmiare molto tempo e fatica.

Gli oggetti inseriti in una pagina mastro non possono essere modificati nella normale modalità di lavoro. C'è una buona ragione per questo: quella di evitare che la pagina mastro sia modificata accidentalmente. Una data pagina mastro appartiene al documento in cui è stata creata, e non può essere salvata separatamente. Tuttavia si può creare un documento campione in cui inserire le pagine mastro utilizzate di frequente, e usarlo come "deposito" da cui importarle in altri documenti di Scribus.

Gli oggetti presenti nella pagina mastro sono considerati al di sotto di tutti quelli presenti nella pagina normale (vedere Lavorare con le cornici immagine: livelli).

Come creare pagine mastro

Metodo A:

Creare un nuovo documento. Nel menù principale selezionare Modifica > Pagine mastro... (figura 1): in questo modo si passerà alla modalità Modifica pagine mastro (figura 2).
Figura 1

La pagina mastro Normale è sempre presente e non può essere cancellata (se è selezionata, il pulsante di cancellazione è disabilitato - figura 2); può essere modificata, ma è meglio lasciarla vuota, in modo che sia possibile inserire nel documento pagine vuote.

Figura 2

Muovendo il mouse sopra i pulsanti, sono mostrate le rispettive funzioni (figura 2):

a partire da sinistra:

  • nuova pagina mastro
  • duplica pagina mastro
  • importa pagina mastro da un altro documento
  • elimina pagina mastro

Facendo clic sul pulsante Nuova pagina mastro si apre una finestra di dialogo in cui inserire il nome della nuova pagina (figura 3). È consigliabile scegliere un nome significativo, che descriva in modo chiaro e sintetico la funzione o le caratteristiche della pagina.

Figura 3
Dopo aver premuto OK compare la finestra Modifica pagine mastro con la nuova pagina mastro evidenziata. Le pagine esistenti sono elencate in questa finestra, e ciascuna di esse può essere selezionata e modificata secondo necessità (figura 4).

Chiudendo la finestra Modifica pagine mastro si torna alla normale modalità di lavoro.

La funzione Duplica la pagina mastro selezionata può essere molto utile quando si ha bisogno di una nuova pagina mastro simile a una già esistente. Duplicare una pagina mastro esistente e poi modificarla può far risparmiare tempo e fatica.

Figura 4

Inoltre si può copiare una pagina mastro che si trova in un altro documento facendo clic su Importa pagine mastro da altro documento, che apre la finestra Importa pagine mastro (figura 5).

Figura 5
Fare clic sul pulsante Seleziona... per cercare il documento che contiene la pagina mastro desiderata, poi selezionare la pagina mastro da importare e fare clic sul pulsante Importa.

Metodo B:

Si può creare una nuova pagina mastro anche a partire dalla pagina su cui si sta lavorando in modalità normale. Nella barra dei menù selezionare Pagina > Converti in pagina mastro (figura 6); si apre una finestra dal titolo Converti pagina in pagina mastro in cui si può inserire un nome per la nuova pagina mastro (simile alla figura 3).

La nuova pagina comparirà in Modifica > Pagine mastro, nella finestra Modifica pagine mastro (figura 4).

Figura 6

Documenti a doppia facciata, 3 e 4 falde

Figura 7
Figura 8 - documento a doppia facciata
Figura 9 - pieghevole a 3 falde
Figura 10 - pieghevole a 4 falde

Le pagine mastro si rivelano molto utili per l'impaginazione di documenti a doppia facciata oppure di pieghevoli a 3 e 4 falde. Ecco come utilizzarle in queste situazioni.

Creare un documento selezionando il layout desiderato (figura 7). Poi, creare le pagine mastro con uno dei due metodi spiegati prima. Le figure qui a destra mostrano che una buona scelta dei nomi delle pagine mastro può rendere il lavoro più facile:

  • documento a doppia facciata (figura 8)
  • pieghevole a 3 falde (figura 9)
  • pieghevole a 4 falde (figura 10)

Applicare le pagine mastro

A pagine esistenti:

Figura 11
Figura 12

Selezionando Pagina > Applica pagina mastro... (figura 6), oppure nel menù contestuale (tasto destro del mouse sulla pagina, figura 11) Applica pagina mastro... si apre la finestra di dialogo Applica pagina mastro. Da qui si può scegliere se applicare la pagina mastro a:

  • pagina corrente
  • pagine pari
  • pagine dispari
  • tutte le pagine
  • e la scelta può essere limitata a un intervallo di pagine.

Selezionare la pagina mastro desiderata nel menù a discesa in alto nella finestra.

L'opzione Pagine pari può essere (ovviamente) selezionata solo quando il documento ha più di una pagina. Inoltre si può selezionare un intervallo di pagine solo con l'opzione Tutte le pagine.

All'inserimento di una nuova pagina:

Figura 13

Quando si inserisce una nuova pagina nel documento (dal menù principale Pagina > Inserisci), si apre una finestra di dialogo in cui si può scegliere se aggiungere una o più pagine, in quale punto del documento inserirle, e anche se applicare loro una pagina mastro (figura 13).
Si noti che il riquadro "Pagine mastro" si adatta in base al layout impostato per il documento: nell'esempio mostrato in figura 14 si vede l'aspetto della finestra Inserisci pagine per un pieghevole a 4 falde.

Suggerimento: Il modo migliore per ottenere la numerazione automatica delle pagine consiste nell'impostarla nell'editor interno. In modalità Modifica pagina mastro, creare una cornice di testo nella posizione in cui si vuole inserire il numero di pagina; poi aprire l'editor interno e selezionare il comando Inserisci > Carattere > Numero pagina (da tastiera: Ctrl+Shift+Alt+P). Il numero di pagina appare con il simbolo # nella finestra dell'editor interno.

Se il numero di pagina deve avere due o più cifre, inserire due o più di questi caratteri speciali. Se si usa la stessa pagina mastro per tutte le pagine in un documento lungo, e si inseriscono due o più caratteri di numerazione nella pagina mastro, Scribus ignora le cifre ridondanti nelle pagine con i numeri minori (e quindi scriverà "1" e non "01" o "001").

Figura 14


La prima versione tedesca di quest'articolo fu originariamente pubblicata nel forum tedesco di Scribus.


Torna.png Torna alla pagina iniziale - Torna al sommario