Lavorare con le cornici immagine

From Scribus Wiki
Jump to: navigation, search

Altre lingue: Deutsch, English, Português

Tutte le pagine della serie Lavorare con...:

Lavorare con Scribus: come iniziare
Lavorare con le cornici di testo
Lavorare con l'editor interno
Lavorare con le cornici immagine
Lavorare con le pagine mastro

Quest'articolo descrive le operazioni relative alle cornici immagine.


Creazione

Una cornice immagine può essere creata in uno dei seguenti modi:

  1. facendo clic sull'icona Inserisci cornice immagine sulla barra degli strumenti.
  2. selezionando Inserisci > Inserisci cornice immagine nel menù principale.
  3. da tastiera, premendo I, oppure Alt+I, I.

La cornice può essere posizionata e dimensionata con il mouse, facendo clic col tasto sinistro e trascinando diagonalmente sulla pagina. Il punto in cui si fa clic sarà uno degli angoli della cornice, e il punto in cui si lascia andare il pulsante sarà l'angolo opposto. Può essere più convenzionale iniziare dall'angolo in alto a sinistra, ma la cornice può essere disegnata a partire da uno qualunque dei suoi quattro angoli.

Menù contestuale

Facendo clic con il tasto destro del mouse si apre un menù contestuale, che contiene alcune operazioni comuni con le cornici. Tra queste, è importante la possibilità di convertire la cornice immagine in una cornice di altro tipo.

Misure e posizione

Il pannello "Proprietà" è uno strumento indispensabile per lavorare con Scribus. La si può aprire dal menù Finestra > Proprietà oppure premendo il tasto F2. In questa finestra la scheda XYZ mostra informazioni molto precise sulla posizione orizzontale e verticale dell'angolo superiore sinistro, su larghezza e altezza e rotazione della cornice. I valori mostrati riguardano la cornice selezionata, che viene evidenziata con un bordo rosso. Una cornice è automaticamente selezionata quando viene creata; può essere deselezionata facendo clic sulla pagina all'esterno del suo bordo, e selezionata di nuovo facendo clic all'interno. Una cornice deve essere selezionata per poterla modificare o spostare.

Caricare un'immagine nella cornice

Una cornice immagine appena creata contiene una grande X i cui bracci uniscono gli angoli opposti: questa X indica che la cornice è vuota. Per riempirla è necessario caricarvi un'immagine.

Possono essere importate immagini nei seguenti formati: TIFF, JPEG, PNG, GIF, XPM, EPS. Si può importare anche un documento PDF, ma solo la prima pagina sarà caricata (più avanti sarà spiegato come ovviare a questo problema). Alcuni consigli sull'uso dei diversi formati immagine si trovano nel manuale online, Aiuto > Manuale di Scribus > Documentazione > Importare contenuti (da tastiera: F1, poi Documentazione > Importare contenuti).

Un'immagine può essere caricata dal menù contestuale (clic col tasto destro del mouse) > Carica immagine (da tastiera: Ctrl+I), o dal menù File > Importa > Carica immagine. L'immagine caricata conserva le sue dimensioni originali, con l'angolo in alto a sinistra posizionato nell'angolo in alto a sinistra della cornice.

Spesso la cornice e l'immagine importata avranno dimensioni diverse, e potrebbe essere necessario adattare le dimensioni di una o entrambe. Il ridimensionamento e il riposizionamento della cornice sono spiegati nel paragrafo successivo; quelli dell'immagine sono spiegati in Proprietà: la scheda Immagine.

Usare immagini in formato SVG

SVG è un formato open source per immagini vettoriali, e per molti aspetti è ideale per il desktop publishing. Le immagini SVG non hanno bisogno di cornici, ma possono essere importate direttamente in Scribus dal menù:
File > Importa > Carica file vettoriale.
Le immagini SVG possono essere ridimensionate e spostate, e vi sono anche alcune limitate possibilità di modificarle direttamente; tuttavia alcune caratteristiche del formato SVG non sono ancora supportate da Scribus. Se si vuole importare un'immagine SVG in una cornice, è necessario prima convertirla in uno dei formati importabili elencati qui a sinistra, usando un'applicazione per la grafica vettoriale come Inkscape.

In questo caso, è consigliabile ingrandire l'immagine (darle un valore DPI più alto di quello predefinito) per ridurre la pixelizzazione nel documento finale prodotto da Scribus.

Importare più pagine di un documento PDF

Attualmente questo è possibile solo utilizzando software di terze parti, come Adobe Acrobat. Esistono anche diverse applicazioni open source che sono in grado di suddividere un documento PDF multipagina in pagine singole: ad esempio pdftk, e PDF Split and Merge scritto in Java Swing (per Windows e Mac). KPDFtool e PDFChain (entrambi per Linux) offrono un'interfaccia grafica per eseguire alcune operazioni su documenti PDF, tra cui l'estrazione di pagine singole da documenti multipagina. E infine è utile ricordare che anche Scribus può esportare un documento generando un PDF per ciascuna pagina.

Proprietà: la scheda XYZ - spostamento e ridimensionamento

Proprietà: la scheda XYZ
Con il mouse: Con il pannello Proprietà:
  1. per spostare una cornice: fare clic al suo interno e trascinarla in una diversa posizione. Nelle versioni più recenti di Scribus, le cornici possono anche essere posizionate al di fuori della pagina, o spostate in un'altra pagina.
  2. per ridimensionare una cornice: fare clic su uno dei piccoli rettangoli rossi lungo il bordo e trascinare fino a quando si raggiunge la dimensione desiderata.
Ci sono tre modi per modificare le singole impostazioni:
  1. digitare il nuovo valore;
  2. fare clic sulle frecce "su" e "giù" a destra di ciascun valore, oppure usare i tasti "freccia su" e "freccia giù" della tastiera;
  3. usando la rotellina del mouse su ciascun valore; di solito basta spostare il puntatore del mouse sul valore da modificare, ma se ciò non ha effetto, fare clic sul valore.

Nelle modalità 2 e 3, la pressione sui tasti Ctrl, Maiusc, o Ctrl+Maiusc provoca la modifica delle decine o della parte decimale del valore. Per impostazione predefinita, la larghezza e l'altezza sono legate tra loro (cioè quando si modifica una viene modificata anche l'altra, mantenendo le proporzioni) ma possono essere scollegate facendo clic sull'icona "catena" a destra.


Due aiuti per posizionare le cornici

  • selezionando nel menù Pagina > Aggancia alla griglia la cornice sarà "attratta" dalle linee della griglia. Vista > Mostra griglia visualizza e nasconde la griglia (la griglia non viene mai stampata né inserita nel PDF finale.) La distanza tra le linee della griglia può essere modificata in File > Preferenze > Guide.
  • selezionando nel menù Pagina > Aggancia alle guide la cornice sarà "attratta" dalle guide. Vista > Mostra guide visualizza e nasconde le guide (le guide non vengono mai stampata né inserite nel PDF finale.) Le guide possono essere aggiunte o modificate in Pagina > Gestione linee guida oppure in File > Preferenze > Guide.

Proprietà: la scheda Immagine

Se la cornice ha già le giuste dimensioni, selezionando Adatta alla cornice l'immagine sarà ridimensionata fino ad avere le stesse dimensioni della cornice. Se in seguito la cornice viene ridimensionata, anche l'immagine viene ridimensionata allo stesso modo, in modo che la cornice e l'immagine mantengano le stesse dimensioni. Per "slegare" le dimensioni dell'immagine da quelle della cornice selezionare Scala libera, e l'immagine potrà essere manipolata indipendentemente dalla cornice.

Spostamento e ridimensionamento di un'immagine

Vedi sopra per spiegazioni sullo spostamento e ridimensionamento della cornice immagine.

Con il mouse sulla cornice: Con il pannello Proprietà:

Ci sono due modi per spostare l'immagine:

  1. Tenere premuto Maiusc+Ctrl+Alt; facendo clic e trascinando all'interno della cornice si può spostare l'immagine (la cornice non si muove, e l'immagine si sposta al suo interno). Non appena i tasti vengono rilasciati, il movimento si applica di nuovo alla cornice invece che all'immagine.
  2. Fare clic sull'icona Modifica contenuto cornice sulla barra degli strumenti (da tastiera: E). Questo ha lo stesso effetto della pressione su Maiusc+Ctrl+Alt, con la differenza che si resta in modalità spostamento immagine finché si fa clic sull'icona Seleziona elemento oppure al di fuori della cornice.
  • Per adattare l'immagine alla cornice usando il mouse, fare clic sulla cornice, poi aprire la finestra Proprietà (tasto destro > Proprietà oppure premere F2) e selezionare la scheda Immagine. Qui attivare l'opzione Adatta alla cornice e l'opzione secondaria Proporzionale (con la quale le proporzioni dell'immagine vengono conservate. Se quest'opzione è deselezionata, l'immagine viene adattata alla cornice, e può essere distorta se le sue proporzioni sono diverse da quelle della cornice).
Qui si possono modificare la posizione dell'immagine all'interno della cornice e le dimensioni dell'immagine. Come nella scheda XYZ, ci sono tre modi per modificare i singoli valori:
  1. digitare il nuovo valore;
  2. fare clic sulle frecce "su" e "giù" a destra di ciascun valore, oppure usare i tasti "freccia su" e "freccia giù" della tastiera;
  3. usando la rotellina del mouse su ciascun valore; di solito basta spostare il puntatore del mouse sul valore da modificare, ma se ciò non ha effetto, fare clic sul valore.

Anche in questo caso, nelle modalità 2 e 3 la pressione sui tasti Ctrl, Maiusc, o Ctrl+Maiusc provoca la modifica delle decine o della parte decimale del valore. Per impostazione predefinita i valori Scala X, Scala Y, Risoluzione orizzontale attuale e Risoluzione verticale attuale sono legati tra loro (cioè quando si modifica uno viene modificato anche l'altro, mantenendo le proporzioni) ma possono essere scollegati facendo clic sull'icona "catena" a destra.

I valori in Proprietà > Immagine hanno i seguenti significati:

  • Pos X, Pos Y: questi valori indicano la posizione dell'immagine all'interno della cornice.
  • Scala X, Scala Y, Risoluzione orizzontale attuale e Risoluzione verticale attuale: per impostazione predefinita questi valori sono collegati tra loro; fare clic sull'icona "catena" per scollegarli. Ovviamente le dimensioni e il valore della risoluzione sono inversamente collegati, ma se il documento è destinato ed essere stampato in alta qualità è essenziale sapere il valore DPI del prodotto finito per ottenere un buon risultato. Se il documento è destinato ad essere pubblicato in rete o utilizzato per una presentazione, il valore DPI può essere più basso.

Alcuni ulteriori dettagli:

Nel menù contestuale (clic col tasto destro nella cornice) > Informazioni visualizza alcune informazioni sull'immagine: file di origine, dimensioni originali e attuali. Le informazioni sull'immagine possono essere visualizzate anche dal menù Utilità > Gestione immagini, che apre una finestra da cui si possono eseguire anche altre operazioni sull'immagine.

Rotazione

Con il mouse:

fare clic sull'icona Ruota elemento nella barra degli strumenti oppure premere R sulla tastiera, poi fare clic all'interno della cornice e ruotare trascinando fino a raggiungere l'angolo desiderato.

Nel pannello Proprietà:

la rotazione può essere modificata negli stessi tre modi visti per il ridimensionamento e posizionamento. Inoltre si può selezionare il punto intorno a cui avviene la rotazione ("Punto base") dall'icona al di sotto (che somiglia un po' a un dado).

Copia di cornici e altre operazioni simili

Ci sono più modi di copiare o spostare le cornici:

  1. con le comuni operazioni di copia e incolla (da tastiera: Ctrl+C, Ctrl+V) e di taglia e incolla (da tastiera: Ctrl+X, Ctrl+V), che si possono eseguire anche dal menù Modifica, e dal menù contestuale (fare clic col tasto destro del mouse all'interno della cornice). Per incollare in una pagina diversa, basta spostarsi in quella pagina, fare clic su di essa, e incollare; la cornice sarà incollata alle stesse coordinate che aveva sulla pagina originale.
  2. con l'operazione di duplicazione (da tastiera: Ctrl+D; da menù: Elemento > Duplica). Questa operazione crea una copia che è leggermente spostata rispetto all'originale, e collocata al di sopra di esso.
  3. con l'operazione di duplicazione multipla, Elemento > Duplicazione Multipla, che apre una finestra di dialogo in cui si può indicare il numero di copie da creare e lo spostamento che deve essere loro applicato. Si può utilizzare questa operazione anche per eseguire una singola copia quando si vuole impostare lo spostamento da applicare alla copia. Si noti che lo spostamento impostato qui sarà usato anche da Elemento > Duplica.
  4. è possibile anche trascinare un oggetto con il tasto destro del mouse. Dopo aver rilasciato il tasto, una piccola finestra di dialogo chiede se l'oggetto deve essere copiato o spostato o se si vuole annullare l'operazione.
  5. infine, si può usare la biblioteca (una raccolta di oggetti che possono essere riutilizzati in altre parti del documento o in documenti diversi). Si può copiare un oggetto nella biblioteca da menù Elemento > Invia alla biblioteca o dal menù contestuale (clic col tasto destro del mouse all'interno della cornice). Viene chiesto un nome per la cornice, che sarà copiata con il suo contenuto nella biblioteca. Per copiare un oggetto dalla biblioteca al documento, selezionare nel menù Finestre > Biblioteca, e scegliere l'operazione Incolla nella pagina. La biblioteca può essere salvata su file, e successivamente caricata in un altro documento e utilizzata in esso.

Con la pratica si può notare che le cornici possono trovarsi anche al di fuori dei bordi del documento, che possono comunque essere copiate, duplicate e manipolate in vari modi, e che la loro posizione si conserva anche salvando il documento. Ma se si tenta di generare un PDF da un tale documento, si ottengono dei messaggi di errore; essi possono essere ignorati, ma gli oggetti fuori dai bordi non saranno presenti nel PDF. Inoltre potrebbe accadere di dimenticarsi o non accorgersi dell'esistenza di questi oggetti "esterni", specialmente in documenti con molte pagine.

Quote e livelli

Quote

Le cornici (tutte, non solo quelle di testo) si possono pensare come oggetti bidimensionali che possono essere manipolati e spostati nello spazio di lavoro, un po' come foglietti che è possibile attaccare o staccare alla pagina. Come si farebbe con dei foglietti, le cornici vengono "appoggiate" una a una sulla pagina, e le nuove sono collocate al di sopra di quelle già presenti (a una "quota" più alta), formando tanti "strati" sovrapposti l'uno all'altro. Nella scheda XYZ della finestra Proprietà, i tasti Quota permettono di spostare la cornice selezionata a una quota superiore o inferiore; le frecce con barra spostano alla quota più alta o più bassa. La quota a cui la cornice si trova influenza la visibilità del suo contenuto, che può essere nascosto in tutto o in parte da altre cornici a quote superiori; e la cornice stessa può nascondere in tutto o in parte altre cornici a quote inferiori.

Livelli

La finestra Livelli

Un livello è uno spazio di lavoro nel quale si collocano cornici e altri oggetti. Un documento di Scribus può contenere uno o più livelli, che si possono pensare come altrettanti fogli trasparenti, grandi quanto l'intera pagina e sovrapposti l'uno all'altro. Il contenuto di ciascun livello è indipendente da quello degli altri; quando si lavora in un certo livello non si influisce sul contenuto degli altri. Per ciascun livello si può stabilire se esso deve essere visibile o invisibile, e se deve essere stampato oppure no. Un livello può essere bloccato per prevenirne la modifica accidentale.

Quando si crea un documento in Scribus, per impostazione predefinita si lavora nel livello "Sfondo". Questo è lo spazio di lavoro attivo, e al suo interno gli oggetti possono essere disposti su più quote. Facendo clic sul menù Finestre > Livelli (da tastiera: F6) si possono creare altri livelli. Si può lavorare su un solo livello per volta: il livello attivo può essere scelto dalla finestra Livelli oppure dal menù nella parte inferiore della finestra di Scribus.

Altre informazioni su come e perché usare i livelli si trovano nel tutorial: Get Started With Scribus:5.

La scheda XYZ: il resto

Gli altri pulsanti nella scheda XYZ hanno le seguenti funzioni:

  1. ribaltare la cornice selezionata orizzontalmente o verticalmente.
  2. bloccare la cornice. Una cornice bloccata non può essere spostata né ridimensionata, e il contenuto non può essere modificato (si noti che i rettangolini di spostamento sugli angoli e sui lati non vengono visualizzati). Copiare e incollare una cornice bloccata può dare risultati inattesi.
  3. bloccare le misure della cornice (in questo caso la cornice può essere spostata e il suo contenuto modificato).
  4. abilitare o disabilitare la stampa della cornice. Questo può essere utile ad esempio se una cornice contiene una nota (per se stessi o per altri) che non deve entrare a far parte della stampa finale, oppure la cornice potrebbe servire a "tenere occupato" un certo spazio per qualche altro scopo.

Proprietà: la scheda Forma

La scheda Forma
In alto nella scheda Forma è presente un pulsante con un quadrato al centro. Facendo clic sul pulsante si può trasformare velocemente la cornice da rettangolare a una delle altre forme mostrate nel menù a discesa. Facendo clic su Modifica si può dare alla cornice qualunque forma.

Un altro modo per dare una forma a una cornice immagine:

Si può anche usare lo strumento Poligono sulla barra degli strumenti (il suo uso è descritto altrove) per creare un poligono regolare, che poi può essere convertito in cornice immagine dal menù contestuale (clic col tasto destro del mouse nel poligono, poi Converti in > Cornice immagine).

Angoli arrotondati

Gli angoli della cornice vengono arrotondati (in misura più o meno accentuata a seconda del valore inserito. Se il valore è negativo gli angoli vengono arrotondati verso l'interno della cornice).

La finestra di dialogo Modifica Forma

Far scorrere il testo intorno a una cornice

Questa impostazione stabilisce cosa accade al testo che si trova sotto la cornice selezionata.
(Vedere Quote e livelli)

Quando si crea una cornice immagine, il riquadro di delimitazione e la linea di contorno coincidono. Ma facendo clic su Modifica è possibile modificare le dimensioni, la posizione e la forma delle linea di contorno, contrassegnando l'opzione Modifica linea contorno.

Particolare della scheda Forma

Ecco un esempio:

TextflowsExample.png

L'esempio mostra che la forma dell'immagine, il riquadro di delimitazione (linea rossa punteggiata), e la linea di contorno (linea grigia punteggiata) possono occupare spazi distinti. Il riquadro di delimitazione è sempre rettangolare, mentre la linea di contorno può avere forma arbitraria.

Contourbounding.png

Proprietà: scheda Linea

La linea di una cornice immagine è il suo bordo. Si noti che l'impostazione predefinita per il colore della linea è "Nessuno", e finché questo non verrà cambiato, il bordo sarà invisibile. Il colore della linea può essere impostato in Proprietà > Colori, in cui si può scegliere il colore della linea e dello sfondo per le cornici e i poligoni.

Le altre impostazioni per la linea sono evidenti e non richiedono spiegazioni. Le impostazioni disattivate non si applicano alle cornici.

Proprietà: scheda Colori

Come spiegato sopra, il colore linea si riferisce al colore del bordo della cornice; l'impostazione predefinita è "Nessuno".

Il colore di sfondo viene applicato allo sfondo della cornice; se è impostato a "Nessuno", lo sfondo sarà trasparente.

Tonalità indica la saturazione del colore. Opacità imposta l'opacità/trasparenza relativa del colore, con il valore 100% che equivale a totalmente opaco e 0% a totalmente trasparente. È opportuno notare che alcune versioni del formato PDF non prevedono questa proprietà e alcuni visualizzatori PDF non sono in grado di riprodurla.

Sovrastampa: Sfonda e Sovrastampa sono descritte qui.

Si noti che si possono usare altri colori oltre a quelli presenti nella scheda Colori, e se ne possono anche eliminare alcuni. Queste operazioni si eseguono nel menù Modifica> Colori. L'eliminazione di alcuni colori può rendere più semplice l'uso di Scribus, e riduce le dimensioni dei file.

Vedi anche



Torna.png Torna alla pagina iniziale - Torna al sommario