Tabelle

From Scribus Wiki
Jump to: navigation, search

Scribus è in grado di creare tabelle. Ma attualmente le tabelle di Scribus (a differenza di quelle create con gli elaboratori di testo) sono soltanto un insieme di cornici di testo raggruppate tra loro, e quindi può non essere comodo lavorare con loro.

Creazione di tabelle

Una tabella può essere creata:

  • facendo clic sull'icona Inserisci tabella nella barra degli strumenti;
  • selezionando Inserisci > Inserisci tabella nella barra dei menù;
  • da tastiera, premendo A, oppure Alt+I, A.

La tabella può essere posizionata e dimensionata con il mouse, facendo clic col tasto sinistro e trascinando diagonalmente sulla pagina. Al rilascio del mouse, compare una finestra di dialogo in cui si inseriscono il numero di righe e di colonne; premendo OK la tabella viene creata.

La tabella così creata è un insieme di cornici di testo raggruppate tra loro, e disposte sulla pagina in modo da avere l'aspetto di una tabella, in cui ogni cornice corrisponde a una cella. Per inserire del contenuto nella tabella, prima di tutto è necessario separare le cornici raggruppate (selezionare la tabella, poi dal menù principale: Elemento > Separa, oppure clic col tasto destro del mouse sulla tabella > Separa, oppure Ctrl + Maiusc + G).

Creazione di tabelle con il comando di duplicazione multipla

È possibile creare tabelle anche utilizzando il comando di duplicazione multipla. Questo comando si applica a un elemento e ne crea altri uguali, che possono essere in posizione spostata o ruotata rispetto a quello originario.

Ecco come procedere:

  1. creare una cornice di testo di misure e posizione opportuna, che sarà la prima cella in alto a sinistra della tabella;
  2. selezionare la cornice così creata e nella barra dei menù selezionare Elemento > Duplicazione multipla;
  3. nella finestra di dialogo che si apre, passare alla scheda Di righe & colonne e impostare il numero di righe e colonne desiderate;
  4. se si desidera che tra le celle vi sia uno spazio, impostare l'ampiezza di tale spazio nelle caselle Distanza orizzontale e Distanza verticale (se si inserisce un valore negativo, le celle potrebbero essere sovrapposte);
  5. quando le impostazioni sono soddisfacenti, premere OK.

Può essere opportuno modificare le caratteristiche della prima cornice di testo (bordo, colore) prima di eseguire la duplicazione.

Modifiche e perfezionamenti

Ciascuna cella è una cornice di testo a sé stante, e il suo contenuto è indipendente da quello delle altre celle della tabella. Non è possibile spostarsi tra le celle con il tasto di tabulazione (come accade negli elaboratori di testo). Invece, per modificare il contenuto della tabella è necessario selezionare le celle con il mouse e modificarle una a una.

Quando una tabella viene creata, le colonne hanno tutte la stessa larghezza, e le righe hanno tutte la stessa altezza. Per cambiare la larghezza di una colonna, selezionare tutte le celle (cornici) che formano la colonna, e trascinare con il mouse uno dei piccoli rettangoli rossi lungo il bordo fino alla larghezza desiderata. Le altre colonne non si adattano automaticamente, quindi dovranno essere ridimensionate manualmente. Lo stesso vale per le righe.

Per unire più celle (cornici), cancellarle tutte tranne una e allargare quella restante fino a riempire lo spazio vuoto rimasto (attenzione: il contenuto delle celle cancellate andrà perduto).

Suggerimento: per rendere più facile il posizionamento preciso delle celle della tabella, può essere utile creare delle guide in posizioni opportune (Pagina > Gestione linee guida) e attivare l'opzione di agganciamento alle guide (Pagina > Aggancia alle guide).

Si può simulare un bordo per l'intera tabella collocando dietro di essa una forma rettangolare (Inserisci > Forma) con le stesse misure della tabella, o leggermente più grande, e impostando adeguatamente i suoi attributi di linea (finestra Proprietà, schede Linea e Colori). Inoltre si possono modificare secondo necessità gli attributi di linea delle singole celle (per impostazione predefinita le celle/cornici avranno il colore di bordo impostato a "nessuno" e quindi il bordo sarà invisibile). Oppure si possono disporre le celle in modo da lasciare uno spazio tra loro (questo può essere fatto facilmente se la tabella si crea con il comando di duplicazione multipla, vedi sopra), e dare un colore di fondo alla forma rettangolare sottostante.

Può essere un po' laborioso, ma in Scribus è possibile costruire anche tabelle complesse soddisfacenti per molte situazioni.

Scribtable.png

Tabelle complesse

Ecco un procedimento alternativo per inserire tabelle complesse in un documento di Scribus.

  1. creare la tabella in OpenOffice.org usando Writer o Calc.
  2. copiare la tabella negli appunti (se usate Calc, non copiare l'intero foglio, ma solo la parte che deve essere inserita in Scribus); creare un nuovo documento in OpenOffice.org Draw, e usare il comando Modifica > Incolla speciale > Metafile GDI per inserire la tabella in Draw come file vettoriale.
  3. con il comando File > Esporta esportare l'immagine come file EPS. Controllare che nella finestra di dialogo di esportazione sia selezionata l'opzione Selezione, altrimenti sarà esportata l'intera pagina.
  4. importare in Scribus il file EPS come immagine vettoriale con il comando File > Importa > Carica file vettoriale.


Torna.png Torna alla pagina iniziale - Torna al sommario