Difference between revisions of "Вводный курс по Scribus:4"

From Scribus Wiki
Jump to navigation Jump to search
Line 36: Line 36:
  
 
===Остальные блоки обложки===
 
===Остальные блоки обложки===
[[Image:Properties4-FYug133_ru.png|left|thumb|272px|Properties Palette - Color/Shade]]Draw another rectangle towards the centre of the image. In the Properties Tool ('''X,Y,Z'''), give X-Pos: 93mm. Y-Pos: 160mm. Width: 115.35mm. Height: 13.75mm. Again in '''Colors''', set the stroke to 'None', and the fill with 'Black' at an opacity of 69%. Call this the 'HeadlineBand'. A third rectangle, named 'SubHeadBand' can be drawn slightly underneath this, at X-Pos: 100mm. y-Pos: 180mm. Width: 109.7mm. Height: 18.35mm. The fourth and final rectangle, this time a little square box, will have the following Properties: X-Pos: 20.5mm. Y-Pos: 245mm. Width and Height will both be 9mm.
+
[[Image:Properties4-FYug133_ru.png|left|thumb|272px|Свойства объекта - Цвет/Тень]]Нарисуйте другой прямоугольник примерно по центру обложки. В Свойствах объекта ('''X,Y,Z'''), задайте X-Поз: 93mm. Y-Поз: 160mm. Ширина: 115.35mm. Высота: 13.75mm. И снова во вкладке '''Цвета''' установите цвет границ в 'Никакого', а в заливке выберите 'Black' с прозрачностью 69%. Назовите этот прямоугольник 'HeadlineBand'. Третий прямоугольник, 'SubHeadBand', должен быть нарисован немного ниже второго: X-Поз: 100mm. Y-Поз: 180mm. Ширина: 109.7mm. Высота: 18.35mm. Четвертый и последний прямоугольник, на этот раз маленький квадрат, должен иметь следующие параметры: X-Поз: 20.5mm. Y-Поз: 245mm. Ширина и Высота по 9mm.
 
{|
 
{|
| bgcolor="palegreen" | Here is a shortcut you might try for a repetitive job like this. Instead of making each rectangle from scratch, then changing all of these parameters, after you make the first one and adjust its colors, just copy it: '''Item > Duplicate'''. Then all you have to adjust is its name, position, and size.
+
| bgcolor="palegreen" | Здесь кратко описано, как вы можете немного оптимизировать создание похожих элементов. Вместо создания каждого прямоугольника с нуля, и дальнейшего изменения всех параметров, после того как вы создадите первый прямоугольник и выберете его цвет, просто скопируйте его: '''Объект > Продублировать'''. Теперь все, что ван нужно будет изменить у прямоугольников - это имя, расположение и размер.
 
|}
 
|}
  

Revision as of 17:50, 3 December 2009

 Вводный курс по Scribus 2006
Авторы современной версии:   Авторы вики Scribus
Автор исходного текста:   Niyam Bhushan, 2004
Лицензия:   GNU Free Documentation License, Version 1.2
    
 Глава 4

Главная страница

Вступление

  1. Что вы можете делать при помощи Scribus
  2. Перед началом работы
  3. Изначальный вакуум
  4. Обложка
  5. Работа со слоями страницы
  6. Макетирование нескольких страниц
  7. Создание конечного макета
  8. Макетирование с графикой
  9. Зажгите огонь графикой в SVG
  10. Публикации нужны свободные PDF
  11. Путешествие на скорости Scribus
  12. Участники
  13. GNU Free Documentation Licence

Обложка

Если вы видите слишком много салатовых линий на только что созданной странице, то зайдите в меню “Вид” и уберите галочку напротив "Показывать сетку". Должны остаться только синие линии, обозначающие границы страницы. Принцип работы в Scribus’е прост: что бы поместить фотографию на страницу, необходимо сначала создать для нее блок, в который и будет вставлена сама фотография. Точно так же и со вставкой текста. Сначала создаем блок, а потом уже вставляем в него текст, который мог быть создан в любом текстовом редакторе. В скором времени, вы поймете, что данный подход имеет существенные преимущества.

Вставка блока изображения

Панель инструментов Scribus’a содержит все необходимые инструменты для работы. Напомним, при подведении указателя мыши к иконке каждого инструмента, выпадет подсказка с названием данного инструмента. Нажмите на третьем (Добавить изображениеButton-Image.png ) [на клавиатуре: I] Это позволит создать блок на странице, в который потом можно будет вставить фотографию. Нажмите правой кнопкой мыши в верхнем левом углу и удерживая кнопку мыши тяните к правому нижнему углу.

Frame-Image.png

Пунктирными линиями будут обозначаться границы будущего блока. Отпустив правую кнопку мыши у вас должен получиться большой прямоугольник с черными диагоналями внутри, образующими букву X. Не волнуйтесь, эти диагонали не будут печататься, это традиция печатной промышленности, созданная для того, что бы отличить блок для текста от блока для изображения.

Душа Scribus

Поставьте галочку в пункте меню Инструменты > Свойства (в Scribus 1.3.x Окна > Свойства) либо нажмите F2. Появившееся диалоговое окно - это сердце и душа Scribus. Все объекты, добавленные вами в документ - графические блоки, тектовые блоки, или те же фотографии, тексты и линии - все они настраиваются в этом диалоговом окне. Убедитесь, что созданный вами графический блок подсвечен, или выделен. Обычно в качестве знака выделения объекта используется красный (либо другого цвета) пунктир и квадраты по всем четырем углам блока. Если выделения нет, нажмите на Панели инструментов первую иконку Button-Arrow.png (Выбрать объект (C)), а потом просто щелкните по нужному объекту. В диалоговом окне свойств тотчас должны появиться все доступные для него параметры. Объект обязательно должен быть выделен для редактирования или удаления.

Properties Palette

Придумайте и введите четкое и понятное название для этого графического блока, такое как 'ОбложкаИзображение' в поле 'Имя'. В том случае, когда вы не видите поле 'Имя', просто щелкните левой кнопкой мыши в верхней вкладке, где написано X,Y,Z. Далее точно совместим верхний левый угол вашего изображения с верхним левым углом страницы. Для этого в полях X-Поз и Y-Поз укажите в качестве значений 0mm. "Поз" - это сокращение от "Позиция":). В поля Ширина и Высота введите 210 mm и 280 mm соответственно. Ваш графический блок прилипнет к углу страницы. И хотя вы можете перемещать и менять размер объектов с помощью мыши, вводить эти значения напрямую - гораздо быстрее, и это сэкономит вам много времени.

Получение изображения

Теперь, снова убедившись, что ваш графический блок выбран, кликните правой кнопкой мыши в любом месте внутри него. Вы должны увидеть Контекстное меню вверху и справа от курсора мыши. Выберите пункт Вставить картинку... (в версии 1.3.x это будет Вставить изображение...). Откроется диалоговое окно выбора файлов, с помощью которого вы будете осуществлять навигацию внутри вашей папки FYug, тогда внутри папки с изображениями вы должны выбрать файл 'TitleFX.jpg'. Нажмите кнопку Открыть. Графический блок на вашей странице Scribus тотчас заполнится изображением из файла TitleFX.jpg.

Смещение изображения влево

Заметьте, что скульптура на изображении слишком сильно смещена вправо. Мы должны подвинуть картинку внутри графического блока влево, с тем чтобы скульптура расположилась в центре блока. Оставшиеся части изображения, которые не вмещаются в видимые границы графического блока мы автоматически обрежем. Во-первых, осуществим позиционирование при помощи мыши. На Панели инструментов нажмите кнопку Изменить содержимое блока (E) Button-Edit-Content.png.

Вкладка "Изображение"

Теперь, щелкнув левой кнопкой мыши внутри графического блока, вы сможете вручную перемещать картинку в нем, и для работы с некоторыми проектами такой точности может быть вполне достаточно. Но для нашего проекта нужна большая точность. Для начала убедитесь, что графический блок выбран (нажмите Выбрать объект панели иструментов и кликните по своему объекту снова или попробуйте это: левый клик снаружи вашего блока - и вы увидите, что иконка Выбрать объект нажата, теперь левый клик внутри блока выберет его). Сейчас вернитесь обратно к диалоговому окну свойств и выберите вкладку с названием 'Изображение'. В поле, помеченном как X-Поз установите значение “-90mm” для перемещения изображения на 90 мм влево. Посмотрите, как изменилось изображение в графическом блоке.

Цветовая карма

Внизу диалога свойств (вкладка Изображение), вы могли заметить раздел 'Входной профиль'. Он может быть виден только в том случае, если LittleCMS на вашем ПК правильно установлена и сконфигурирована. Цвета вашего изображения на экране могут сильно отличаться от исходных, несоответствие может стать еще больше, если вы распечатаете его. Этот раздел позволяет свести к минимуму несоответствие цветов. В верхней части раздела 'Входной профиль' выберите цветовой профиль, который лучше других подходит для вашего монитора. Scribus тут же перерисует изображение на экране для отображения цветов в выбранном профиле.

Фактически установка LittleCMS и использование этой библиотеки в связке со Scribus задача довольно простая, но она выходит за рамки этого руководства. Ограничимся лишь несколькими советами:

  1. Скачайте набор свободных профилей с Сайта компании Adobe, таким образом вы сможете легко перемещать изображения между компьютерами с MacOS, Windows и Linux.
  2. Создайте вручную цветовой профиль для своего собственного монитора и используйте его как основной.

Сохранение

Вы должны сохранить свой файл, прежде чем продолжить. Для этого выберите Файл>Сохранить и введите для него имя 'Fyug.sla'. Сохраните его в папке FYug. Теперь вы можете просто нажимать на иконку с дискетой в панели задач для текущего сохранения своего файла.Button-Save.png

Блок названия журнала

На обложке любого журнала вдоль верхнего края расположен логотип с его названием. Это называется Masthead (к сожалению, адекватного этому русского термина не существует). Наш называется “FreedomYug”. Мы начнем с создания полупрозрачных подложек для названия журнала (Masthead). Идем в меню Settings > Preferences > Display (для версии 1.3.x Файл > Параметры документа > Экспорт в PDF). Убедитесь, что выбрано “Использовать PDF1.4 Transparency Features” (В 1.3.x убедитесь, что в поле Совместимость стоит PDF 1.4). Нажмите OK. Теперь ваш документ поддерживает прозрачные объекты.

Окно свойств объекта - Masthead

Нажмите пятую иконку Button-rectangle.png в Панели инструментов. Когда вы наведете на этот инструмент курсор мыши, должен появиться текст “Добавить фигуру” или что-то подобное. Выберите прямоугольник в выпадающем меню. Нажмите левую кнопку мыши примерно сверху по центру обложки и нарисуйте прямоугольник. Убедившись, что прямоугольник выбран, зайдите в окно свойств объекта, кликните по вкладке X,Y,Z, и введите следующие значения: X-Поз: 30mm. Y-Поз: 0mm. Ширина: 150mm. Высота: 33mm. Дайте блоку имя, например 'MastheadBand'. Теперь перейдите на вкладку Цвета. Выберите Изменить свойства цвета линии Button-Pencil.png для изменения свойств границы объекта. Нажмите 'Никакого' в списке цветов. Теперь выберите иконку с ведром для изменения цвета самого прямоугольника. Нажмите 'Black' в списке доступных цветов, а в поле прозрачность введите 69% (если вы не видите поля Прозрачность, значит вы не выбрали совместимость со стандартом PDF 1.4 -- смотрите первый абзац этого пункта). Вы должны увидеть, что прямоугольник стал полупрозрачным, и сквозь него можно частично увидеть картинку - немного затемненную. Поэкспериментируйте с прозрачностью и другими цветами на свой вкус.

Остальные блоки обложки

Свойства объекта - Цвет/Тень

Нарисуйте другой прямоугольник примерно по центру обложки. В Свойствах объекта (X,Y,Z), задайте X-Поз: 93mm. Y-Поз: 160mm. Ширина: 115.35mm. Высота: 13.75mm. И снова во вкладке Цвета установите цвет границ в 'Никакого', а в заливке выберите 'Black' с прозрачностью 69%. Назовите этот прямоугольник 'HeadlineBand'. Третий прямоугольник, 'SubHeadBand', должен быть нарисован немного ниже второго: X-Поз: 100mm. Y-Поз: 180mm. Ширина: 109.7mm. Высота: 18.35mm. Четвертый и последний прямоугольник, на этот раз маленький квадрат, должен иметь следующие параметры: X-Поз: 20.5mm. Y-Поз: 245mm. Ширина и Высота по 9mm.

Здесь кратко описано, как вы можете немного оптимизировать создание похожих элементов. Вместо создания каждого прямоугольника с нуля, и дальнейшего изменения всех параметров, после того как вы создадите первый прямоугольник и выберете его цвет, просто скопируйте его: Объект > Продублировать. Теперь все, что ван нужно будет изменить у прямоугольников - это имя, расположение и размер.

Создание цветов

Hold on! Don't fill this with the same 69% Black. Let's give it a fresh lime green color. Go to Edit > Colors... in the menu. A dialog box listing existing colors displays on your screen. Click on 'New' and give your new color swatch a name, 'Lime Green' (if you already have a LimeGreen, call it LimeGreen2 or something else). In the second dialog-box that opens up, choose 'CMYK' as the Color Model. This closely follows the inks of Cyan, Magenta, Yellow, and Black, used in your desktop printer and in printing plants, that mix inks to create new colors. With the sliders at the bottom, give C:69%, M: 10%, Y:100%, and K: 0%.

Click OK in this dialog box, and then click OK again in the Colors dialog box, where you'll notice your new color added. Go back to your page, click on the small square you just created, and in the Colors tab of Properties Tool, give it a stroke of None, and a fill of LimeGreen, at 100% opacity. You cover should look like the screenshot here, with all the bands for text.

FYugcover stage1.png

Запертые блоки

One last thing. Select each semi-transparant band individually, and in the Properties palette, in the X,Y,Z tab, click on the icon of the padlock Button-Lock.png at the bottom. This ensures you accidentally do not move or resize each locked object.

Similarly, lock the CoverPicture Frame as well, and the green square, using this padlock. Also, uncheck 'Text Flows Around Frame' in the Shape tab of the Properties Tool for each of these rectangles. This allows text to overlap the rectangles.

Checkbox-Text-Overflows ru.png