Praca z ramkami tekstowymi

From Scribus Wiki
Revision as of 16:18, 2 December 2006 by Deejay1 (talk | contribs) ('POLONized' image)
Jump to: navigation, search
edytuj

Strona główna

Jak to zrobić

  1. Pierwsze kroki ze Scribusem
  2. Praca z ramkami tekstowymi
  3. Praca z ramkami graficznymi
  4. Praca ze stronami wzorcowymi
  5. Praca w Edytorze artykułów
  6. Tekst na krzywej
  7. Scribus w Ubuntu Linux
  8. Klik i Scribus działa
  9. Instalacja za pomocą Cmake
  10. Tworzenie spisu treści
  11. Formularze PDF
  12. Kolory dodatkowe
  13. Obrazek ze ścieżką odcięcia

Porady i triki

  1. Instalacja profili ICC
  2. Dodawanie fontów
  3. Import grafik EPS
  4. Zawieszone spójniki
  5. Twój pierwszy artykuł
  6. Tworzenie hiperłączy

Często zadawane pytania

  1. Zarządzanie kolorami
  2. Skąd pobrać Scribusa?
  3. Podgląd wydruku nie działa
  4. Scribus dla MacOSX?
  5. Dodawanie fontów
  6. Scribus po polsku
  7. Type 1 i ligatury
  8. Automatyczne numery stron
  9. Interlinia w Scribusie
  10. Pierwsze kroki z DTP
  11. Skalowanie obrazka w ramce
  12. Export do PDF/X-3
  13. Ligatury i cyfry nautyczne?
  14. Pomoc w rozwoju Scribusa
  15. Przykładowe dokumenty
  16. Zgłaszanie błędów
  17. Słowniki dzielenia na sylaby


Tłumaczenie w toku!


Ten artykuł opisuje różne czynności związane z pracą z ramkami tekstowymi.

Tworzenie

Utwórz ramkę tekstową:

  1. klikając ikonę Utwórz ramkę tekstową na pasku narzędzi
  2. lub wybierając z menu opcję Wstaw > Ramka tekstowa
  3. skrótem klawiszowym: T lub Alt+W, T.

Pozwoli to na umiejscowienie i wybranie rozmiaru ramki za pomocą myszy. Aby tego dokonać przyciśnij lewy klawisz myszy, a następnie przeciągnij kursor po przekątnej strony. Przyciśnięcie klawisza myszy wyznacza jeden róg ramki, a puszczenie go wyznaczy róg znajdujący się na końcu przekątnej. Najbardziej typowym sposobem jest zaczęcie w lewym górnym rogu, jednakże można zacząć w dowolnym z nich.

Usuwanie

Usuń wybraną ramkę przyciskając klawisz Delete lub Ctrl+X.

Menu kontekstowe

Klikając prawym klawiszem myszki uzyskasz dostęp do menu kontekstowego, które zawiera najczęściej wykonywane operacje na ramkach, z których najważniejszą jest możliwość zamiany ramki tekstowej na inny typ ramki.

Pozycja i rozmiar

Właściwości: Zakładka XYZ

W tym punkcie zauważysz, że okno Właściwości jest niezastąpionym elementem podczas pracy ze Scribusem. Jeśli nie jest okno wyświetlone na ekranie, możesz otworzyć je poprzez skorzystanie z menu Okna > Właściwości. Zakładka XYZ okna Właściwości pokazuje bardzo dokładne informacje o pozycji punktów X i Y lewego górnego rogu wybranej ramki - oznaczonej kreskowaną, czerwoną ramką. Ramka jest automatycznie wybierana w chwili jej utworzenia. Możesz odznaczyć ramkę klikając na obszar poza jej granicami, a zaznaczyć ponownie klikając w jej wnętrzu. Ramka musi zostać zaznaczona, aby mogła być modyfikowana lub przestawiana.

Zmiana rozmiaru/pozycji

Za pomocą myszy:

  1. Kliknij we wnętrzu ramki i przeciągnij na wybraną pozycję. Ramki mogą być umieszczane również poza stroną lub przesuwane z jednej strony na drugą (w zależności od wersji Scribusa).
  2. Kliknij i przeciągnij dowolny z czerwonych prostokątów umieszczonych na ramce by zmienić jej rozmiar.

Za pomocą okna Właściwości:

Istnieją 3 sposoby zmiany poszczególnych ustawień --

  1. edycja za pomocą klawiatury
  2. klikając na strzałkach w górę lub w dół umieszczonych na prawo od każdej wartości. Naciskając klawisze kursorów na klawiaturze uzyskasz ten sam efekt.
  3. używając rolki myszy -- zazwyczaj ustawienie kursora nad polem w zupełności wystarcza, jeśli nie kliknij w nie najpierw

Zauważ że dla drugiego i trzeciego sposobu, równoczesne przytrzymanie klawiszy Ctrl, Shift lub Ctrl+Shift (działa również dla klawiszy kursorów) możesz wybrać, które miejsce po przecinku ma zostać zmienione. Dodatkowo używając okna Właściwości, wysokość i szerokość są domyślne ze sobą połączone, lecz wystarczy kliknięcie na ikonę łańcucha by je rozłączyć.

Dodatkowe informacje

  • Wybranie z menu pozycji Strona > Wyrównaj do linii pomocniczych spowoduje przyciąganie ramki do linii pomocniczych na stronie. Widok > Wyświetlaj linie pomocnicze wyświetla je na ekranie. (Tak jak siatka, linie pomocnicze nigdy nie zostaną wydrukowane ani nie staną się częścią pliku PDF.). Jeśli chcesz zmienić lub dodać nowe linie pomocnicze, skorzystaj z menu Strona > Zarządzaj liniami pomocniczymi lub Plik > Konfiguracja > Linie pomocnicze.

Obracanie

Za pomocą myszy:

Kliknij ikonę Obróć element na pasku narzędzi (skrót klawiszowy: R), a następnie kliknij wewnątrz ramki i ciągle trzymając lewy klawisz myszy obróć o żądany kąt.

Za pomocą okna Właściwości:

Tak jak podczas zmiany rozmiaru i pozycji istnieją takie same możliwości zmiany parametrów obrotu ramki. Ponadto poniżej znajduje się ikona (wyglądająca jak para kostek) pozwalająca zmienić oś, wokół której następuje obrót -- może to być środek lub jeden z czterech rogów ramki.

Kopiowanie ramek i inne operacje

Istnieje wiele sposobów na to, aby skopiować lub przesunąć ramki.

  1. Na pewno znana jest Ci czynność kopiowania i wklejania (skróty klawiszowe: Ctrl+C, Ctrl+V) oraz wycinania i wklejania (skróty klawiszowe: Ctrl+X, Ctrl+V) -- dostępna także z menu Edycja oraz z menu kontekstowego (dostępnym poprzez kliknięcie prawym klawiszem myszki wewnątrz ramki). By wkleić na inną stronę, przejdź do żądanej strony, kliknij w nią, a następnie wklej -- ramka będzie umieszczona w tym samym miejscu co na oryginalnej stronie.
  2. Jest także możliwość klonowania elementów (skrót klawiszowy: Ctrl+Alt+Shift+D) Obiekt > Klonuj. Tworzy ona kopię, która jest przesunięta i umieszczona warstwę wyżej względem oryginału.
  3. Znajdziesz też opcję wielokrotnego klonowania (Obiekt > Wielokrotne klonowanie) która wyświetli okno pozwalające na utworzenie dowolnej ilości kopii z dowolnym przesunięciem. Ponadto możesz użyć tej opcji do jednokrotnego klonowania z wybranym przesunięciem. Uwaga: jeśli ustawisz przesunięcie w tym oknie, będzie ono wykorzystywane również przez Obiekt > Klonuj.
  4. Możesz też przesunąć obiekt za pomocą prawego klawisza myszy. Po zwolnieniu przycisku zostanie wyświetlone okno dialogowe z zapytaniem czy obiekt ma zostać skopiowany, przesunięty lub czy operacja ma zostać anulowana.
  5. Ponadto istnieje Biblioteka (Obiekt > Dodaj do biblioteki lub za pomocą menu kontekstowego). Utworzy to nazwaną kopię wybranej ramki wraz z jej zawartością w Bibliotece. Aby uzyskać do niej dostęp, wybierz z menu Okna > Biblioteka -- zostanie wtedy wyświetlone okno, z którego możesz wkleić żądany obiekt na stronę. Zauważ, że możesz zapisać całą zawartość Biblioteki do pliku, który może zostać załadowany w innym dokumencie.

Zapewne zauważysz, że ramki mogą znajdować się poza granicami strony i nadal podlegać kopiowaniu, klonowaniu i być manipulowane na różne sposoby. Zostają również zapisywane wraz z dokumentem z zachowaniem ich aktualnych pozycji. Jednakże podczas generowania dokumentu PDF zostanie wyświetlone ostrzeżenie, że niektóre elementy nie znajdują się na stronie -- jeśli zostanie zignorowane, wygenerowany dokument PDF nie będzie zawierał tych elementów. Ponadto, szczególnie w przypadku dużych dokumentów, można łatwo stracić kontrolę nad elementami znajdującymi się poza stroną.

Edycja tekstu w ramce

Edytor artykułów

Mając wybraną ramkę tekstową kliknij ikonę Edytor artykułów na pasku narzędzi (skrót klawiszowy: Ctrl+Y) lub wybierz z menu pozycję Edycja > Edytuj tekst -- opcja ta jest również dostępna w menu kontekstowym (kliknij prawym klawiszem myszy w ramce). Edytor artykułów jest najbardziej wydajnym sposobem ręcznego wpisywania tekstu. Tekst zostanie wyświetlony w poprawnym kolorze, jednakże krój czcionki jak i podcinanie nie zostaną pokazane bezpośrednio w Edytorze artykułów. Jeśli kolor czcionki jest podobny do koloru tła Edytora artykułów, możesz dowolnie zmienić jego kolor poprzez menu Ustawienia > Tło....

Wiele możliwości Edytora artykułów zostało opisanych w innym miejscu (zobacz też rozdział pod tytułem Właściwości: Zakładka Tekst poniżej - układ jest inny, lecz możliwości identyczne). W tej chwili, ważne jest tylko to, że za pomocą Edytora artykułów masz pełną kontrolę nad dużymi ilościami tekstu, m.in. nad krojem czcionki, kerningiem, wyrównaniem, itp. Uwaga: zmiana ustawień dotyczy tylko obecnie zaznaczonego fragmentu tekstu jak i wpisanego później.

Poświęć trochę czasu, by nauczyć się tworzyć i używać stylów, które pozwolą zaoszczędzić czas przy częstym używaniu czcionek ze specyficznym zestawem cech.

Edycja w głównym obszarze roboczym

Kliknij ikonę Edytuj zawartość ramki na pasku narzędzi (skrót klawiszowy: E). W chwili, gdy klikniesz wewnątrz ramki, zobaczysz mrugający pionowy znak kursora, który pozwala na dodanie lub edycję tekstu. Możesz również zaznaczyć (podświetlić) tekst i zmienić jego cechy korzystając z okna Właściwości > Tekst, przy czym możliwości są analogiczne go tych w Edytorze Artykułów.

Formatowanie całości tekstu w ramce

Jeśli jeszcze nie jest zaznaczona, kliknij ikonę Wybierz obiekt na pasku narzędzi (skrót klawiszowy: C | uwaga -- jeśli znajdujesz się już w trybie edycji tekstu w ramce, naciśnięcie klawisza C spowoduje dopisanie znaku do zawartości tejże ramki). Następnie wybierz ramkę, której zawartość chcesz edytować. Jeżeli w tym momencie dokonasz zmian w zakładce Tekst okna Właściwości, cały tekst zawarty w ramce zostanie zmodyfikowany.

Znaki specjalne oraz obcojęzyczne

Istnieje potencjalna możliwość wstawiania znaków używanych w innych językach, symboli specjalnych nie znajdujących się na klawiaturze, znaków typograficznych (takich jak np. cudzysłowy, dywizy, spacje o różnej długości) oraz ligatur. Można uzyskać do niej dostęp zarówno poprzez główne menu lub Edytor Artykułów za pomocą pozycji Wstaw > Glif, Wstaw > Znak, Wstaw > Cytat, Wstaw > Spacje i przenoszenie, jak i Wstaw > Ligatury.

  • Jeśli znak specjalny nie zostaje poprawnie wyświetlony, przeważnie oznacza to iż nie występuje on w aktualnie używanej czcionce. Fakt, iż znak wyświetla się on poprawnie w Edytorze Artykułów nie oznacza, że zostanie poprawnie wyświetlony na stronie.
  • Zobacz również Typografia.

Pobieranie tekstu z pliku

Aby pobrać tekst z pliku, wybierz z menu kontekstowego (poprzez kliknięcie prawym przyciskiem myszy wewnątrz ramki) pozycję Pobierz tekst lub skorzystaj z menu Plik > Importuj > Pobierz tekst. Możesz również dołączyć tekst do ramki jak i wgrać plik tekstowy bezpośrednio w edytorze artykułów.

Dostępne są też specjalne pliki z tekstem "lorem ipsum" w różnych językach - aby skorzystać z nich użyj pozycji "Przykładowy tekst" menu kontekstowego lub poprzez Wstaw > Przykładowy tekst.

Łączenie ramek ze sobą

Tekst może przepływać z jednej ramki do drugiej, zarówno na tej samej stronie jak i na różnych.

Na początku upewnij się, że jest zaznaczona pierwsza ramka, następnie kliknij ikonę Połącz ramki tekstowe na pasku narzędzi (skrót klawiszowy: N), po czym kliknij w drugą ramkę -- to wszystko. Jeśli masz więcej ramek do złączenia po prostu klikaj w nie, aż uzyskasz porządany efekt. Pamiętaj, że ramki łączą się ze sobą w takiej kolejności w jakiej klikasz.

Zauważ, że ramki można łączyć zarówno przed jak i po umieszczeniu w nich zawartości.

Ikona Rozłącz ramki tekstowe jest podobna w użyciu -- kliknij pierwszą ramkę, następnie ikonę Rozłącz ramki tekstowe i klikaj kolejno w ramki, które mają zostać rozłączone.

Poziomy i warstwy

Ramki w ogólności, nie tylko tekstowe, reprezentują dwu wymiarową przestrzeń, którą możesz manipulować i przesuwać po swoim obszarze roboczym, podobnie jak notatkę, którą możesz dowolnie przyczepiać i odczepiać. Tak jak normalne kartki z notatkami, są one układane jedna na drugiej na stronie, każda warstwę powyżej innych. Mały obszar nazwany Poziom w zakładce XYZ okna Właściwości pozwala na przesuwanie ramki w górę lub dół poszczególnych warstw; strzałki z poprzeczkami przesuwają obiekty na samą górę lub na dół stosu. Jako że tło ramki może być przeźroczyste lub wypełnione, poziom na której znajduje się będzie miał wpływ na to jaki jej fragment będzie widoczny w nawiązaniu do innych ramek leżących wyżej lub niżej.

Zakładka XYZ: Pozostałe funkcje

Pozostałe przyciski w zakładce XYZ odpowiadają za następujące funkcje:

  1. Odwracanie ramki w pionie lub w poziomie.
  2. Zabezpieczanie ramki. Wszystkie właściwości ramki zostają zabezpieczone -- rozmiar, pozycja, zawartość. Kopiowanie i wklejanie do takiej ramki może przynieść nieoczekiwane efekty.
  3. Zabezpieczanie rozmiarów ramki. Zauważ, że punkty sterujące w rogach i po bokach ramki znikają po użyciu tej funkcji.
  4. Włączanie/wyłączanie drukowania ramki. Po co ktoś miałby to robić? Czasem po prostu przydaje się ramka na stronie zawierająca wyłącznie jakąś informację dla siebie lub kogoś innego, jednakże nie mająca stać się częścią gotowej pracy, lub może tylko ma zajmować miejsce pod jakiś inny element.

Properties: Shape Tab

Właściwości: Zakładka Kształt ramki


Edit Shape requester
v 1.3.3.3

Click the Shape tab in Properties. Near the top is a button with a square in the center. If you click that button, you may quickly switch to one of a group of set shapes from your original rectangle. In addition, if you click Edit Shape, you now have full vector-editing control of your shape.


Another angle on shapes and text frames:

You may also use the Polygon tool on the toolbar (use will be described in detail in another section) to create a regular polygon, which may then be converted using the Context Menu (right-click in the polygon) to Convert To > Text Frame. Note that before you enter text, you may want to change the background color of the frame.

Round Corners

Causes an adjustable degree of rounding of the Text Frame corners. Also note the effect of negative values.

Distance of Text

Columns, Gap: Set the number of columns inside the frame and the gap between columns.

Top, Bottom, Left, and Right adjust the space from the edge of the frame to the text inside.

Tabulators: For setting tab stops within your frame.

Text Flows Around Frame

Use this to determine what happens with text underneath the selected frame.
Remember Levels & Layers?

When you create an image frame, the Bounding Box (of the image) and the Contour Line are the same size and position. But click on Edit Shape... and you can change this Contour Line's size, position, and shape as desired -- just check the box for Edit Contour Line.

Close-up in Shape Tab
Here is an example with an image frame, but this could just as well be a text frame:

Textflows example.jpg

Properties: Text Tab

The top two buttons are straightforward: font face and style. Remember that if you are in Select Item mode, as opposed to Edit Contents mode, changes in the font settings will change all the text in the frame. To modify only some of the text, switch to Edit Contents mode (keyboard: E), then highlight the text you wish to modify.


Właściwości: Zakładka Tekst

Next is a block of six requestors with number values:

  1. Left top is font size
  2. Left middle is the space between lines of text. When you are in Select Item mode, this will automatically change as you adjust font size (but can be adjusted afterward independently), in Edit Contents mode it will not. See Working with Story Editor: Font Size and Line Spacing about the different ways that font size and line spacing adjustments interact.
    You may change the degree of automatic line spacing in File > Preferences > Typography.
  3. Left bottom is the width of characters -- note that height remains constant
  4. Right top raises (positive values) or lowers selected characters from the baseline. This adjustment is not present in Story Editor.
  5. Right middle is kerning: the distance between characters
  6. Right bottom adjusts height of characters -- note that width remains constant, and that characters remain on the baseline.

As described above in Resizing, Repositioning, there are three ways to change these values.


There are two color buttons next, the top referring to the outline and/or shadow if selected (see below, items 8 and 9), and the bottom to the fill color. Aside from the hue, you may also adjust saturation - click on the number for a list of choices.


A row of buttons follows, so from left to right:

  1. Underline, including spaces between words. Adjustable line width, vertical position. No adjustments in v1.2.4
  2. Underline, characters only. Adjustable line width, vertical position. Not available in v1.2.4
  3. Subscript. You may also want or need to adjust size. For v1.2.4, adjustments are in Effects > Preferences > Typography
  4. Superscript. Size is separately adjusted. For v1.2.4, adjustments are in Effects > Preferences > Typography
  5. All caps. Applies to letters. Not available in v1.2.4
  6. All small caps. Letters only; sizes of other characters and capitalized letters not affected.
  7. Strikethrough. Line width and position adjustable. No adjustments in v1.2.4
  8. Adds an outline to the font, width adjustable. No adjustments in v1.2.4
  9. Creates a shadow, in essence a duplication of the character, just "behind" it, position adjustable. You may have both an outline and a shadow, but both will have the same color and shade. Not available in v1.2.4
  10. Reverse (horizontal mirror image) of selected letters.

The next row of buttons selects justification. The rightmost button forces every line to be fully justified, which can produce unexpected results.


The Style button allows for easy application of a set of font features. There are no default styles, these are user-created. See the Menu item Edit > Paragraph Styles... or Edit > Line Styles... to create a New style, or Save and Import styles.

For more on styles, see Working with Story Editor:Styles.

Lastly, the Language button chooses a language for automatic hyphenation.

Properties: Line Tab

The Line of a Text Frame refers to the border of the frame. The first thing to be aware of is that the default setting for Line Color is None, so regardless of the settings in the Line Tab, nothing will show until the Line Color is set.

Otherwise, the various settings for Line are straightforward. If a setting is greyed-out, it does not apply to frames.

Properties: Color Tab

As noted above, the Line Color refers to the border of the frame, with the default being None.

Fill Color means background color of the frame. None for a Fill Color means that the background is transparent. Text Color can be set in the Text Tab in Properties, or in Story Editor.

Shade refers to saturation of the color, so that 0% should represent a neutral grey scale color. Opacity refers to the relative opacity/transparency, with 100% being totally opaque, 0% totally transparent. It is worth noting at this point that some PDF versions and some PDF viewers do not support transparency.

Overprinting versions 1.3.4 and above

Knockout versus Overprinting are described here.

Please note that you are not limited to colors you see displayed in the Color Tab, nor are you compelled to have all these choices. See the Menu item Edit > Colors to add, edit, or remove colors. Removing colors can simplify the use of Scribus, and does reduce saved file size.

See also: