Pierwsze kroki ze Scribusem:6

From Scribus Wiki
Jump to: navigation, search
 Pierwsze kroki ze Scribusem 2006
Aktualni autorzy:   Autorzy Scribus Wiki
Autor oryginału:   Niyam Bhushan, 2004
Licencja:   GNU Free Documentation License, Version 1.2
    
 Rozdział 6
edytuj

Scribus Wiki PL: Strona główna
Scribus Wiki PL: Spis treści

Wstęp

  1. Co możesz zrobić za pomocą Scribusa?
  2. Scribus i jego siostry
  3. Światło, więcej światła
  4. Okładka
  5. Praca z warstwami na stronie
  6. Zaprojektuj kolejne strony
  7. Utwórz ostateczne projekty stron
  8. Projektuj z grafiką i wolnością
  9. Rozpal ogień grafiką SVG
  10. Publikowanie wymaga wolności. PDF
  11. Podróżuj z prędkością Scribusa
  12. Porady dla polskich użytkowników
  13. Autorzy i modyfikacje
  14. GNU Free Documentation Licence

Zaprojektuj kolejne strony

Dużo indywidualnych projektów stron

Strony tego magazynu mają wymiary 210mm x 280 mm. Jednak nie wszystkie strony będą miały ten sam wygląd. Potrzebujemy trzech stron o układzie graficznym nadającym się na główny artykuł, być może o dwu szpaltach i z dużą ilością pustej przestrzeni po zewnętrznej lewej lub prawej zewnętrznej krawędzi strony. Kolejna strona mogłaby wyglądać jak formularz na listy od czytelników, zawierający tylko wiersze i tabele. Znowu inna strona mogłaby być spisem treści.

Zdecydujemy, że strona na główny artykuł wymaga dwu szpalt i po pół szpalty pustej przestrzeni po zewnętrznej lewej i prawej stronie, z tytułem działu na apli u góry. Chcemy też, aby każda strona artykułu wstępnego wyglądała tak samo. Musimy więc utworzyć stronę wzorcową dla tych stron, na której zdefiniuje ny wszystkie szpalty i inne wspólne elementy graficzne. Będziemy potem za pomocą tej strony wzorcowej dodawać do pliku Scribusa tyle stron, nowych tekstów i zdjęć, ile tylko dusza zapragnie.

Utwórz stronę wzorcową

Otwórz w menu Edycja>Strony wzorcowe... Pojawi się okienko, w którym zobaczysz jedną standardową stronę wzorcową o nazwie „Normalna”. To ta sama strona wzorcowa, której użyliśmy przy tworzeniu okładki. Kliknij na przycisk Nowa. W okienku, które się pojawi, nazwij nowy szablon „FeatureL” i wybierz „Lewa strona” z listy rozwijanej. Pojawi się pusta strona z niebieskimi liniami oznaczającymi zewnętrzne marginesy.

Strony wzorcowe1.png

Z otwartym jeszcze okienkiem Edytuj strony wzorcowe i z nową pustą stroną na ekranie, wybierz z menu Strona>Zarządzaj liniami pomocniczymi... Chcemy dodać parę poziomych i pionowych linii pomocniczych, które nie będą drukowane, a są tylko pomocą wizualną przy precyzyjnym rozmieszczaniu tekstu i grafiki.

Operatory

Lewa strona ma 20mm marginesu. Wewnątrz tego marginesu chcę zostawić pół kolumny pustej przestrzeni o szerokości 45mm. W okienku Zarządzaj liniami pomocniczymi kliknij na Dodaj pod rubryką Pionowe i wpisz w polu Wsp. X : „20+45”. Tak jest, Scribus radzi sobie z prostymi operatorami matematycznymi we wszystkich polach, w których wymagane są numeryczne wpisy. (Możesz nawet wpisać „30 mm + 1.5 in”, aby wykonać operację na różnych jednostkach).

L-pom1.png

Dodaj inne pionowe linie pomocnicze o współrzędnych 122.5mm i 127.5mm. Zwróć uwagę na ilość miejsc dziesiętnych, które dodawane są przez Scribusa. Dodaj poziomą linię pomocniczą Y: 265mm. Uwaga: zakreśl opcję Zabezpiecz linie pomocnicze, aby zapobiec ich przypadkowemu przesunięciu. Kliknij na OK. Twoja strona wzorcowa będzie teraz zawierała takie same linie pomocnicze, jak te przedstawione na zrzucie ekranowym poniżej.

L pom2.png

Numery stron

Dodaj czerwoną aplę na górze strony, umieść na niej ramkę tekstową z luźno rozstrzelonym tekstem „Khajuraho”. Wykonaj po kolei kroki, których nauczyłeś się w poprzednim rozdziale. W ten sam sposób dodaj na dole ramkę na stopkę i numer strony. Nie wpisuj statycznego numeru strony, tylko wciśnij kombinacje klawisza CTRL+#. Aby sprawdzić, czy ten skrót klawiaturowy się zgadza, przejdź do Plik>Konfiguracja>Skróty klawiaturowe... i przewiń listę, aby znaleźć odpowiedni skrót.

Prawa strona

Aby utworzyć stronę artykułu wstępnego dla prawej strony, kliknij na przycisk Nowy w okienku stron wzorcowych, wybierz „Prawa strona” z listy rozwijanej i nadaj stronie wzorcowej nazwę „FeaturesR”. Otwórz menu Strona>Zarządzaj liniami pomocniczymi... i wpisz następujące współrzędne pionowych linii pomocniczych: 82.5mm, 87.5mm, 145mm. Dodaj poziomą linię pomocniczą o współrzędnej 265mm. Podobnie jak w przypadku szablonu „FeaturesL”, dodaj u góry czerwoną aplę z tekstem, a stopkę na dole. Kliknij na Zamknij w okienku dialogowym stron wzorcowych. Znajdziesz się znowu na normalnych stronach Scribusa.

Przeciągaj i upuszczaj strony

Otwórz Okna>Rozmieść strony w menu głównym. W palecie stron zobaczysz okładkę jako stronę 1, a w górnej części okienka trzy strony wzorcowe: Normalna, FeaturesL i FeaturesR. Kliknij i przeciągnij stronę wzorcową FeaturesL na dół do obszaru Strony dokumentu i upuść go po lewej stronie poniżej strony 1. Automatycznie utworzona zostanie strona 2. Następnie przeciągnij i upuść stronę 3 z użyciem strony wzorcowej FeaturesR, oraz stronę 4 za pomocą strony wzorcowej FeaturesL. Powiększ widok stron i zwróć uwagę na wygenerowane automatycznie numery stron.

Strony1.png

Dwa łamy tekstu na stronę

Używając linii pomocniczych jako pomocy wizualnej, utwórz na każdej z tych stron ramki tekstowe, klikając w górnym lewym rogu pierwszego łamu i przeciągając mysz do dolnego prawego rogu drugiego łamu. Tak jest, to ma być jedna ramka tekstowa na stronę. Zaznaczaj po kolei każdą ramkę tekstową, przechodź do palety Właściwości, klikaj na Kształt ramki i w dole okienka wpisuj „2” w polu Łamy i „5” w polu Odstęp między łamami. Każda ramka tekstowa zawiera teraz dwa łamy. Dla każdej ramki tekstowej usuń zakreślenie opcji Tekst opływa ramkę w karcie Kształt ramki palety Właściwości.

Wlasciwosci2.png

Używaj spójnych stylów akapitów

Dobre projektowanie publikacji polega na używaniu spójnych stylów. Format głównego tekstu, zwanego „Body Text”, musi być taki sam na wszystkich stronach i we wszystkich artykułach. Z taką samą konsekwencją należy używać w całej publikacji lub w całym rozdziale stylów tytułów, nagłówków i śródtytułów. Zamiast za każdym razem ręcznie dobierać specyficzną czcionkę, rozmiar i inne ustawienia, lepiej zdefiniować styl raz, a potem tylko klikać na niego, aby przypisać go do wybranego akapitu. Automatyzm dla zwykłych ludzi.

Zdefiniuj style akapitów

Oto zrzut ekranowy wszystkich stylów akapitów w naszym dokumencie.

Style1.png

Listę tę można znaleźć w menu Edycja>Style akapitów.... Utwórzmy nowy styl o nazwie „Body Text”. Kliknij na przycisk Nowy w palecie styli akapitów i w okienku, które się pojawi, wybierz font, wyrównanie, stopień pisma, interlinię i inne właściwości. Ważną rzeczą, na którą należy zwrócić tutaj uwagę, jest opcja Wyrównaj do linii pisma. Jest to profesjonalna właściwość, pozwalająca na wyrównanie ze sobą tekstu w różnych łamach. Ten rodzaj precyzyjnego wyrównania elementów na całej stronie lub na rozkładzie stron jest tym, co odróżnia profesjonalną typografię od pracy amatora.

Style2.png

Zdefiniuj style akapitów dla wszystkich możliwych elementów: tytułu, śródtytułu, nagłówka, dolnej rubryki i innych. Najlepszą metodą jest utworzenie próbki tekstu dla każdego typu, zapisanie wszystkich właściwości po osiągnięciu pożądanego efektu, a następnie ręczne utworzenie stylu dla każdego z nich.

Zapełnij ramki tekstem

Kliknij prawym przyciskiem myszy na pierwszą ramkę tekstową na drugiej stronie. Z menu kontekstowego wybierz Pobierz tekst... i przejdź do katalogu Text poniżej katalogu FYug. Wybierz plik „khajuraho.txt” i kliknij na przycisk Otwórz. Zobaczysz, jak tekst zapełnia dwie szpalty na tej stronie. W prawym dolnym rogu ramki tekstowej zobaczysz obramowany symbol X, który oznacza, że tekst nie mieści się w ramce. Kliknij na pierwszą ramkę, aby ją zaznaczyć, przejdź do listwy narzędzi, kliknij na symbol Połącz ramki tekstowe.


Manipulateicons1331.png Od lewej do prawej: Obróć element, Powiększ/Pomniejsz widok, Edytuj zawartość ramki, Edytor artykułów, Połącz ramki tekstowe, Rozłącz ramki tekstowe.


Kliknij na ramkę tekstową na następnej stronie. Voila! Tekst przelewa się z ramki tekstowej na stronie 2 do ramki tekstowej na stronie 3. W podobny sposób połącz ze sobą ramki tekstowe dla każdej dodatkowej strony.

Sformatuj do stylu Body Text

Zauważyłeś pewnie, że tekst na każdej stronie sformatowany jest przypadkowo. Kliknij prawym przyciskiem myszy na pierwszą ramkę tekstową z tego wielostronicowego artykułu. Chodzi o ramkę na stronie 2. Przejdź do palety Właściwości, kliknij na kartę Tekst i wybierz „Body Text” z menu rozwijanego styli akapitów o nazwie Styl. Zauważ, że poniżej możesz nawet wybrać język.